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Building Models

An Enterprise Architect model is a top level (root) Package in a repository. It is possible to have more than one root
Package in a repository and hence more than one model. Each model is the root node of a hierarchy of Packages,
elements, features and diagrams that are nested under the Package. The Project Browser window is used to manage the
model and the hierarchy of elements, features and diagrams, showing how the models are structured and helping you to
reorganize a model by dragging and dropping objects to new locations in the hierarchy.

Enterprise Architect has a powerful Model Wizard that helps you to create models and a hierarchy of Packages under
each root, from a wide selection of model Patterns. The wizard is displayed automatically when a new model is added to
a repository, but can be invoked manually. Using the wizard simplifies the process of setting up repositories and models
for the novice modeler. More experienced modelers are free to add a single Model Package and build up the structure as
they see fit, or to create a model from a base (template) repository.

As the repository is developed and during the lifetime of a project or program of work, new models might have to be
added and existing ones refactored.
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Views

The top-level Packages in a model (below the project root nodes) can be created as Views, which are simply used to
structurally partition and extend the model according to specific requirements and modeling techniques, such as
Component View or Dynamic View. These Views have the same concept as the Simple UML Views generated as Model
Packages; however, unlike the Model Package views, basic Views:

Do not have any automatically-generated components·
Can be created only under a root node·
Are top-level Packages with special Package icons·
Are not directly available for Requirements, Analysis or Testing, although you can develop these Views from·
Simple Views or within Use Case Views

Types of View

There are six main types of View, each with their own Package icon, as listed; the types of diagram are the suggested
content of each View type:

Use Case View - containing Use Case diagrams and Analysis diagrams·
Dynamic View -containing Activity diagrams, Communication diagrams, Sequence diagrams and StateMachine·
diagrams

Class View - containing Class diagrams, Code Engineering and Data Models·
Component View - containing Component diagrams·
Deployment View - containing Deployment diagrams·
Simple View - to customize your own type of view·

You can work within the first five standard View types, or devise your own type based on the Simple View. You can
create Views, rename them, move them into a different order or delete them, by right-clicking on the selected View and
choosing the appropriate context menu option.
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Add Views

This example shows a customized view called Java Code View, which has been added to the end of the Views list.

Access

the Project Browser, select a model root node, then:

Ribbon Design > Package > New

Context Menu Right-click on root node | Add | Add View

Other Package Browser caption bar menu | New Package

Create a View

Option Action

Name Type the name of the View (in the example, this is Java Code View).

Set View Icon Style Click on the appropriate radio button to set the icon to display next to the View
name (the Java Code View has a Class icon).

Add to Version Control If the model root node is under version control, this checkbox displays, defaulted to
selected.

If you do not want the new View to also be under version control, deselect the
checkbox.

OK Click on this button to add the View to the Project Browser.
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Rename Views

If you decide to change the name of a View, you can do so very easily.

Rename a view

Step Action

1 Right-click on the View in the Project Browser, and select the 'Properties' option.

Alternatively, click on the View name and press F2.

The 'Package Properties' dialog displays.

2 In the 'Name' field, type the new name and click on the OK button.
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Delete Views

You can use Views as the main divisions of your project, or as temporary holding structures that you delete after you
have redistributed any content you want to keep.

Delete a View

Step Action

1 In the Project Browser, right-click on the View to delete and select the 'Delete <viewname>' option.

2 If you have selected the 'Confirm Deletes' option in the Project Browser section of the 'Start > Workspace
> Preferences > General' dialog page, the system displays a warning that child elements are to be deleted.

To delete the View and its contents, click on the Yes button.·
To cancel the deletion, click on the No button.·

Notes

If you delete a View, its contents are deleted at the same time; they cannot be restored·
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Packages

A Package is a grouping element that acts as a container for other modeling elements (including other Packages) and
diagrams; Packages are represented in the Project Browser as a familiar folder icon. Using the Package element,
hierarchical models can be constructed allowing complex systems to be decomposed and categorized. Packages and their
contents can be moved around freely in the Project Browser, so that you can easily refactor the repository. They can be
copied and pasted between model branches, renamed or viewed as a list. Packages are important in Enterprise Architect
because a number of functions can be applied at Package level, such as Baselines, Version Control, Transformation and
more.

Formally, the Package is a Namespace for the members it contains, and a model element can be a member of one and
only one Package. In software engineering and other formal modeling disciplines a Package can be set as a Namespace
Root, which acts as the starting point of a given namespace.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Update Element' permission to update or delete a Package
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Add a Package

Adding a Package to a model is a simple but versatile process. It is possible to add a new Package to a View, Model
Package or lower-level Package. In the process you can automatically:

Create a Package using a specific Model Pattern·
Create a child diagram for the Package·
Add the new Package to the version control system that its parent object is under·

Access

Ribbon Design > Package > New

Context Menu Project Browser | Right-click on Package | Add a Package

Keyboard Shortcuts Ctrl+W

Other Project Browser caption bar menu | New Package

Add a Package to the model hierarchy

Option Instruction

Owner Displays the name of the currently-selected Package or View, to which you are
adding the new Package.

If this is not the required owner Package, click on the  button and select the
correct Package.

Name Defaults to the automatic name, either 'Package n' or, if you have an autonaming
scheme turned on, the defined name. If necessary, overtype this name with the
preferred name of the new Package.

Select and Apply Model
Pattern

Select this radio button to create the new Package from a Model Pattern.

Create diagram Select this radio button if you want to immediately create a child diagram for the
Package.

Package Only Select this radio button if you want to just create a Package.

Add to Version Control (Available if you are adding this Package to a parent object that is under version
control.) Select this checkbox to add the new Package to the same version control
system, deselect the checkbox to exclude the Package from version control.

OK Click on this button to create the Package in the Project Browser.

If you selected the 'Select and Apply Model Pattern' radio button, the Model Wizard
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screen displays. Select the appropriate Technology and select the checkbox against
the Model Pattern (in the 'Name' panel) to import.

If you selected the 'Create diagram' radio button, the 'New Diagram' dialog
displays. Provide a name for the diagram and select the Technology and type.

The new Package is inserted into the Project Browser under the selected parent
Package or View.

Cancel Click on this button to abort the changes you have made and close the dialog.

Notes

You can also add a new Package element by dragging the Package icon from the Toolbox into a diagram; in this·
case the Package is created under the diagram's owning Package

In a multi-user environment, other users do not see the change until they reload their project·

(c) Sparx Systems 2015 - 2017 Page  16 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Open Package in the Project Browser

When you access a model in Enterprise Architect, you can explore the contents of any Package in the Project Browser by
clicking on the white arrow to the left of the Package name, to expand the Package structure. If the model has a default
diagram (which displays automatically when you access the model) the diagram's parent Package is already expanded.

To display the Package's properties, double-click on the Package name; the element's 'Properties' dialog displays.

Notes

Package contents are arranged alphabetically, and elements can be dragged from one Package to another using the·
computer mouse

To collapse the Package structure again, click on the black arrow to the left of the Package name in the Project·
Browser
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Rename a Package

If you want to correct or change a Package name, it is very simple to do so using the 'Properties' dialog for the Package.  

Access

In the Project Browser, select a Package and:

Ribbon Design > Package > Manage > Properties

Context Menu Right-click on Package | Properties

Keyboard Shortcuts Alt+Enter

Other Double-click on Package

Rename a Package

Step Action

1 In the 'Name' field, type the new name.

2 Click on the OK button.

Notes

Alternatively, highlight the Package to rename, and press F2·
In a multi-user environment, other users do not see the change until they reload their project·
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Copy a Package

In developing your model, you might want to duplicate the structure and organization of a section so that, for example,
you can replicate that part of the model in another model, or make it easier to cross-refer the contents of duplicate
sections. You can quickly do this by copying a complete Package, including its child Packages, elements and diagrams,
and then pasting it under:

The same parent Package·
One or more other Packages in the same model or project, or·
One or more other Packages in another model or project·

You would tend to use this procedure for copying sections of a model within the project rather than reproducing an entire
model or project, although copying these larger structures is equally feasible.

Duplicate a Package

Action Detail

Copy the Package In the Project Browser, right-click on the Package and select the 'Copy / Paste |
Copy to Clipboard | Full Structure for Duplication' option (or click on the Package
and press Ctrl+Shift+C).

The 'Copy selected Package to Clipboard' dialog briefly displays until the copy
operation completes.

Paste the Package In the Project Browser, right-click on the target Package into which to paste the
copied Package, and select the 'Copy / Paste | Paste Package from Clipboard'
context menu option (or click on the Package and press Ctrl+V).

The 'Paste Package from Clipboard' dialog briefly displays until the paste operation
completes.

In the Project Browser, the target Package is expanded to show the pasted Package;
if you are pasting the Package within the same model as the copied source, the
source parent Package is also collapsed.

If the target Package already contains:

A Package with the same name as the pasted Package, the pasted Package·
name has the suffix - Copy

A Package with the same name as the pasted Package including the - Copy·
suffix, the suffix becomes - Copy1 (or - Copy2, - Copy3 and so on, as copies of
the Package accumulate in the target parent Package)

You can keep the same Package name as the source, or you can rename the Package
by either:

Clicking twice on it and editing the name in the Project Browser, or·
Double-clicking on it and editing the name in the 'Properties' dialog·

Notes

You cannot paste a Package into a parent Package that is locked by another user or that is checked in; the 'Paste...'·
option is grayed out in the context menu

This procedure is effectively the same as exporting and importing the Package XMI file, with the 'Strip GUIDs'·
checkbox selected
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The paste operation can be a single transaction or a series of transactions to paste each data item separately,·
depending on the setting of the 'Import using single transaction' checkbox in the 'XML Specifications' page of the
'Preferences' dialog

You can also move a Package to a different part of the model, in the same way as moving an element·
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Drag a Package Onto a Diagram

You can drag a Package element from the Project Browser onto the current diagram, to show an icon of the Package
containing a list of the Package contents. This is a useful feature to help organize the display and documentation of
models.

In this illustration, note the child Actor and Use Case icons.
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Show or Hide Package Contents

If you have Package elements displayed in an open diagram, you can toggle between showing the Package contents
within the elements, or leaving them clear.

Access

Ribbon Design > Diagram > Manage > Properties > Elements

Context Menu Project Browser or open diagram | Right-click on diagram | Properties > Elements

Steps

Step Instruction

1 Select the 'Package Contents' checkbox to list the content of each Package within its element.

Clear the 'Package Contents' checkbox to hide the content of each Package within its element.

2 Click on the OK button.

(c) Sparx Systems 2015 - 2017 Page  22 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Delete a Package

If you do not want to keep a particular Package in the model, it is very simple to remove it.

Access

Context Menu Right-click on Package | Delete '<package name>'

Keyboard Shortcuts Ctrl+Del

Notes

Deleting a Package also deletes all contents of the Package, including sub-Packages and elements; make very sure·
that you really want to do this before proceeding

In a multi-user environment, other users do not see the change until they reload their project·
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Model Wizard

The Model Wizard provides Patterns from a wide range of technologies, which you can use to quickly generate new
models in your project both when you first create the project and over time.

The Model Wizard has three tabs:

Model Patterns - from which you can create basic models that you can develop further as components of your·
project

Application Patterns - from which you can generate starter projects including model information, code and build·
scripts for one of several basic application types

VEA Examples - through which you can import complete sample models (Packages), including all necessary model·
information, code and build scripts, to explore and try out the Visual Execution Analyzer

This topic describes the use of the 'Model Patterns' tab. See the Application Patterns and Visual Execution Analyzer
Samples topics for information on the other two tabs.

Access

Automatically displays when creating a new project; otherwise

Ribbon Design > Package > Model Wizard

Context Menu Right-click on Package | Add a Model using Wizard

Keyboard Shortcuts Ctrl+Shift+M

Other Project Browser caption bar menu > New Model from Pattern

Generate a New Model
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Field/Button Action

Add to Package Displays the name of the Package you have selected in the Project Browser.

If you are using the Model Wizard by default on a newly-opened project, this field
shows the Model root, 'Model'.

If you need to change the Package to generate the model under, click on the 
icon and browse for the correct Package on the 'Navigator' browser.

Customize Pattern on
import

A Pattern can contain several Packages; select this checkbox to indicate that you
will import only some of these Packages from the Pattern into your model. After
you click on the OK button, the 'Select Packages' dialog displays on which you
specify which of the Packages to import.
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If you select more than one Pattern, the 'Select Packages' dialog displays for each
Pattern in turn.

If you do not select the checkbox, all Packages in each Pattern will be imported into
the model.

Technology Lists the technology categories integrated  with or imported into Enterprise
Architect, which provide Model Patterns specific to the technology. A Technology
can have one or more categories.

If you are a Technology Developer you can create and import your own MDG
Technology, and distribute one or more custom Model Patterns from that
technology through the Model Wizard; the name of your technology (or technology
categories) displays in this list for your users to select to access the technology
Patterns.

You can also use the Model Wizard to create these MDG Technologies, by
selecting the Framework technology and the MDG Technology Builder Patterns.
These create a Model Package containing templates that you can use to generate the
technology and a set of Profiles.

Click on the required technology to list the associated Model Patterns in the 'Name'
panel.

Name Lists the groups of Model Patterns provided by the selected technology category,
and the Pattern templates within each group.

For example, the Core Modeling technology category supports the core UML
modeling groups:

Basic UML 2 - Model Patterns for general purpose, 'diagram type' UML·
modeling, generating extensive model structures

Extensions - Model Patterns for the extended application of UML modeling·
Simple UML Views - Model Patterns for 'view' oriented modeling, generating·
an appropriate Package with an empty diagram, eliminating the need to delete
unwanted sections of  boilerplate structure
These are slightly different from the basic Views that you can create instead of
Model Packages, under the model root node

Click on the check box for each model type you want to create in your project.

All Click on this button to select all of the Model Patterns listed in the 'Name' panel.

None Click on this button to clear all Model Patterns selected in the 'Name' panel.

OK Click on this button to generate the model structures for your project.

The structures are added to the Project Browser and can be expanded and worked
on immediately.

Cancel Click on this button to abort the creation of model structures.

Notes

The 'Select Package(s)' dialog does not display for the Simple Template and Basic Template Patterns in the·
Framework Technology, even if the 'Customize Pattern on import' option is selected
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Templates

Model templates generated by Enterprise Architect are designed to assist in the creation of projects and models for both
new and experienced users.

The templates are provided through the Model Wizard, for a wide range of model types available under the technologies
integrated with or imported into Enterprise Architect; for example, Basic UML 2, Core Extensions, BPMN, SysML,
ArcGIS, NIEM 3 and Database Engineering.

Each template provides a framework of Packages, diagrams, representative elements and connectors on which to build a
model appropriate to your purpose. These can include overview diagrams that provide an introduction to the terminology
and icons used in the model templates, and a quick guide to the concepts important to the templates and how they are
applied in Enterprise Architect. This information can be provided either in Note elements or via hyperlinks to the
Enterprise Architect Help and Sparx Systems or external resources.

In this illustration, the 'Dashboard: Issue Elements & Defects' template has been selected from the Core Modeling
technology. It generates a skeleton model in the Project Browser and a set of charts for reporting on Issues and Defects in
the model, ready to key into your project structure.
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Template Groups

Templates are available for a number of model types and to support various project activities. In the Model Wizard they
are grouped according to type or activity under the technology that provides them. This table describes some of the
technologies and groups from which you can select one or more templates; to be listed in the Model Wizard, the
technology must be enabled in the 'Configure > Technology > Manage > MDG Technologies' dialog.

Technology Grouping and Templates

Core Modeling Provides templates for the core UML models, for extensions of these models, and
for the alternative Views of the model structures. As examples, these groups
contain templates for:

UML 2 Class, Use Case and Component models·
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Dashboard, Business Process, User Interface and Requirements extensions·
Analysis, Dynamic and Logical Views·

There is some overlap between the types, allowing you to address similar modeling
concepts in a different type of structure.

BPMN Provides a set of BPMN model templates for whichever version of BPMN you have
loaded. For example, for BPMN 2.0 the templates are:

BPEL 2.0·
Business Process·
Choreography·
Collaboration and·
Conversation·

SysML Provides a set of SysML model templates for whichever version of SysML you
have loaded. For example, for SysML 1.4 the templates are:

Primitive Value Types library·
Unit and Quantity Kind library·
Control Values library·

Business Can hold several groups of templates, depending on which business modeling
technologies you are using. Provides templates for:

Business Rules·
ArchiMate·
Data Flow Diagrams·
Erikson-Penker diagrams·
Mind Mapping·
Strategic Modeling·
UMM 2.0·
Web Modeling·
Whiteboard diagrams·

Database Holds templates for all the supported DBMSs that you might want to create a data
model for. It also provides an Entity Relationship Diagram template.

Software Holds templates for modeling user/software interfaces, such as for Win 32 UI,
SPEM and Wireframing.

Services Provides templates for SoaML and SOMF.

Geospatial Provides templates for ArcGIS and GML.

Frameworks Holds templates for the range of frameworks and standards that can be integrated
with Enterprise Architect, such as:

TOGAF·
Zachman Framework·
GRA-UML·
NIEM·
NIEM 3.0·
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ODM·
UPCC·

This technology also provides templates for the MDG Technology Builder, which
you can use to create your own technologies.

Others Currently holds templates for technologies that have not been grouped with the
previously-listed sets, such as UPDM 2.0 and UBL.
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Customize Model Content

When you set up a project by importing models using the Model Wizard, you generate the model structures from Patterns
that you select in the Wizard. Each Pattern can contain a number of Packages and sub-Packages, and it is possible to
select which of these Packages to add to your model and which to omit, using the 'Select Packages' dialog.

This is especially useful when setting up a new model with a reasonably complex structure, such as the TOGAF
framework model. Being able to select which Packages are included and which are omitted is a good way to customize
the level of implementation necessary for the current project.

Access

Ribbon Design > Package > Model Wizard > Select 'Customize Pattern on import' : OK
button

Context Menu Project Browser | Right-click on a Package node | Add a Model using Wizard |
Select 'Customize Pattern on import' : OK button

Keyboard Shortcuts Ctrl+Shift+M | Select 'Customize Pattern on import' : OK button

Other Project Browser caption bar menu | New Model from Pattern | Select 'Customize
Pattern on import' : OK button

Select Package(s) dialog

Option Description

Select Package(s) to import
from <pattern>

Shows the hierarchy of Packages contained in the Pattern, with a checkbox to the
left of each item. The checkboxes are selected by default.

Deselect the checkbox against each Package that you do not want to import.

Deselecting a Package automatically deselects all its child Packages·
Re-selecting a Package automatically selects all its ancestor Packages·

OK Click on this button to import the selected Packages from the current Pattern.

Cancel Click on this button to abort the creation of model structures from the current
Pattern.

If you originally selected only one Pattern, clicking on this button also closes the
Model Wizard.

Notes

The 'Select Package(s)' dialog does not display for the Simple Template and Basic Template Patterns in the·
Framework Technology, even if the 'Customize Pattern on import' option is selected
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Diagrams

Diagrams are one of the most expressive views of the repository. They show a number of elements connected to each
other by relationships, creating a narrative that describes a part of the repository in a visual language. Quite commonly
the elements in a diagram exist in the same Package in the Project Browser; however, the most expressive diagrams
typically contain elements of different types from different Packages.

Creating a diagram is one of the most common ways for a modeler to add elements or relationships to the repository. As
new elements are dropped onto the diagram canvas from the Toolbox, they are added to the same Package (or element)
that contains the diagram. These same elements can participate in other diagrams, in fact the more diagrams the elements
appear in the richer the model.

Diagrams are displayed in the Project Browser as a child of either a Package or another element. While they often reside
in the same Package (or element) as the elements they contain, they can be freely moved around the Project Browser to
any location.

Like learners of natural languages, newcomers to modeling often create basic diagrams that lack expression, but with a
little practice and some time spent examining the diagrams of experienced modelers their diagrams will soon become
rich and expressive.

Enterprise Architect supports a wide range of modeling languages, each of which has a set of diagrams; these include the
UML, BPMN, SysML and a wide range of other languages and technologies.

Developing Diagrams

As you create your diagrams and add modeling elements to them, you can use a number of powerful facilities to add
extra meaning and expression, such as:

Partition the diagram, whatever the type, either vertically into columns or horizontally into rows, using Swimlanes·
Partition the diagram into a grid of cells, using a Swimlanes Matrix·
Create a Kanban diagram, sectioned and color-coded to organize the elements' project management properties·
Add Legend elements, which both provide and can automatically apply a key to the colors and styles you have used·
for the modeling elements on the diagram

Depict the more elements on the diagram as the objects that they represent, using graphical images from the Image·
Manager

Automatically apply one of a range of layout formats to the diagram·

Notes

If the diagram display is too small to read comfortably, click on the diagram, press and hold Ctrl and use the mouse·
wheel to temporarily expand or reduce the display magnification
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Diagram View

If you have created diagrams in the Project Browser, you can select to open them and then add elements and connectors
to them within the Diagram View. This is the main workspace for developing the structure of your model components,
dragging new objects onto the diagram from the Diagram Toolbox and existing objects from the Project Browser. You
can also add elements and connectors using the Quick Linker and other context menus within the Diagram View, and
move, format and edit them.

Most work on elements and connectors is carried out in the Diagram View, so understanding how it works and how to
manipulate elements is essential. You can use the EAExample project supplied with the system, or your own 'sandpit'
models, to explore the capabilities and behavior of the Diagram View.

Access

Project Browser Double-click on the diagram name or

Select the diagram node and press the Enter key

Diagram sections

Section Description

Caption Bar Across the top of a diagram is the diagram caption bar, which includes:

A horizontal 'chevron' icon to display or hide the Diagram Toolbox; the·
Toolbox itself is unchanged, whether it is docked, floating, expanded or for the
current diagram type, it is simply hidden or displayed
If you hide the Toolbox and change to a different diagram type, when you
show the Toolbox it is appropriate to the new diagram type but otherwise
unchanged

Icon and text label for the diagram type·
Diagram name·
A drop-down arrow that lists the currently-open diagrams; click on:·
    - A diagram name to switch to that diagram
    - Options to redisplay the hidden Start Page, Model Default diagram (if
defined) or User Default diagram (if defined)
    - The window 'close cross'; click on this to close the displayed diagram

Diagram View The larger area underneath the Caption bar is the work area within which you can
create and view the diagram structures. The borders of the printable diagram page
are represented by pale broken lines; structures created beyond these borders will
print on separate pages.

The Diagram View area is also where the diagram and object context menus
operate, and where the representation of the model structure can be changed to a
Gantt chart or Diagram List format.

Notes
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Diagrams can contain hyperlinks to other diagrams, which are opened when you click on the links·
It is possible to open several diagrams at once, but within the Diagram View you can only view one at a time·
You can view and work on several diagrams at once, by making the tab containing a diagram into a floating window,·
using the 'Window' menu

You can also work on elements using the Diagram List·
Additional information on the diagram, or a selected element within the diagram, is displayed in the system Status·
bar
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Context Filter a Diagram

As you review a modeling diagram, it is possible to click on any element on the diagram and show only those elements
that are directly related to the selected element. All other elements are grayed out until you click on the diagram
background.

Access

Ribbon Layout > Filter : Choose 'Relationships' from the drop-down list

Layout > Tools > Diagram Filters : Right-click background > Context Filtering

Show > Window > Diagram Filters : Right-click background > Context Filtering

Context Menu Right-click diagram background > Context Filtering

Notes

When you set the option and click on an element, any elements on the diagram that are not directly related to the·
selected element are grayed out

Setting the context filter applies to all diagrams that are open; you can select an element on each opened (floating)·
diagram and examine their relationships together

To clear the filtering (but not turn Context Filtering off) press Esc·
To select the next element in a direct chain or group of relationships on a diagram, press the Tab key; the Tab key·
does not take you out of the element group

To select the next element on the diagram, and display that element's related elements, use the arrow keys to move·
up, down, left or right to the next element in that direction; when moving left or right, the selection tends to be
upwards rather than downwards

When you enable the option on the diagram background or Diagram Filters window, it overrides the Diagram Filters·
settings; to use the Diagram Filters again, toggle the 'Context Filtering' option off

Context Filtering can be made even more useful by highlighting the incoming and outgoing relationships in different·
colors, by pressing and holding the L key on the selected element
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The Pan & Zoom Window

The Pan & Zoom window provides a 'birds-eye' view of diagrams. It enables you to navigate quickly around large
diagrams.

Access

Ribbon Layout > Tools > Pan and Zoom

Keyboard Shortcuts Ctrl+Shift+N

Reference

Topic Detail

View The window shows a reduced image of the whole diagram.

The shaded box represents the viewed area, displayed on the open diagram.

Toolbar The toolbar provides these functions (in order):

Zoom In·
Zoom Out·
Zoom to fit diagram·
Zoom to fit page·
Zoom to 100%·
Zoom Slider·

Use Open the required diagram.

Move the cursor onto the shaded box inside the Pan & Zoom window.

Hold down the mouse button as you move the cursor to move the shaded box over
the open diagram.

To zoom, use either the Zoom Slider or the buttons located on the tool bar.
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Diagram Tabs

Diagram tabs indicate which diagrams and views (such as the Start Page, document reports, code editors and the Model
Search) are currently open in the work area, by showing the view name and icon. The currently displayed view is
indicated by the diagram name being in bold on a white tab. An asterisk against the tab name indicates that the diagram
or view contains unsaved changes.

To open the view that you want, click on its tab. You can select options for saving, reloading, moving and closing the
views from the tab context menu. You can also review the tabs and select one using the View Tab Switcher window. The
tabs are located, by default, at the top of the Diagram View; if you prefer, you can move them to the bottom of the
Diagram View using the 'Visual Styles' dialog (the 'Main View Tabs at bottom' checkbox).

Access

Context Menu Right-click on the 'Diagram' tab

Other The View Tab Switcher window can be accessed by pressing and holding the Ctrl
key, while pressing the Tab key.

Diagram tabs context menu options

Option Action

Save Changes to '<tab
name>'

Select this option to save changes made to the diagram or view.

Save All Select this option to save changes made to the model.

Reload '<tab name>' Select this option to reopen the diagram or view without the unsaved changes; that
is, revert to the state before any of your changes were made.

This also refreshes the diagram or view from the repository, to show any changes
made by other users in a shared model.

Float Select this option to convert the diagram or view into a floating window that you
can move around your screen(s).  

An alternative is to simply click on the selected tab and drag it off the 'Diagram
Tabs' row.

You could use this option to display and work on several diagrams at the same
time.

To restore a floating view to a tab in the Diagram View, right-click on its Caption
Bar and select the 'Tabbed Document' option.

Close '<tab name>' Select this option to close the selected diagram or view; the system prompts you to
save any changes.

You can also close the tab by clicking the middle mouse button/scroller.
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Close All Select this option to close all open diagrams and views; the system prompts you to
save any unsaved changes.

Close All Except '<tab
name>'

Select this option to close all diagrams and views except for '<tab name>'; the
system  prompts you to save any  unsaved changes.

Close All <view type> (Where several views of the same type can be opened at the same time, such as
diagrams, report documents, or text editors.)

Select this option to close all views of the same type as the selected tab, leaving
views of other types still open.

Hide (Start Page only) Select this option to hide the Start Page.

To redisplay the Start Page, use the drop-down menu at the top right of the Diagram
View, or select the 'Start > Windows > Manage > Show Start Page' menu option.

Notes

The only context menu option available for the 'Start Page' tab is the 'Hide' option·
You can change the sequence of tabs by clicking on each tab and dragging it to a different position, as required;·
however, you cannot change the position of the 'Start Page' tab - when displayed, it always sits at the left-hand end
of the sequence
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Switch Between Views

When there are a number of open views available in the Diagram View (such as separate diagrams, editors and the
Model Search screen), you can review them and switch between them using the View Tab Switcher.

Access

Other Click on a view tab, press and hold Ctrl while you press the Tab key.

Switching between views

Action Detail

Selecting a different view

The View Tab Switcher lists the currently open views, in order of most recently
activated to least recently activated; the selection cursor is on the name of the view
that was activated just before the currently active one.

Details of the selected view are displayed on the right hand side of the screen, and
include:

A preview thumbnail of the view, and·
A description of the view and its contents·

Continue holding the Ctrl key to keep the window open; to move the selection
cursor:

Down the list of views, press the Tab key·
Up the list, press the Shift+Tab keys·
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Alternatively, use the arrow keys.

Activating a view To activate a view in the Diagram View, either release the Ctrl key or press the
Enter key; alternatively, click on the required view.

Activating a view moves it to the top of the 'Active Views' list, whereas closing a
view removes it from the list completely.
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Diagram Toolbox

The Diagram Toolbox is a panel of icons that you can use to create elements and connectors on a diagram.

Within the Toolbox, related elements and connectors are organized into pages, each page containing the elements or
connectors used for a particular type of diagram. The diagrams include standard UML diagrams, Enterprise Architect
Extended diagrams, and diagrams customized for any MDG Technologies and Profiles that you have added to the
system.

When you open a diagram, the Toolbox automatically provides the element and relationship pages corresponding to the
diagram type. This does not prevent you using elements and connectors from other pages in a given diagram, although
some combinations might not represent valid UML.

Access

Ribbon Design > Diagram > Toolbox

Keyboard Shortcuts Alt+5

Other You can display or hide the Diagram Toolbox by clicking on the  or  icons at
the left-hand end of the Caption Bar at the top of the Diagram View.

Example
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Options
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Option Detail

Display specific pages To display specific pages in the Toolbox, click on the More Tools button at the top
of the Toolbox and then on either the 'UML' or 'Extended' menu option, or on one
of the customized/MDG options.

The 'UML' option lists the 13 standard UML diagram types; select one of these to
display the Toolbox pages for that type.

The 'Extended' option lists a number of diagram types or model types that have
been extended from the core UML types. Select one of these to display the Toolbox
pages for that type.

A number of pages might display, but these generally include:

<type> Elements·
<type> Relationships·
Common and·
Artifacts·

If you select the <default> option, you display only the 'Common' page.

Customize the Toolbox You can customize the Toolbox display by pinning pages within the Toolbox, or by
adding  MDG Technologies and UML Profiles to the Toolbox.

Create elements and connectors from the Toolbox

Step Instruction

1 In the Project Browser, double-click on the icon against the required diagram.

The diagram opens with the appropriate Toolbox pages for that diagram type.

If you want a different set of elements and connectors, click on More tools and select the appropriate
diagram type as explained above.

2 Click on the required item; for example, the Class element or Associate relationship.

3 For element items, click anywhere on the diagram to place the new element.

4 For connector items, drag the cursor between the source and target elements on the diagram; as you pass
the cursor over the elements, a hatched border displays inside each element's solid border, indicating the
source and potential target elements.

To add bends to the connector, press Shift as you change the drag direction of the cursor.

Alternatively, drag from the source element to an empty area of the diagram; the Quick-linker suggests
 common target element types and connector types to create.

5 Edit the element properties or connector properties, as required.

Notes
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Dropping a Package element from the Toolbox into a diagram creates a new Package in the Project Browser, and a·
default diagram of the same type as the current diagram

If you are creating several elements of one type, after creating the first just press Shift+F3 or Ctrl+click to create the·
next element of that type; for connectors, click on the source element and press F3 to create another connector of the
same type

You can change an unstereotyped element to one of its stereotyped elements by dragging the stereotyped element·
from the Toolbox onto the unstereotyped element in the diagram; for example, you can stereotype a Class by
dragging a Table element or a Profiled Class element onto it

As you drag the stereotyped element, you can press Ctrl to apply the element stereotype to the unstereotyped·
element, or Shift to add the stereotyped element as a new element; otherwise a small context menu displays offering
these actions as options

If the diagram element already has the stereotype, you can also drag the Toolbox element onto it to synchronize the·
element's stereotype Tagged Values

The Toolbox can be docked on either side of the diagram, or free floated on top of the diagram to expose more·
surface for editing; you can also hide and redisplay the Toolbox by clicking on the horizontal 'chevron' icon at the
left  of the diagram header bar

Enterprise Architect provides Toolbox pages for a wide range of MDG Technologies, such as ArchiMate, BPEL,·
BPMN, Data Flow Diagrams, ICONIX and Mind Mapping, as part of the initial install
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Toolbox Appearance Options

You can modify the appearance of the Diagram Toolbox pages in several ways, through the Toolbox context menu.

Access

Other Right-click on a Toolbox page background

Options

Option Detail

Hide or Show element or
relationship labels

Select the 'Hide Labels' (or 'Show Labels') context menu option.

The icons in the page then 'wrap' within the page, without text labels.

When you hide the labels, you can display the label of an individual element or
relationship by moving the cursor over the icon.

Pinning pages to display all
the time

Select the 'Pin in Toolbox' context menu option (not available on the 'Common'
page, which displays all the time anyway).

For example, if you 'pinned' the 'Class elements' page, and switched to the
'Communication' pages, the Toolbox would include a collapsed 'Class elements'
page below the 'Communication' pages.

You can also pin a 'SysML Common' page to the Toolbox, simply by making the
SysML 1.3 Technology the Active technology for your work login.

Unpinning pages To unpin the page so that it displays only in its own Toolbox group, select the
'Unpin from Toolbox' context menu option.

Collapsing pages To collapse a page to just show the heading (<type> elements, <type>
Relationships or Common), click on the 'minus' box at the left of the page heading;
alternatively, right-click on the page and select the 'Collapse the current branch'
option.

To expand the page again, click on the heading.

Tailor Toolbox to list all required pages at once
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Step Instruction

1 Click on the 'Set Toolbox Visibility' context menu option.

The 'Pinned Toolbox Pages' dialog displays.

2 By default, the dialog lists the element pages only, in the order: UML pages, Extended pages, MDG
Technology pages.

To include the corresponding relationship pages, select the 'Show Relationship Pages' checkbox at the
bottom of the dialog.

3 For each page to display on the Toolbox, select the 'Pinned' checkbox.

Deselect the checkbox if you no longer require a page to be displayed.

4 When you have defined the list of pages to display, click on the OK button.

The pages you have selected are pinned to the Toolbox in a collapsed state, underneath the current
diagram-type pages.

5 To expand a page, click on the heading.

To remove an individual page, expand it, right-click on it, and select the 'Unpin from Toolbox' option.

Notes

On a Toolbox page for an MDG Technology or UML Profile, if you right-click directly on a Profile element an·
additional option - 'Synchronize Stereotype' - is available at the end of the context menu; this enables you to
synchronize the Tagged Values and constraints for all elements created from the selected Profile element

MDG Technologies can impose their own Toolbox page visibility; for example, if ICONIX is the active technology,·
all six ICONIX pages are automatically exposed in the Toolbox
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If the active Technology pages duplicate UML or Extended pages (as the ICONIX pages do), the pinned Technology·
pages override and replace the pinned UML and Extended pages; for example, if ICONIX is active and you have
pinned the 'Extended | Analysis' page, the 'Analysis' page in the list is the ICONIX-defined page, not the 'Extended |
Analysis' page
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Toolbox Shortcut Menu

When you add elements and connectors into a diagram, you can do so using the 'Toolbox' shortcut menu instead of
employing the full graphical Toolbox. The menu provides options to select:

Elements specific to the current diagram type·
Relationships specific to the current diagram type·
Elements and relationships from any pages pinned in the Toolbox·
Multiple elements at once, of types appropriate to the diagram or selected Toolbox page·
Common elements and relationships·
Elements and connectors for other diagram types·

The advantage of using the shortcut menu is that it provides an increased amount of the workspace to be used for
diagramming rather than displaying fixed (instead of pop-up) menus.

Use the Toolbox Shortcut Menu

Step Action

1 Open a diagram.

2 Either:

Click on the diagram background and press the Insert key or Space bar·
Press and hold Ctrl or Shift and right-click on the diagram background·
Right-click on the diagram background and select the 'New Element or Connector' option·
On the UML Element Toolbar, click on the 'New Element' icon·

The shortcut menu displays, listing the current diagram-type elements and connectors.

3 If necessary, to list elements and connectors for a different diagram type, select the 'Other', 'Common' or
'Artifact' options, or a pinned Toolbox page option.

If you want to create a group of elements in one go, select the 'Create Multiple Elements' option to display
the 'Create Multiple Elements' dialog. (Not available if you display the menu using the 'New Element or
Connector' context menu option, or the UML Element Toolbar.)

4 Click on the element or connector to include in the diagram; the element is added to the diagram, or you
can drag from one element to another to create the connector.

If you select the 'Other' context menu option, the final menu in the sequence offers the 'Activate <Type>
Toolbox' option at the top; this opens and activates the corresponding page in the Toolbox, if the Toolbox
is visible.

Notes

As with the Toolbox itself, if an MDG Technology:·
    - Is active
    - Automatically pins Toolbox pages, and
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    - Duplicates UML or Extended pages
The pinned Technology pages override and replace the pinned UML or Extended pages in the initial Toolbox
shortcut menu.
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Add Multiple Elements

Enterprise Architect provides a facility for quickly creating a number of elements to be added to a diagram in one go.
This helps you to organize a set of elements - all the same type or a mixture of types - and review them, renaming or
deleting some if necessary, before committing them to the diagram and model. One of the very useful features of this
facility is that you can import a block of lines of text and automatically create a new element from each line. You can use
this to generate a large number of, say, Requirement or Business Rule elements with meaningful names, from a source
document such as a spreadsheet or specification in an instant.

You set up the group of new elements using the 'Create Multiple Elements' dialog.

There are two variants of this dialog. You can create:

Separate elements through one of a number of keyboard commands, in which case the dialog shows the 'Name' and·
'Type' columns, or

Elements related to one selected element using the Quick Linker arrow, in which case the dialog also provides a·
'Link' column (as shown) through which you specify what the relationships are between the selected element and the
new elements

Access

On an open diagram:

Keyboard Shortcuts Insert key > Create Multiple Elements

Space Bar > Create Multiple Elements

Ctrl+right-click > Create Multiple Elements

Shift+right-click > Create Multiple Elements

Other Drag an element's Quick Linker arrow to an open space on the diagram and release
the mouse button > Create Multiple Elements
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Create the group of elements

On the 'Create Multiple Elements' dialog:

Step Action

1 In the 'Name' column, overtype the Create new element text with the name of the new element.

2 In the 'Type' column, click on the drop-down arrow at the right of the field and select the required element
type.

The types offered in the drop-down list are those currently listed in the Toolbox selected for the diagram
(or, if you selected the option with the Quick LInker arrow, the types are the same as those in the Quick
Linker list).

3 Selecting the type positions the cursor on the next line, with the 'Type' field set to the same element type
as you selected from the previous element.

You can simply type in the next element name and press the Enter key to create another element of the
same type, or type in the name and repeat Step 2 to add an element of a different type.

4 If you have displayed the 'Create Multiple Elements' dialog from the Quick Linker arrow menu, the dialog
displays a 'Link' column for the type of relationship between the selected element and each new element.

Click on the drop-down arrow and select the relationship type from the list; the list is the same as that
provided by the Quick Linker, and consists of the appropriate common relationships for the source and
element types.

The first selected relationship sets the default for the next relationship you create on the dialog, and you
can either leave that as it is or select a different type.

5 When you have specified a complete set of elements and relationships, you can quickly review and - if
necessary - modify them using a context menu within the dialog (see the Review New Elements table)
before you commit them to the diagram and model.

When you are satisfied that you have defined the objects you require, click on the OK button to add them
to the diagram and model.

If the linked elements need to have other structures (such as the Object Flow link between an Activity and
an Action) these are also added (in this case, an ObjectNode on the Activity and an ActionPin on the
Action).

6 If you decide not to create elements from the names you have entered, press the Cancel button to delete
them all and to close the dialog.

Review New Elements

Right-click on an item in the list, to display the context menu.

Option Action

Add
New
Elem
ent

Position the cursor in the next empty 'Name' field, ready for you to type in an element name. The 'Type'
and 'Link fields' default to the values from the previous entry.

Shortcut: Ctrl+N

Edit
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Item Place the selected element name in Edit mode, to be typed over with a different name.

You can also change the name, element Type and Link type by clicking on the field and overtyping or
selecting a new value from the drop-down list.

Shortcut: Enter key

Dele
te
item

Immediately remove the selected item from the dialog. The element does not and will not exist in the
diagram and model, and therefore will not have any links to other elements, Packages or diagrams to
check. There is no validation to establish whether to delete the element from the diagram only, or from the
diagram and model.

Shortcut: Ctrl+D

Impo
rt
Nam
es
from
Clip
boar
d

Insert a number of lines of text from the Windows clipboard, each line becoming the name of a new
element. The element Type and Link type default to the last-defined types, which you can leave as is or
change as required. If the dialog is too narrow to display the element names, you can resize it.

The imported text can come from an internal or external file. The system takes any line break (Enter,
Shift+Enter, Ctrl+Enter) as the end of the text string and hence the end of the element name.
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Common Page

The 'Common' page of the Diagram Toolbox provides the elements and relationships that can be used on any diagram. It
is displayed at the bottom of every other set of pages in the Toolbox.

The Artifacts Toolbox page is also a common page, displayed at the bottom of every Toolbox.

Common Elements

Element Description

A Note element is a textual annotation that can be attached to a set of elements of
any other type.

A Constraint is a form of Note, identifying a constraint on other elements.

A Text element is a textual annotation that is similar to a Note, however has no
boarder or background color.

A Legend element provides a key to the colors and line thicknesses you have used
to distinguish between element and/or connector groupings on the diagram.

On a diagram, it is possible to display a customized text box called the Diagram
Properties Note, which automatically shows the diagram properties.

A Hyperlink element is a special kind of Text element that, when double-clicked,
opens the configured target object such as a document, web page or diagram.
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An Artifact is any physical piece of information used or produced by a system.

A Requirement element captures the details of a system requirement.

An Issue element represents an item of concern (that might or might not arise) or a
failure to meet a defined requirement in the current system.

A Change element represents a change in the defined requirements for the current
system and can be used to request and manage the change process.

A System Boundary element is a non-UML element used to define conceptual
boundaries.

An Image is a System Boundary element that has automatically has a Alternate
Image defined.

Common Connectors

Connectors Description

Dependency relationships are used to model a wide range of dependent
relationships between model elements.

A source object implements or Realizes its destination object.

The Trace relationship is a specialization of an Abstraction, connecting model
elements or sets of elements that represent the same concept across models.

An Information Flow represents the flow of Information Items (either Information
Item elements or classifiers) between two elements in any diagram.

A Notelink connector connects a Note to one or more other elements of any other
type.

(c) Sparx Systems 2015 - 2017 Page  55 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Artifact Toolbox

An Artifact is any physical piece of information used or produced by a system. In Enterprise Architect these are
represented by the Artifact element, which can have one of a number of stereotypes to tailor it to a specific purpose,
including internal operations and structures within the model as indicated in the examples. Artifacts can have associated
properties or operations, and can be instantiated or associated with other Artifacts according to the object they represent.

You can create an Artifact element by dragging one of the Artifact icons from the Artifacts page of the Diagram
Toolbox, or from one of several other Toolbox pages according to type. The Common page of the Toolbox also has a
generic Artifact icon that - when you drag it onto a diagram - offers a choice of types of Artifact to create.

Types of Artifact
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Type Description

Artifact (Base) A Base Artifact defines the external artifacts used in a process and the internal
artifacts generated in the process, such as model files, source files, database tables,
development deliverables or support documents. The files represented by the
Artifact are listed on the 'Files' tab of the element 'Properties' dialog.

To open the files represented by the Artifact, click on the element on the diagram
and press Ctrl+E. Each file is opened either on a separate tab in the Diagram View
workspace (if the file can be opened within Enterprise Architect) or in the default
Windows viewer/editor for the file type (if the file cannot be opened within
Enterprise Architect).

Files can also be launched individually from the 'Files' tab (opening in the Windows
default editor), as for elements of any other type that have associated files.

Toolbox Icon

Checklist Artifact A Checklist Artifact provides the facility for generating a list of items, each with a
checkbox, to be used as a checklist. You can set each checkbox to default to being
selected or unselected, and set all selected options to be grayed out or struck
through, so that the unselected options are more prominent. The end users can then
work with the element to tick off items that have been obtained or activities that
have been completed.

A version of this Artifact - the Requirements Checklist - is available in the
'Extended Requirements' Toolbox page. This automatically contains ten
characteristics of a good Requirement, for a Requirement author to tick off as they
check that their Requirement has been set up to show those characteristics.
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Toolbox Icon

Document Artifact A Document Artifact is an Artifact having a stereotype of «document». You create
the Document Artifact using the Artifacts, Component, Documentation or
Deployment pages of the Diagram Toolbox, and associate it with an RTF document
or CSV file.

Double-click on the element to display the Linked Document Editor. When you
have created the linked document, the Document Artifact element on the diagram
shows an 'A' symbol in the bottom right corner.

Toolbox icon

Encrypted Document
Artifact

An Encrypted Document Artifact is used to create and hold a Linked Document that
is automatically encrypted, and that cannot be opened and automatically decrypted
within Enterprise Architect without entering a password. You can therefore use the
generated Artifact element to record sensitive information, which you protect from
general access by assigning a password.

When you drag the 'Encrypted Document' icon onto the diagram from the 'Artifacts'
page of the Toolbox, a prompt displays to type in a password. When you enter the
password, you can create the Linked Document. Thereafter, if any user attempts to
open the document, the same password prompt displays. If the user does not
provide the password that you originally specified, the document will not open. If
the correct password is provided, the document is decrypted and opened.

The Encrypted Document Artifact is indicated in the Toolbox page, diagram and

Project Browser by a red 'document' icon - .

Working Set Artifact A Working Set Artifact defines a Working Set that opens various windows,
diagrams and views, recreating a work environment that you frequently use.

To create or modify the Working Set, right-click on the element and select the·
'Edit Working Set' option

To execute the Working Set to open the defined windows and views and·
execute any commands, double-click on the element

Toolbox icon

Executable StateMachine
Artifact

An Executable StateMachine Artifact is the vehicle through which you can
generate, build (compile) and execute - via simulation - code for a StateMachine or
complex of StateMachines.

Each StateMachine is the child of a Class element; when you drag the Class from
the Project Browser onto the Artifact element, it is pasted inside the Artifact as a
Part. You can paste several Classes - and, therefore, Parts - into a single Artifact.

Having set up the Executable StateMachine Artifact, you use simple context menu
options on the Artifact to perform the code generation, build and execution
operations on all StateMachines bound within the Artifact.

Toolbox icon
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Matrix Specification
Artifact

A Matrix Specification Artifact encapsulates a Relationship Matrix Profile
definition. When you have created the element on the diagram, you double-click on
it to display the 'Matrix Specification' dialog, in which you create the Profile
definition. The Profile takes the name of the element. The profile defined in the
Artifact is independent of the Package that contains the Artifact element, and
therefore could specify source and target Packages other than parent Package.

After you create the Profile definition, each time you double-click on the Artifact
element the Relationship Matrix displays with the Profile applied.

To edit the Profile, right-click on the  Artifact and select the 'Documentation | Edit
Matrix Profile' option.

Toolbox icon

Report Specification
Artifact

A Report Specification Artifact encapsulates a report definition. When you have
created the element on the diagram, you double-click on it to display the 'Generate
Documentation' dialog, on which you enter the report parameters and, if required,
generate the report.

After you create the Report Specification, each time you double-click on the
Artifact element the 'Generate Documentation' dialog again displays with the same
report parameters. You can continue to generate the same report, or alter the
parameters if necessary. If you change the parameters, they are re-presented until
such time as you change them again,

Toolbox icon

User Story Artifact A User Story Artifact provides a means of documenting a business Use Case in the
context of Agile methodologies such as Extreme Programming (XP). In the Linked
Document, you define the functions a business system must provide; it captures the
'who', 'what' and 'why' of a requirement in a simple, concise format. The User Story
Artifact behaves as a Document Artifact (above), prompting you to select a Linked
Document template to base the document on.

Toolbox icon

Standard Chart Artifact A Standard Chart Artifact provides the facilities for generating a Pie Chart or Bar
Chart on an aspect of the data in your model. It adds three 'Chart Details' tabs to the
standard tabs of the element 'Properties' dialog.

After you have added the element to your diagram, double-click on it. The element
'Properties' dialog automatically opens at the 'Chart Details - Source' tab. Define the
chart type and data source, then go on to define any filters you want to apply, and
how the chart should display.

Once you have defined the chart, it automatically displays with the latest
information whenever you open the parent diagram.

Toolbox icon

Model View Artifact A Model View Artifact provides the facilities for generating a tabular Model View
Chart on a segment of the data in your mode, extracted using a custom SQL search.

After you have added the element to your diagram, double-click on it. The element
'Properties' dialog automatically opens at the 'Chart Details - Source' tab. Define the
SQL Search to extract and tabulate the information.

Once you have defined the chart, it automatically displays with the latest
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information whenever you open the parent diagram.

Toolbox icon

Time Series Chart Artifact A Time Series Chart Artifact provides the facilities for generating a linear graph of
a model  property over time.

After you have added the element to your diagram, double-click on it. The element
'Properties' dialog automatically opens at the 'Chart Details - Source' tab. Define the
Package from which the data is to be extracted, and the time interval over which the
data is to be sampled. Then go on to define the appearance of the chart.

Once you have defined the chart, it automatically displays with the latest
information whenever you open the parent diagram.

Toolbox icon
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Use Case Toolbox

The Use Case Toolbox is used to model system functionality from the perspective of a system user; Use Case objects are
used to build the Use Case models, which describe the functionality of the system to be built, the requirements, the
constraints and how the user interacts with the system.

Sequence diagrams can be associated with Use Cases to capture workflow and system behavior.

Use Case Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

These two relationships are stereotyped Dependency relationships defined by the
Open Modeling Language (OML):

Invokes indicates that Use Case A, at some point, causes Use Case B to happen·
Precedes indicates that Use Case C must complete before Use Case D can·
begin

The 'Basic Use Case' icon adds the Basic Use Case Pattern to your diagram as a
starting point for developing the diagram (drag the icon onto the diagram to open
the 'Add Pattern <name> to Diagram' dialog and click on the OK button).

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Class Toolbox

The Class Toolbox can be used for creating Class models and Data models. Such models contain Package diagrams,
Class diagrams and Object diagrams - those diagrams that usually display elements concerned with the logical structure
of the system, such as Objects, Classes and Interfaces.

Logical models can include domain models (high level business driven object models) through to strict development
Class models (defining inheritance, attributes and operations).

Class Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

You use the Table element to insert a stereotyped Class for use in data modeling.

The Association element is an n-ary Association, which is used to model complex
relationships between three or more elements.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Object Toolbox

The Object Toolbox is used to create Object diagrams, which reflect multiplicity and the roles that instantiated Classes
could serve. They are useful in creating different cases in which relationships and Classes are applied.

Object Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

A Boundary is a stereotyped Object that models some system boundary, typically a
user interface screen.

A Control is a stereotyped Object that models a controlling entity or manager.

An Entity is a stereotyped Object that models a store or persistence mechanism that
captures the information or knowledge in a system.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Composite Toolbox

The Composite Toolbox is used to create Composite Structure diagrams. These reflect the internal collaboration of
Classes, Interfaces or Components to describe a functionality or to express run-time architectures, usage patterns and the
participating elements' relationships, which static diagrams might not show. The Class elements form the basic structure
of the diagram, with Interface, Part, Port and Collaboration elements defining the functionality or use of the Classes.

Composite Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Communication Toolbox

The Communication Toolbox is used to develop Communication diagrams, in which you model dynamic interactions
between elements at run-time. These diagrams are used to model workflow and sequential passing of messages between
elements in real time; they are often placed beneath Use Case elements to further expand on Use Case behavior over
time.

The Actor element models a user of the system, while the other elements model things within the system, including
standard elements (Object) and the user interface component (Boundary), Controller and Entity.

Communication Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

A Boundary is a stereotyped Object that models some system boundary, typically a
user interface screen.

A Control is a stereotyped Object that models a controlling entity or manager.

An Entity is a stereotyped Object that models a store or persistence mechanism that
captures the information or knowledge in a system.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Interaction Toolbox

The Interaction Toolbox is used to develop Sequence diagrams. You use Sequence diagrams to model dynamic
interactions - workflow and the sequential passing of messages - between elements in real time. Sequence diagrams are
often placed beneath Use Case elements to further expand on Use Case behavior over time.

Interaction Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

A Boundary is a stereotyped Object that models some system boundary, typically a
user interface screen.

A Control is a stereotyped Object that models a controlling entity or manager.

An Entity is a stereotyped Object that models a store or persistence mechanism that
captures the information or knowledge in a system.

Notes

The Interaction element supports the capture of Interaction diagrams through the Project Browser and diagram·
context menus; you cannot capture these diagrams by dragging the element onto a diagram

The 'Fragment' icon creates Combined Fragment elements·
Message, Self Message and Call are described as Sequence diagram messages·
Messages can be simple or recursive calls·
To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Timing Toolbox

The Timing Toolbox provides the modeling elements for creating Timing diagrams, which define the behavior of objects
along a time-scale to visualize how the objects change state and interact over time.

Timing diagrams can be used for defining hardware-driven or embedded software components, and time-driven business
processes.

Timing Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

The Message relationship is specifically described for Timing diagrams.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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State Toolbox

The State Toolbox is used to develop StateMachine diagrams, to show the enableable states a Class or other element
might be in and the transitions from one state to another. These diagrams are often placed under a Class element in the
Project Browser to illustrate how a particular element changes over time. States can have substates; for example,
Accelerate and Brake might be substates of Active.

State Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

Event is used to create a basic Send element (the default) or Receive element on the
StateMachine diagram.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Activity Toolbox

The Activity Toolbox is used to model system dynamics from a number of viewpoints (represented by activities and the
flows between them) in Activity diagrams and Interaction Overview diagrams. Both types of diagram are usually created
under Activity elements.

Activities can be stereotyped as a process to display a business process icon; the Activity represents some work that is
carried out, which might overlap several Use Cases or form only a part of one Use Case.

Activity Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

The 'Basic Activity' icon adds the Basic Activity Pattern to your diagram as a
starting point for developing the diagram (drag the icon onto the diagram to open
the 'Add Pattern <name> to Diagram' dialog and click on the OK button).

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Component Toolbox

The Component Toolbox provides model elements that you can use to model the physical components of your system in
a Component diagram. The Component pages contain elements and connectors related to the actual building of the
system - the components that make up the system (such as ActiveX DLLs or Java beans), the Interfaces they expose and
the dependencies between those elements.

A component is a piece of hardware or software that makes up the system; for example, a DLL or a Web Server are
components that might be deployed on a Windows 2000 Server (Node).

Component Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

A Packaging Component is an element that appears very similar to a Component in
a diagram but behaves as a Package in the Project Browser.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Deployment Toolbox

The Deployment Toolbox provides model elements that you can use to model the physical components and deployment
structure of your system in a Deployment diagram. The Deployment group contains elements related to the actual
building of the system - the hardware or software Components that make up the system (such as ActiveX DLLs or Web
Servers) and the physical platforms (Nodes) those Components run on (such as a Windows 2000 Server), including the
physical connections between Nodes.

Deployment Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

The 'Basic Deployment' icon adds the Basic Deployment Pattern to your diagram as
a starting point for developing the diagram (drag the icon onto the diagram to open
the 'Add Pattern <name> to Diagram' dialog and click on the OK button).

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Profile Toolbox

The Profile Toolbox is used in creating Profiles, a generic mechanism for extending UML models. Profiles can define
custom Stereotypes, Tagged Values, Diagram Types and Toolboxes.

The Toolbox also contains a set of Profile Helpers that provide templates and dialogs to help you create Stereotype
Profiles, Toolbox Profiles and Diagram Profiles within an MDG Technology.

Profile Toolbox pages

Image Detail

The Profile Package element acts as the container for the diagrams, elements and
connectors that define the Profile itself.

The Stereotype element provides a mechanism for varying the behavior and type of
a base UML model element.

A Metaclass element represents the base UML element or connector type that you
are extending.

An Enumeration element is used to define an enumeration Tagged Value, which
can be attached to one or more Stereotypes that have been defined in the Profile.

Profile Helpers are templates and dialogs that help you create, respectively:

An MDG Technology Package to contain Profile definitions·
Stereotypes and Metaclasses within a UML Profile·
A customized Toolbox Profile·
Toolbox pages within the customized Toolbox·
A Diagram Profile to define an extended diagram type·

An Extension relationship shows that a Stereotype extends a Metaclass; all
Stereotypes must extend either:

One or more Metaclasses, or·
Another Stereotype that extends a Metaclass; you can create a chain of·
extending Stereotypes that ultimately extend the Metaclass (however, in
practice you are unlikely to have more than two Stereotypes in the chain)

A Generalize relationship shows that one Stereotype specializes a more general
Stereotype; the more general Stereotype must still extend a Metaclass.

A Tagged Value relationship defines a reference-type (that is, RefGUID) Tagged
Value owned by the source stereotype; the Tagged Value is named for the target
role of this association, and is limited to referencing elements with the stereotype
by the association target element

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Metamodel Toolbox

The Metamodel Toolbox provides model elements for creating Metamodel diagrams.

Metamodel Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

The Metamodel Primitive element that supports the MOF specification, which you
create using the Primitive icon, is deprecated. Use the Primitive element from the
Class Toolbox.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the source element in the diagram and drag to the·
target element
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Analysis Toolbox

Analysis-type elements are used early in modeling to capture business processes, activities, collaborations and general
domain information. They are generally used in Analysis diagrams.

Analysis Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

A Process is a stereotyped Activity, used to model business processes.

A Boundary is a stereotyped Object that models some system boundary, typically a
user interface screen.

A Control is a stereotyped Object that models a controlling entity or manager.

An Entity is a stereotyped Object that models a store or persistence mechanism that
captures the information or knowledge in a system.

You can also use a number of stereotyped elements from the 'Business Modeling'
pages of the Toolbox, to capture UML business process modeling extensions such
as worker, case worker, entity and controller.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Custom Toolbox

The Custom Toolbox contains extended UML elements that can be of use in modeling or designing your system in a
Custom diagram.

Custom Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

A Requirement is a custom element used to capture requirements external  to
standard UML elements; a Requirement expresses required system behavior that
can cross several Use Cases.

You can connect Requirements to other elements using the Realize connector to
express the implementation of a requirement and hence the traceability from user
requirements to what is being built.

An Issue element is a structured comment that contains information about defects
and issues relating to the system/model; affected elements are connected by Trace
connectors.

A Change element is a structured comment that contains information about changes
requested to the system/model; affected elements are connected by Trace
connectors.

A Screen provides a stereotyped Class element that displays a GUI type screen; this
can be used to express application GUI elements and flows between them.

A UI Control likewise can be used to express GUI controls.

A Test Case element defines what must be set up in order to test a particular
feature; you can use it to define a set of tests once for a number of elements. As an
element rather than a property, it provides greater visibility for tests.

Entity - use of this element is deprecated - it was originally intended to take the role
now supplied by the Table element.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Requirements Toolbox

As an analysis step, often it is desirable to capture simple system requirements. These are eventually realized by Use
Cases.

Requirements Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

A Requirement is a custom element used to capture system requirements external to
individual UML elements; a Requirement expresses required system behavior that
can cross several Use Cases. You can create a number of specific types of
stereotyped Requirement from their own element icons.

Requirements Checklist is a stereotyped Checklist, and is rendered as this element:

A Feature is a small client-valued function expressed as a requirement. Features are
the primary requirements-gathering artifact of the Feature-Driven Design (FDD)
methodology.

A Risk element represents an identified risk to the project.

You can also add structures of Functional and Non-Functional Requirements to
your diagram, each with a Checklist, using the two Requirements Patterns.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Maintenance Toolbox

The Maintenance Toolbox provides the elements and connector for defining and monitoring Issues, Defects, Changes,
work Tasks and Tests for project management.

Maintenance Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

An Issue element is a structured comment that contains information about issues
relating to the system or model; affected elements are linked by Trace connectors.

A Change element is a structured comment that contains information about changes
requested to the system/model; affected elements are connected by Trace
connectors.

A Task element defines a task attached to an element; you can  assign resources
specifically to the task rather than just to the parent element, and monitor the tasks
on diagram Gantt charts.

A Test Case element defines what must be set up in order to test a particular
feature; you can use it to define a set of tests once for a number of elements. As an
element rather than a property, it provides greater visibility for tests.

An Entity is an abstract type that is often used in analysis to record that something
is of interest to the system, without necessarily defining how it will be represented
in the system. 

A Test element represents a step in any of the Basic, Alternate  or Exception Paths
of a Scenario, created within a Use Case or other element.

A Defect element is a structured comment that contains information about defects
relating to the system or model; affected elements are linked by Trace connectors.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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User Interface Toolbox

The User Interface Toolbox provides a wide range of icons that you can use to create User Interface diagrams.

User Interface Toolbox pages

Image Detail

Except where discussed here, each element and relationship that you can create
using these Toolbox pages is described in the UML Elements and UML Connectors
sections of the Help.

The Screen element represents the screen  or dialog frame in a graphical user
interface. You can identify fields, delimiters and buttons on the screen using the
different UI Control elements.

UI Control elements are different stereotyped elements defining controls such as
buttons, fields and combo boxes. You arrange these on the Screen element, as part
of a User Interface diagram, to define a screen or dialog in a user interface.

This diagram illustrates each type of UI Control element from the Toolbox, within a
Screen element.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
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end element

To place one UI Control object inside another (for example, adding fields or options to a Panel or Form), press Shift·
as you drag the object into place

You can add objects to the diagram and move them around, but once the object is within the boundary of a Screen·
element (or another UI Control element) you cannot move it out of that boundary on the diagram; you can move
child elements between parents on the Project Browser

If you delete a Screen (or other parent element) on the diagram, all the UI Control elements it contains are also·
deleted from the diagram
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WSDL Toolbox

The WSDL Toolbox provides elements you can use to rapidly develop a W3C Web Service Definition Language
(WSDL) model, from which you can  automatically generate WSDL documents.

WSDL Toolbox page

Image Detail

A Namespace represents the top-level container for the WSDL model. Drag this
element onto an open diagram to create the necessary model structure for WSDL
documents.

A physical WSDL document is represented as a UML Component. Its interfaces
represent the WSDL Services.

A WSDL Port Type is modeled as a UML Interface. Its Port Type Operations are
realized by Binding elements.

Each of the operation parameters is derived from the Message elements defined in
the Messages Package.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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XML Schema Toolbox

The XML Schema Toolbox provides model elements that you can use to model W3C XSD schema files. This Toolbox
implements the constructs provided by the UML Profile for XML Schema. Having created your model, you can
automatically generate the W3C XSD schema files from it.

XML Schema Toolbox pages

Image Detail

A Schema corresponds to a UML Package, which contains the type and element
definitions for a particular targetNamespace. Drag this item onto an open diagram
to create the Package to contain your schema model elements. The Package is
stereotyped as XSDschema.

Open the logical diagram created under the XSDschema Package and add
additional schema elements to define the model.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Data Modeling Toolbox

The Data Modeling Toolbox provides a basic set of elements for database modeling and database design, in conjunction
with the UML Data Modeling Profile.

Data Modeling Toolbox page

Image Detail

In the data model, a:

Table defines a database table·
View represents a database view·
Procedure represents database (or Stored) procedures·
Sequence represents a database Sequence·
Function represents a database Function·
Database Connection helps you to configure a connection to the database you·
are modeling, for testing, import and export of schema, and comparison of
differences between database and model using the Database Builder
When you drop this icon onto the diagram the system prompts you to indicate
whether to create the connection for an Access database, a Firebird database or
an ODBC database
For the first two options, when you click on the OK button the system prompts
you to select the file to create the connection to
If you select the 'ODBC database' option, the 'Select Data Source' dialog
displays; click on the 'Machine Data Source' tab and select the data source
(project on a database)
After you have defined the data source, when you double-click on the element
the Database Builder view opens for the current database model

SQL Query is an Artifact element that provides a convenient mechanism for·
storing an SQL Statement in the repository, for repeated execution on live
database(s)

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Test Domain Toolbox

The Test Domain Toolbox provides a basic set of elements that you can use to create Test Domain diagrams, used in the
Testpoint facility. A Test Domain diagram provides specific elements that can aid in the logical composition of tests into
Test Sets and Test Suites.

Test Domain Toolbox page

Image Detail

A Test Cut is a group of operations that represent a specific behavior (such as Print)
defined for a Class, separate from other constraints defined for the Class.

A Test Set aggregates one or more groups of methods (Test Cuts) that perhaps span
multiple Classes, into a single task.

A Test Suite aggregates one or more groups of tasks (Test Sets).

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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XML Transformation Toolbox

The XML Transformation Toolbox page provides elements for modeling and executing the transformation of an input
document into XML or other document formats under the control of an XSL Stylesheet. You can model and execute the
transformation on an XML Transform diagram.

XML Transformation Toolbox page

Image Detail

XML File generates a File Artifact element, through which you identify the
location of the input file to be transformed.

XSLT generates a File Artifact element, through which you identify the XSLT
Stylesheet to apply to the transformation.

XSD generates a File Artifact that identifies the schema against which the output of
the transformation (as directed in the Output Artifact element) is validated. The
results of the validation are written to the 'XSL' tab of the System Output window.

XML Transform generates a stereotyped Activity that performs the transformation.

Output Artifact generates a File Artifact element, through which you specify the
location of the output file generated by the transformation, on the 'Files' property
page of the element. Output from the transformation will be written to this file.

The elements can be connected to each other using Trace connectors.

Notes

To add an element to the currently-open diagram, click on the appropriate icon and drag it into position on the·
diagram; set an element name and other properties as prompted

To add a relationship, click on the appropriate icon, then click on the start element in the diagram and drag to the·
end element
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Set Diagram Properties

You can set several properties of a diagram using the 'Diagram Properties' dialog. Some properties influence the display
of the diagram and some are logical attributes that appear in the documentation.

There are several options for opening the 'Diagram Properties' dialog for a given diagram:

Right-click on the required diagram in the Project Browser and select the 'Properties' context menu option·
Double-click in the background of the open diagram·
Right-click on the background of the open diagram and select the 'Properties' option·
Select the 'Design > Diagram > Manage > Properties' ribbon option to open the 'Properties' dialog for the currently·
open diagram

In the 'Diagram Properties' dialog you can set properties including name, author and version information, zoom factor,
paper size and layout, diagram notes and various appearance attributes.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Update Diagrams' permission to change diagram properties

Using the 'Diagram - Gradients and Background' page of the 'Preferences' dialog, you can define the default diagram·
background color and color gradients for all your diagrams; these settings are also applied to any Diagram Theme
you apply across your model
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General Tab

You use the 'General' tab of the diagram 'Properties' dialog to record facts concerning the diagram as an object, such as
its title, version and modification date.

Access

Ribbon Design > Diagram > Manage > Properties > General

Layout > Diagram > Manage > Properties > General

Context Menu Right-click diagram in Project Browser | Properties | General

Right-click background of open diagram | Properties | General

Set Diagram Properties

Option Action

Name Defaults to the name of the parent Package, as the name of the diagram.

If necessary, overtype the field with a different diagram name. You can change the
diagram name in this field whenever necessary.

Author Defaults to the name of the person who created the diagram.

If necessary, overtype the field with a different author name, or click on the
drop-down arrow and select a name from the list. You might do this if the diagram
becomes the responsibility of another person.

Version Displays the version number (or other version reference) that has been manually set
for the diagram. If this is a cloned diagram, the version number will have been
defined as part of the cloning process. If no number has been set, the field defaults
to 1.0.

To update the version number, overtype the field.

Filter to Version Select this checkbox to filter the elements on the diagram and mute those that do
not have the same version number as the diagram. This is of particular value when
you are working on the elements of a cloned diagram and want to distinguish which
have been cloned to match the diagram and Package structure and which are still
the same version as the source.

You can use the facility to check more generally which elements are not of the
same version as the diagram, such as when you drag elements from the Project
Browser as links to local or, more especially, external elements.

The filter takes effect when you click on the OK button.

Stereotype (Optional) Type in the name of a diagram stereotype to apply, or click on the
drop-down arrow and select a stereotype from the list.

You can define stereotypes to select here using the 'Configure > Reference Data >
UML Types' ribbon option, selecting the 'Stereotypes' page and creating stereotypes
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with a 'Base Class' of 'Diagram'.

Created Automatically displays the date on which the diagram was created.

If necessary, overtype the field with an amended creation data, or click on the
drop-down arrow and select the date.

Modified Automatically displays the date and time when the diagram was last modified.

Notes Type in any additional information on the diagram. You can format the notes using
the Notes toolbar at the top of the field.

OK If you have finished updating the diagram properties, click on this button to save
the changes and close the 'Properties' dialog.

Cancel If you do not want to save the changes you have made, click on this button to
discard the changes and close the dialog.

Help Click on this button to display this Help topic.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Update Diagrams' permission to update diagram properties
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Configure Diagram Display

A diagram can show or hide information, and represent it in different ways depending on how you configure the display
characteristics. You can maintain your display configuration using the diagram 'Properties' dialog ('Diagram' tab).

Access

Ribbon Design > Diagram > Manage > Properties > Diagram

Layout > Diagram > Manage > Properties > Diagram

Context Menu Right-click diagram in Project Browser | Properties | Diagram

Right-click background of open diagram | Properties | Diagram

Set the diagram display options

Option Action

Use Alias if Available Select this checkbox to display the element alias as the element's name, wherever
the alias is specified.

Show Additional Parents Select this checkbox to show the names of all parent elements not in the current
diagram, for all Classes and Interfaces.

Hide Page Border (All
Diagrams)

Select this checkbox to disable the display of page borders on all diagrams in the
model.

Hide Page Border (Current
Diagram)

Select this checkbox to disable the display of the page border on the current
diagram only. (Disabled if 'Hide Page Border (All Diagrams)' is selected.)

Show Diagram Details Select this checkbox to show diagram details in a note in the top left corner of the
diagram.

Deselect the option to hide the diagram details.

Show Sequence Notes (On a Sequence diagram) Select this checkbox to display the internal Notes for
each Message down the left-hand edge of the diagram. Each note has the same
number as the Message it comes from.
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Whiteboard Mode Select this checkbox to display the diagram as if it had been drawn on a whiteboard,
with white fill and background.

(This illustration also has 'Hand Drawn' mode enabled.)

Disable fully scoped object
names

Select this checkbox to disable the use of fully scoped object names for elements in
this diagram.

This option hides the 'Namespace::element Name' if 'Show Namespace' is selected,
but not the '(from 'Namespace')' label.

The effect of this option is disabled if 'Fully Qualified Namespace' is also selected.

Hand Drawn Select this checkbox to display the diagram contents as if they had been roughly
drawn by hand.

Show Namespace Select this checkbox to show the namespace of each element on the diagram.

For Class, Interface, Enumeration, Component, Node and Artifact elements, the
namespace is shown as part of the element name; that is, 'Namespace::element
Name'.

For elements of other types, the namespace is shown as a '(from 'Namespace')' label
beneath the element.

Fully Qualified Namespace (Enabled when 'Show Namespace' is selected) Select this checkbox to show the
fully qualified namespace of each element on the diagram, as a '(from 'Namespace')'
label under the element.
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Show Shape Scripts Defaults to selected to show elements and connectors with their Shape Scripts, on
the diagram. Clear the checkbox to show elements and connectors in their native
shapes.

This option does not affect Custom Compartments. To hide those, deselect the
appropriate 'Show Compartments' checkboxes on the 'Elements' tab of the 'Diagram
Properties' dialog, or the element 'Feature Visibility' dialog.

Display Element Lock
Status

Select this checkbox to add a locking indicator (! or !) outside the top left corner of
each locked element on the diagram.

If the element is:

Fully locked or locked by another user, the indicator is red·
Locked by you or by another user in the same user group as you, the indicator·
is blue

Not locked, no indicator displays·

Always Open as Element
List

Select this checkbox to always display the diagram contents as a Diagram List
rather than as a diagram.

Always Open as Gantt Select this checkbox to always display the diagram contents as a Gantt chart.

Page Setup Adjust the scaling of the diagram image according to the size of the page it is to be
printed on.

Print Page Header and
Page Footer

Select this checkbox to add page headers and footers to a print-out of the diagram.
The headers and footers are generated from the diagram characteristics, such as the
name of the creator and the date of modification.

Background Tile
Click on the  button and select a background tile design to apply just to this
diagram. The filename of the background design file displays in the left-hand field.

If you no longer want to apply a background tile to the diagram, click on the Clear
button.

Document Generation
Options

These are options for generating document reports that include the selected
diagram.

Exclude image from
Documentation

Select this checkbox to exclude this diagram image from any document report
generated on the parent Package or element.

Document each contained
element in Documentation

Select this checkbox to include documentation on each element in this diagram, in
any document report generated on the parent Package or element.

Divide Diagram into
Multiple Pages

Select this checkbox to divide each large diagram into separate pages in the
document report.

Rotate Images Select this checkbox to rotate each diagram image by 90 degrees in the document
report.
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Default Zoom This facility is enabled when the selected diagram in the 'Diagram Properties' dialog
is open and available for editing in the Diagram View.

Zoom in or out of the diagram to achieve the required magnification using either
Ctrl+mouse wheel before you open the 'Diagram Properties' dialog, or the slider
control on this 'Diagram' page. Click on the Set as Default button. Now, each time
the diagram is opened, it will default to this zoom level.

This diagram-local default zoom overrides any global zoom setting you have
imposed for your user ID, using the slider in the Status bar.

Set Layout Style Click on this button to define the layout of the diagram, to be applied automatically
when you select the 'Layout Diagram' options.

OK If you have finished updating the diagram properties, click on this button to save
the changes and close the 'Properties' dialog.

Cancel If you do not want to save the changes you have made, click on this button to
discard the changes and close the dialog.

Help Click on this button to display this Help topic.

Notes

The 'Divide Diagrams into Multiple Pages' option is only effective when the 'Scaled Printing' option on the 'Print·
Advanced' dialog is set to 'None'

'Rotate Images' is only available for bitmap (.bmp) images·
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Define Element Characteristics

It is possible to show a number of element characteristics on a selected diagram. You can define which of these
characteristics to show, by selecting the corresponding check boxes on the 'Elements' tab of the diagram 'Properties'
dialog (and, conversely, which to hide by clearing their check boxes). You can also override the model default coding
language and set a different language for the elements in the context of this diagram.

Access

Ribbon Design > Diagram > Manage > Properties > Elements

Layout > Diagram > Manage > Properties > Elements

Context Menu Right-click diagram in Project Browser | Properties | Elements

Right-click background of open diagram | Properties | Elements

Set Component Display Options

Option Action

Use Stereotype Icons For elements that have whole shapes drawn by Enterprise Architect (such as
Analysis stereotypes), select this checkbox to draw the alternative shape (if
defined).

For elements that have an icon displayed in the top right corner (such as an Artifact
element), if 'Show Element Stereotypes' is selected, select this checkbox to display
the stereotype icon instead of the stereotype text.

Show Element Stereotypes For elements that have whole shapes drawn by Enterprise Architect, if 'Use
Stereotype Icons' is deselected, select this checkbox to display any stereotype on
the element.

For elements that have an icon displayed in the top right corner, select this
checkbox to indicate that a stereotype is present (icon if 'Use Stereotype Icons' is
selected, text if not).

Show Port Classifiers Select this checkbox to show the classifier of each Port on the diagram.

Collapse Embedded
Elements

Reduces embedded elements to black dots on the parent element border, on the
current diagram. Each black dot represents one embedded element or one hierarchy
of elements; for example, a Port with an Interface collapses to one dot.

                  

This simplifies the information presented by the diagram, when the embedded
elements are currently not the focus of interest.
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You can move the dot representing an embedded element, but you cannot create
new embedded elements or connectors involving embedded elements on the
diagram whilst this option is in use.

Show Data Model Owner Select this checkbox to display the owner of each Table element in the diagram.  

This is defined in the Owner Tagged Value on the table or, for PostgreSQL, Owner
To.

Show Element Property
String

Select this checkbox to show the advanced property string for all elements; for
example, {leaf}.

Show Compartments Select each checkbox to show the corresponding named feature or property
compartment for all elements using rectangle notation on the diagram:

Attributes·
Operations·
Tags (Tagged Values)·
Requirements·
Constraints·
Testing (Testing Scripts)·
Maintenance (Maintenance Scripts)·
Package Contents·
Notes·

Deselect the checkbox for each compartment you want to hide.

If you have added custom compartments to your model display, such as Related
Elements, Flow Ports or Parts, 'Show Compartments' checkboxes are also listed for
each of them. These checkboxes default to selected to show the compartments on
the diagram; deselect the checkboxes to hide the compartments.

If the checkboxes do not seem to operate for an element on a diagram, also check
the 'Feature Visibility' settings for that element.

Language Click on the drop-down arrow and select the programming language that elements
created on this diagram receive, overriding the model default language.

If you do not want to override the model default, select the value <none> from the
drop-down list.

OK If you have finished updating the diagram properties, click on this button to save
the changes and close the 'Properties' dialog.

Cancel If you do not want to save the changes you have made, click on this button to
discard the changes and close the dialog.

Help Click on this button to display this Help topic.
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Features Tab

The features - attributes and operations - of an element have a number of properties that you can show or hide on a
diagram, or use to show or hide the features themselves. You control how the features are displayed using the 'Features'
tab of the diagram 'Properties' dialog.

Access

Ribbon Design > Diagram > Manage > Properties > Features

Layout > Diagram > Manage > Properties > Features

Context Menu Right-click diagram in Project Browser | Properties | Features

Right-click background of open diagram | Properties | Features

Define the display of features on the diagram

Option Action

Show Qualifiers and
Visibility Indicators

Select this checkbox to show the qualifiers and visibility indicators of each feature
on the diagram.

Qualifiers include such things as the 'derived' symbol (/) and the public key symbol
(PK).

Visibility indicators include such things as +, -, # and ~, which indicate the scope of
access of the item (such as an attribute, operation or role).

Show Stereotypes Select this checkbox to show the stereotypes of all features that have them.

Deselect the checkbox to hide the stereotypes.

Show Property String Select this checkbox to show the advanced property string for all element features,
for example, {readOnly}.

Show Operation Return
Type

Select this checkbox to display the return data type of each operation.

Suppress Brackets for
Operations Without
Parameters

Select this checkbox to suppress brackets on operations that have no parameters;
that is, Opn; rather than Opn();.

Always Show Linked
Features

Select this checkbox to force display of linked attributes and operations, regardless
of the setting of any other option that might hide them.

Visible Class Members Select the appropriate checkboxes to show Class members according to their scope
and methods that specify properties.

Show Attribute Detail Click on the drop-down arrow and select whether to show both the attribute name
and type, or the attribute name only.
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Show Parameter Detail Click on the drop-down arrow and select how to display method parameters:

None - No details shown·
Type Only - Show the type of parameter only·
Full Details - Show all details of each parameter·
Name Only - Show the name of the parameter only·

OK If you have finished updating the diagram properties, click on this button to save
the changes and close the 'Properties' dialog.

Cancel If you do not want to save the changes you have made, click on this button to
discard the changes and close the dialog.

Help Click on this button to display this Help topic.
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Connectors Tab

It is possible to control a number of aspects of how connectors are shown on a diagram, using the 'Connectors' tab of the
diagram 'Properties' dialog.

Access

Ribbon Design > Diagram > Manage > Properties > Connectors

Layout > Diagram > Manage > Properties > Connectors

Context Menu Right-click diagram in Project Browser | Properties | Connectors

Right-click background of open diagram | Properties | Connectors

Define connector appearance

Option Action

Show Relationships Select this checkbox to show connectors between elements in the current diagram.

Deselect the checkbox to hide all connectors on the diagram.

Show Collaboration
Numbers

(In Communication diagrams) Select the checkbox to show the group numbering on
Communication Messages.

Messages are added to Association connectors in the Communication diagram.

Show Non-Navigable Ends Select this checkbox to indicate when Association ends are not navigable; a cross is
shown on each non-navigable end of an Association connector.

Show Connector Property
String

Select this checkbox to show the property strings (constraint text) for connectors.

Suppress All Connector
Labels

Select this checkbox to hide all connector labels on the diagram.

Show Stereotype Labels Select this checkbox to show a label on each connector indicating the connectors'
stereotype.

Deselect the checkbox to hide these stereotype labels.

Connector Notation Click on the drop-down arrow and select the required connector notation:

UML 2.1 - use the standard UML 2.1 notation for connectors·
Information Engineering - use the Information Engineering (IE) connection·
style

IDEFX1 - use the Integrated Definition Methods IDEFX1 connection style·

OK If you have finished updating the diagram properties, click on this button to save
the changes and close the 'Properties' dialog.
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Cancel If you do not want to save the changes you have made, click on this button to
discard the changes and close the dialog.

Help Click on this button to display this Help topic.
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Theme Tab

A Theme is a definition of the display characteristics for a diagram, such as the text font used or the background colors
of the elements and diagram. You generally create and/or select a theme to apply to all diagrams across the model, but
you can apply a different (existing) theme to a selected diagram, using the 'Theme' page of the diagram's 'Properties'
dialog.

Themes applied to diagrams are model-based rather than user-based. If the diagram is imported into a model without an
applied theme, the global theme will be used instead.

Access

Ribbon Design > Diagram > Manage > Properties > Theme

Layout > Diagram > Manage > Properties > Theme

Context Menu Right-click diagram in Project Browser | Properties | Theme

Right-click background of open diagram | Properties | Theme

Select Theme

Option Description

Theme Click on the drop-down arrow and select the theme to apply to the current diagram.
The field defaults to the value 'Use global theme', which applies the theme selected
on the 'Diagram > Theme' page of the model 'Preferences' dialog.

Font Select the check box to apply the 'User Font Face' and 'Font Size' settings assigned
to the selected theme on the 'Appearance' page of the model 'Preferences' dialog.

Deselect the check box to apply the font from the global theme on the 'Preferences'
dialog.

Color Select the check box to apply the element, connector and diagram colors assigned
to the selected theme on the 'Gradients and Background' page and the 'Standard
Colors' page of the model 'Preferences' dialog.

Deselect the check box to apply the colors from the global theme on the
'Preferences' dialog.

Line Thickness Select the check box to apply the default element border width and connector line
thickness assigned to the selected theme on the 'Appearance' page and 'Link' page
of the model 'Preferences' dialog.

Deselect the check box to apply the line widths from the global theme on the
'Preferences' dialog.

Gradient Select the check box to apply the gradient of the diagram background color and
element fill color, as assigned to the selected theme on the 'Gradients and
Background' page of the model 'Preferences' dialog.

Deselect the check box to apply the gradients from the global theme on the
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'Preferences' dialog.

Background Image Select the check box to apply the diagram background image assigned to the
selected theme on the model 'Preferences' dialog.

Deselect the check box to apply the image from the global theme on the
'Preferences' dialog.

Element Shadows Select the check box to apply the element shadow setting ('on' or 'off') and color
assigned to the selected theme on the model 'Preferences' dialog.

Deselect the check box to apply the shadow setting and color from the global theme
on the 'Preferences' dialog.

OK Click on this button to apply the theme aspects you have defined on this tab, and to
close the 'Properties' dialog.

Cancel Click on this button to abort the changes you have made and close the 'Properties'
dialog.

Help Click on this button to display this Help topic.
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Diagram Context Menu

You can perform a wide range of tasks and operations on a diagram and its contents. To access and initiate these
operations, you can select options from the diagram context menu.

Access

Context Menu Right-click on diagram background

Options

Option Action

Extensions Select this option to access a submenu of enabled Technologies on the system (for
example, ArcGIS or TOGAF), each of which provides options for performing
technology-specific operations on the diagram.

This option is available in the Professional, Corporate and Extended editions of
 Enterprise Architect.

Scripts Select this option to list the scripts available for execution directly from the
diagram.

The option is not listed if there are no diagram scripts available.

Properties Select this option to display and/or edit the diagram properties, using the 'Diagram
Properties' dialog.

New Element or Connector Select this option to add an element or connector to the diagram, by selection from
a context-sensitive list.

Insert Other Element Select this option to locate an existing element using the 'Select Element' dialog,
and insert it into the diagram as a linked element.

Synchronize Structural
Elements

Select this option to show, on a SysML Internal Block diagram, all structural
elements (such as Ports and Parts) relating to the Block that owns this diagram.

This command will also generate Properties defined by existing Association
connectors.

Hide Diagram Frame /
Show Diagram Frame

The elements on the diagram are automatically enclosed in a Diagram Frame
having the name of the Block element that owns the diagram. Click on these
options to hide and redisplay this Diagram Frame. This option applies to these
diagram types when the diagram is a composite diagram:

SysML Internal Block·
SysML Activity·
SysML Parametric·
SysML StateMachine·
UML StateMachine·
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Advanced Select this option to access the options for more advanced operations, such as
comparing the diagram to a Baseline or creating a Working Set Artifact.

Paste Element(s) as Link /
Paste Element(s) as New

Select these options to paste copied elements into the diagram as links or as new
elements.

Paste Image from
Clipboard

Select this option to paste an image held on the clipboard into the diagram.

Shortcut: Ctrl+Shift+Insert

Paste as Image Asset Select this option to paste the contents of the clipboard as a new Image Asset
Artifact on the diagram.

View as List Select this option to display the diagram contents as a Diagram List instead of as a
pictorial diagram.

View as Gantt Select this option to display the diagram contents as a Gantt chart instead of as a
pictorial diagram.

Statechart Editor For a StateMachine diagram, select this option to switch the current format of the
diagram to:

Diagram·
Table (State-Next State)·
Table (State-Trigger) or·
Table (Trigger-State)·

Swimlanes and Matrix Select this option to add or modify Swimlanes or a Swimlanes Matrix on the
diagram.

Roadmap Options Select this option to display the 'Roadmap options' dialog, which you use to define
a Roadmap Timeline on the diagram.

Kanban Select this option to display the 'Kanban' dialog, through which you can define the
structure, content and appearance of a new or existing Kanban diagram, or to
convert a different type of diagram to a Kanban diagram.

Lock Diagram Select this option to lock the diagram to protect it from inadvertent changes.

This does not apply in the Corporate, Business and Software Engineering, Systems
Engineering and Ultimate editions if security is enabled, in which case you lock the
model elements.

Context Filtering Select this option to toggle context filtering within the diagram view.  By default,
this will highlight the currently selected element and related elements within the
diagram while making all other elements appear faded into the background.

Make all Elements
Selectable

Select this option to make all the elements on the diagram selectable.

If an element is:

Selectable, you can move it around the diagram and perform right-click·
context-menu operations

Unselectable, you cannot move it around the diagram and the only right-click·
operation available is to make the element selectable

This option has no effect on double-click operations on the element, such as
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displaying child diagrams.

Modify Element Z Order Select this option to re-sequence overlapping objects in the diagram.

This option both:

Numbers the objects in the diagram by Z-order, in red, and·
Lists the objects by Z-order in the 'Modify Z Order' dialog·

In the dialog, you select the required object and move it up or down in the Z-order
using the Up and Down Arrow keys, each click on an Arrow key changes the
Z-order by 1.

When you select the object in the list, that object is also selected on the diagram
and its Z-order number is shown in blue.

Click on the OK button to save your changes.

On the diagram, you can move the focus from element to element according to Z
Order, by pressing Shift+Tab. Each time you press these keys, the element with the
next-lowest Z Order number is selected.

Clear all Checklists Select this option to clear all selected checkboxes within every Checklist Artifact
element in the current diagram.

Find in Project Browser Select this option to locate the current diagram in the Project Browser.

Shortcut: Shift+Alt+G

Add to Working Set Select this option to add the diagram to a Working Set, to display automatically
when you open the model.

Set as User Default
Diagram

(Available in the Corporate, Business and Software Engineering, Systems
Engineering and Ultimate editions of Enterprise Architect; User Security must  be
enabled.)

Select this option to make the current diagram the default diagram displayed when
you re-open this model.

The User Default diagram overrides the Model Default diagram; the User Default
setting is itself overridden by a project shortcut, which defines displays to present
on opening the project.

To cancel a User Default diagram, either:

Create a dummy diagram, set it as the User Default and delete it, or·
Delete the original diagram (if it is no longer relevant)·

This still blocks the Model Default diagram, whilst security is enabled; to
re-establish the Model Default diagram, set it as the User Default.

Import from source file(s) Select this option to import, or reverse engineer, source code (the option is not
available in the Desktop edition).

Import DB schema from
ODBC

Select this option to import database tables from an ODBC data source (the option
is not available in the Desktop edition).

Save Current Changes Select this option to save any changes to the current diagram.

Shortcut: Ctrl+S

Execute Simulation Select this option to list and select from three further options for performing a
model simulation on a behavioral diagram:

'Interpreted simulation' - Perform dynamic execution of a simulation·
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(Corporate and Extended Editions)

'Manual simulation' - Step through a simulation manually (the only option·
available in the Professional edition)

'Using Script' - If simulation scripts exist for the diagram, list the scripts·
available; if no scripts exist, the option does not display

Help Select this option to view the Help on this type of diagram.

Notes

Not all the menu options described appear on the context menu of every diagram·
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Insert Elements and Connectors

When you click on the 'Diagram | New Element or Connector' context menu option, a list of elements and connectors
displays. This is the 'Toolbox Shortcut menu'.

Structure

The 'Toolbox Shortcut' menu is divided into sections:

Other - expands to offer options to select elements and connectors from diagram types other than either the current·
diagram type or pinned Toolbox pages

The expanded list of elements and connectors for the current diagram type·
Collapsed lists of elements and connectors for pages that have been pinned in the Toolbox; if an MDG Technology:·
    - is active
    - automatically pins Toolbox pages, and
    - has pages that redefine UML or Extended pages
then the MDG Technology pages override the UML or Extended pages, which are not shown

At the end:·
    - 'Common' expands to display a list of the common elements and connectors, and
    - 'Artifact' expands to display a list of the different types of Artifact element you can create

Notes

The list of elements and connectors also displays on the diagram if you press Ctrl or Shift as you right-click the·
mouse, or if you press Spacebar or the Insert key while the cursor is on the diagram
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Advanced Diagram Submenu

You can perform a number of advanced tasks and operations on a diagram and its contents. To access and initiate these
operations, you can select options from the diagram 'Advanced' submenu.

Access

Context Menu Right-click on diagram background | Advanced

Options

Option Action

Compare Diagram to
Baseline

Select this option to perform a comparison of the diagram layout against a version
from a previously saved baseline.

This option can be used to roll back individual changes made to the diagram since
the baseline was created.

Save as Profile Select this option to save the current diagram as a Profile.

Create Working Set
Artifact

Select this option to create a Working Set Artifact on the diagram, to define a
Working Set that includes an instruction to open the diagram.

Set Theme Select this option to set the Theme to apply to all diagrams that you display in the
model.

The 'Preferences' dialog displays, at the 'Diagram > Themes' page.
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The Quick Linker

If you want to create new elements and connectors quickly on a diagram, you can use the Quick Linker on an initial
element to guide you in creating related elements and connectors of the appropriate types, without having to weigh up
the full range of options from the Diagram Toolbox.

The Quick Linker consists of paired menus that list the commonest objects appropriate to the context of the selected
element. You simply choose the type of element you need from the first menu, and that displays the second menu
offering a choice of appropriate types of connector between the original and new elements. When you select the
connector, you create a new element connected to your initial element, complete with any subordinate objects such as
Object Nodes and Action Pins.

If you drag the Quick Linker arrow onto an existing element on the diagram, only the connector menu displays, so that
you select the type of connector to create between the two existing elements.

There are two methods of accessing the Quick Linker menus.

Access

Action Detail

Click on Quick Linker
Arrow

When you click on an element in a diagram, the Quick Linker arrow is displayed at
the upper right corner of the element:

Click on this arrow and drag it in the direction in which you want to create the new
connector and element. When you release the mouse button, the element menu
displays. When you select an element type, the connector menu displays.
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When you select the connector type, the element and connector are added to the
diagram in the location in which you displayed the menus.

Press Ctrl+Shift+Arrow
key

After selecting the element, press Ctrl+Shift and the keyboard arrow key for the
direction in which you want to create the new connector and element (Right, Left,
Up or Down).

The element and connector menus display as above. When you select the type of
connector, the new element and connector are created off the edge of the element
appropriate to the arrow key you pressed. For example, if you press the Right arrow
key, the new element is created to the right of the original element.

Notes

When using the Ctrl+Shift+<arrow key> method on a Sequence diagram, you cannot use the Up or Down keys; the·
Right and Left keys create a connector to a Lifeline element

When using the Ctrl+Shift+<arrow key> method on a Timing diagram, you cannot use the Right or Left keys·
If the connectors and elements suggested by the Quick Linker do not include the types you need, you can create·
them from the Diagram Toolbox pages

A Technology Developer can create new or different lists and combinations of elements and connectors·
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Create New Elements

The elements and connectors listed on the two menus depend on the type of the element you initially selected; for
example, if you click on the Quick Linker arrow for a Class, the options are not the same as if you clicked on the arrow
for an Actor. However, in either case the menus show the most appropriate, commonly used target elements and
connectors for that initial element; you can create other target elements and connectors by selecting them from the
appropriate Toolbox page.

Certain types of element - such as Action and Artifact - are available in a range of subtypes. You can select which
subtype to create by holding down the Ctrl key as you select the main element type and connector. For an:

Action element, the 'New Action' dialog displays from which you select the Action subtype, such as CallOperation·
or SendObject

Artifact element, a submenu displays from which you select the Artifact subtype, such as Report Specification or·
Checklist

Notes

For rapid modeling, you can suppress the element 'Properties' dialog when creating new elements; see the option·
'Start > Workspace > Preferences > Objects : Edit Object on New'

You can create a connector to an existing classifier from the Project Browser, by pressing Shift while clicking on the·
type of connector; the 'Select existing element' dialog displays on which you browse for and select the element, then
the connector and element are added to the diagram
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Create Connectors

The connector list does not actually display until you release the mouse button over the target element; however, a dotted
line shows where the connector would be at any point, and a hatched outline displays within the border of an element as
you move the cursor onto it - this helps you identify where the connector should connector to, if there are many
closely-arranged elements, Parts, Ports or other extensions.

The list contains the most appropriate, commonly-used types of connector for the source and target element types. If you
want to use a different type of connector, select the appropriate Toolbox page, click on the required connector and then
on the source element, and drag across to the target element.

Notes

You can quickly create a Notelink to attach a Note or Constraint to a connector, simply by dragging the Quick·
Linker arrow on the Note element onto the connector
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Working In Diagrams

Enterprise Architect provides a wide range of facilities for creating, editing and managing the diagrams that represent
aspects of your models.

Facilities

Facility

Create a UML diagram, Extended diagram or MDG Technology diagram in your model, through the Project
Browser.

Set or change various properties of a diagram, such as the diagram name, through the diagram 'Properties' dialog.
Some properties influence the display of the diagram and some are logical attributes that appear in the
documentation.

Display a Diagram Properties Note on the diagram. A Diagram Properties Note is a simple fixed-text box containing
the diagram name, author, version, creation date and modification date. You can move this text box to any point on
the diagram.

Add new elements and connectors to a diagram using the Diagram Toolbox pages specific to the diagram type, or
other Toolbox pages as you need.

Add new elements and connectors to a diagram using the Quick Linker facilities.

Drop existing elements from the Project Browser into the diagram.

Drop elements copied from a diagram into another diagram.

Change the Z-order of selected elements on the diagram, to define which elements might lie over or underneath
other elements.

You can convert a tabbed diagram in the Diagram View into a floating diagram. In this case, you can move or copy
elements between that diagram and another floating diagram or tabbed diagram.

Move sections of the diagram independent of the rest of the diagram.

Automatically resize the selected elements on the diagram to the default size for the element type, or as close to it as
the element contents allow.

Identify which other elements are related to a selected element on the diagram and, if necessary, add one or more of
those other elements to the diagram.

Generate virtual images of connector end elements, to simplify complex and extended relationships on a diagram.

Control the display of labels around elements and connectors on the diagram.

More precisely represent realized interfaces of a Class on your diagram.

Expand the contents of a Package element within a diagram.
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Manage the visibility of a range of element features on the diagram.

Undo and redo the immediately previous changes to the diagram.

Pan across and down a large diagram, and zoom into or out of the diagram display.

Select and move elements on the diagram using keyboard keys ('hotkeys').

Switch between the currently-open diagrams and views in the Diagram View.

Change a diagram from one type (such as Class) to another (such as Data Modeling).

Flag a selected diagram as the Model Default diagram for your project, or your User Default diagram.

Scale down the Printable image of the diagram to fit the size of paper it is being printed on.

Set the scrollable/printable area of the diagram display area.

Present a set of diagrams in a Model Views slideshow.

Lock the current diagram so that it cannot be updated.

Create a duplicate copy of an existing diagram.

Copy an image of the diagram to a file on disk, in a range of graphic file formats.

Copy an image of the diagram to the MS Windows clipboard.

Delete one or more diagrams from the model.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have Update Element permission to update or delete items on a diagram,
and Manage Diagram permission to create, copy or delete diagrams
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Add New Diagrams

Enterprise Architect provides a number of ways in which to create a new UML diagram, Extended diagram or MDG
Technology diagram in your model. The principal method is to select the Package or element under which to create the
diagram and select a menu option to add it, as explained here.

Add a new diagram to the model

Step Action

1 In the Project Browser, click on the Package or element under which to place the diagram.

2 Either:

In the Project Browser header bar, click on the labeled button and select the 'New Diagram' option, or·
Right-click on the object to open the context menu and select the 'Add Diagram' (Package) or 'Add |·
Add Diagram' (element) option, or

Press the Insert key and select the 'Add Diagram' menu option·
The 'New Diagram' dialog displays.

3 The 'Package' field defaults to the name of the selected Package in the Project Browser. If necessary, click

on the  button and select a different Package to create the diagram under.

(The  button is disabled when you are creating a diagram under an element, and the 'Parent' field
shows the name of the element under which you are creating the diagram.)

4 The 'Diagram' field defaults to the name of the selected Package or element; if necessary, type a different
name for the new diagram.

5 In the 'Select From' panel, click on the appropriate technology or category for the diagram.

The 'Diagram Types' panel displays a list of the diagram types for the selected category.

6 In the 'Diagram Types' panel, click on the type of diagram to create.

7 Click on the OK button to create your new diagram.

Enterprise Architect checks whether there is a template diagram for this diagram type in the Templates
Package and, if so, applies the display characteristics defined in that template.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Manage Diagrams' permission to create new diagrams

The diagram type determines the default Toolbox associated with the diagram and whether it can be moved as a·
child of another element in the Project Browser (for example, a Sequence diagram under a Use Case)
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Insert Diagram Properties Note

On a diagram, it is possible to display a customized text box called the Diagram Properties Note, which automatically
shows the diagram properties:

Name·
Author·
Version·
Creation date and·
Modification date·

You can move this Note around the diagram and change its appearance, and you can create several instances of it to, for
example, put the property information on each page of the diagram. You cannot change the content.

Access

Ribbon Layout > Diagram > Manage > Show Property Note

Other Drag the Diagram Notes icon from the Common page of the Toolbox onto the
diagram

Click on the Diagram Properties Note icon in the UML Elements toolbar and click
on the diagram

Notes

The Diagram Properties Note is not the same as the Diagram Details Note, which displays if the 'Show Diagram·
Details' checkbox is selected on the 'Diagram Properties' dialog; this always displays in the top left corner of the
diagram - you cannot move it, change its appearance or have more than one instance of it on the diagram
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Drop Elements from Project Browser

As well as creating new elements in the current diagram, you can drag existing elements (individually or as a group)
from the Project Browser into the diagram. To select multiple elements, click on the element names in the Project
Browser while pressing and holding:

Ctrl to add single items to the selection of multiple elements, or·
Shift to select all the elements between the first and last selected items·

When you drag an element onto a diagram from the Project Browser, the system response depends on whether you are
dragging a Package element or any other type of element. For information on dragging a Package element onto a
diagram, see the Drop Packages topic.

Access

Other Drag existing element(s) from the Project Browser onto the diagram

(If the 'Drop <element> from Project Browser' dialog does not display, press Ctrl
while dragging the elements)

Select Paste options

Option Action

Drop as Click on the drop-down arrow and select one of the drop types:

Link - Drop the element as a simple link: in this case the one element is·
represented in the Project Browser and in any diagram to which it has been
added; changes to the element are reflected in all diagrams in which it is shown

Lifeline - (On Sequence diagrams) Drop a copy of the element as a separate·
Lifeline element, classified by the original element

Instance - (On diagrams other than Sequence) Drop a copy of the element as a·
separate instance of the original element, classified by the original element

Invocation - Drop a copy of a StateMachine or Activity element as an·
invocation of the source element; the resulting element is a State object or
Action - respectively - with the source element as its classifier

Property - Drop a copy of the element as a separate Object instance·
Attribute - (Available when dragging a classifier onto an element that supports·
attributes) Create a new attribute classified by the dragged classifier; the
attribute is automatically selected in in-place editing so that you can add the
attribute name

Child - Drop the element as a child of the copied element - that is, as a new·
 element with a Generalization connector back to the copied element; this is
very useful when you have a Class library or framework from which you
inherit new forms - for example, you can drop a Hashtable as 'MyHashtable',
which automatically becomes a child of the original Hashtable

Used with the Override Parent Operations feature, this is a quick way to create
new structures based on frameworks such as the Java SDK and the .NET SDK
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Name If the dropped element is a new element (that is, a Lifeline, Instance, Child, or
Property), this field is active; type a name for the new element.

Structural Elements If the original element has any structural elements (for example, ports and parts)
this field contains the value 'Select'. Either:

Leave this value as is, so that when you click on the OK button the 'Structural·
Elements' dialog displays, from which you can select the child elements to
reproduce with the pasted element, or

Click on the drop-down arrow and select:·
    - 'None' to not reproduce any child elements
    - 'All' to reproduce all child elements on the original element, or
    - 'Based on Instance <diagram names>' to reproduce the configuration of
child elements on an instance of the
       original element on another diagram, if there are any other instances

The resulting Object element is created large enough to display the selected child
elements laid out neatly within the Object border.

Copy Connectors This checkbox is enabled when you select to drop the copied element as an
Instance, Property or Invocation.

Select the checkbox to reproduce on the diagram any connectors between the
original element and any other elements that have also been dropped into this
diagram, as connectors between the instances.

Select for all (If dragging multiple elements onto the diagram at once.)

Select the checkbox to apply the dialog settings to all multiple-selected elements
being dragged onto the diagram, and to add the elements together.

Leave the checkbox unselected to add the elements to the diagram one at a time,
with the opportunity to change the dialog settings for each element.

Save selection as default Select this checkbox to make the current settings on this dialog the default for all
drag and drop operations from the Project Browser.

This option also deselects the 'Auto Instance' checkbox on the 'Diagram > Behavior'
page of the 'Preferences' dialog. The automatic drop operation becomes whatever
you have set on the 'Drop ... from Project Browser' dialog, and is not overridden by
the drop-as-Instance imposed by the 'Auto Instance' checkbox.

The default setting you apply on Sequence diagrams is separate from the default for
other types of diagram. Therefore, you can set the default to 'Lifeline' (if you prefer)
and this does not affect or  get changed by the default you might set for other types
of diagram.

Hold Ctrl to Show this
dialog

Select this checkbox to display this dialog for drag and drop operations only if you
press and hold Ctrl as you drag the element onto the diagram.

If you select this option, you can drag elements from the Project Browser without
displaying the dialog; the paste operation complies with whatever settings you used
the last time you opened the dialog. To change these settings, hold Ctrl as you drag
an element, and edit the field values on the dialog.

OK Click on this button to complete the drop operation and close the dialog.

Cancel Click on this button to cancel the drop operation and close the dialog.

If you have selected multiple elements, the first-selected element is not dropped,
but the remainder are.
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Cancel All (If dragging multiple elements onto the diagram at once.)

Click on this button to cancel the insertion of all the multiple-selected elements
being dragged onto the diagram.

Notes

Not all drop options apply to all element types; for many types, the only option available is 'Link'·
When an element dragged from the Project Browser is dropped into the diagram, its default style and size is applied·
rather than any alternative styles and sizes used for instances of the element in other diagrams

When using the 'Drop as - Instance' option, if the Instance is the same element type as the Classifier, then any·
stereotype that has been applied to the Classifier will be propagated to the Instance also
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Drop Packages

When you drag a Package element from the Project Browser onto the current diagram, you can drop it into the diagram
as one of a number of different objects, by simple selection from a menu.

Access

Other Drag existing Package(s) from the Project Browser onto the diagram

Select Drop options

Option Action

Package element Drop the Package as an element representing the Package in the Project Browser  (a
simple link): in this case any changes to the Package are reflected in all diagrams in
which it is shown.

Report Specification linked
to package

Drop the Package as a Report Specification linked to the Package; a Report
Specification is a stereotyped Document Artifact element from which you can
generate a report and view the report as a linked document of that element.

Graph based on package
contents

Drop the Package as a Pie Chart or Bar Chart that you can edit to graphically
represent some aspect of the Package content.

Matrix profile Drop the Package as a Matrix Specification object.

Package as List Drop the Package as a Model View chart element that lists the elements within the
Package and shows the type (by icon), name, Scope, Status and Author of each
element.
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Copy And Paste Diagram Element

It is possible to copy one or more elements from an open diagram and paste them into a different diagram as either new
elements or as links to the original elements.

Copy diagram elements

Step Instruction

1 Select the element(s) to copy.

2 Either:

Select the element(s) and the 'Layout > Diagram > Edit > Copy' ribbon option, or·
Press Ctrl+C, or·

Click on the 'Copy' icon ( ) in the Default Tools toolbar·

Paste diagram elements

Step Instruction

1 Open the diagram to paste into.

2 Either:

Click on the Paste button ( ) in the Default Tools toolbar, or·
Right-click on the diagram background to open the diagram context menu·

3 Select either the 'Paste Element(s) as New' menu option (completely new element) or the 'Paste
Element(s) as Link' menu option (reference to the original element).

Notes

The Date Created and Time Created parameters of a pasted-as-new element are set to the current date and time; the·
parameters for a linked element remain the same as the copied element

You can also move elements between diagrams by cutting the elements from one diagram and pasting them into·

another; to cut the selected elements, click on the Cut button ( ) in the Default Tools toolbar
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Z Order Elements

Z Order refers to the sequence in which elements are layered through the depth of the diagram; each element on the
diagram has a specific Z-order number that - when elements overlap - determines which elements the selected element
displays over, and which underneath. You can move an element:

One place further back, deeper into the diagram·
One place further forward, towards the front of the diagram·
To the bottom of the diagram (deeper in than all other elements in the diagram)·
To the top of the diagram (further forward than all other elements in the diagram)·

Access

Ribbon Layout > Alignment > choose either 'Bring to Front' or 'Send to Back'

Context Menu Right-click on element | Z-Order : Select the appropriate option to reposition the
selected element.

Notes

This option enables you to change the Z order of a single element approximately in relation to the rest of the·
diagram; you can also select the 'Modify Z Order' option from the diagram context menu, to review and adjust the Z
Order of each element on the diagram precisely relative to each other element

On a diagram, you can move the focus from element to element according to Z Order, by pressing Shift+Tab; each·
time you press these keys, the element with the next-lowest Z Order number is selected
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Move/Copy Elements To & From Floating Diagrams

If you have converted a tabbed diagram in the Diagram View into a floating diagram, you have a number of context
menu options to move or copy elements between that diagram and another floating or tabbed diagram.

Access

Other Drag element(s) from one diagram to another and release mouse button

Move or copy selected elements

Option Action

Move to this diagram Select this option to cut the selected element or elements from the source diagram
and paste them into the target diagram.

If the moved elements are held in a different Package, when the elements are pasted
each has a label underneath identifying the parent Package.

Function Keys: Drag+Shift

Create link on this diagram Select this option to create an element or elements on the target diagram, each as an
instance of a selected element on the source diagram.

Function Keys: Drag+Alt

Copy as New Object(s) Select this option to create an element or elements on the target diagram, each as a
copy of a selected element on the source diagram.

The 'Paste Element(s) as New' dialog displays, on which you enter a new name for
each element to identify it as a new, separate element. Click on the Paste button to
complete the create task.

Function Keys: Drag+Ctrl

Instance (Object) Select this option to create an element or elements on the target diagram, each as an
object instance or invocation of an element on the source diagram. The source
element is the classifier for the new object element.

Function Keys:

as New Child
(Generalization)

Select this option to create a new child element on the target diagram, as a
generalization of the element of the source diagram.

The 'Element Name' dialog displays for each copied element, on which you enter a
new name for the element to identify it as a new, separate element.

Click on the OK button to complete the create task.

Function Keys:

Notes
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Multiple elements are processed individually, so if one element is 'illegal' the other elements are still copied and/or·
transferred

If you select multiple elements to copy as instances or generalizations, those elements must be of the same type and·
stereotype

Embedded elements are moved or copied only if they are specifically selected with the parent element·
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Move Elements In Diagram Sections

As you build up a diagram, you might find that you have to move all elements within a part of the diagram up, down or
to one side. You can do this in a number of ways.

Fine Movement

You can nudge the position of a single element or a selected group of elements in 1 pixel increments. Press Shift and
then the arrow key for the direction of movement (Right, Left, Up or Down).

Drag Selected Groups of Elements

If you want to reposition a certain group of elements, hold down the left mouse button and drag the cursor over the
elements to move (creating an outline around the elements), then click on an element within the outline and drag the
group as required.

Move Sections of the Diagram

You might need to create some space in the diagram. Selecting and moving even groups of elements around in a large
diagram can be difficult, so it is possible to just move everything beyond a certain point further away from the rest of the
diagram, without having to select the elements you are moving. To do this:

Press Alt, click on the diagram, and drag the cursor to move everything beyond the cursor in the direction of the·
movement

As you move the cursor either vertically or horizontally, a line displays on the diagram just behind the cursor. If you are
moving the cursor left, everything to the left of the line moves with the cursor. If you move the cursor up, everything
above the line moves upwards.

If you move the cursor diagonally, both vertical and horizontal lines display to create a quadrant, and everything within
the quadrant moves. For example, if you move the cursor left and down, everything below and left of the cursor is
moved.
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Autosize Elements

You can autosize an element or group of elements in a diagram to the default size for the element type (for a Class, 90 x
70 pixels at 100% zoom). However, if the element contains more information than the default size can show (such as a
long name, long attributes or additional compartments) the autosize option resizes the element to the minimum size for
displaying the information.

The size change effectively operates around the mid point of each element, so the layout and size of the diagram do not
change. Automatically changing the layout of a diagram is a different process.

Access

Context Menu Right-click on selected elements | Autosize (available only when multiple elements
are selected)

Keyboard Shortcuts Alt+Z

Notes

Not all elements resize: elements such as Events remain the same; Timing and Sequence diagrams (where position is·
crucial) are unchanged; and elements added from a profile or Shape Script maintain any size definitions imposed by
the profile

With an element image created with a Shape Script that contains a defSize command, Autosize returns the element·
to the defSize value and not the element default size
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Virtual Connector Ends

Virtual connector ends assist you to simplify complex diagrams containing many elements with multiple connectors,
supporting good layout strategies that minimize crossed relationship lines and group related elements accordingly. They
are highly effective when the element of interest is:

The focus of a large number of relationships, or·
A member of two or more groups of elements that are a distance apart on the diagram, or·
Simply used in several contexts when you currently want to focus attention on one of those contexts·

While Enterprise Architect does not support placing an element on the diagram more than once, using this strategy you
can create any number of virtual representations of the element on the diagram, so that you can show the full image of
the element in one context and have separate, simpler images of it on the same diagram in other contexts. This reduces
the number of visible connectors crossing the diagram without you having to hide the connectors individually, and helps
you create cleaner, more readable diagrams on which you can place linked elements closer together.

To achieve this, you right-click on the connector that you want to keep the element on, and select to virtualize the
appropriate connector end (source or target). The system adds a simple rectangle containing the element name and with
the element fill color to the connector end, with no other connectors on it.

Consider this example:

The diagram is relatively simple but still quite large, and the connector between the ShoppingBasket and LineItem
elements crosses another connector. You might want to simplify the diagram for any of several reasons, such as avoiding
the crossover or temporarily bringing the LineItem element more closely into the Account/Order/ShoppingBasket group
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as a simple participant. So, you create a virtualization of LineItem as the target of the Association connector to
ShoppingBasket.

Access

Context Menu On diagram | Right-click on connector | Virtualize Connector End | Target (or
Source)

Notes

A 'Virtual Element' is an extension of a connector that provides access to some of the properties of the element it·
represents

Virtualization operates on waypoints in a connector line, and therefore requires the connector line style to be set to·
Custom Line

If no waypoints exist on the connector, the operation creates one·
If you virtualize the target element on a connector, the virtual connector end displays on the last waypoint of the·
connector line
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If you virtualize the source element on a connector, the virtual connector end displays on the first waypoint of the·
connector line

You cannot virtualize both ends of a connector·
The original connector still exists, and if you click on the 'Virtualize Connector End' option again, the full connector·
redisplays and the virtual element disappears

If you click on one virtual element, the original element and all its other virtual elements are selected and·
highlighted; any changes to properties made through the 'Properties' dialog of a virtual element affect the original
element

Changes to an element's appearance (other than fill color) do not affect its virtual elements·
Virtual elements appear on prints, reports and copies of diagrams; they do not appear in lists or reports on the·
model structure

Virtual elements are specific to the diagram they are created on; if you copy a diagram (with or without virtual·
elements) and add virtual elements to the copy, those changes are not reflected in the original diagram
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Locate Related Elements

When you are reviewing an existing element on a diagram, it is possible that the diagram does not show all of the
relationships between that element and others. The related elements might be:

On the diagram, but with the relationships hidden, or·
Depicted on a different diagram·

You can quickly check what other elements have relationships with the selected element, using the Relationships
window. The right-click context menu for each relationship listed in the window also indicates if the corresponding
related element is not shown on the same diagram, by providing the 'Place Related Element in Diagram' option to add the
related element to the diagram. This is useful when you are building up a picture of what an element interacts with,
especially when reverse engineering an existing code base. To put the element in a specific position on the diagram, click
on that point.

Access

Ribbon Show > Window > Relationships

Start > Windows > Relationships

Keyboard Shortcuts Ctrl+Shift+2
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Manage Object Labels

When you create certain elements or connectors, some of the properties of the created object are displayed on the
diagram as labels offset from the object. For example, these properties display as labels:

Embedded element name·
Run state, attributes and operations (if they exist) of an element that has an alternative image·
Connector name, stereotype, constraints and/or source and target role names·

You can format and hide these labels using the 'Labels' context menu.

Access

Context Menu Right-click on a label

Options

Option Action

Edit Label (Connector Labels only.)

Select this option to display the text within a small editing box, with the cursor
within the text. Delete or add text as appropriate.

Shortcut: F2

Set Label Color Select this option to display the 'Color' dialog, on which you select a standard color
or define a custom color in which to display the label text.

Hide Label Select this option to hide the label on the diagram; to reveal the label again:

For an element label, right-click on the element and select the 'Appearance |·
Show labels' option

For a connector label, right-click on the connector and select the 'Visibility |·
Set Label Visibility' option; select the checkbox against each label to redisplay

You can also hide all connector labels on a diagram using the 'Suppress All
Connector Labels' option on the 'Connectors' tab of the 'Diagram Properties' dialog.

Bold Select this option to display the label text in bold.

Label Rotation (For embedded elements and connectors.)

Select this option to orient the label in the horizontal (default) or vertical planes.
You can rotate the text in the vertical plane either clockwise or anti-clockwise from
horizontal.

Text Alignment Select this option to align the text to the left, center or right of the label text area.
This is more apparent where there are several items of text in the label, of different
lengths.

Direction (Connector labels only.)
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Select this option to set or clear a small arrow on the label. You can choose to set
the arrow pointing to the label source or destination.

This arrow is part of the label, so if there is no label text (or if the label consists
only of spaces) there is no direction indicator.

Default Position Select this option to move the label to the position it was initially created in,
relative to the parent element or connector.

Default Color Select this option to set the label color to the default color in which it was first
created.

Notes

As labels can be concentrated on and around the element or connector, try to click on a section of the required label·
that is clear of any other label or structure

The 'Label Rotation' option is not currently available for stereotyped elements and connectors·
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Hide/Show Labels

A connector can have a number of different labels along its length and at each end. It is possible to selectively hide or
display these labels to reduce the volume of text around the connector or to focus attention on specific properties.

Access

Context Menu Right-click on connector | Visibility | Set Label Visibility

Hide or display labels on a connector

Step Action

1 On the 'Label Visibility' dialog:

Select the checkbox against each label to show, and·
Clear the checkbox against each label to hide·

2 Click on the OK button.

The diagram displays the connector with the selected labels shown.
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Show Realized Interfaces of Class

If you are modeling interfaces that are directly realized by a Class, you can render each of those interfaces as a 'lollipop'
style interface node, which protrudes from the left-hand side of the Class.

Consider this example:

The Bank Class realizes (or provides) the Internet Banking Interface. The diagram would be a useful depiction of this
simple relationship if you wanted to populate the elements with visible features and properties. However, in more
complex diagrams with more detailed realized (and dependent) interfaces, you might not want to show all the
information defining each element. Therefore you can represent the realized interface as the 'lollipop' node, and remove
the original Interface element from the diagram (but not from the model).

and then

To depict the interfaces that a Class realizes as nodes, right-click on the Class and select 'Features & Properties | Show
Realized Interfaces'. This setting only applies to the selected Class, and can be changed at any time. If you turn the
option off, in the scenario here, neither the node nor the Interface element are shown. If you turn the option back on, the
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node redisplays.

Notes

There are various mechanisms for showing that an interface is realized by one object and required by another,·
including using the Expose Interface element; however, the simplest method of representing such interactions is to
create an Assembly connector between the 'realizing' object and the 'using' object
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Open Package From Diagram

As you develop your model, you might create diagrams that show the organization and/or content of some or all of the
Packages in the model. From a Package element shown in one of these diagrams, you can quickly locate and expand the
Package in the Project Browser and open the Package default diagram in the Diagram View.

The default diagram is the first available diagram in the Package, selected in alphabetical order - for example, a diagram
called Alpha in a child Package or element several levels down opens before a diagram called Beta immediately under
the selected Package.

Access

Context Menu Right-click on Package element | Open Package

Keyboard Shortcuts Ctrl+K

(c) Sparx Systems 2015 - 2017 Page 135 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Feature Visibility

When you set up the characteristics and features of an element, you can set a collection of options to display or hide the
features of that element on a specific diagram. You can also filter the attributes and operations that are shown by scope -
such as hiding all protected attributes - or select to hide or show specific attributes and operations. The visibility you set
applies only to the current diagram, so a Class can appear in one diagram with all features displayed, and in another with
features hidden.

It is possible to hide or show inherited attributes, operations, responsibilities, constraints and Tagged Values for elements
that support those features. When the system displays inherited features, it creates a merged list from all generalized
parents and from all realized interfaces. If a child Class redefines something found in a parent, the parent feature is
omitted from the list.

Access

Context Menu Right-click element | Features & Properties | Feature and Compartment Visibility

Keyboard Shortcuts Ctrl+Shift+Y

Customize Feature Visibility

Field/Button Action

Attribute Visibility Select the checkbox against each scope that should be visible, and clear the
checkbox against each scope that should not be visible.

Operation Visibility Select the checkbox against each scope that should be visible, and clear the
checkbox against each scope that should not be visible.

Show and Custom Use these to show or hide specific operations or attributes.

If you select the 'Show' checkbox, the Custom button displays the 'Show Features in
Diagram' dialog; if you deselect the checkbox, the button displays the 'Suppress
Features in Diagram' dialog.

The two dialogs are identical. Select the checkboxes of specific features to show or
hide on the element in the diagram.

You can also use the:

'Filter by Scope' drop-down arrow to filter the list to show only features that·
have a specific scope

All button to select all operations or attributes in the list·
None button to clear the checkboxes against all selected operations or attributes·
in the list

The 'Show' checkbox, if selected, overrides the selections to display attributes or
operations in the element, other than those specifically selected in the 'Show
Features in Diagram' dialog.

When Resizing Elements Select the appropriate option for resizing the Class, object or table to manage very
wide diagram objects. Select the:
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'Resize to longest Feature' radio button (the default), so that the minimum·
width for a diagram object is determined by its longest displayed attribute,
operation or other compartment value

'Wrap Features' radio button (so that any long features are wrapped onto·
multiple lines) or

'Truncate Features' radio button (so that long features are not displayed in full)·

Inherited Features If you want to display inherited attributes and/or operations as well as directly
owned ones, select one or both of the 'Show Attributes' and 'Show Operations'
checkboxes.

Hide Stereotyped Features If you do not want to show attributes or operations that have a particular stereotype,
type that stereotype name - exactly as defined - in this field; the field is
case-sensitive.

If you want to specify more than one stereotype, separate the stereotype names with
a comma.

Show Element
Compartments

Select the checkbox against each compartment to display in the element on the
diagram.

Some technologies such as SysML define additional compartments in the element,
such as for Ports, Parts and Flow Ports. Visibility of these compartments will also
be controlled by a checkbox matching the name of the compartment.

If you select the 'Fully Qualified Tags' checkbox, the Tags compartment will
contain the full provenance of each Tagged Value (if created in Enterprise Architect
release 7.1 or later) where the same Tagged Value is used several times in different
contexts with different values. The description in the Tags compartment reads:

    <Profile>::<Stereotype>::<Tagged Value name>=<Value>

For example:

    BPMN::Activity::Activity Type = Task

You can display an informal internal or composite diagram of child elements such
as Ports, Parts and Classes within a compartment of the parent element, by selecting
the 'Structure Compartment' checkbox. The Structure Compartment acts as a
container for the child elements; Classes cannot be dragged out of the compartment,
and Ports and Parts are confined to the borders of the compartment.

If you want to apply a structure and formal relationships to the child elements,
create a proper Composite Structure diagram containing the elements and select the
'Show Composite Diagram in Compartment' context menu option.

Element Notes Select the 'Show Notes' checkbox to display, in the Notes compartment on the
element in the diagram, the text that has been typed into the 'Notes' field of the
element 'Properties' dialog.

This checkbox also enables the 'maximum chars' field, which defaults to 1000 as
the number of characters of Notes text that can be displayed. Overtype this value to
display less text or more text, as you need.

The setting applies only to the selected elements on the diagram, so you can display
full notes for the selected element whilst the other elements on the diagram have no
notes text.

You can also select the 'Render Formatted Notes' checkbox to display the text on
the diagram as formatted using the 'Notes' field toolbar.

Runstate Select the checkbox if you want to hide the object runstate of the element on the
diagram.

(Available for Ports and Parts only.) Select the checkbox if you want to display the
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Type element type.

OK Click on this button to save your settings.

The diagram redisplays with the appropriate level of feature visibility.

Notes

To show features for element types that do not have visible compartments, such as Use Cases and Actors, right-click·
on the diagram object to display the context menu and select the 'Advanced | Use Rectangle Notation' option
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Undo Last Action

When you are editing diagrams, moving, re-sizing and deleting elements and deleting connectors, and you make a
mistake, you can work back through multiple levels of undo to roll back the error.

Access

Ribbon
Layout > Undo >  Undo

Keyboard Shortcuts Ctrl+Z

Other
Click on the Undo button in the Default Tools toolbar - 

Notes

Currently you cannot undo element additions or connector moves·
If an undo action is itself in error, you can reverse it with a redo action·
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Redo Last Action

When you are editing diagrams, moving, re-sizing and deleting elements and deleting connectors, and you make a
mistake, you can work back through multiple levels of undo to roll back the error. If the undo actions are themselves in
error, you can reverse them with the equivalent number of redo actions.

Access

Ribbon
Layout > Undo >  Redo

Keyboard Shortcuts Ctrl+Y

Other
Click on the Redo button in the Default Tools toolbar - 
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Add Diagram Links To Diagrams

Whilst a diagram usually represents a structure of modeling objects, it can also act as a portal through which you can
access related diagrams that provide more detail on an aspect, or alternative views of the structure, or other structures.
Where there are many diagrams (or, indeed, other objects and features) to move on to, the initial diagram can become a
home page for a part of the project, or even the entire project.

Several options for linking to another diagram are provided by the 'Select Type' dialog, which displays when you drag
the target diagram from the Project Browser onto the host diagram.

Drop Diagram Options

Select the appropriate option to set up the required type of link to the target diagram, and then click on the OK button.

Option Description

Diagram Frame This option creates a Diagram Frame element containing an image of the dropped
diagram, with the name of the dropped diagram in the frame label. Any user
looking at the host diagram can double-click on the Diagram Frame and open the
target diagram for review and - if they have the access permissions - for edit.

Diagram Reference This option creates an empty Diagram Frame element with the name of the dropped
diagram in the frame label. Any user looking at the host diagram can double-click
on the Diagram Frame and open the target diagram for review and - if they have the
access permissions - for edit.

Hyperlink This option adds a Hyperlink element to the diagram, containing a diagram icon
with no frame, followed by the names of the parent Package and target diagram.
Double-clicking on this hyperlink will open the target diagram.

You can edit the hyperlink to point to another diagram, or to not display the
diagram icon, by right-clicking on the element and selecting the 'Properties' option.

You can also create an identical Hyperlink element by dragging the Hyperlink icon
onto the host diagram from the 'Common' Toolbox page, right-clicking on the
element and selecting 'Properties', and then selecting 'Diagram' from the 'Type'
drop-down list.

Navigation Cell This option creates a Navigation Cell (a UMLDiagram element) that contains the
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name of the target diagram and, in the top right corner, an icon representing the
diagram type. Just after you click on the OK button, the 'Select Image' dialog
displays, from which you can select a graphic that represents the nature of the
diagram. You can also select a diagram Theme for the image, from the 'Image List'
field. If you do not want to add an image to the element, click on the Cancel button.

If you are using an image, it displays in the center of the element with the target
diagram name at the top. If you are not using an image, the name displays in the
center of the element.

If you subsequently decide to change or remove the image in a Navigation Cell,
right-click on the element and select the 'Appearance > Select Navigation Image'
option. The 'Select Image' dialog displays, and you can simply click on a different
image or - to just remove the existing image - click on the Cancel button.

Selecting the 'Navigation Cell' option also enables the 'Run auto layout' checkbox,
which you can select to automatically adjust the layout of the Navigation Cells to
form a grid with 10 units of separation between cells. (The unit is defined in the
diagram Properties). If you do not want to adjust the layout of the cells, clear the
checkbox before clicking on the OK button.

When a diagram user double-clicks on the Navigation Cell, the target diagram that
it represents is opened and displayed.

Navigation Cells are an excellent tool for creating a 'Home' page for a project or
website, as illustrated by the default model diagram for the Sparx Systems Example
Model.
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Basic Modeling Business Modeling Software Modeling Systems Modeling

Database Modeling Requirements Model Simulation

Project Management Publishing

Profile Extensions

Getting Started

Pro Cloud Server

Enterprise
Architecture

Geospatial ModelingSchema Modeling

If you use Navigation Cells in a model, they add the stereotype
<<NavigationCell>> and its associated ShapeScript to the model. Users opening the
model in builds of Enterprise Architect earlier than 13.5 can then use this stereotype
to create more Navigation Cells that are functionally the same as the Cells under
Release 13.5, though a little more rudimentary.

List This option creates a Model View chart that lists the elements within the target
diagram. When you select the option and click on the OK button, the Model View
element 'Properties' dialog displays at the 'Chart Details > Source' page, showing
the SQL statement that populates the list. Click on the OK button to execute the
search and generate the List of Elements Chart.

Other Links to Diagrams from Diagrams

There are additional ways to link to and access one diagram from another. These include:

From the Project Browser, drag a Package containing the target diagram (as the first diagram listed in the Package)·
onto the host diagram, and select the 'As Element' option; when a user double-clicks on the Package element on the
host diagram, the target diagram displays
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Right-click on a suitable element in the host diagram and select the 'New Child Diagram | Composite Structure·
Diagram' option, then double-click on the element to display the first diagram underneath the element; if that is not
the required diagram, right-click on the element and select the 'New Child Diagram | Select Composite Diagram'
option, then choose the target diagram from the 'Select a Diagram' dialog
    - You can display the target Composite diagram instead of the parent element on the host diagram; right-click and
       select the 'New Child Diagram | Show Composite Diagram in Frame' option
    - Alternatively, you can display the target diagram in a compartment within the parent element outline; right click
and
       select the 'New Child Diagram | Show Composite Diagram in Compartment' option
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Pan and Zoom a Diagram

When you are viewing a diagram, you can pan across, up and down the whole diagram in a low magnification to locate a
particular section, and then zoom into that section in a higher magnification.

Pan over diagram

You can pan over the Diagram View using the:

Left, Right, Up, Down, Page Up, Page Down, Home and End keys when the Diagram View is selected·
Diagram scrollbars·
Middle mouse button·
Pan & Zoom window (Ctrl+Shift+N)·

Zoom into and out of diagram

You can zoom into and out from the diagram using the:

'Layout > Diagram > Persistent Zoom' options or·
The Zoom + and - icons and slider bar in the Status bar at the bottom of the screen, or·
Zoom buttons on the Diagram toolbar or Pan & Zoom window toolbar·

Change the zoom level by clicking on either the Zoom In (+) button or Zoom Out (-) button; each click changes the
magnification by 10%.

You can return the diagram to 100% in one of these ways:

Click on the  ('Zoom to 100%') button·
Press Ctrl and click on the middle button of the mouse·

Notes

You can zoom in and out of the main window dynamically by holding Ctrl and rolling the mouse wheel·
Changes in diagram magnification through the zoom options can be saved as permanent changes to the diagram·
At high levels of zoom, element features cease to display; this is because the Windows font mapper cannot easily·
select a font for extreme conditions, and the result can look odd
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Diagram Navigation Hotkeys

Whilst you are working on a diagram, a number of facilities are also available to you through the keyboard keys. Some
of these facilities are exclusively provided by keyboard keys - the diagram navigation hotkeys - which you can use to
quickly move or operate on elements within a diagram.

Keys

Key Combination Facility

Shift+Arrow Move the selected element(s) by increments (in the direction of the arrow)

Arrow key Scroll the diagram (in the direction of the arrow)

Esc Clear the current selection

Tab key (If no element is selected) Select the element with the lowest Z-Order number - the
furthest back in the diagram

(If an element is selected) Move focus to the element with the next-lowest Z Order
number (coming forward out of the diagram)

Shift+Tab (If no element is selected) Select the element with the highest Z-Order number - the
furthest forward in the diagram

(If an element is selected) Move focus to the element with the next-highest Z Order
number (moving back into the diagram)

Shift+click or Ctrl+click Add the clicked element to the current selection

Ctrl+Shift+drag Pan the diagram

Alt+G Locate the item in the Project Browser and highlight it
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View Last and Next Diagram

If you are working on more than one diagram at a time, and have the diagrams open on separate tabs, you can step
backwards and forwards through them. You will also step through any other views that are open, such as the Model
Search, Project Gantt chart and Start Page.

You move between views using buttons on the Diagram Toolbar:

To access

The previous diagram or view, click on the Previous Diagram button or press Alt+Left·
The next diagram or view, click on the Next Diagram button or press Alt+Right·
The default model diagram (if one has been defined) click on the Home Diagram button·
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Change Diagram Type

If necessary, you can change the type of a diagram to another type. This is useful if you have either made a mistake in
selecting the diagram type to begin with, or if the purpose and nature of a diagram changes during analysis.

Access

Ribbon Layout > Diagram > Manage > Change Type

Change a diagram type

Step Action

1 On the 'Change Diagram Type' dialog, in the 'Select From' panel, click on the appropriate technology or
category containing the new type for the diagram.

The 'Diagram Types' panel displays a list of the diagram types for the selected category.

2 In the Diagram Types panel, click on the diagram type to change to.

3 Click on the OK button to change the diagram type.

The system checks whether there is a template diagram for this diagram type in the Templates Package
and, if so, applies the display characteristics defined in that template.

Notes

Some diagram types do not switch to others; for example, you cannot change a Class diagram into a Sequence·
diagram
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Scale Image to Page Size

When you print a diagram, the default setting is to scale the image to fit the size of the printer paper you have defined in
the page set-up. The image is not scaled up to fill the page, but it is scaled down if it exceeds the current page boundary.
The image retains its current proportions; that is, it is scaled down equally in the X and Y dimensions. For a large
diagram, this can mean that the components of the diagram are small and hard to read.

Alternatively, you can print a multi-page image; that is:

allow the diagram image to print on as many printer pages as it naturally occupies, (no scaling), or·
scale the diagram image to exactly fit a specified number of pages·

In all three cases you also define the paper size and orientation.

Access

Ribbon Design > Diagram > Manage > Properties > Diagram: Advanced

Context Menu Right-click on background of open diagram | Properties > Diagram: Advanced

Right-click on diagram in Project Browser | Properties > Diagram: Advanced

Turn off or customize image scaling options

Step Action

1 Select from these options as required:

'None': select to print on as many pages as the diagram image requires·
'Scale to 1 page': select to scale the diagram image to fit on the currently selected page·
'Custom': select to specify the width and height of the diagram images in terms of the number of·
pages in height and width; specify the number of pages for each dimension

'Page Setup': click to select the page size and alignment·

Notes

Before printing, make sure you have selected the required page layout using the Page Setup button·
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Set Up Diagram Page

You can change the size of the diagram area (or scrollable/printable area) using the 'Diagram Properties' dialog.

Access

Ribbon Design > Diagram > Manage > Properties > Diagram

Context Menu Right-click on background of open diagram | Properties > Diagram

Right-click on diagram in Project Browser | Properties > Diagram

Set the page size

Step Action

1 Select the 'Show Page Border' checkbox.

2 On the 'Page Setup' panel, click on the Advanced button.

The 'Print Advanced' dialog displays.

3 Click on the Page Setup button.

The 'Page Setup' dialog displays.

As you adjust the settings on this dialog, the page icon at the top illustrates the effects of your changes.

4 In the 'Size' field, click on the drop-down arrow and select an appropriate page size.

5 In the Orientation panel click on the radio button for the orientation of the page to print.

6 In the Margins panel, type the required left, right, top and bottom page margins for the diagram, in inches.

7 Click on the OK button on the 'Page Setup' dialog, the 'Print Advanced' dialog, and the 'Diagram
Properties' dialog, in turn.

The area within the page boundary lines on your diagram is expanded or reduced accordingly. When you
print or print preview, the output is cropped to these boundary lines and the diagram divided between the
necessary number of pages.

Notes

You can set the default paper size for new diagrams on the 'Diagram' page of the 'Preferences' dialog (select the·
'Start > Workspace > Preferences > Diagram' ribbon option); once the paper size is set there, all new diagrams have
that as the default size

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Update Diagrams' permission to change diagram page setup
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Lock Diagram

If User Security is not enabled, to protect a diagram against inadvertent changes such as moving or resizing elements,
you can lock the diagram. If you or any other users select any object on a locked diagram, the object's border or outline
displays in red.

Access

Context Menu Right-click on the background of open diagram | Lock Diagram

Notes

This does not apply in the Corporate, Business and Software Engineering, Systems Engineering and Ultimate·
editions if User Security is enabled; in this case, see the Lock Model Elements topic

To unlock the diagram, select the 'Lock Diagram' menu option again·
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Copy (Duplicate) Diagram

As you develop the diagrams in your model, you might find that some of the diagrams use many of the same elements
and have a similar format. You can copy and replicate the complete diagrams for minor modification, resulting in a
duplicate diagram with either:

Links back to the original diagram elements, unless those elements are Text, Note, Hyperlink, Lifeline or Object·
elements that are specific to the diagram and that are copied (shallow mode) or

Complete copies of all elements in the diagram, other than Packages (deep mode) or·
Complete copies of all elements in the diagram that have the same parent as the diagram, and links back to the·
original diagram elements for all other elements on the diagram (smart mode)

Access

Ribbon Select a diagram in the Project Browser then,

Design > Diagram > Manage > Copy Diagram

Select a Package or an Element in the Project Browser then,

Design > Diagram > Manage > Paste Diagram

Context Menu Right-click on diagram in Project Browser | Copy/Paste | Copy Diagram then:

Right-click on Package | Copy/Paste | Paste Diagram or

Right-click on element | Copy/Paste | Paste Diagram

Keyboard Shortcuts Copy the diagram then:

Select Package > Ctrl+V or·
Select element > Ctrl+V·

Duplicate a diagram

Option Action

Name Type the name for the new diagram.

Type of copy Click on the radio button for the type of copy you require; either:

Shallow·
Deep, or·
Smart·

OK Click on this button to initiate the copy.

The new diagram is automatically created with linked or new elements arranged as
in the original diagram.

All connectors are also copied between diagram elements where appropriate.
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Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have Manage Diagrams permission to copy diagrams

For a diagram copied in shallow mode, any changes to the properties of the original elements are reflected only in·
those elements that are copied as simple links in the pasted diagram

For a diagram copied in deep mode, any changes to the properties of the original elements are not reflected in the·
elements in the pasted diagram

For a diagram copied in deep mode, Package elements are copied as simple links only; you cannot paste as new·
For a diagram copied in smart mode, any changes to the properties of the original elements are reflected only in·
those elements that are copied as simple links in the pasted diagram

Element position and size are independent in all copy modes·
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Copy Image to Disk

It is possible to capture a modeling diagram as an image file on disk, for later use in - for example - external documents
and presentations. You can capture the image in a number of different file formats, including:

Windows bitmap (256 color bitmap)·
GIF image·
Windows Enhanced Metafile (standard metafile)·
Windows Placeable Metafile (older style metafile)·
PNG format·
JPG·
TGA·

Access

Ribbon Publish > Documentation > Save Image > Save to File

Keyboard Shortcuts Ctrl+T

Capture a diagram as an image file on disk

Step Action

1 On the 'Save As Image' dialog, select the appropriate folder location for the file.

2 In the 'File name' field, type the file name to save the image under.

3 In the 'Save as type' field, click on the drop-down arrow and select the appropriate graphic format.

4 Click on the Save button.

Notes

The system clips the image size to the smallest bounding rectangle that encompasses all diagram elements·
By deselecting the 'Printable' option on an element on a diagram, you can omit that element from the diagram image·
copied to disk
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Copy Image to Clipboard

It is possible to capture a modeling diagram as an image on the MS Windows clipboard for immediate use in - for
example - external documents and presentations in MS Word or other applications, or in another diagram within
Enterprise Architect.

You can set the format of the clipboard images - bitmap or metafile - on the 'Preferences' dialog ('Start > Workspace >
Preferences').

Access

Ribbon Open diagram then,

Publish > Documentation > Save Image > Save to Clipboard

Keyboard Shortcuts Open diagram, then press Ctrl+B.
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Delete Diagrams

Diagrams are representations of the ways in which model element structures are organized. If you no longer want to
depict an arrangement of model elements, you can quickly delete the diagram from your model. This has no effect on the
elements shown in the diagram - they and their relationships remain unchanged within the model, and accessible through
the Project Browser and several other views and windows.

Access

Context Menu Project Browser | Right-click on diagram name | Delete '<diagram name>'

A confirmation prompt displays. Click on the Yes button to confirm the deletion.

Keyboard Shortcuts Select diagram in Project Browser | Ctrl+Del

A confirmation prompt displays. Click on the Yes button to confirm the deletion.

Notes

In Enterprise Architect there is no 'Undo' feature for deleting diagrams, so be certain that you want to delete a·
diagram before you do so

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Manage Diagrams' permission to delete diagrams

You can also delete multiple diagrams from the Project Browser, by holding Ctrl or Shift while you select them, then·
right-clicking on one of them and selecting the 'Delete selected items' option
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Diagram Filters

Using Diagram Filters (Dynamic Visual filters), you can modify the display of diagram components so that the required
items are immediately identified, without damaging the structure and integrity of the model. The filters operate on
elements, connectors or Tagged Values according to properties such as Author, Status, Date Created or Stereotype Value
and, for connectors, whether the connector is hidden or visible. Filters are stored against the model, so a filter you create
is available to other users of the model; however, use of a filter is specific to the user, so your use of a filter does not
affect another user's view of the diagram.

Access

Ribbon Layout > Tools > Diagram Filters   or

Show > Window > Diagram Filters

Applying Diagram Filters

You can use Diagram Filters singly, in sequence, or in combination to tailor the display of diagrams to show:

Information for different users, so that - for example - technical staff and stakeholders each can apply filters that·
highlight the information pertinent to them

What elements have been recently developed or changed·
Which part of a model was developed by a particular person·
Which parts of a diagram are at a particular phase, status or version·

Examples of ways in which you might apply filtering include:

Setting up a filter for immediate use on a diagram, and modifying that filter as you review the diagram so that you·
highlight elements with different values for the same properties - perhaps, by filtering on Phase, to compare 'As-Is'
and 'To-Be' elements

Setting up a filter and leaving it active so that all diagrams you display are automatically filtered the same way·
Setting up a series of filters to use:·
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    - in one or more sequences to progressively highlight a diminishing set of items, or
    - alternately to highlight contrasting views of the diagram

Grouping filters so that their combined results identify objects that meet the characteristics of each filter and indicate·
an 'overview' status as well; for example, 'Work In Progress' plus 'Work Not Started' show objects in each category
at the same time, under the group filter 'Work Not Completed'

Filters for elements can also be applied to the Package Browser and Diagram List.

The 'Diagram Filters' context menu (right-click on the body of the window) provides an option for toggling between the
filters and simple context filtering of diagrams; if you select the 'Context Filtering' option, the Diagram Filters are
disabled and the contents of the diagram are grayed-out, except for a selected element and those elements directly related
to it.

Facilities

Facility Detail

Developing  Filters You create and define as many filters as you require, setting up each filter by
defining which element, connector or Tagged Value properties to specifically check
for and (depending on how you set up the filter parameters) whether to include or
exclude elements or connectors having particular property values.

You cannot combine element, connector and/or Tagged Value properties in one
filter, but you can apply any combination of element filter, connector filter and/or
Tagged Value filter to a diagram at the same time, individually or as a grouped
filter.

You can select to:

Mute the excluded items in Gray Scale, or Fade the display color·
Hide the excluded items completely, or·
Select and highlight (with a hashed line) the included items·

Filter Effect - Gray Scale,
Fade or Hide

If you select 'Gray Scale', 'Fade' or 'Hide', the action of the filters is to exclude items
that do not match the parameters rather than include items that do.

If, for example, you selected to filter on element name, looking for elements with
the word 'Class' in the name, the filter would apply this logic:

    Does 'Name' contain string 'Class'? If 'No', apply effect; if 'Yes', take no action.

The elements you want are therefore what is left on the diagram, rather than what
was operated on.

The filter effect remains in force while you do other work on the diagram, until
such time as you disable the filter.

Filter Effect - Highlight If you click on 'Select', the logic is reversed:

    Does 'Name' contain string 'Class'? If 'No', take no action. If 'Yes', apply effect.

In this case, the filter effect is not permanent, and clicking off the items deselects
them.

This effect is excellent for selecting items having the same characteristics across a
large diagram, to be processed in a single task; instead of having to locate the items
and select them with Shift+click individually, you can apply the filter.

If you inadvertently lose the selection by clicking off the items, you can get it back
again almost immediately by re-applying the filter.
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Work With Diagram Filters

You can modify the display of objects on a diagram using Diagram Filters, which you create and use through the
Diagram Filters window. This window is dockable, so you can move it around or 'fix' it next to the Diagram View while
you activate, deactivate and edit the filters.

Access

Ribbon Layout > Tools > Diagram Filters   or

Show > Window > Diagram Filters

Create a single filter to be applied to your diagrams

Step Action

1 Perform one of these actions:

On the Diagram Filter toolbar, click on the 'New Filter' icon - the first on the left·
Right-click on the list panel and select the 'New Filter' option·

The 'Create New Diagram Filter' dialog displays.

2 In the 'Enter Filter Name' field, type a name for the filter, then click on the OK button.

The 'Diagram Filter' dialog displays.
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3 In the 'Active Filter Set' field, either:

Use the default value of 'Element' or·
Click on the drop-down arrow and select 'Connector' or 'TagValue'·

The body of the dialog displays a list of properties of elements, connectors or Tagged Values.

4 Scroll through the properties to filter on, and select the checkbox against each property you require.

5 For each property, click on the 'Condition' field and select, from the drop-down list, the comparison
condition to be applied.

Consider how the combination of 'Condition - Equal To / Not Equal To' and 'Filter Effect' might affect the
results on the diagram.

6 For each property, double-click on the 'Value' field and type or select any specific value to filter on.

7 Click on the OK button to save the filter and return to the Diagram Filters window.

Unless you have specifically created the filter in a Filter Group, the filter is listed underneath the default
Model group at the top of the window.

Create a Filter Group

Step Action

1 In the Diagram Filters window toolbar, click on the drop-down arrow next to the Filter icon and select the
'New Filter Grouping' option.

The 'Create New Diagram Filter Grouping' dialog displays.

2 In the 'Enter Filter Name' field, type the name of the filter group, and click on the OK button.

The filter group is added to the end of the list in the Diagram Filters window, and the 'Create New
Diagram Filter' dialog displays for you to add a new filter to the filter group.

3 Define the new filter in the group as described in the Create a single filter to be applied to your diagrams
table. You can apply that procedure to define the other filters for the group, clicking on the group name
and then on the 'New Filter' option to start.

Alternatively, you can copy or cut an existing filter from the Model list or from another filter group, and
paste that filter into the new group. Right-click on the source filter and select the 'Cut' or 'Copy' option,
then right-click on the target group and select the 'Paste' option.

Other Operations

Operation Detail

Edit a Filter To edit an existing filter on the Diagram Filters window, either:

Double-click on the filter name·
Click on the filter name and select the 'Properties' icon from the toolbar (the·
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second icon from the left), or

Right-click on the name and select the 'Properties' option·
The 'Diagram Filter' dialog displays; adjust the filtered fields as described in the
Create a single filter to be applied to your diagrams table.

Change the name of the
Filter or Filter Group

Right-click on the name and select the 'Change Name' option.

The appropriate 'Create New Diagram Filter ...' dialog displays.

Type over the existing name with the new name, and click on the OK button.

Define how filters in a
group combine

When you define two or more filters in a filter group, they default to operating in
combination, with an AND relationship. That is, an object must satisfy the criteria
of all the selected filters in the group before being operated on.

You can change this to an OR relationship, where the object must satisfy the
criteria of any of the filters before being operated on. To set the relationship of the
group filters to OR (or change it back from OR to AND):

Right-click on the filter group name and select the 'Properties' option. The 'Set1.
logical operator for Filter Grouping' dialog displays.

In the 'Operator' field, click on the drop-down arrow and select the required2.
value - OR or AND.

Click on the OK button.3.

Set Effect of Filters The filter effect applies to all filters in the Diagram Filters window. To set how
your filters identify selected items on your diagrams, click on the drop-down arrow
of the toolbar 'Filter Effect' field, and select one of these options:

Fade - display all items that do not match the filter criteria in a pale version of·
the diagram background color

Gray Scale - display all items that do not match the filter criteria in pale gray·
Hide - conceal all items that do not match the filter criteria·
Select - select and highlight (with a hashed line) all those items that do match·
the filter criteria

If the filter is for elements in the Package Browser or Diagram List, note that the
'Select' filter effect cannot show up in this context.

Enable Filters To enable a filter so that it takes immediate effect on your diagrams, select the
check box against the filter name.

You can select more than one filter at a time, to combine their effects.

For a Filter Group, if you select the group checkbox all filters in the group are
selected. You can then, if necessary, disable individual filters in the group.

Disable/Clear Filters To disable a filter and clear the effect of the filter on the diagram so that it displays
in full, clear the checkbox.

To disable all filters, either:

Click on the 'Reload Filters' icon in the toolbar (third option from the left), or·
Right-click on the list panel and select the 'Reload Filters' option·

Copy or Move a Filter
between Filter Groups

To add an existing filter to another Filter Group, right-click on the filter and select
the 'Copy' or 'Move' option as appropriate. Then right-click on the target Filter
Group and select the 'Paste' option. If you are moving a filter, it is not removed
from the source group until it has been pasted to the target group.

You cannot move a Filter Group or add one group to another.
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Toggle between Diagram
Filters and Context
Filtering

To disable the filters you have defined and simply highlight a selected element and
its immediate relatives, right-click on the Diagram Filters window background or
the diagram background itself and select the 'Context Filtering' option.

To re-enable the Diagram Filter effects, display the Diagram Filters window or
diagram context menus again and deselect the 'Context Filtering' option.

Delete a Filter To remove a filter or filter group from the Diagram Filters window, either:

Click on the filter name and click on the Delete icon in the toolbar, or·
Right-click on the filter name and select the 'Delete Filter' option·

A prompt displays to confirm the deletion.

(c) Sparx Systems 2015 - 2017 Page 164 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Diagram List

The Diagram List is a tabular, editable view of elements in a selected diagram, which can be displayed in the main
workspace. You can use the Diagram List to:

Streamline the process of creating and updating elements in a diagram selected from the Project Browser; this can be·
particularly useful for analysts to create and maintain formal requirement definitions within the model

Print the list or generate a document report directly from the entries on the list·

Access

Ribbon Design > Diagram > List View

Context Menu Right-click on diagram background | View as List

Project Browser | Right-click on diagram | View Diagram As | View as List

Keyboard Shortcuts Ctrl+Alt+R    (opens a new view, as a list)

Topics

Topic Detail

The Diagram List The Diagram List is related to the Package Browser, which lists the elements in a
selected Package; however, the Package Browser has a wider range of options.

Formats The Diagram List is displayed in 'User Defined' format, where you can change how
the element information is structured on the screen using the value-grouping band
below the toolbar.

Change display Sort the items by any column value in ascending or descending order, by·
clicking on the column header; initially the elements are listed in numerical
order (if level numbering is turned on in the Project Browser) or alphabetical
order within type

Apply a diagram filter for elements (the Fade, Gray Scale and Hide modes·
reduce the number of elements listed; Select mode has no effect)

Change the sequence of columns, by dragging column headers left or right·

Display Element Properties Double-click on the element entry.

Select Items Select:

an element by clicking on it·
a specific value by clicking twice on it (not double-clicking); either the value·
becomes directly editable or the 'Properties' dialog displays in which you can
edit the value

several individual elements by holding Ctrl as you click on them·
a range of elements by holding Shift as you click on the first and last in the·
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range

Add new items to the
diagram

Create new elements on the Diagram List, using the toolbar or context menu
options; these elements are automatically added to the diagram.

Delete elements from the
list

Select the item and press Ctrl+D.

Include each element's
notes (documentation)

Notes are shown underneath the element.

To add or edit notes, click on the item and press Ctrl+Space to transfer control to
the Notes window, in which you create or edit the note text.

Review the element's
custom (advanced)
properties

Right-click on the item and select the 'Properties' option, then select the 'Advanced'
page.

Further Options You can do further work on the Diagram List using the same toolbar and context
menu options as for the Package Browser, except that the Diagram List does not
have:

The Model Hierarchy format and hence does not have the  button in the·
toolbar

The  toggle button·

The  toggle button·
The Diagram List does have these additional context menu options:

Diagram View - show the elements of the selected diagram as a diagram·
instead of as the Diagram List

Gantt View - show the list as a Gantt chart of resource allocations·
Diagram Properties - display the 'Diagram Properties' dialog for the diagram·
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Layout Diagrams

As you develop a model diagram and add more elements and connectors to it, you can apply one of a number of formats
to automatically lay out specific areas or sets of elements in the diagram in a structured arrangement. If the diagram is
very simple, you could even use this facility to lay out the entire diagram.

Additionally, you can provide filters and parameters for two or three types of layout and then 'chain' the layouts so that
they are executed in sequence to result in a more refined layout. You can select a system-defined chain, or one that you
have created yourself.

Access

Ribbon Layout > Tools > Diagram Layout > Diagram Layout Tools

Context Menu Right-click a selected element on a diagram | Layout Selected Elements (available
only when multiple elements are selected)

Other
Right-click on any toolbar | Diagram Layout Tool : Select a Layout | Apply
Layout

Lay out elements on a diagram

Step Action

1 Select the elements to lay out on the currently-active diagram - hold Shift or Ctrl while you click on each
required element, or hold the mouse button down while you sweep over the area containing the required
elements.

If no elements are selected on the active diagram, then all elements on the diagram are laid out (except
where otherwise documented).

2 Click on the drop-down arrow on the top left field of the Layout Tools window, and select the required
layout type:

Circle/Ellipse·
Box·
Per Page·
Digraph·
Spring·
Neaten·
Converge/Diverge·
Fan Relations·
Auto Route·

The layout type determines the fields presented in the window, therefore the appropriate fields are
described separately for each layout type.

If you want to apply a sequence or chain of diagram layouts to a diagram, select either:

The appropriate system-defined chain name, or·
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The name of a chain you have created yourself·

You can create and modify a 'Layout Chain' by clicking on the  button in the dialog toolbar.

3
When you have completed the fields, click on the  button.

The selected elements are reorganized into the pattern format you have selected and according to the
options you have chosen.

4
If you do not want to work with the new layout, click on the Undo button in the toolbar ( ).

Notes

If you have adjusted the settings for a layout, you can automatically apply those settings to another diagram by·
selecting the 'Layout > Tools > Diagram Layout > <layout name>' ribbon option when you have opened the diagram

You can also automatically lay out an entire diagram, without specifying any format or filters, using the alternative·
Layout Diagram facility

Nested elements will remain within their parent element when applying a layout·
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Circular/Elliptical Layout

The Circle and Ellipse layouts arrange the selected elements in a circle or elliptical pattern, using the largest horizontal
and vertical element edge in the set of elements when calculating the radius of the layout arc.

Invoke the Circular or Ellipse layout

Diagram A - Top To Bottom Layout
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Step Action

1 Follow the general Layout Diagrams procedure, and at step 2 select either 'Circle' or 'Ellipse' as required.

2 Click on the drop-down arrow in the 'Sort By' field and select the required sort parameter:

None - elements are passed to the specified layout in the order in which they appear on the original·
diagram (left to right, top to bottom)

Area (Ascending) - elements are passed to the specified layout in order of the screen space they·
occupy, smallest to largest

Area (Descending) - elements are passed to the specified layout in order of the screen space they·
occupy, largest to smallest

Name (Ascending) - elements are passed to the specified layout in alphanumeric order, based on the·
element name

Name (Descending) - elements are passed to the specified layout in reverse alphanumeric order,·
based on the element name

Element Type - elements are grouped by type (for example, Class, Use Case) and in alphanumeric·
order within the group by name

3 Under the 'Placement' option, select either:

Top to Bottom - the elements are positioned in the required order, zig-zagged across the perimeter of·
the circle or ellipse, as in Diagram A

Circular - the elements are placed in the required order, clockwise around the perimeter of the circle·
or ellipse, as in Diagram B

4 Select the 'Center focused element' checkbox to put the last-selected element (the one with the hashed
border) in the center of the circle or ellipse, as in Diagram C.
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Diagram B - Circular Layout

Diagram C - Center Focused Element
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Box Layout

The Box layout arranges the set of selected elements into a square grid.

The dimensions of the box are determined by the number of columns that either:

You set manually or·
The system automatically sets to a value that results in the same number of columns and rows (for example, 5, 6, 7, 8·
or 9 elements would all be arranged in a three-column rectangle).

Invoke the Box layout

Step Action

1 Follow the general Layout Diagrams procedure, and at step 2 select 'Box'.

2 Click on the drop-down arrow in the 'Sort By' field and select the required sort parameter:

None - elements are passed to the specified layout in the order in which they appear on the original·
diagram (left to right, top to bottom)

Area (Ascending) - elements are passed to the specified layout in order of the screen space they·
occupy, smallest to largest

Area (Descending) - elements are passed to the specified layout in order of the screen space they·
occupy, largest to smallest

Name (Ascending) - elements are passed to the specified layout in alphanumeric order, based on the·
element name

Name (Descending) - elements are passed to the specified layout in reverse alphanumeric order,·
based on the element name

Element Type - elements are grouped by type (for example, Class, Use Case) and in alphanumeric·
order within the group by name

3 In the 'Padding (px)' field, type the vertical and horizontal distance between elements, in pixels.

4 Select the appropriate element distribution option:
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Automatically distribute: Automatically calculate the dimensions of the box (the square root of the·
number of selected elements; for example, 16 elements create a 4x4 box)

Specify distribution: Manually define the width of the box, in columns·

5 If you selected 'Specify Distribution', in the 'Columns' field type the required number of columns.
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Per Page Layout

The Per Page layout divides each diagram page into a number of cells, which house the selected elements. The number of
cells per page is determined by the page distribution parameter.

Invoke the Per Page layout

Step Action

1 Follow the general Layout Diagrams procedure, and at step 2 select 'Per Page'.

2 Click on the drop-down arrow in the 'Sort By' field and select the required sort parameter:

None - elements are passed to the specified layout in the order in which they appear on the original·
diagram (left to right, top to bottom)

Area (Ascending) - elements are passed to the specified layout in order of the screen space they·
occupy, smallest to largest

Area (Descending) - elements are passed to the specified layout in order of the screen space they·
occupy, largest to smallest

Name (Ascending) - elements are passed to the specified layout in alphanumeric order, based on the·
element name
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Name (Descending) - elements are passed to the specified layout in reverse alphanumeric order,·
based on the element name

Element Type - elements are grouped by type (for example, Class, Use Case) and in alphanumeric·
order within the group by name

3 In the 'Padding (px)' field, type the vertical and horizontal distance between cells, in pixels.

4 Select the appropriate page distribution option:

Automatically distribute: automatically calculate the optimum number of cells, taking into·
consideration the largest horizontal and vertical element edges

Specify distribution: manually enter the per page grid dimensions·

5 If you selected 'Specify Distribution', in the 'Rows' and 'Columns' fields type the required number of rows
and columns.

6 Select the 'Center Elements' checkbox to place each element in the center of its cell; otherwise the element
placement defaults to the top left corner of the cell.

7 In the 'Start Page' field, type the number from which to start the page numbering; pages begin at the top
left and continue horizontally to the right.
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Digraph Layout

The Digraph layout arranges the selected elements into a directed graph ('digraph' for short). The Digraph attempts to
highlight the hierarchy of the elements while keeping the direction of all connectors pointing to the same edge of the
diagram.

The Digraph layout provides the same behavior as the Automatic Diagram layout.
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Spring Layout

The Spring layout uses a force-directed approach to arrange the selected elements organically. It employs a physical
analogy to lay out elements; each element is treated as a particle with a like electrical charge that repels other elements.
Connectors act as springs (hence the name Spring layout) that draw connected elements back together. The layout is
good for highlighting clusters of related objects and identifying symmetry in the graph.

Invoke the Spring layout

Step Action

1 Follow the general Layout Diagrams procedure, and at step 2 select 'Spring'.

2 In the 'Iterations' field, type the number of iterations, or rounds, to perform to reach the final layout.

The layout is developed over several iterations; depending on the complexity of the graph, increasing the
number of iterations produces a better result but takes longer to calculate.

3 If the diagram contains elements that significantly vary in size, and that might overlap in the final layout,
select the 'Scale to prevent overlap' checkbox to scale up the positions of the selected elements (preserving
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size) until no elements overlap.
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Neaten Layout

The Neaten layout attempts to pull the selected elements into a grid based on their horizontal and vertical proximity to
each other. That is, the layout pulls elements that are roughly aligned into a neater arrangement. Elements that share the
same row or column are aligned based on the 'Column' and 'Row Snap' parameters. The arrangement shown for the
Spring layout, when the Neaten layout is applied, might resemble this:

Invoke the Neaten layout

Step Action

1 Follow the general Layout Diagrams procedure, and at step 2 select 'Neaten'.

2 In the 'Threshold (px)' field type the separation, in pixels, up to which elements are considered to be in the
same row or column.

A higher threshold value produces a tighter result, pulling elements that are far distant into the same row
or column. A lower threshold value provides for a larger number of rows and columns.

3 In the 'Column Snap' field, click on the drop-down arrow and select the appropriate alignment for
elements in the same column:

Left - elements are aligned with the left edge of the left-most element in the column·
Center - elements are aligned with the vertical center of the center-most element in the column·
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Right - elements are aligned with the right edge of the right-most element in the column·

4 In the 'Row Snap' field, click on the drop-down arrow and select the appropriate alignment for elements in
the same row:

Top - elements are aligned with the top edge of the highest element in the row·
Center - elements are aligned with the horizontal center of the center-most element in the row·
Bottom - elements are aligned with the bottom edge of the lowest element in the column·

Notes

To prevent elements from overlapping in the neatened layout, check that the appropriate left, right, top, bottom,·
vertical center or horizontal center values of the elements (as dictated by the 'Column Snap' and 'Row Snap' options
you select) are greater than the value in the 'Threshold' field
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Converge/Diverge Layout

The Converge layout attracts the set of selected elements towards the center of their bounding rectangle. Conversely, the
Diverge layout repels the set of selected elements away from the center of their bounding rectangle. The
Converge/Diverge layout also tries to maintain connector angles if an element in the set contains a connector with
waypoints.

Invoke the Converge/Diverge layout

Step Action

1 Follow the general Layout Diagrams procedure, and at step 2 select 'Converge/Diverge'.

2 Select the radio button for the required direction of the layout:

Converge - attracts the set of selected elements to the center point·
Diverge - repels the set of selected elements from the center point·

3 Set the 'Amount (%)' slider to the required percentage. A smaller percentage provides finer control of the
change in layout.

The slider determines how far the elements are moved towards or away from the center point; the
movement is the element's current distance from the center point multiplied by the percentage value set on
the slider.
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In the Converge layout, the element moves towards the center point; in the Diverge layout the element
moves further away from the center point.
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Fan Relations Layout

The Fan Relations layout arranges the immediate relations of an element around a specified edge. This layout requires a
single element to be selected on the diagram, to be used as the context for the layout.

Invoke the Fan Relations layout

Step Action

1 Open the Layout Tools window; either:

Select the 'Layout > Tools > Diagram Layout' ribbon option, or·
Right-click on the main toolbar and select the 'Diagram Layout Tools' option·

2 Select the single element around which to lay out related elements on the currently-active diagram.

3 Click on the drop-down arrow on the top left button of the Layout Tools window, and select Fan
'Relations'.

4 Click on the drop-down arrow in the 'Sort By' field and select the required sort parameter.

The options are:

'None' - elements are passed to the specified layout in the order in which they appear on the original·
diagram (left to right, top to bottom)

'Area (Ascending)' - elements are passed to the specified layout in order of the screen space they·
occupy, smallest to largest

'Area (Descending)' - elements are passed to the specified layout in order of the screen space they·
occupy, largest to smallest

'Name (Ascending)' - elements are passed to the specified layout in alphanumeric order, based on the·
element name

'Name (Descending)' - elements are passed to the specified layout in reverse alphanumeric order,·
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based on the element name

'Element Type' - elements are grouped by type (for example, Class, Use Case) and in alphanumeric·
order within the group by name

5 In the 'Padding (px)' field, type the separation required between the selected element and its related
elements, in pixels.

6 Select the connector direction to use in determining the related elements to lay out; either:

Incoming Nodes - to lay out related elements that have the selected element as the target·
Outgoing Nodes - to lay out related elements that have the selected element as the source·

7 In the 'Fan Edge' field, click on the drop-down arrow and specify the edge of the selected element from
which to lay out the related elements:

Left - to arrange related elements to the left of the selected element·
Right - to arrange related elements to the right of the selected element·
Top - to arrange related elements from the top of the selected element·
Bottom - to arrange related elements from the bottom of the selected element·
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Auto Route Layout

The Auto Route layout orthogonally routes connectors between the selected elements. The layout attempts to find the
shortest path between the two connected elements while minimizing crossings. In this illustration, the original connectors
are shown in red.

Invoke the Autoroute layout

Step Action

1 Follow the general Layout Diagrams procedure, and at step 2 select 'Auto Route'.

2 In the 'Cell Size (px)' field, type the effective connector separation in pixels.

When calculating connector routes, the algorithm divides the diagram into cells of a size determined by
this field value; a smaller cell size results in connectors being placed closer together.

3 In the 'Element Margin' field, type the separation between connector segments and element borders, in
pixels.
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Lay Out a Diagram Automatically

As you develop a diagram, it can become difficult to position the elements and connectors so that the layout and
organization remain clear. Rather than continually moving structures around manually, you can simply select a 'Layout
Diagram' option to automatically reposition all the structures on the diagram in a logical, tree-based structure. If your
diagram is complex, you can then do some manual 'tweaking' to draw out particular elements and relationships.

Generally the default layout parameters provide adequate layouts for a wide range of diagrams, but for a fine degree of
control you can also set layout parameters using the 'Diagram Layout Options' dialog.

Access

Ribbon To configure settings:

Design > Diagram > Manage > Properties > Diagram: Set Layout Style or·
Layout > Diagram > Manage > Properties > Diagram: Set Layout Style·

Context Menu To configure settings:

Right-click on diagram | Properties > Diagram: Set Layout Style·

Other To configure settings:

Double-click background of diagram > Diagram : Set Layout Style·

To apply layout:

diagram toolbar :  Auto Layout·

Apply Layout Configurations

Option Action

Cycle Remove Options These settings remove cycles in the element organization (where element X is the
source of a path but also becomes the target of a branch of the path), by reversing
the connectors that impose the cycling and then reorganizing the diagram and
reinstating the reversed relationships; this identifies the primary source element in
the diagram. Select:

Greedy - to use the Greedy Cycle Removal algorithm, which minimizes the·
number of connectors reversed

Depth First Search - to use the Depth First Search Cycle Removal algorithm,·
which establishes the longest linear sequence possible before establishing
parallel sequences and branches; this algorithm is less effective in large and/or
complex diagrams, but produces a more natural layout than the Greedy
algorithm

Crossing Reduction
Options

These options determine the length of time the routine searches for ways of
reorganizing the layout to avoid crossed relationships:

Iterations - Type the number of iterations to be used during cycle removal·
(more than 8 does not usually provide any improvement)
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Aggressive - Select this checkbox to use an aggressive (detailed and·
time-consuming) crossing reduction step

Layering Options These settings determine how elements are organized in layers during layout.
Select:

Longest Path Sink - to use the Longest Path Sink Layering algorithm, where·
the final target elements (sinks, which have no relationships issuing from them)
are arranged in a layer at the top of the diagram, and the relationship paths built
downwards from there in as many layers as there are nodes in the longest path

Longest Path Source - to use the Longest Path Source Layering algorithm,·
where the original source elements (those with no relationships entering them)
are arranged in a layer at the bottom of the diagram and the relationship paths
built up from there in as many layers as there are nodes in the longest path

Optimal Link Length - to use the Optimal Link Length Layering algorithm,·
which organizes the elements into the number of layers that minimizes the total
source-to-sink relationship chain; in this layout you can have both source
elements and sink elements at various levels of the diagram

Layout Options These settings define how far apart the element layers and columns are in the
layout.

Layer Spacing - Type the default number of logical units between layers of·
elements (vertical spacing)

Column Spacing - Type the default number of logical units between elements·
within a layer (horizontal spacing)

Initialize Options The autolayout routine inserts line waypoints and connectors into relationship paths
to help plot the direction of the relationships; the routine then assigns an index
number to every node, such that nodes in the same layer are numbered left to right.
These settings determine how those index numbers are assigned. Select:

Naive - to use the Naive Initialize Indices algorithm, which assigns index·
numbers to nodes as they are encountered in a sweep and tends to place all
waypoints to the right of real nodes (and therefore long relationships between a
small number of elements to the right of chains of short relationships between
several elements)

Depth First Search Outward - to use the Depth First Out Initialize Indices·
algorithm, which assigns index numbers to nodes as they are encountered in a
depth first search from source nodes outwards (and would therefore place
longer relationship chains to the left of shorter chains, with the primary source
node at the start of the diagram flow)

Depth First Search Inward - to use the Depth First In Initialize Indices·
algorithm, which also assigns index numbers to nodes as they are encountered
in a depth first search, but from sink nodes inwards (and would therefore place
longer relationship chains to the left of shorter chains, with the ultimate target
node at the end of the diagram flow)

Direction Select the direction in which all directed connectors should point, to set the position
of the primary source element and the overall flow of the diagram. That is, Up,
Down, Left, or Right.

Set as Project Default Select this checkbox to apply the diagram layout settings to all diagrams in the
project.

If you later define different settings and select this checkbox, the new settings
override all those saved previously.

OK Click on this button to save your settings.
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Example

This illustration shows an automatically laid out diagram with these options set:

'Depth First Search'·
'Optimal Link Length'·
'Depth First Search Outward'·
'Direction - Up'·

Notes
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This facility is available for all types of diagram other than Timing and Interaction Overview diagrams·
If you decide that the autolayout is not appropriate, you can reverse it before saving the diagram; click Ctrl+Z·
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Chain Diagram Layouts

Each of the diagram layout formats has a specific effect on the layout and appearance of a diagram. These effects can be
combined by chaining certain layouts in a sequence, to further improve the final appearance of the diagram. Enterprise
Architect provides a selection of standard 'chains' for your use, and you can quickly and easily set up chains of your own.

The system does not restrict the way in which you combine the layouts, but in practice some layouts complement each
other better than others, or are more logically executed in a certain order. You therefore need to consider the effect of
each layout on the diagram - or part of the diagram - as you develop the chain. You also provide parameters for each
layout, so you would set the parameters for each format to complement those for the other formats in the chain, using the
'Layout Chains' dialog.

The available formats could be grouped by impact on the diagram:

Circle, Ellipse, Box, Per Page, Digraph and Spring each adjust element positions completely, so would destroy the·
effects of any other layout if used after it in a chain; one of these would therefore be the first layout to apply in the
chain

Fan Relations operates on a specific element, so you might not want to further adjust the diagram layout; if you did,·
you would only use these next layouts

Converge/Diverge could be used after some of the above layouts, to broaden or narrow the final layout·
Neaten is a logical successor to the previous types, adjusting positions to provide more uniform separation·
Auto-route is the best final layout, to adjust connectors to the clearest routes without changing element positions·

In creating a chain of layouts, you might consider these suggestions in selecting which layouts to use and in which
sequence.

Access

Ribbon
Layout > Tools > Diagram Layout: 

Other
Right-click on any toolbar | Diagram Layout Tools: 

Set up a chain

On the 'Layout Chains' dialog:

Step Action

1 Either:

Click on the New Chain button and type in a new chain name (and click on the OK button) or·
Click on the drop-down arrow and select the name of an existing chain to edit·

If you want to delete the existing chain you have selected, click on the Delete Chain button.

If you want to rename the existing chain, click on the  button and overtype the existing name with the
new name (and click on the OK button).

2
In the 'Existing Layouts' field, click on the first layout to execute in the chain, then click on the 
button to add it to the chain.
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Repeat this step to add further layouts to the chain.

3
If you do not want to include a layout that is currently in the chain, click on it and click on the 
button.

If you want to move a layout in the chain to a different point in the sequence, click on it and click on the

 or  button as appropriate.

4 If you want to change the name of a layout, click once on the name in the chain list and overtype it.

To set the parameters of each layout, double-click on the layout name in the chain list. The appropriate
parameter dialog for the layout displays; complete the fields as appropriate and click on the OK button.

These are the parameters that will be applied whenever you execute this layout chain, regardless of the
settings in any other use of the layout.

5 Click on the Save Chains button to save your changes, then click on the OK button.

(If you have not saved your changes, an error message displays; click on the Yes button.)
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Swimlanes

Swimlanes are vertical or horizontal bands in a diagram that divide the diagram into logical areas or partitions. You can
apply them to all Enterprise Architect diagram types. Activities relating to particular entities within the model (such as
the User, or the back end Repository) can be placed within the same Swimlane to indicate their association. You set up
the Swimlanes using the 'Swimlanes and Matrix' dialog.

Access

Ribbon Design > Diagram > Manage > Swimlanes > Swinlanes

Layout > Diagram > Swimlanes > Swimlanes

Context Menu Right-click on diagram background | Swimlanes and Matrix > Swimlanes

Options

Option Action

Active Select this checkbox to make the Swimlane facilities active on the diagram, as
opposed to the Matrix facilities.

Orientation Click on the drop-down arrow and select the orientation of the Swimlanes: Vertical
or Horizontal.

Font Color Click on the drop-down arrow and select the color in which to display all Swimlane
text.

If the color you require is not shown, click on the Other button and either select
from a wider range of standard colors or define a custom color.

A Click on this button to display the 'Font' dialog, on which you can define the type,
style, size and effects of the font used for text on all Swimlanes in the diagram.

If you also change the text color here, it overrides the setting of the 'Font Color'
field.

Line Color Click on the drop-down arrow and select the color in which to display all Swimlane
borders.

If the color you require is not shown, click on the Other button and either select
from a wider range of standard colors or define a custom color.

Line Width Click on the drop-down arrow and select the line width of all Swimlane borders -
either 1 (thinnest), 2 or 3 (thickest).

Locked Select this checkbox to prevent the Swimlanes in the diagram from being made
narrower or wider.

Bold Font Select this checkbox to display all Swimlane text in bold.
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Hide Classifier Select this checkbox to block all Swimlane classifier names from being shown on
the diagram.

Hide Names Select this checkbox to block all Swimlanes names from being displayed on the
diagram.

Show Names in Title Bar (If the 'Orientation' field is set to 'Vertical'.)  Select this checkbox to display each
Swimlane name in the title bar, above the Swimlane.

Swimlanes This panel lists the currently defined Swimlanes, in the sequence (top to bottom) in
which they are displayed on the diagram (left to right, or top to bottom).

New Click on this button to begin defining a new Swimlane for the diagram.

The 'Swimlane Details' dialog displays, on which you provide the name, classifier
and background color of the Swimlane.

Hand (Up) Click on this button to move a selected Swimlane one position up in the Swimlanes
list.

Hand (Down) Click on this button to move a selected Swimlane one position down in the
Swimlanes list.

Modify Click on this button to change the name, classifier or background color of a selected
Swimlane.

The 'Swimlane Details' dialog displays.

Delete Click on this button to delete a selected Swimlane from the Swimlanes list and from
the diagram. A prompt displays for you to confirm the deletion.

OK Click on this button to save and apply your changes, and close the dialog.

Cancel Click on this button to abort your changes, and close the dialog.

Notes

If you set a background color for a swimlane, it takes on the same shading profile as the main diagram background·
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Swimlane Details

To define a vertical or horizontal Swimlane on a diagram, you use the 'Swimlane Details' dialog.

Access

Ribbon Design > Diagram > Manage > Swimlanes > Swinlanes: New or Modify

Layout > Diagram > Swimlanes > Swimlanes: New or Modify

Context Menu Right-click on diagram background | Swimlanes and Matrix > Swimlanes: New or
Modify

Options

Options Action

Name Type a name for the Swimlane.

Classifier
(Optional) Click on the  button to browse for and select a classifier for the
Swimlane.

To delete a previously-assigned classifier, click on the  button and select the
'<none>' option.

Back Color Click on the drop-down arrow and select the color in which to display the
Swimlane background.

If the color you require is not shown, click on the Other button and either select
from a wider range of standard colors or define a custom color.

OK Click on this button to save and apply your changes, and close the dialog.

Cancel Click on this button to abort your changes, and close the dialog.
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Swimlanes Matrix

On any type of Enterprise Architect diagram, you can develop a Swimlanes Matrix to divide your diagram into cells at
the intersections of columns and rows. This Matrix is based on the Zachman Framework. The top left cell of the Matrix
contains the heading text, the cell at the top of each column contains the column title text and the cell at the left of each
row contains the row title text.

You can define only one Matrix Heading cell, but you can create as many row and column headings as you need. You
can also leave the column width and row height adjustable on the diagram, or fix the positions so that the cell borders
cannot be moved.

Access

Ribbon Design > Diagram > Manage > Swimlanes > Matrix

Layout > Diagram > Swimlanes > Matrix

Context Menu Right-click on diagram background | Swimlanes and Matrix > Matrix

Options

Option Action

Active Click on this checkbox to set the diagram to use the defined Matrix facilities, as
opposed to any Swimlanes that have also been defined.

Title # Type in a title name. You can provide one, two or three title names per heading to,
for example, group a set of columns or rows.

There is no effective limit on the length of the text string but it does not wrap, so to
display the full text you might have to drag the cell borders out to create a wide
cell. Alternatively, you can divide the text string between the 'Title' fields to reduce
the overall cell width.

Color Click on the drop-down arrow and select the color in which to display the text in
the heading, row or column title.

If the color you require is not shown, click on the Other button and either select
from a wider range of standard colors or define a custom color.

Font Click on this button to display the 'Font' dialog, through which you define the font
and style, size and effects of the text in the Matrix header, column and row titles.

If you also change the text color here, it overrides the setting of the 'Color' field
(above).

Hidden Select this checkbox to hide the corresponding Matrix header, row or column Title
text on the diagram.

Type Click on the drop-down arrow and select 'Heading', 'Column' or 'Row' to apply your
field settings to the Matrix heading cell, a column heading or a row title,
respectively.
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Back Color Click on the drop-down arrow and select the color in which to display the heading
cell, row or column background.

If the color you require is not shown, click on the Other button and either select
from a wider range of standard colors or define a custom color.

Hide Item Select this checkbox to hide the Matrix heading cell, row or column on the diagram.

Model Profiles Click on the drop-down arrow and select:

An existing Profile to override the current contents of the dialog·
'Empty Profile' to clear the fields so that you can define a matrix to save as a·
new Profile (see Model Profiles: Save)

Model Profiles: Save Click on this button to save the current dialog contents as a new Profile.

A prompt displays for you to assign a name to the Profile.

Model Profiles: Delete Click on this button to delete the currently-displayed user-defined Matrix Profile
from the drop-down list.

Line Widths Click on the drop-down arrow and select the line width of all row and column
borders - either 1 (thinnest), 2 or 3 (thickest).

Line Color Click on the drop-down arrow and select the color in which to display all lines in
the matrix.

Lock Select this checkbox to prevent the Matrix rows and columns in the diagram from
being resized.

Matrix list Lists the components of the current Matrix Profile, starting with the Heading and
followed by the columns and then the rows. For each item, the list shows the first
title (Title 1) whether it is visible on the diagram, and what type it is.

The columns are listed in the order in which they are displayed, left to right, on the
diagram.

The rows are listed in the order in which they are displayed, top to bottom, on the
diagram.

Hand (Up) Click on this button to move a selected column or row one position up in the Matrix
list. You cannot move a Column item above the Heading item, or a Row item above
a Column item.

When you save the changes, on the diagram the selected column or row is moved
left or up one place.

Hand (Down) Click on this button to move a selected column or row one position down in the
Matrix list. You cannot move the Heading item below a Column item, or a Column
item below a Row item.

When you save the changes, on the diagram the selected column or row is moved
right or down one place.

New Click on this button to clear the dialog fields so that you can add a new column or
row item to the Matrix.

Copy Click on this button to copy a selected item from the list so that you can give it a
new Title 1 and edit it as a new item.
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If you change the item, it is added to the list when you click on the Save button.

Delete Click on this button to delete a selected item from the list. The column or row is
removed from the list and diagram, which both close up.

OK Click on this button to save and apply your changes, and close the dialog.

Cancel Click on this button to abort your changes, and close the dialog.

Notes

When you define columns and rows, you define the header or title cells; the properties of these cells do not reflect on·
the matrix cells themselves - for example, the intersection cell of a column and row has a transparent background
and therefore takes the color and shading effect of the diagram background

You can transport the Swimlanes Matrix Profiles between models (as Diagram Matrix Profiles), using the 'Configure·
> Model > Transfer > Export Reference Data' and 'Import Reference Data' ribbon options

By applying a Matrix Profile to a diagram, you replace the current profile; save the current profile to avoid losing it·
To size the rows and columns, drag the row and column borders on the diagram - elements placed inside each cell·
are shifted when sizing; to prevent the elements shifting, press and hold Ctrl while sizing
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Diagram Legends

A diagram Legend is an element that you can add to your diagram to provide information about the colors and/or line
thicknesses and styles that have been used in the current diagram, where those colors and other styles have some
particular meaning. For example, it is common to have a Legend that indicates a particular color is indicative of a
particular element status or version. Connectors might be colored according to whether they are of a particular type or
direction. Element borders might be thicker or thinner according to some other property or condition.

Legends have additional capabilities, including the ability to auto color elements in different ways and according to
different rules and filters. The next sections detail the mechanics of setting up your Legend, but first a quick overview.

Simple Legend

Simple Legends are the kind that provide a manually configured key set that references the various styles used in the
diagram. For example, an element might be manually set to fill with the color red, and the Legend can be configured to
indicate that red means 'Overdue'. This is a very useful and powerful way of providing information about the conventions
and styles used and the meanings that they represent. You can create and add as many Simple Legends as you like to
your diagram.

Auto Legend

An Auto Legend is one that has the 'Auto Color' checkbox ticked. This puts the Legend into a more 'active' mode, and
will influence how the diagram is actually drawn without you having to make manual changes to the elements on display.

For example, it is possible to set up a Legend that will set all Requirement elements that have a Status of 'Validated' on a
diagram to a specific fill color. The color will be applied automatically to the filtered element set with no manual
intervention. This is a very powerful mechanism for providing a dynamic view of a diagram and exposing inner
attributes, properties or statuses in real-time. This technique can be applied to element fill, element border color, element
line thickness, connector line thickness and connector color.
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It is important to remember that when the auto-color property is set, the change in element appearance is only
dynamically applied on the Legend's diagram, and is not a permanent change. If you de-activate the Legend, all elements
affected will return to their base appearance.

Stacked (Multiple) Legend

What is even more powerful is the ability to 'Stack' multiple auto-color Legends on a diagram and let Enterprise
Architect dynamically color according to the union of all the different Legend conditions. For example, this approach lets
you dynamically color or affect the appearance of Requirements according to Status, Components according to Phase,
Use Cases according to Version, and so on. By stacking multiple Legends you have the ability to create a very rich and
detailed diagram that conveys a huge amount of information in its dynamically applied styles.

Getting Started with Legends

These topics provide the necessary information for creating and configuring Legends on diagrams. Keep in mind that you
can use Legends at any level, from the Simple type to the more dynamic Auto-Coloring and Stacked styles.
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Create Legends

A Legend element on a diagram provides a visual key to the colors and line thicknesses you have used to identify
elements and/or connectors that have particular meaning. The Legend can reflect a simple, manually-applied convention
such as all elements concerned with a management system being shaded in blue, or all outgoing connectors colored red.
However, the Auto-Color Legends can also automatically apply the style to elements or connectors having a chosen
property, such as a specific phase, stereotype or type.

The Legend lists the element appearance conventions first, and the connector appearance conventions underneath.

You work on a Legend element in two stages: first create and define the Legend element itself, then define the
appearance styles as displayed on the diagram.

Access

Toolbox
Drag the Diagram Legend icon ( ) from the Common page of the Toolbox onto
the diagram

Toolbar
Click the 'New Diagram Legend' icon ( ) on the UML Elements toolbar

Multiple Legends

In many cases a single Legend will be sufficient to define the styles and their meanings within the current diagram. In
some situations though, it is much more interesting and powerful to use multiple Legends, especially if the Legends are
Auto-Coloring. Situations where multiple Legends are useful include:

If you want to use more than one automatically-applied style (Stacked Legends)·
If you have used several manually-applied styles, and you want to identify them in small groups·
Where the diagram is large, and you want to reproduce the same key where it can be referred to in different sections·
of the diagram

Because a single Legend is limited to a single filter per element type (or all types), such as a range of Status values for
Requirements, multiple Legends are a good way of addressing different filters on different element types. A second
Legend, for example, might indicate that all Components are colored according to a Version or Phase number.

You can have conditions that operate on different properties, by defining those conditions in separate Legend elements.
However, check that the conventions in the two Legends operate on different display characteristics; for example, one
Legend setting Class fill color whilst the other sets Class border width. They cannot both act on the same property, such
as Class fill color. If they do, the most recently-created Legend (or the one with the highest Z-order) over-rides the
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previous Legend.

(c) Sparx Systems 2015 - 2017 Page 202 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Legend Properties

The 'Legend Properties' define the appearance of the Legend element itself, such as its background color, title text color
and size, and border color. If you choose to use default colors, these are derived from the 'Preferences' dialog, 'Standard
Colors' page.

Access

The 'Style Options' dialog for a Legend element can be displayed using any of the methods outlined here.

Ribbon Design > Element > Manage > Properties: Style Options

Context Menu Right-click on Legend element | Properties: Style Options

Other Double-click Legend element: Style Options

Define properties of a Legend

Option Action

Heading Size Either:

Overtype the font size of the Legend Title text with a different value, or·
Click on the 'spinner' arrows to increase or decrease the font size·

Font Color Click on the drop-down arrow and select one of the standard font colors for the
Legend Title text.

If you want to use a non-standard color, click on the Other button and either select
from the larger pallet or define a custom color.

Background Click on the down arrow and select one of the standard colors as the background
fill color of the Legend element.

If you want to use a non-standard color, click on the Other button and either select
from the larger pallet or define a custom color.

Border Color Click on the down arrow and select one of the standard colors as the color of the
border lines of the Legend element.

If you want to use a non-standard color, click on the Other button and either select
from the larger pallet or define a custom color.

OK button Click on this button to save your changes and close the dialog.

Cancel button Click on this button to abandon any changes and close the dialog.

Notes

(c) Sparx Systems 2015 - 2017 Page 203 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

As you define the properties of the element, the changes are reflected in the preview window to the right of the value·
fields
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Legend Key

A Legend element on a diagram provides a key to the element and connector appearance conventions used on that
diagram. Each element or connector convention is separately defined within the Legend element, using the 'Legend'
dialog and the element and connector tabs. If you want to present the Legend items in a specific sequence, you can adjust
the order in which the items are listed on the element.

You can create more than one Legend on a diagram, to represent particular combinations of conditions.

Access

The 'Properties' dialog for a legend element can be displayed using any of the methods outlined here.

Ribbon Design > Element > Manage > Properties

Context Menu Right-click on Legend element | Properties

Other Double-click on the Legend element
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Add a Legend to a diagram

Option Action

Name This field defaults to the name 'Legend'; overtype or edit the name if necessary. If
you are using the 'Apply auto color' facility, you might use the Legend title to state
which object property you are filtering for.

Apply auto color Select this checkbox if you intend to apply an appearance convention automatically,
according to a property of the objects as identified in the 'Filter' field.

Filter
Click on the  button and, firstly, select whether the convention is to apply to an
element (or connector) property or to a Tagged Value.

For an element or connector, a list of properties displays from which you select the
appropriate type.

For a Tagged Value, select whether to use a customized tag or select a standard
one. In either case, the 'Select Tagged Value' dialog displays. This dialog has a
drop-down field from which you select the tag to apply the appearance convention
to. The drop-down list is populated according to the options you select:

Global Tagged Values - populates the drop-down list with all global tags in the·
project; you can therefore select a tag that is applicable to a large number of
elements

Tagged Values from the selected Element - click on the Select Element button·
and locate and select the required element; this populates the drop-down list
with the Tagged Values from that element, so you can select from a specific set
of tags

Note that the tag does not have to exist already; you can type in the name of a new
tag if necessary.

Click on the OK button to apply your selection.

Applies to Click on the drop-down arrow and select the type of element or connector to apply
the filter and, hence, appearance convention to. If you want to apply the convention
to all types of element or connector, select <All>.

Use numeric evaluation Select this checkbox if automatic application of the convention has to evaluate the
numeric value of the property. For example, if a color is to be applied to elements
with a Phase of 3.0, the value can be simply matched; no evaluation is necessary. If
a color is to be applied to elements with a Phase value of less than 4, the Phase
values have to be evaluated to see if they are less than 4 (and not equal to 4).

The 'Apply auto color' checkbox must be selected for this checkbox to take effect.

Value Type the actual value of the tag or property that must be satisfied for the
appearance convention to be applied. You can use any of these operators with the
value:

.. (inclusive range); for example, 3..6 colors objects with the property having a·
value of 3, 4, 5 or 6

< (less than); for example, <4 colors objects with the property having a value·
of 1, 2 or 3

> (greater than); for example, >4 colors objects with the property having a·
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value of 5 or greater

= (equal to); for example, =5 colors objects with the property having a value of·
5 and only 5

n (single number on its own, same as equal to)·
n:y:x:z (matches on any number equal to one of the values); for example,·
2:4:6:8 colors objects with the property having a value of 2, 4, 6 or 8

The value that you enter becomes the name of the convention item in the Legend.

Fill Color Click on the down arrow and select the standard color used as the fill or
background color of the elements that match the selection criteria.

If you have manually applied a non-standard color on the diagram, it should be
available from the bottom of the pallet. If not, click on the Other button and either
select from the larger pallet or define it as a custom color.

Apply Fill (Defaults to selected; disabled if 'Apply auto color' is not selected.)

Deselect the checkbox if you do not want the fill color to be automatically applied
(that is, you only want the line color and/or line width automatically applied). This
setting applies to the Legend as a whole, not just to a key on the Legend.

Line Color Click on the down arrow and select the standard color used for the connector line or
element border.

If you have manually applied a non-standard color on the diagram, it should be
available from the bottom of the pallet. If not, click on the Other button and either
select from the larger pallet or define it as a custom color.

Apply Line (Defaults to selected; disabled if 'Apply auto color' is not selected.)

Deselect the checkbox if you do not want the line color to be automatically applied
(that is, you only want the fill color and/or line width automatically applied). This
setting applies to the Legend as a whole, not just to a key on the Legend.

Line Thickness Either:

Overtype the line thickness value with a different value (between 1 and 5), or·
Click on the 'spinner' arrows to increase or decrease the thickness·

Apply width (Defaults to selected; disabled if 'Apply auto color' is not selected.)

Deselect the checkbox if you do not want the line width to be automatically applied
(that is, you only want the fill color and/or line color automatically applied). This
setting applies to the Legend as a whole, not just to a key on the Legend.

New Click on this button to clear the fields in preparation for defining a new appearance
convention in the Legend. Take into account the points concerning multiple
conventions and multiple Legend elements.

Save Click on this button to save any changes you have made to an appearance
convention.

Delete Click on this button to delete the appearance convention you have selected in the
current list.

Value Lists the appearance conventions defined for objects in the diagram.

Hand (Up) If more than one definition is listed, click on this button to move the selected item
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closer to the start of the list.

Hand (Down) If more than one definition is listed, click on this button to move the selected item
closer to the end of the list.

Style Options Click on this button to define or edit the appearance of the Legend element itself.

OK Click on this button to save any current changes and close the dialog.

Cancel Click on this button to abort any unsaved changes you have made, and close the
dialog.

Notes

When you close the dialog, the Legend element is displayed showing all the appearance conventions defined;·
element conventions are listed first with connector conventions underneath, separated by a line across the Legend
element
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Image Assets

Image Assets are model elements that are used to store images in the model.

To create an Image Asset element, simply drag an 'Image Asset' icon onto a diagram from the 'Artifact' page of the
Diagram Toolbox. A prompt displays to choose an image file.

Alternatively, you can drag an image file from your file system straight onto a diagram. Enterprise Architect creates a
new Image Asset Artifact, then stores the image from the file in the Artifact, as the 'owned image'.

The Image Asset images can then be used as alternative images in place of the standard UML notation for elements on
diagrams. They can also be used in documentation by inserting hyperlinks to the Image Asset element. When a report is
generated, the hyperlinked Image Asset element is rendered using its 'owned image'.

Access

Diagram Toolbox Select the 'Artifacts' page | select 'Image Asset' | click on the diagram, or

Drag an 'Image Asset' Artifact from the toolbox onto a diagram.

Other Select an image file in your file system (say, on the desktop) then drag and drop it
onto a diagram in Enterprise Architect. A context menu will display; select the
option 'Image Asset'.

Using Image Assets in Documentation

Step Action

1 While editing the Notes of an element, or editing a Linked Document, right-click
and choose 'Create Hyperlink. The 'Hyperlink Details' dialog displays.

2 Select 'Element Image' from the drop down list. The 'Select Element' dialog
displays, showing only Image Assets.

3 Browse through the model and select the required Image Asset.

4 Click on the OK button.

Select an Image Asset as an Alternative Image

Step Action

1 Right-click an element on a diagram and choose the option 'Appearance | Select
Image Asset as Alternate Image' from the context menu. The 'Select Element' dialog
displays, showing only Image Assets.
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2 Browse through the model and select the required Image Asset.

3 Click on the OK button.

Viewing the Image

When placed on a diagram, the Image Asset can be displayed either as a simple artifact element, or as the owned image.
The display can be toggled from one to the other, by right-clicking the element and selecting 'Show Owned Image' from
the context menu.

When the Image Asset is displayed on a diagram as a UML Artifact element, double-clicking it will launch the default
external viewer for images and load the Artifact's owned image.

Ctrl+click on a hyperlink to an Image Asset displays the image in the default external viewer.

When hovering over the hyperlink the standard hyperlink element buttons will also be displayed, allowing you to display
the 'Properties' dialog, find the element in diagrams or find the element in the Project Browser.

Properties

To display the 'Properties' dialog for the Image Asset:

Select the element and press Ctrl+Enter, or·
If the Image Asset is displayed on a diagram as the image, double-click on it, or·
If the Image Asset is referenced by a hyperlink, hover the mouse over the hyperlink to display a floating toolbarand·
click on the View Properties button
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Using the Image Manager

When you add an element to a diagram, it is rendered according to the standard UML notation. However, you can
replace that representation with an image. For example, you could add a custom background image to a diagram, or
display an image of a Router or PC on a UML element. You import, store and select these alternative images using the
Image Manager. You can apply the image either as a:

Default image, which displays on all instances of the element in diagrams across the model, or·
An alternative image, which displays only for the specific instance of the element to which it is applied, and which·
overrides the default image for that instance

To locate and display images within the Image Manager, click on individual image filenames, or press the Up arrow and
Down arrow keys to scroll through the list of images. As you highlight each image filename, the 'Preview' panel changes
to reflect the image. Double-click on the required image filename to display the image in full size.

Access

Ribbon Configure > Reference Data > Images

Context Menu Right-click on an element within a diagram | Appearance | Select Alternate Image
or

Right-click on an element within a diagram | Appearance | Select Default Image

Keyboard Shortcuts Click on an element within a diagram : Ctrl+Shift+W

Image Manager Options

On the Image Manager, these buttons are available:

Button Action

View Click on this button to display the selected image in full size.

Shortcut: Alt+V

Usage Click on this button to display the 'Element Usage' dialog, which lists the diagrams
in which the selected image is used.

Rename Click on this button to change the filename of the selected image.

The option first warns you that the change would impact the other elements that use
this image, and prompts you to confirm that you want to go ahead with the name
change.

If you continue, a prompt displays for you to enter the new filename.

Add New Click on this button to display options for importing images from a file system or
from the clipboard.

From File - select this option to display a browser through which you can·
search appropriate directories to locate and import new images

(c) Sparx Systems 2015 - 2017 Page 211 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

You can import images in .bmp, .png, .emf, .wmf, .tga, .pcx or .jpg format

From Clipboard - select this option to download the image from the clipboard·
into the Image Manager (not via a diagram)

Internally, the images are stored in .png or metafile format to conserve space.

You can also add images by:

Importing a library of alternative images from the Sparx Systems website·
Copying the Image Library from another model using the 'Export Reference·
Data' and 'Import Reference Data' facilities, and

Capturing images from other sources into the clipboard and applying them to·
an element in a diagram, which automatically adds the image as an autonamed
file to the Image Library

If necessary, you can change the file name using the 'Rename' option.

Shortcut: Alt+A

Update Selected Click on this button to refresh the selected image; for example, after it has been
modified.

A browser screen displays for you to select the updated image file from its parent
directory.

Shortcut: Alt+U

Delete (Not available for an image from a deployed MDG technology.)

Click on this button to delete the selected image.

A message displays to indicate how many elements use the image. Click on the Yes
button to delete information about the image from those elements, which then revert
to their previous appearance.

Shortcut: Alt+D

Cancel Click on this button to close the Image Manager.

OK Click on this button to confirm selection of the alternative image for the element
selected in the diagram.

Shortcut: Alt+O

Notes

If you do not want an element to continue to have a default image or an alternative image, assign it the '--NONE--'·
option in the image list

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Configure Images' permission to configure alternative element
images

If you are connected to a SQL Server repository, you require ALTER permission on the t_image table in Enterprise·
Architect, to be able to import model images

For elements with Lifelines, such as those used on Sequence diagrams, the Lifeline must remain intact so that·
messages can be created between the elements; therefore such elements cannot have alternative images

There are two categories of image available through the Image Manager:·
    - Images that have been imported into the model and are stored in the model
    - Images that are incorporated into a deployed MDG Technology, which are not copied into the current
       model but are held in memory; the technology images can be identified by the Technology name
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       followed by the image file name, such as 'MDGFrame::ovalshape.emf', but can also be accessed by
       their short form (the name minus the technology name)

If you are creating many elements of the same type that have a particular image, you should use a custom stereotype·
with an associated metafile

If an element has an image, the element name is likely to be hidden; you can display the name underneath the image·
by right-clicking on the element and selecting 'Appearance | Show Name Under Image', and hide it again by
selecting 'Appearance | Hide Name Under Image'

You can transport image files between models, using the 'Configure > Model > Transfer > Export Reference Data'·
and 'Import Reference Data' ribbon options
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Create Custom Diagram Background

Enterprise Architect provides a number of options for setting the background of a diagram - a Theme, a system-defined
tile background, a single-color flat background or a fading color gradient down the screen.

Alternatively, using the Image Manager, you can create a customized tiled or non-tiled background for your diagrams.

Create a customized background

Step Action

1 Check that a suitable image is available in the Image Manager. If the image you require is held elsewhere,
import the file or the library containing the file.

2 Open a diagram and create a Boundary object from the 'Use Case Elements' page of the Toolbox (do not
use the Boundary element from any other section of the Toolbox).

3 Stretch the Boundary to a size that can contain all of the elements you intend to place on the diagram, and
drag it to the edges of the diagram workspace.

4 Right-click on the Boundary element and select the 'Z-Order | Send to Bottom' option.

This places the Boundary behind all other elements on the diagram.

5 Either:

Press Ctrl+Shift+W, or·
Right-click on the Boundary and select the 'Appearance | Alternate Image' option·

6 On the Image Manager window, select the required image for the diagram background and check that the
image size is large enough to span the required size of the diagram background.

7 Click on the OK button.

Notes

As an alternative method: after you have added the Boundary element to the diagram, copy an image from another·
source onto the Windows clipboard, right-click on the Boundary element, and select the 'Appearance | Apply Image
From Clipboard' option
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Import Image Library

Using the Image Manager, you can create attractive diagrams with custom images. You can quickly extend the range of
images available through the Image Manager, by importing a bundled clip art collection of UML-based images as an
Image Library file downloaded from the Sparx Systems website.

Import the Image Library file

Step Action

1 Download the Image Library from the Sparx Systems website onto your system.

2 In Enterprise Architect, open the project into which to import the Image Library.

3 Select the ribbon option 'Configure > Model > Transfer > Import Reference Data'. The 'Import Reference
Data' dialog displays.

4 Click on the Select File button and locate the ImageLibrary.xml file to import, in the directory to which
you downloaded the file.

Click on the Open button.

5 On the 'Import Reference Data' dialog, select the 'Model Images' data set that now contains the Image
Library.

Click on the Import button and, when the import is complete, the OK button.

Use the images contained within the Image Library

Step Action

1 Create and/or open a diagram in which to use images from the Image Library.

2 Click on the element to which to apply one of the images contained within the library.

3 Either:

Press Ctrl+Shift+W, or·
Right-click on the selected element and select the 'Appearance | Select Alternate Image' option·

4 On the 'Image Manager' dialog, in the 'Loaded Images' panel, click on the appropriate image name and
then on the OK button.

The element appearance changes to the selected image.

Notes
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Images contained within the Image Library are the copyright of Sparx Systems, are only available for use in·
conjunction with Enterprise Architect, and are supplied on the understanding that they are not used under any other
circumstances

If you are connected to a SQL Server repository, you require ALTER permission on the t_image table in Enterprise·
Architect, to be able to import model images
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Print Preview

Before you print an Enterprise Architect diagram or document, you can display a preview of its output appearance.

Access

Ribbon
 > Print Preview

Publish > Documentation > Print Diagram > Print Preview

Document-Edit > File > File > Print Preview

Notes

The display initially shows the first two pages on one screen, with no scroll bar·

To toggle between the two-page display and a single-page display, click on the  button in the preview screen·
toolbar; in either mode, you can use the    and  buttons in the toolbar to scroll through the pages of the diagram
or document

To display more than two pages on one screen, up to a maximum of ten pages, click on the  button in the·
Preview screen toolbar; the screen now includes the vertical scroll bar, which you can also use to scroll through the
pages of the diagram

Having checked the preview, you can immediately print the diagram or document by clicking on the ·
button; otherwise click on the Close button
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Elements

Elements are the building blocks of models and, together with Connectors, they help a modeler to describe an enterprise,
business engineering, real-time or software system. They can be found in the Project Browser and will typically appear
on one or more diagrams, where a modeler will describe what role they play in the model. They also appear in a wide
range of dialog windows that show other aspects of the elements, such as testing and resource allocation.

The element types are defined by the modeling languages or profiles they belong to; for example, Classes and Use Cases
are part of the grammar of UML, Activities and Gateways are part of the grammar of BPMN, and Blocks and
Requirements are part of the grammar of SysML. Each element type has a notation that helps modelers recognize the
element and understand its purpose.

Elements typically have a name, description and a series of properties and features that describe them, including project
properties such as status, phase and author.
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Element Facilities

Enterprise Architect provides a wide range of facilities for creating, editing and working with the elements that represent
aspects of your models.

Facilities

Facility Description

Create Elements Creating elements is extremely versatile. You can create entirely new elements or
elements derived from existing ones, on diagrams or directly into Packages, from
the standard system-provided definitions or from your own definitions in templates,
Patterns or MDG Technologies.

Customize Elements If the standard elements provided do not serve the purposes of your model, you can
give some elements different appearances and/or define a set of properties for them,
or create completely new types of element, and use these as the bases for creating
the elements in your model.

Name Elements As you create an element, you can either provide the name yourself, manually, or
leave it for the system to provide from a simple standard or a more advanced
automatic naming and numbering system set up by your department.

Set Element Parents Once you have created an element, you can assign it to a parent element or to an
interface that it realizes.

Trace Element Use As you develop your models and use elements in several diagrams to represent
different views of the model, you can track and list where the element is in use.

Move Elements You can easily move individual elements or element structures around the model to
other Packages and/or diagrams, either changing the parent Package or diagram, or
duplicating the elements in another Package or diagram.

You also have a number of different ways in which to change the position of an
element or a group of elements within a diagram, either in relation to the diagram or
in relation to each other.

Cross Referencing
Elements

It is possible to set up a cross reference (or Custom Reference) from one element in
Enterprise Architect to another. You can also view existing cross references on an
element, using the 'Context References' dialog or the Traceability window.

Change Element Type Sometimes, you might find that an object that you have represented as one type of
element would be better represented as another type. You can change the type very
quickly and simply.

Delete Elements Elements can be created in error, or used on the wrong diagrams, or have a
temporary function that becomes redundant. In such case you can easily and safely
delete the elements from the diagram only or from both the diagram and the model.

Change Element Visibility Some elements are not shown in Packages and in report documents, by default.
These include Events, Decisions, Sequence elements and Associations. You have
the option of making these elements visible in the documentation.
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Write External
Descriptions for Elements

One aspect of modeling is to describe and document the purpose and use of an
element in the context of a particular diagram. You can provide such documentation
in the form of Note or Text elements displayed with and connected to the elements
they describe. The Note text can be extra to anything contained within the element,
or can expose the internal description of a feature or property of the element.

Customize Element
Appearance

You can set a number of standard default features that are applied globally to all
elements, but you can also define a different default appearance for one element
wherever it might be used.

Set Context Element Sometimes, when you are working on a diagram, you might want to identify the
element against which you are comparing or standardizing some or all of the other
elements on the diagram. You can highlight the selected element as the context
element.

Use Element Multiple
Times

When you are using an element in more than one diagram, you can either create a
representation of the element linked to the original, or a copy of the element as a
separate object. If you create a link, you can subsequently convert it to a separate
object.

Reuse Element Features Many types of element have Features (Attributes and Operations) that define the
properties and actions of the element. You can duplicate selected features of one
element in another, or take a feature out of one element and place it in another.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have Update Element permission to update element properties or delete an
element
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Create Elements

Enterprise Architect provides a number of ways to create completely new elements and those derived from existing
elements. The simplest of the methods for creating a new element is to drag the icon for the required type of element
from the Diagram Toolbox onto a diagram, as shown.

This method creates the element according to the system standard for that element type. You can also provide alternative
element definitions that the Toolbox icons reference (using the system 'Preferences' dialog, Patterns or element
Templates) and add further element definitions using Profiles and MDG Technologies (either supplied with the system or
developed by your project team).

Notes

If you are creating several elements of one type, after creating the first just press Shift+F3 or Ctrl+click to create the·
next element of that type

Once you have created an element, you can re-use it by dragging it from the Project Browser and dropping it onto·
your diagrams

Sometimes it is useful to add elements directly to a Package, without adding them to a diagram; you can do this·
within the Project Browser
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Add Elements Directly To Packages

You can quickly add new elements to a Package without necessarily adding the element to a diagram at the same time.
This is particularly useful in defining a group of Requirements, Changes, Issues, base Classes or other element types that
you might not need to represent on diagrams in the model. You do, however, still have the option of adding the element
to an open diagram.

Access

Ribbon Design > Element > New > Add New Element

Context Menu Right-click on Package | Add Element

Keyboard Shortcuts With a Package selected in the Project Browser: Ctrl+M

In a diagram, press the M key

Other Project Browser caption bar menu | New Element

Add an element to a Package

Option Action

Name Type the name of the element.

Auto As an alternative to typing in the name, click on this button to insert predefined
auto-counter text.

If you already have some text in the 'Name' field, it is over-written by the
auto-counter text.

Type Click on the drop-down arrow and select the required element type from the list.

The list of element types is derived from the diagram or technology shown in the
'Toolset' field.

Toolset Shows the current UML diagram type, Profile, Add-In or MDG Technology within
which you are creating the element.

Toolset (button) If the Toolset is not appropriate for the type of element you want to create, click on
this button and select the required diagram type or technology.

The <default> group in the list provides a basic set of elements drawn from across
the UML Behavioral and Structural groups, and the Enterprise Architect Extended
groups.

The selected technology is displayed in the 'Toolset' field.

Stereotype If required, either type the stereotype name or click on the drop-down arrow and
select the stereotype.

This field is not available if the element you are creating is an extended element
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that already has a stereotype.

Add to current diagram This checkbox is available if you have a diagram open and you are working from
the Project Browser.

The checkbox defaults to selected to add the new element to the diagram also; if
you do not want the element in that diagram, deselect the checkbox.

If you accessed this dialog by pressing the M key on the open diagram, this
checkbox is not available. The element is automatically added to the diagram, in the
top left corner.

Save Click on this button to create the element and close the dialog.

If you accessed this dialog by pressing the M key in an open diagram

the element is created in the top left corner of the diagram, and·
the dialog remains open·

If you accessed the dialog by selecting the 'New Element' option from the Project
Browser header drop-down menu, clicking on this button also leaves the dialog
open.

Save and Exit Available if you have accessed this dialog by pressing the M key on an open
diagram, or by selecting the 'New Element' option from the Project Browser header
drop-down menu.

Click on this button to create the element and close the dialog.

Cancel Click on this button to abort the changes and close the dialog without creating an
element.

Notes

The 'New Element' dialog also displays when you create an element in the Specification Manager, if the·
Specification Type is <Any>
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Set Auto Naming and Auto Counters

When you create a new element in your model, you have different options for naming the element depending on how you
are creating it. If you create the element:

On a diagram, the system applies a default naming convention of the element type plus the increment of the number·
of elements of that type in the same Package - for example, Actor4; you can change this to any other name by
editing the 'Name' field on the element's 'Properties' dialog

Within the Project Browser, the system prompts you to type the element name into the 'New Element' dialog·
You can also set up your own, automatic, naming and numbering convention for elements of the same type, so that:

On a diagram, it is your naming/numbering convention that is automatically applied to the new element (which you·
can still change if you need to, as before)

Within the Project Browser, the 'New Element' dialog Auto button applies the naming convention to your new·
element

If you have existing elements in a Package, and you want to apply the new naming convention to them, you can make
this change very easily to all elements of the same type in the Package at once.

You define a naming convention for the element type as a model setting. At the same time, you can also optionally define
a naming/numbering convention for the 'Alias' field for elements of that type.

Access

Ribbon Configure > Reference Data > Settings > Auto Names and Counters

Set up auto naming for an element type

Option Action

Type Click on the drop-down arrow and select the element type to which to apply auto
naming/auto numbering.

Name Prefix Type a prefix for the new names (optional).

Name Counter Type the counter value; use as many 0's as required to pad the number.

Name Suffix Type a suffix for the new names (optional).

Name Apply on creation Select the checkbox to apply auto naming to each new element of the specified
type, on creation.

If you do not select the checkbox (but click on Save), the autonaming details for the
specified element type remain defined in the dialog, but are not applied to new
elements of that type. The default element naming convention takes effect
(<element type><n>).

Alias Prefix Type a prefix for the new Aliases (optional).

Alias Counter Type the counter value; use as many 0's as required to pad the number.
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Alias Suffix Type a suffix for the new Aliases (optional).

Alias Apply on creation Select the checkbox to apply Alias auto naming to each new element of the
specified type, on creation.

If you do not select the checkbox (but click on the Save button), the Alias
autonaming details for the specified element type remain defined in the dialog, but
are not applied to new elements of that type. The default element naming
convention takes effect (<element type><n>).

Save Click on this button to preserve the values you have entered.

New elements of this type now have an automatically-generated name and/or Alias
with an incrementing counter value.

If the user creates an element on a diagram, such as from the Diagram Toolbox·
or Quick Linker, the element is automatically assigned the defined name and/or
Alias

If the user creates an element outside a diagram (such as in the Project·
Browser) using the 'New Element' dialog, they can click on the Auto button
next to the 'Name' and/or 'Alias' field on the appropriate dialog to apply the
auto-generated text

If the user already has some text in the 'Name' or 'Alias' field, it is over-written·
by the auto-counter text

If an Alias is active, to view the Alias in a diagram requires that the option 'Use
Alias if Available' is selected in 'Diagram Properties'.

Notes

Automatic numbering - whether system default or user-defined - does not increment across Package levels; if you·
have an element called Actor1 in Package A, and you create an Actor element in a child Package of Package A, that
Actor will also be Actor1

(c) Sparx Systems 2015 - 2017 Page 225 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Apply Auto Naming to Existing Elements

If you have set up auto-naming conventions for the names and/or Aliases of specific types of element, you can apply
those conventions to all of the existing elements of those types in a selected Package, in one operation.

You apply auto-naming through the 'Apply Auto Naming to Elements' dialog. This groups the elements that have
auto-naming conventions by type, and shows the effects of applying the conventions to the element names and/or
Aliases. You can change all the element names in the Package, or select only certain elements to update.

Access

Context Menu Right-click on Package | Advanced | Apply Auto Naming to Elements

Apply Auto-naming to elements

Option Action

Current Name Initially displays a contracted group for each element type that has auto-naming
conventions, showing the number of elements of that type in the selected Package.

Click on the '+' symbol to expand the type group and list the elements within it by
their current name, with the most recently created element first.

Select the checkbox against each element to be renamed, or against the element
type name to select all elements in the group. Deselect the checkbox to leave the
element name and Alias at their current values.

Name Preview Initially shows the elements' current names.

When you select the checkbox against each element, the name changes to show the
effect of applying the auto-naming conventions to it.

Alias Preview Initially shows the elements' current Aliases.

When you select the checkbox against each element, the Alias changes to show the
effect of applying the auto-naming conventions to it.

All Click on this button to select all elements listed on the dialog.

Clear Click on this button to clear the checkboxes of all selected elements.

Update Name

Prefix Auto Name to
Current Name

Click on this radio button to set the new element names to the auto-name text
followed by the current name. That is, of this structure:

    MyPrefix00001MySuffix Original Name

Overwrite current Name
with Auto Name

Click on this radio button to set the new element names to the auto-name text only.
That is, of this structure:
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MyPrefix00001MySuffix

Move current Name to
Notes

Apply Auto Name

Click on this radio button to show the current name in the 'Notes' field in the
element 'Properties' dialog (in front of any existing notes) and overwrite the element
'Name' field with the auto-name.

No change Click on this radio button to leave the current names unchanged. That is, review
what the auto-naming would look like but not apply it.

Update Alias

Prefix Auto Alias to
Current Alias

Click on this radio button to set the new element Aliases to the auto-Alias text
followed by the current Alias. That is, of this structure:

    MyPrefix00001MySuffix Original Alias

Overwrite current Alias
with Auto Alias

Click on this radio button to set the new element Aliases to the auto-Alias text only.
That is, of this structure:

MyPrefix00001MySuffix

Move current Alias to
Notes

Apply Auto Alias

Click on this radio button to show the current Alias in the 'Notes' field in the
element 'Properties' dialog (after any replaced element name text, but in front of any
existing notes) and overwrite the 'Alias' field with the auto-Alias.

No change Click on this radio button to leave the current Aliases unchanged. That is, review
what the auto-Aliases would look like but not apply them.

Include sub packages Select this checkbox to include elements in sub-Packages in this run of applying
auto-naming (the checkbox reverts to deselected when the dialog is closed).

Configure Auto Naming Click on this button to immediately define automatic naming conventions for an
element type if:

You want to change the conventions for the element type, or·
The element type that you want to apply auto-naming to has no conventions·
(and is therefore not listed on the dialog)

The 'Auto Name Counters' dialog displays, on which you define your automatic
element and/or Alias naming convention. When you click on the Save button on
that dialog, any elements of that type in the Package are listed on the 'Apply Auto
Naming to Elements' dialog.

OK Click on this button to close the dialog and put the naming changes into effect.

Cancel Click on this button to close the dialog and cancel any naming changes you have
defined.

Notes

If you select this facility and there have never been any auto-naming conventions defined in the model, the 'Current·
Name' column displays the message Configure Auto Naming; click on the Configure Auto Naming button to define
any conventions for any element type you need
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The contents of Packages that are locked under version control will not be auto-named·
Because you are applying auto-naming to existing elements, the auto-naming set up 'Apply on Creation' setting has·
no impact on this operation

The 'Apply Auto Naming to Elements' dialog is resizable; if you want to expand or reduce the dialog, drag its edges·
to the size you want
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Set Element Templates Package

In building up a model, you might want to represent or emphasize certain characteristics of elements in the appearance of
those elements, or select particular display options as standard. For example, you could make new Interface elements a
different default color to new Class elements, ensure all new Activity Partitions are vertical rather than horizontal, or set
a specific group of display options for new Use Case diagrams.

To do this, you create an element or a diagram with all the characteristics you require, and store it in an Element
Templates Package; the system then checks this Package:

Whenever you create a new diagram, or·
Whenever you start to create an element using the Diagram Toolbox·

When you are creating a new diagram, the system checks for the diagram type in the Templates Package and, if it finds
that diagram type, will copy the display options of the template diagram into the new diagram.

When you are creating a new element, the system checks for that element type in the Templates Package and, if it finds
that element type, will copy the template element as defined. The definition includes any default display options of the
template element, so you can apply the template definition and switch to the default appearance for the new element, if
you prefer.
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You can create the Templates Package anywhere in your model; however, it is better to create it in a location that is not
likely to be accidentally changed or lost in any project development work.

Set up the Element Templates Package

Step Action

1 Create a new Package. 'Templates' is used as the Package name in the illustration, but you can give the
Package any name you prefer.

2 Within the Templates Package create new diagrams, one for each type of diagram to template.

Give the diagrams easily recognized names; for example Class Template for the template for Class
diagrams.

3 Add elements to the template Package (each element must also appear on one, and only one, diagram),
and configure the size, appearance, notes, version and other properties that you want new elements to
have. You can use a standard UML element or a stereotyped element as the base for your template
definition.

4 Select the 'Configure > Reference Data > Settings > Project Template Package' ribbon option to set the
templates as the default element templates.

The Find Package window displays.
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5 Locate and click on the Templates Package, and click on the OK button to set the Package as the default
Element Template Package (you can set only one Package as the Templates Package at a time).

Now each new element or diagram you add to your project is created with the settings from the
appropriate template element or diagram.

Notes

In the Corporate, Business and Software Engineering, System Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Manage Reference Data - Update' permission to set up or access the
Element Templates Package

The fill color for an element derived from the element template can be overridden by the element fill color defined·
by a Shape Script applied to the element via a stereotype, or you can switch to or change the default appearance in
the 'Default Appearance' dialog

If you decide not to use any element templates, set the Element Templates Package to '<none>' in the Find Package·
window; the '<none>' Package is at the bottom of the hierarchy shown in the window

An alternative way in which you can modify the immediate appearance of elements as you create them in diagrams·
is to redefine them, either under the same type name or as new element types, in a UML Profile
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Set Element Font

When you display an element on a diagram, the text font defaults to a global setting defined from the 'Diagram
Appearance' page of the 'Preferences' dialog. You can change this global default setting if you need to. On the diagram,
however, you might want to change the font only on a specific element or group of elements, to distinguish them from
other elements. You have several options for doing this.

Access

Ribbon
Layout > Style >  (Set Font)

Context Menu Right-click on element | Appearance | Set Font

Font Dialog Options

Option Action

Font Scroll through the list of font types and click on the name of the appropriate font,
which is then displayed in the field at the top of the list.

This setting affects all text in the selected element except for the Note compartment
text.

Font Style In the list of font styles click on the name of the appropriate style, which is then
displayed in the field at the top of the list.

This setting affects all text in the selected element except for the Note compartment
text.

Size Scroll through the list of font sizes and click on the appropriate size, which is
displayed in the field at the top of the list.

Alternatively, type the font size directly into the field.

This setting affects all text in the selected element.

Strikeout Select this checkbox to show the element text with a line through it. (This checkbox
is not currently available.)

Underline Select this checkbox to show the element text with an underline.

Color Click on the drop-down arrow and click on a color in the list.

(If you access the 'Font' dialog through the 'Default Appearance' dialog, the color
you select will be overridden by the color in the 'Font Color' field of the 'Default
Appearance' dialog, if different.)

Script If Western script is not appropriate for the element text, click on the drop down
arrow and select a different script type.
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Sample Review the combined effects of the settings you have selected.

OK Click on this button to save your changes.

Notes

If you set the element font through the 'Default Appearance' dialog (F4) the changes can be overridden by any·
different values set through the other two access paths

When it has been called directly on one or more selected elements ('Appearance | Set Font'), the 'Font' dialog·
overrides the 'Default Appearance' dialog
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Move Elements Within Diagrams

As you add new elements to a diagram, you might want to move the existing elements to create more space, make a
structure more apparent, or create a nesting relationship between two elements. There are several ways in which you can
move the elements within the diagram.

Move Elements

Image Action

Change Position Select an element or group of elements in the diagram, then:

Use the mouse to drag the element or group of elements to the required·
position (the cursor switches to the four-arrow icon as shown)

Hold down Shift and press the appropriate arrow keys to move the element or·
group of elements by small increments in the arrow direction

Align Elements Select a group of elements in the diagram and align them on the last-selected
element using:

The 'Align...' options in the right-click context menu or·
The Alignment buttons on the Diagram toolbar·

Confirm Possible Nest
Elements

If you want to nest one element within another, you can drag that element onto the
'nest' element; the nesting element is then always encapsulated by the nest and
moved within the nest.

Not all element combinations are valid. For example:

Drag a Signal element over a Class; because a Class element can nest a Signal,·
the Signal element is encapsulated

Drag a Class element over a Signal element; because a Signal cannot nest a·
Class, the Class element is not encapsulated

To confirm that the proposed nest element is able to accept the selected nesting
element, observe the nest element border as you drag the nesting element over it:

If the nest element can accept the selected element, the nest element border·
changes to a dashed line

If the border does not change, the selected element cannot be encapsulated·
within the nest element
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Notes (on Adding nesting element to nest)

The 'Support for Composite Objects' checkbox must be selected on the 'Objects' page of the 'Preferences' dialog·
(select 'Start > Workspace > Preferences > Objects'); if this option is not selected, the dashed border does not show
and the nesting element cannot be embedded on the nest element in the diagram

Both elements must already exist on the diagram; the nest element border does not change if you drag a potential·
nesting element over it from the Toolbox or Project Browser

The nesting element must be dragged right over the nest element, so that its borders are completely within the nest·
element borders

The Z-order of the nesting element is automatically adjusted so that it is not hidden by the nest element·
When you embed a nesting element on its nest element, the nesting element becomes part of the nest element·
hierarchy in the Project Browser; if you drag the nesting element out of the nest element, the nesting element
becomes independent and is no longer embedded in the nest element hierarchy

If you have selected the 'Structure Compartment' checkbox on the 'Feature and Compartment Visibility' dialog, the·
nesting element is confined to the Structure Compartment and cannot be dragged out until the checkbox is
deselected again
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Copy Elements Between Diagrams

On a diagram, if you have created a structure of elements such as a StateMachine, you might want to copy that structure
onto another diagram as a new set of elements without losing the organization of the structure. In doing this, you can
change any of the element names within the structure and still preserve the relative nesting of the elements.

You can also cut multiple elements from one diagram and paste them into another, and simple paste an element or
elements as links to the original elements. If you cut elements from a diagram, the elements are not cleared from the
source diagram until they are pasted into the target diagram.

Access

Ribbon With element(s) selected in source diagram:

Layout > Diagram > Edit > Copy·

With input focus on target diagram:

Layout > Diagram > Edit > Paste as Link or·
Layout > Diagram > Edit > Paste as New·

Keyboard Shortcuts With element(s) selected in source diagram:

Ctrl+C·

With input focus on target diagram:

Shift+Insert (Paste as Link)·
Ctrl+Shift+V (Paste as New)·

Complete the Paste Element(s) as New Dialog

Option Action

Original Element Name Each element name defaults to selected, to be inserted in the target diagram.

If you want to omit an element from the copied structure, clear the checkbox
against it.

New Element Name If you want to give a copied element a new name, delete the current name and type
in the new name.

Include Connectors This checkbox defaults to selected, to make copies of the original connectors where
both source and target elements in the relationship have been copied. This
maintains the relationships between and organization of the copied elements.

If you do not want to copy the connectors, clear the checkbox.

Paste Click on this button to add the copied elements and connectors to the target diagram
as new elements.
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Notes

Package elements cannot be copied as structured elements·
The Date Created and Time Created parameters of a pasted-as-new element are set to the current date and time; the·
parameters for a linked element remain the same as the copied element

Elements - including special embedded elements such as SysML Properties - do not have to have a parent element·
when pasting as new, although normal embedded elements such as Ports must have a parent

Elements in State regions cannot be pasted as new outside the parent element·
Parenting is still applied when copying and pasting as new using Ctrl+click-and-drag between (floating) diagrams·
You can also use the Cut, Copy and Paste icons in the Default Tools toolbar·

(c) Sparx Systems 2015 - 2017 Page 237 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Move Elements Between Packages

If an element or Package is not in the most appropriate part of the model structure, you can move it to a different location
in the Project Browser, either by:

Dragging and dropping the element to a target destination, or·
Cutting and pasting the element or Package·

If you move a Package, all the subordinate Packages and their contents are moved to the new location also.

Drag an element between Packages

Step Action

1 Click on the element in the Project Browser.

See 'Customer' in the example diagram.

2 Drag the element so that the cursor is over the target Package icon. The element symbol (and, in some
operating systems, the element name) displays at the moving cursor position.

3 Release the mouse button.

The element is moved into the target Package.

Cut and Paste the Element

Step Action

1 In the Project Browser, right-click on the element to be moved and select the 'Copy / Paste | Cut' option.
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The selected element is highlighted.

2 Right-click on the Package or element under which to move the cut element, and select the 'Copy / Paste |
Paste' option.

The cut element is listed as a child of the selected element or Package, in the Project Browser.

Notes

You can also drag the element under a host element in the new Package; for example, drag an element under a Class·
Moving an element has no effect on any relationships that the element might have·
Moving an element in the Project Browser has no effect on the use of that element in any diagram·
Moving a diagram generally does not affect the location of elements in Packages - if you move a diagram out of one·
Package into another, all the elements in the diagram remain in the original Package; however, certain elements
(such as Decision, Initial and Final elements) are used only within one diagram, have no meaning outside that
diagram, and are never re-used in any other diagram, therefore, if you move a diagram containing these elements
they are moved to the new parent Package with the diagram

In a multi-user environment, if one person moves or updates the Project Browser structure, other users must reload·
their project to see the latest changes in the Project Browser; although this is true of any addition or modification to
the tree, it is most important when big changes are made, such as dragging a Package to a different location
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Copy Elements Between Packages

You can quickly and easily duplicate one or more elements, with their child elements and diagrams, across Packages.
You can insert a copy of an element under one or more other Packages, in the same project file or any other project file.

Operations

Operation Actions

Copy the Elements In the Project Browser, select the elements to copy, right-click on one and select:

    'Copy / Paste | Copy to Clipboard | Full Structure for Duplication'

Alternatively, click on a selected element and press Ctrl+Shift+C.

The 'Copying Selected Element(s) to Clipboard' dialog briefly displays while the
copy operation completes.

Paste the Elements In the Project Browser, right-click on the Package into which to paste the copied
elements, and select the 'Copy / Paste | Paste Element(s) from Clipboard' option.

Alternatively, click on the Package and press Ctrl+V.

The 'Pasting Element(s) from Clipboard' dialog briefly displays while the paste
operation completes.

The target Package is expanded and the pasted elements are exposed in the Project
Browser. If you are pasting the elements within the same model as the copied
source, the source parent Package is also collapsed.

If the target Package already contains:

An element of the same type with the same name as a pasted element, the·
pasted element name has the suffix - Copy

An element with the same type and name as the pasted element including the -·
Copy suffix, the suffix becomes - Copy1 (or - Copy2, - Copy3 and so on, as
copies of the element accumulate in the target Package)

You can keep the same element names as the source, or you can rename each
element either by clicking twice on it and editing the name in the Project Browser,
or by double-clicking on it and editing the name in the 'Properties' dialog.

Notes

A copy of an element does not have the external cross references of the source element; that is:·
    - if one element is copied it has no connectors
    - if more than one element is copied, only the connectors between the copied elements are retained
    - however, if those elements come from a Sequence or Communication diagram and the diagram itself is not
copied, the message
       connectors between the copied elements are not retained

You cannot paste an element into a Package that is locked by another user or that is checked in; the 'Paste...' option·
is grayed out in the context menu
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Copy Features Between Elements

As well as copying elements between Packages using a diagram, you can also copy features - attributes and/or operations
- between elements in a similar way, dragging the features from an element in the Project Browser or Element Browser
and dropping them onto another element in a diagram.

Copy a single element feature

Open a diagram containing the target element. In the Project Browser or Element Browser, click on the attribute or
operation and drag it onto the element in the diagram.

In this example, the attribute Account is being dragged and copied from the Customer element in the Project Browser
into the AccountItem element in a diagram. The process from the Element Browser is, visually, almost identical.

This image shows AccountItem after the attribute Account has been dropped on to it.

Notes

You can also select and copy multiple features at the same time; you simply press Ctrl or Shift as you select the·
features in the element in the Project Browser, drag them onto the diagram and drop them into the target element
(you cannot copy multiple features from the Element Browser)
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Move Features Between Elements

As well as moving elements between Packages in the Project Browser, you can also drag and drop features - attributes
and operations - between elements to move them out of the source element and into the target element.

Move element features

Perform these actions in the order in which they are listed.

Images Action

In the Project Browser, click on the attribute or operation to move from the source
element.

If you are moving several features at once, while you click on the features hold
down:

Ctrl (several individual features) or·
Shift (the first and last features in a range)·

Holding down the mouse button, drag the attributes and/or operations to the target
element.

A single feature symbol (and, under some operating systems, the first feature name)
displays under the cursor during the move; however all of the selected features are
moved.

Release the mouse button.

The features that you selected and drag/dropped are now features of the target
element, as seen in the Project Browser.
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Highlight Context Element

When you click on an element on a diagram, it becomes the context element; that is, all actions take effect on that
element. The context element has black rectangles on its border, firstly to indicate that the element is selected and
secondly to act as 'handles' that you can click on and drag to enlarge or shrink the element.

Many actions that you can take on an element involve selecting menu options or working on windows and dialogs that
are separate from the element, and on a large or complex diagram you can lose track of the context element. To make
every context element more visible, you can configure the system to add a hatched border to the element.

Access

To add a hatched border to the context element, open the 'Preferences' dialog using one of the methods outlined here,
then select the 'Always Highlight Context Element' checkbox on the 'Diagram Behavior' page.

Ribbon Start > Workspace > Preferences > Preferences > Diagram > Behaviour: Always
Highlight Context Element

Multiple Selection

If you select multiple elements to work on at the same time, the context element has a hatched border by default,
regardless of whether the Always Highlight Context Element checkbox is selected or not. The context element here is the
element against which other selected elements are aligned, or through which the changes to properties are made.

Notes

If you have selected multiple elements and you want to change which element is in context, simply click once on the·
element to become the context element
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Insert Related Elements

Elements can be used more than once in a model, either individually or as a group. If you want to reproduce an existing
set of elements that have one element as the focus, without copying and linking the elements individually in the new
diagram, you can use the Insert Related Elements facility. With this facility, you drag the context element from the
Project Browser onto your diagram, right-click on it and select to add related elements. The 'Insert Related Elements'
dialog displays, on which you can specify:

Which types of relationship to filter on, and what direction these relationships have·
Which types of element to filter on·
Which Package the related elements exist in·
How many levels of relationship to bring in; that is, just the elements immediately related to the focus element, or·
also elements related through those elements

Whether to add all elements that satisfy the criteria you have specified, or just those you select·
Whether or not to automatically re-organize the diagram when the related elements have been added·

Access

First, select an element on the diagram, then:

Ribbon Design > Element > Insert Related

Context Menu Right-click on element | Insert Related Elements

Define selection criteria to insert related elements

Field/Button Action

Connector types Displays the types of relationship in which the selected element and, if more than
one level of relationship is selected, its related elements are currently involved.

To limit the inserted elements to those connected by specific relationship types,
select the checkbox against each of those types of connector.

To deselect a selected checkbox, click on it again.

Element types Display the types of element to which the selected element and, if more than one
level of relationship is selected, its related elements are connected.

To limit the inserted elements to those of specific types, select the checkbox against
each of  those types.

To deselect a selected checkbox, click on it again.

Link Direction Limit the inserted elements to those in incoming or outgoing relationships with the
selected element; click on the drop-down arrow and select the appropriate direction,
or <All> for either direction.

Limit to Namespace Restrict the inserted elements to those from a specific Package; select the
 namespace from which the elements are to come. Select <None> for elements in
any namespace.
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Find relationships to: levels Click on the drop-down arrow and select the level down to which to insert
connected elements, between levels 1 (immediately related elements) and 5
(elements 5th in a chain from the focus element).

You can select levels 4 or 5 to see how far the element/relationship hierarchy
extends, but as this can produce a complicated and tangled diagram, it is better to
use level 1 or 2 on selected elements in turn.

Refresh Click on this button to locate and list all elements that satisfy the criteria you have
specified.

Each list item shows the depth at which the related element exists in relation to the
focus element, the name of the element, its parent Package, and whether it is
currently in the diagram.

If there are many entries, you can re-organize them for clarity using the 'Drag a
column header...' panel.

If you want to add an element to your diagram, select the checkbox against that
element. Alternatively, to select all elements, click on the All button.

To deselect all selected checkboxes, click on the small Clear button.

To empty the list panel altogether, click on the large Clear button.

Layout Diagram when
complete

Select the checkbox if you want the system to layout the diagram after the elements
have been inserted; the layout applied is the Digraph layout.

If no elements have been added, this option has no effect; elements have to be
added for the system to adjust the layout.

OK Click on this button to add the selected elements to the diagram and close the
dialog.

Notes

If the selected element has a relationship to an edge-mounted structural element such as a Port or Exposed Interface,·
adding the Port or Interface to the diagram using the 'Insert Related Elements' dialog will also add the associated
parent elements onto the diagram, if they are not already shown

(c) Sparx Systems 2015 - 2017 Page 245 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Make Linked Element a Local Copy

When you use an element on more than one diagram, you drag the element from the Project Browser and drop it onto the
diagram either as a link to the original element or as a separate instance or copy of the original element. Subsequently,
you might decide to change a link to the element into a new object, as a local copy of the element in the same Package as
the diagram. You can do this very quickly and simply by selecting a menu option.

Access

Context Menu On diagram, right-click element | Advanced | Convert Linked Element to Local
Copy
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Change Element Type

You might find that an object that you have represented as one type of element would be better represented as another
type. The 'Select Element Type' dialog allows you to change the type very quickly and simply.

Access

Ribbon Design > Element > Manage > Change Type

Show > Window > Properties : In the Type field of the Properties window, click on

the  button

Start > Windows > Properties : In the Type field of the Properties window, click on

the  button

Change Type

On the 'Select Element Type' dialog, click on the 'Element Type' drop-down arrow and select the new element type from
the list.

Click on the OK button.

The target element is transformed into the required type.

Notes

This operation is effective on basic UML elements, but has limited use for profile-stereotyped elements such as·
those used in BPMN or ArchiMate modeling
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Set an Element's Default Appearance

All elements that you use have global default appearance settings for:

The fill, border and font colors·
Font styles, including font face and size·
The border thickness·

You define these settings on the 'Preferences' dialog. However, you can change the default appearance for a specific
element on all diagrams on which it is found, using the 'Default Appearance' dialog.

Access

Context Menu Right-click on element | Appearance | Default Appearance

Keyboard Shortcuts F4 or

Ctrl+Shift+E

Options

Option Action

Background Color Click on the drop-down arrow and select the fill - or background - color of the
element.

This setting overrides all other fill color definitions in the model, except for:

A color defined in a Shape Script and applied through a stereotype·
If you want to use a color that is not available, click on the Other button and define
the required color.

Border Color Click on the drop-down arrow and select the border color for the element.

If you want to use a color that is not available, click on the Other button and define
the required color.

Border Width Type in the width of the border surrounding the element, or use the
increment/decrement arrows to the right of the field.

The minimum width setting is 1, the maximum is 5.

Font Style Displays the current font typeface for the element text. To change this, click on the

 button.

The 'Font' dialog displays, on which you can select a different typeface, style (such
as bold/italic) and font size.

You can also select from a limited number of font colors and effects on this dialog.

Font Color Click on the drop-down arrow and select the font color to apply to the text of the
element.

If you want to use a color that is not available, click on the Other button and define
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the required color.

Reset to defaults (Optional) Click on this button to reset all appearance settings to the system default
values.

Preview Displays a representation of the colors, border width and font styles, which updates
as you choose the new settings.

OK Click on this button to close the dialog and apply the appearance settings you have
defined.

Cancel Click on this button to close the dialog and abort all the changes you have made
within the dialog.

Notes

You can adjust several elements at the same time; select all of the required elements, right-click on one of them and·
select the 'Appearance | Default Appearance' option, or use the 'Layout > Style' ribbon panel

You can also define a default image for the element, that displays for all instances of the element in diagrams across·
the model

If the 'Show Project Custom Colors in Color Combo Boxes' checkbox is selected on the 'Preferences' dialog,·
'Standard Colors' page, the last 16 color squares in the color selection palettes contain the project colors set on that
dialog

The 'Font Color' field affects only the element name text; it does not override the feature text colors as defined on·
the 'Preferences' dialog, 'Standard Colors' page

When it has been called directly on one or more selected elements ('Appearance | Set Font'), the 'Font' dialog·
overrides the 'Default Appearance' dialog

When called from the 'Default Appearance' dialog, the 'Color' field on the 'Font' dialog is overridden by the 'Font·
Color' field on the 'Default Appearance' dialog

The 'Font' and 'Font Style' fields on the 'Font' dialog affect all text except for the Note compartment text·
The 'Size' field on the 'Font' dialog affects all text·
An alternative option for changing an element's appearance is to define a stereotype that has different fill, border and·
font settings, or either a Shape Script or an image file associated with it; you can then assign the stereotype to the
element to change the element's appearance to that defined by the stereotype
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Align Elements

When you have created a number of elements on a diagram, you might want to organize them in groups so that they form
a column or row with a uniform edge. You can do this quickly and easily by selecting the group of elements and aligning
them all against the left, right, top or bottom edge or center of one element in the group. You can also space three or
more elements evenly in a row or column, at an average of their previous separations.

The selected elements are aligned with respect to the 'context' element, which is the element that has a hatched border
drawn around it. You can set a given element as the 'context' element by right-clicking on the element, or by deselecting
then re-selecting, using 'Ctrl+click'.

Access

Ribbon Select a set of elements, then

Layout > Alignment > <alignment button>·

Context Menu Select a set of elements, then right-click on a selected element and choose:

Align Left·
Align Right·
Align Top·
Align Bottom·
Align Centers |Vertically or Horizontally·
Space Evenly | Across or Down·

Keyboard Shortcuts Select a set of elements (ensuring that the 'context' element is correctly set), then

Ctrl+Alt+Left Arrow (align left)·
Ctrl+Alt+Right Arrow (align right)·
Ctrl+Alt+Up Arrow (align top)·
Ctrl+Alt+Down Arrow (align bottom)·
Alt+'-' (space evenly across)·
Alt+'=' (space evenly down)·

Align multiple elements

Step Action

1 Select a group of elements by dragging a selection box around them all with the cursor (or select them one
by one by holding down Ctrl and clicking on each element).

2 Right-click on the element in the group to align others to.

The context menu displays.

3 Select the alignment function you require.

All selected elements are aligned with the one beneath the cursor.
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Notes

You can also use the first four buttons of the Diagram toolbar to align elements; these are made available when more·
than one element is selected in a diagram
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Resize Elements

You can change the size of an element, or of several elements in a group, using the cursor or various menu options.

Resize using handles

Image Detail

resizeelement Select an element or group of elements in the diagram view, then:

(Single element) With the mouse, drag the resize handles that appear at each·
corner and side, to resize the element (the cursor switches to the double-ended
arrow as shown in the image)

Press and hold Ctrl and use the Arrow keys to resize elements by increments;·
to make elements:
    - Wider - press Ctrl+Right Arrow
    - Narrower - press Ctrl+Left Arrow
    - Taller - press Ctrl+Down Arrow
    - Shorter - press Ctrl+Up Arrow

Autosize selected element(s) to their default size using 'Layout > Diagram >·
Edit > Autosize Selected', or by pressing Alt+Z

If you select multiple elements, 'Autosize' is also available in the right-click context
menu for the elements

Resize a Set of Objects to a specfic size

Image Detail

resizeelementselected If you right-click a selected set of objects, you can resize them to the same
dimensions (height, width or both) using context menu options.

When you select multiple elements using Ctrl+click, you can right-click and select
options that use the dimensions of the last-selected (hatched) object to set the
dimensions of the other selected objects.

For example, in this diagram, the Message Class height and width are used to set
the height and width of the Account and Message Folder Classes.

The steps are:

Set one element to the required size (for example, Message).1.

Select that element and the elements to resize (for example, Account and2.
Message Folder).

Right-click on the pre-sized element (Message).3.

Select the appropriate resizing option ('Same Height', 'Same Width', or 'Same4.
Height and Width').
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Create Notes and Text

One aspect of modeling is to describe and document the purpose and use of an element in the context of a particular
diagram. You can provide such documentation in the form of Note or Text elements displayed with and connected to the
elements they describe.

Both Note and Text elements display text on the diagram; a Note element contains the text within a border with a
background color and a turned-down corner image, whilst a Text element has no border or background color. Otherwise
they behave in the same way.

Access

Context Menu Right-click on element | New Child Element | Attach Note

Other Diagram Toolbox : More tools | Common page > Drag Note or Text icon onto·
diagram - drag the Quick Linker arrow from the new Note element to connect
to the element being annotated

UML Elements Toolbar > Click on the 'New Note' icon, then click on the·
diagram - drag the Quick Linker arrow from the new Note element to connect
to the element being annotated

Drag the Quick Linker arrow from an element into an empty space on the·
diagram > Common > Note

Complete a Note or Text element

The element displays on the diagram.

If, on the 'Objects' page of the 'Preferences' dialog, the 'Edit Object On New' checkbox is deselected, the Notes window
displays, and you can type the element text within it. To display the text in the element, click on the element.

If the checkbox is selected, the 'Notes Properties' dialog immediately displays; type your text in the dialog, and click on
the OK button to display the text in the element.

In either case, if you want to display the text in a more readable layout, you can resize the Notes window or dialog, and
you can also format the text using the Notes toolbar.

Note element appearance

It is possible to change the appearance of a Note element, by right-clicking on the element and selecting one of the
'Appearance' menu sub-options. The available images are:
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The two Memo-style images list all the elements that the Note is linked to, in the 'Applies to:' field. You can hide the
actual Notelink connectors, so that the Note identifies the elements it refers to without complicating the diagram
appearance by having the connectors visible. To hide (and reveal) the connectors, click on the element and select the
'Advanced | Hide (Show) attached links' option.

Notes

You can also create a Note or Text element by clicking on the New Note or New Text Element icon on the UML·
Elements toolbar and clicking on the diagram

When you have created your Note or Text element, you can leave it free-standing to display information on the·
diagram, or you can connect it to the specific modeling element or elements it describes using a Notelink connector,
which you also drag from the Common toolbox

Instead of typing in text for the element, you can reflect an element's internal documentation, such as the value of a·
constraint or feature
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Link Note to Internal Documentation

Whilst a Note often contains information in addition to that contained within other elements, you can also expose the
internal description of a feature or property of an element. In this way you can externalize model documentation at the
diagram level, and as the system keeps the Note and the internal text in synch, you do not have to update the Note; in
fact, you are blocked from editing the Note text, because it is maintained automatically.

Similarly, it is also possible to expose the Notes text of the diagram properties in a Note element.

In this example, two Notes are connected to an element's internal structures. One Note is connected to an attribute and
displays the attribute name and notes. The other is connected to a constraint, showing the constraint name and
documentation.

Connect a Note element to another element's feature

Step Action

1 Click on the target element and then click on the feature itself, so that it is highlighted for inline editing.

2 Right-click on the feature and select the menu option 'Create Linked Note'.

This creates a Note element linked to the selected feature, reflecting the content of that feature.

Alternatively

Step Action

1 Insert or identify the target element in a diagram.

2 Drag the 'Note' icon from the 'Common' page of the Diagram Toolbox onto the diagram, next to the target
element.

The 'Notes' dialog displays. Do not type any text, simply click on the OK button.

3 Click on the 'Note Link' icon from the 'Common' page of the Toolbox, and drag the cursor from the Note
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to the target element to create the connector.

4 Right-click on the Note Link to display the context menu, and select 'Link this Note to an Element
Feature'.

The 'Link note to element feature' dialog displays.

5 In the 'Feature Type' field, click on the drop-down arrow and select the type of feature to link to.

The 'Feature' list now shows the features of the selected type in the element.

6 In the Feature list, click on the specific feature to link to, and click on the OK button.

The Note now automatically shows the contents of the feature's Notes or Description field, and is
automatically updated with any changes to this field.

Connect a Note element to the diagram Notes text

Step Action

1 Open the diagram and right-click on the background.

2 Select the 'Properties' menu option, type an appropriate description in the 'Notes' field, then click on the
OK button.

3 Drag the 'Note' icon onto the diagram, from the 'Common' page of the Toolbox.

The 'Notes' dialog displays.

Simply click on the OK button.

4 Right-click on the Note element and select 'Advanced | Link to Diagram Note'.

The Note now automatically shows the contents of the diagram's 'Notes' field, and is automatically
updated with any changes to this field.

Notes

You can unlink a Note linked to an element feature, leaving the Note text, which can be edited manually and directly·
as normal; to unlink the Note from an element feature, either:
    - Right-click on the Note and select the 'Advanced | Unlink from Element Feature' option, or
    - Right-click on the Notelink connector, select the 'Link this Note to an Element Feature' option and, on the 'Link
note
       to element feature' dialog, set the 'Feature Type' field to 'None'
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Delete Elements from Diagram and Model

An element might become inappropriate in a certain context, so you would want to remove it from the diagram in which
that context is represented. It is also possible that the element becomes unnecessary in the model as a whole, so you
would want to delete it altogether. You therefore have a number of situations under which you would 'delete' an element:

Just from a particular diagram·
As a member of a group of elements to be removed from a diagram·
From a diagram and from the model at the same time·
Directly from the model, through the Project Browser·

Delete an element just from a diagram

Step Action

1 In the diagram, click on the element to delete.

2 Either:

Press the Delete key or Ctrl+D, or·
Right-click and select 'Delete <element name>'·

The element is immediately deleted from the diagram, but not from the model. There is no prompt to
confirm the deletion.

Delete a group of elements from a diagram

Step Action

1 In the diagram, press Ctrl while you click on each element to delete.

2 Either:

Press the Delete key or Ctrl+D, or·
Right-click and select 'Delete selected elements'·

The elements are immediately deleted from the diagram, but not from the model. There is no prompt to
confirm the deletion.

Delete an element from the model

Step Action

1 Either:

In the Project Browser, right-click on the element to delete and select 'Delete <element name>', or·
In the diagram or Project Browser, click on the element to delete and press Ctrl+Delete·
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A confirmation prompt displays.

2 Click on the Yes button.

The element is completely removed from all diagrams in which it has been used, and from the model. If
you delete an element in this way, you delete all its properties, child objects and connectors as well.

Delete multiple elements from the model

Step Action

1 On the diagram or in the Project Browser, press Ctrl as you click on the elements to remove from the
model, to select them.

2 Press Ctrl+Delete to completely remove the elements from the model.

Alternatively, in the Project Browser, right-click on one of the selected items and select the 'Delete
selected item(s)' option.

In either case, a confirmation prompt displays.

3 In the diagram, the prompt is to confirm deletion of all elements from the model and all diagrams, at once.
Click on the Yes button.

In the Project Browser, the prompt offers options to confirm and delete:

Each element individually (click on the Yes button), or·
All the elements together (click on the Yes to all button)·

The elements are completely removed from all diagrams in which they have been used, and from the
model. If you delete elements in this way, you delete all their properties, child objects and connectors as
well.
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Customize Visibility of Elements

Some modeling objects are, by default, not listed in Packages shown on diagrams, or in report documents. These include
Events, Decisions, Sequence elements, Activity Endpoints and Association Classes. For example, in this Event Test
Package, the Events and Decisions contained in the Package are not shown on the Package diagram.

You have the option of turning on display of the hidden elements.

Access

Ribbon Start > Workspace > Preferences > Preferences > Objects: Advanced

Display Hidden Elements

Step Action

1 On the 'Advanced Settings' dialog, select the checkbox against each type of element to show in Package
diagrams and in report documents.

2 Click on the Close button on each dialog in turn.

3 Reload the current diagram if required.

The Package from the earlier example now shows the Event and Decision elements it contains.
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Set Up Cross References

It is possible to set up a cross reference (or Custom Reference) from one or more elements in a diagram to another
element or to a diagram selected in the Project Browser. You can also review the existing cross references on an element,
using the 'Context References' dialog or the Traceability window.

Set up a cross reference

Step Action

1 Open the diagram that contains the elements that will reference the target element or diagram.

2 In the Project Browser, right-click on the target element or diagram (the object of the cross reference) and
select:

'Add Custom Reference' (for a target diagram)·
'Add | Add Custom Reference' (for a target element)·

The 'Set up references' dialog displays.

3 Click on the checkbox against each element that is to refer to the target element.

4 Optionally, in the 'Comment' field, type the purpose of the references.

5 Click on the OK button to set the references and close the dialog.

Use the cross reference

Step Action

1 Click on the required element in the opened diagram.

2 Either:

Right-click on the element and select 'Find | Custom References' or·
Press Ctrl+J·

The 'Custom References' dialog displays, showing a list of elements that have been set as cross references
for the selected element.

3 Optionally, open the 'Properties' dialog for a referenced element by clicking on it and clicking on the
Open button.

Similarly, open a referenced diagram by clicking on it and clicking on the Open button.

4 If you have opened a string of diagram links, click on the Home button to return to the original diagram.
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Notes

You can create cross references from an element on the diagram to a number of elements and/or diagrams in the·
Project Browser, and from another element on the diagram to different elements and diagrams in the Project Browser

You cannot create a commented cross reference from one element on the diagram to an element in the Project·
Browser, and a separate commented cross reference from a different element on the diagram to the same element in
the Project Browser

You can delete a cross reference by selecting it on the 'Custom References' dialog and clicking on the Delete button;·
cross references are also automatically deleted if the source or target element in the reference is deleted

You can also add, review and delete cross references on the 'Cross References' tab of the 'Scenarios' page in an·
element's 'Properties' dialog
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Show Element Use

An object can be used several times in a model; for example, an image might be used for different elements on different
diagrams, or an element might be represented on several diagrams depicting different concepts. You can quickly locate
where the object is used in the model, by selecting a 'Find' menu option that displays the 'Element Usage' dialog. This
lists the occurrences of the object and, when you select one, the diagram containing that occurrence opens with the object
selected.

You can locate occurrences of:

A Package·
An element·
An image·

You can also list the:

Extension Points of the target Use Case in an <<extend>> relationship·
Triggers associated with a Transition·
Items conveyed on an Information Flow connector·
Objects derived from an Operation·

If the object:

Occurs once only (such as in one diagram only), the object is immediately highlighted in the diagram or Project·
Browser

Is not used in any diagram, the 'Element Usage' dialog displays with no entries; click on the Close button to close the·
dialog

Is used in more than one diagram, the 'Element Usage' dialog lists those diagrams; either:·
    - Double-click on a diagram name to open that diagram (the 'Element Usage' dialog remains open), or
    - Click on the diagram name and click on the Open button to open that diagram (the 'Element Usage' dialog
closes)

The 'Element Usage' dialog defaults to showing, in order, the 'Usage Type' of the object, 'Diagram Type' and 'Diagram'

columns. If you float the cursor over the right edge of the 'Diagram' column header, so that it changes to , you can
drag the column border right to expose the hidden columns 'Diagram ID', 'Object ID' and 'Kind' (do this in separate
passes for each hidden column).

To make the display of information easier to read, you can resize the 'Element Usage' dialog and drag the borders of the
column headers to the appropriate width for the listed items. You can also click on a column header and re-sort the items
in the forward or reverse alphanumeric order of the selected column content.

Locate Objects

This table provides the instructions for locating occurrences - uses - of different types of object.

Object Type Action

Element In the Project Browser, right-click on the element and select the 'Find in all
Diagrams' option.

On a diagram, right-click on the element and select the 'Find | Find in all Diagrams'
option.

Alternatively, click on the element and press Ctrl+U.

Package In the Project Browser, right-click on the Package and select the 'Find in all
Diagrams' option.

On a diagram, right-click on the Package and select the 'Find | Find in all Diagrams'
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option.

Alternatively, click on the Package and press Ctrl+U.

Image On a diagram, right-click on the element to which you want to assign an image and
select either the 'Appearance | Select Default Image' option or the 'Appearance |
Select Alternate Image' option. In either case, the Image Manager screen displays.

Click on the required image name and on the Usage button. The 'Element Usage'
dialog displays showing, in this case:

The names of the elements to which the image has already been applied·
The name of the diagram on which each instance of the image has been used·
The Image Manager image ID for the image (a hidden column)·
The Diagram ID (DID) for each diagram (a hidden column)·
The Object ID for each element on which the image has been used (a hidden·
column)

Click on an element name and on the Open button to display the diagram on which
the image has been used, with that instance of the image highlighted.

Use Case Extension Point On a diagram, right-click on the <<extend>> connector and select the 'Advanced |
Extension Point | Set Extension Point' option.

The 'Element Usage' dialog displays, listing the Extension Points currently assigned
to the target Use Case element.

Click on the required Extension Point and on the Open button; the dialog closes,
and the <<extend>> connector shows a small circle attached to a Note element that
identifies which extension point it represents.

If the target Use Case has no extension points, you are prompted to create them.

Objects derived from an
operation

In the Project Browser, right-click on the operation and select the 'Find in all
Diagrams' option.

The 'Element Usage' dialog displays, listing the Action elements and/or Sequence
Message types derived from the operation in the model. For a Sequence Message,
in the 'Kind' column, you can see the value of the 'Kind' property of the message.

Double-click on an object to open its parent diagram and show the location of the
object in the diagram.

Triggers Associated with a
Transition

On a StateMachine diagram, right-click on the Transition connector between two
States and select the 'Find Triggers Associated' option. The 'Element Usage' dialog
displays, listing the Triggers assigned to the Transition. The 'hidden' column in this
instance is 'GUID', showing the GUID of each Trigger element. If you double-click
on a Trigger name, the system locates and highlights the Trigger element in the
Project Browser.

(Information) Items
Conveyed

You can also use the 'Element Usage' dialog to identify and select items conveyed
and/or realized on an Information Flow connector. On the diagram, right-click on
the connector and select the 'Find Items Conveyed' menu option. The 'Element
Usage' dialog displays, listing the items conveyed on the connector. The 'hidden'
column in this instance is 'GUID', showing the GUID of each conveyed element. If
you double-click on an element name, the system locates and highlights the element
in the Project Browser.
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Manage Structural Elements

In UML Modeling, you can define certain constructs and events with structural - or embedded - elements that are added
on to a parent element. For example, you can add Ports to a Class (as shown), Action Pins to an Action, or Activity
Parameters to an Activity. Structural elements cannot exist by themselves, they must be part of a parent element.

Access

Ribbon Design > Element > Manage > Structural Elements

Context Menu Right-click on element in diagram | Structural Elements

Create and manage Structural Elements

Option Action

Show Owned/Inherited The 'Structural Elements' dialog lists the structural or embedded elements on the
selected parent element. If you want to include inherited or owner properties from
any classifier that the parent element might have, select this checkbox.

New Click on this button to create a new embedded element. The 'Insert New Embedded
Element' dialog displays.

The 'Type' field defaults to the first in the list of types of structural element you can
create for the selected element. If this is not the type you need, click on the
drop-down arrow and select another type.

Type a name in the 'Name' field or, if you have set up auto-naming conventions,
click on the Auto button to generate the name.

If appropriate, in the 'Stereotype' field type the name of a stereotype to apply, or
click on the drop-down arrow and select the stereotype.

If you want to go straight on to create another embedded element when you save
the current one, de-select the 'Close dialog on OK' checkbox. You can add as many
embedded elements as you need.

Click on the OK button. The embedded element is now listed on the 'Structural
Elements' dialog and is depicted on the primary element, as in the Class/Port
example above.
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Defined Elements Review the definition of each structural element currently associated with the
selected parent element. If you have selected the 'Show Owned/Inherited' checkbox,
the list will include any structural elements from any classifiers that the parent
element has.

If you want any structural element to be visible on the parent element on the
diagram, select the checkbox next to that element's name. Notice that the 'Visible'
column in this panel then shows the value True against each selected element.

To hide the structural element on the diagram, clear the checkbox. The structural
element still exists on the parent element, but is just not visible in the diagram.

All

None

Click on these buttons to select (All) or clear (None) the checkboxes against all
listed elements.

Redefine If you want an inherited structural element to have different properties from the
original structural element on the parent's classifier, click on that element's entry in
the list and click on this button.

A duplicate structured element is created in the list and on the diagram, where the
Owner of the structured element is the parent element and not its classifier. You can
now modify that duplicate element.

(The Redefine button is not available for structural elements directly owned by the
parent element.)

Modify If you want to change a structural element directly owned by the parent element,
click on the element entry in the list and click on this button.

The 'Modify Embedded Element' dialog displays, which is almost identical to the
'Insert New Embedded Element' dialog; edit the field values as necessary.

On the 'Modify...' dialog the Advanced button is enabled; click on this button to
display the element 'Properties' dialog and provide any characteristics the element
might require, such as Notes, Tagged Values, advanced properties and related files.
Click on the OK button to close the dialog and return to the 'Modify Embedded
Element' dialog.

(The Modify button is not available for inherited structural elements.)

Delete If you want to remove a structural element from the parent (and therefore from the
model altogether), click on that element's entry in the list and click on this button.
The element is immediately deleted.

Close Click on this button to save all changes and close the dialog.

Notes

The name of an embedded element displays on the diagram as a label, which you can edit using the 'Labels' context·
menu
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Set Element Parent

In the context of one element being generalized by one or more other elements, those other elements are referred to as the
parent elements. You can define the parent element(s) for a generalizable element, or an interface it realizes
(implements), using the 'Set Parents and Interfaces' dialog. The parent elements do not necessarily have to exist in the
model; you can specify an element that you intend to create later. You can also delete an existing parent/child
relationship using the dialog.

Access

Ribbon Design > Element > Manage > Parents and Interfaces

Context Menu Right-click on element in diagram | Advanced | Parent

Keyboard Shortcuts Ctrl+I

Set an element parent

Option Action

Type Click on the drop-down arrow and select the type of relationship to set (Implements
or Generalizes) from the list.

You select the relationship type first because, if you use the Choose button, the
'Select Classifier' dialog actually creates the relationship based on this field value,
immediately when you select the parent or interface element.

Class Name Either:

Type in the parent or interface name, or·
Click on the Choose button to browse or search for the element within the·
current model (the relationship is created immediately when you select the
classifier)

Accept classifier even if
not in model

If the parent element does not currently exist in the model, select this checkbox to
protect the reference to a non-existent element.

Add If you do not use the Choose button, click on this button to add the relationship to
the 'Type Details' list, to the selected child element and to the model.

Prior to this:

If the parent element does not exist in the model and you have not selected the·
'Accept classifier even if not in model' checkbox, an Unknown Classifier error
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message displays

If you have specified an existing element with the same name as other elements·
in the model, a dialog displays listing the elements and their parent Packages,
prompting you to select the correct classifier

Delete selected If you no longer want to keep the relationship between a parent and child element,
click on it in the Type Details panel and click on this button to remove it.

Operations on the parent element

If the parent name is shown in the element, you can select it (click on the child element, then click on the parent element
name) and right-click to display a context menu of further operations:

Apply the facilities of any relevant technology enabled in Enterprise Architect·
Redisplay the 'Set Parents and Interfaces' dialog to, for example, delete the parent or add further parents·
Display the parent element 'Properties' dialog·
Find the parent element in the Project Browser·
Find the parent element in any diagram in which it exists·

If the parent element does not currently exist in the model, but is shown on the child element in the diagram, you can still
access the first two of the context menu options for it.

Notes

On a diagram, the parent element name is displayed in the top right corner of the child element if:

The parent element is not on the same diagram as the child element, and·
The 'Show Hidden Parents' option is selected on the 'Diagram > Behavior' page of the 'Preferences' dialog·
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Composite Elements

You might want to use one element to represent a structure composed of other elements; for example, a general Use Case
representing a collection of more specific Use Cases. To achieve this, you can make the 'general' element a composite
element, as a pointer to a child diagram containing the 'detail' elements. The elements that you can turn into composites
include Classes, Objects, Activities and Use Cases.

Access

Ribbon With an element selected in the Project Browser:

Design > Diagram > New : Select diagram type> Composite Structure

Context Menu Right-click element in diagram | New Child Diagram | Composite Structure
Diagram     or

Right-click element in Project Browser | Add | Composite Structure Diagram

Make an element composite

Images Step / Action

When you select to make an element composite, it displays in the diagram and in
the Project Browser as illustrated on the left.

Note:

The small icon in the bottom right hand corner of the element shape, indicating·
that this is now a composite element

The icon against the child diagram name in the Project Browser, indicating that·
this diagram was created as a child of the composite element

Double-click on the composite element in the diagram to access the child diagram
that it points to. You can populate the child diagram with elements and connectors
to represent the internal structure of the (parent) composite element.

In this process, structural (embedded) elements cannot be directly added to the
child diagram. However, you can add them using a different, modified procedure.

The composite element and its child diagram are now represented in the Project
Browser as shown. ClassX, ClassY and ClassZ are elements added to the child
diagram.

If you already have, or subsequently create, another diagram that better represents
the content of your composite element, you can select that diagram as the child of
the composite.

Right-click on the composite element and select the 'New Child Diagram | Select
Composite Diagram' option. The 'Select a Diagram' browser displays, through
which you can browse the entire project to locate the alternative diagram. Click on
the diagram and on the OK button to apply it as the child of the composite element.

Neither the original nor the alternative child diagram move location or change icons
in the Project Browser (unless you specifically make these changes as a separate
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operation).

Alternative Notation

You can display the contents (the child diagram) of a Composite element within the element, in two ways.

Display Format Detail

Display Composite
Element as Frame

Composite elements can show their contents in place of their usual notation.

Right-click on the element to open the context menu.1.

Select the 'New Child Diagram | Show Composite Diagram in Frame' option.2.

The composite element is replaced by a frame containing the child diagram. The
frame label shows the composite element name. The element is resized to contain
the diagram; whilst it can be enlarged, it cannot be reduced to less than the diagram
size.

Some technologies, such as SysML, qualify the frame label to show the diagram
type, element type, element name and child diagram name. If you design custom
diagram profiles, you can also qualify the frame label as required.

Display Composite
Element Content In

Compartment

Composite elements can also show their contents in addition to their usual notation,
in a separate compartment of the element.

Right-click on the element to open the context menu.1.

Select the 'New Child Diagram | Show Composite Diagram in Compartment'2.
option.

A compartment is added to the element, containing the child diagram. The element
is resized to contain the diagram; whilst it can be enlarged, it cannot be reduced to
less than the diagram size.

You can also display a Composite Diagram inside its parent element, using a Shape
Script. The diagram is displayed in a custom compartment in the center of the
element and not necessarily with the standard compartments (such as attributes,
tags).

Notes

If the 'Composite Structure Diagram' option is not listed in the context menu, the option is not available for the type·
of element you have selected

If you select either of the alternative notation options to display the child diagram on the composite element, and·
then you select a different child diagram, the display settings are cleared; reselect the appropriate option to display
the new diagram on the composite element
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Automation support is available for Composite elements - Element has an Elements collection and a Diagrams·
collection; additionally you can set the Composite diagram with SetCompositeDiagram
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Show Structural Elements In Composite Diagram

A Composite element shows the external relationships of the element with other components of the model and, via a
child diagram, its own internal structure. You cannot normally add structural (embedded) elements to the representation
of this internal structure; however, this procedure describes a modified process through which you can add embedded
elements to the child diagram.

Embedded elements include:

ActivityParameter·
RequiredInterface·
ActionPin·
Port·
EntryPoint·
ExpansionNode·
ObjectNode·
ProvidedInterface·
ExitPoint·
Part·

Include embedded elements in a child composite diagram

Images Step / Action

Create the element to set as a Composite element. For example, a Class, Activity, or
SysML Block.

Right-click on the element in the diagram and select the 'New Child Diagram |
Composite Structure Diagram' option.

The element redisplays with a small icon in the bottom right hand corner, indicating
that this is now a Composite element.

Double-click on the Composite element to access the child diagram that it points to.

From the Project Browser, drag the Composite element itself onto the child
Composite diagram, and paste it in as a Link.

Right-click on the element in the diagram, and select the 'New Child Diagram |
Show Composite Diagram in Frame' option.

(c) Sparx Systems 2015 - 2017 Page 272 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

The element redisplays with a labeled frame around it.

Press Ctrl+S to save the diagram.

Right-click on the diagram tab and select the 'Reload <diagram name>' option.

The diagram redisplays with just the frame showing. This frame represents the
original composite element.

Populate the frame with the appropriate internal elements, including the structured
elements that attach to the frame itself.
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Visual Representation

Each UML element has a default representation. However, you can:

Change the appearance, features, position and - for some elements - orientation using a number of toolbars·
Display or hide various types of information held in the element, in compartments·
Display the element in a simpler format, showing basic properties and notes but hiding features·
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Element Icons

When you select an element on a diagram, or add a new element, a number of small icons display off the right hand side
of the element underneath the Quick Linker arrow, as shown.

   OR

These icons display small versions of the diagram toolbars or perform specific actions, to help you quickly edit the
element you have highlighted. If you do not want to show or use these icons, you can prevent their display by deselecting
the 'Show buttons for selected Object on diagram' checkbox on the 'Objects' page of the 'Preferences' dialog.

Also, if an element shown in the diagram is locked, and the 'Display Element Lock Status' option is selected in the
'Diagram Properties' dialog, a locking indicator is displayed outside the top left hand corner of the element. The indicator
is the same as the exclamation mark (!) against a locked element in the Project Browser:

Red if the element is under a full lock or locked by another user·
Blue if the element is under a lock set by yourself or by a user in the same User Group as yourself·

Icon Use

Icon Action

Click on this icon to rotate a Fork/Join element from vertical to horizontal or
vice-versa.

Click on this icon to display a short formatting toolbar, to change the appearance of
the element. The options are the same as those on the 'Layout > Style' ribbon panel.

Click on this icon to display the Current Element toolbar, to edit the element's
properties and features.

When multiple elements are selected, click on this icon to display the Diagram
Toolbar to change or align the elements together.

Click on this icon to toggle an Activity Partition between vertical and horizontal.

Indicates that the Interaction Fragment currently contains messages; in this state
you can:

Move the fragment vertically, but not horizontally; all elements and messages·
below the fragment move up or down by the same amount

Resize the fragment to larger than the contained messages/elements, but not·
smaller
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This is the default condition when you open or reload a diagram containing a
fragment. You can click on the icon to toggle to 'move freely' mode.

Indicates that the Interaction Fragment can be moved independently of the
Messages or other elements contained within the fragment.

This is the default condition when you first create the fragment. You can click on
the icon to toggle to 'contains messages' mode (above).
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Compartments

When you place an element on a diagram, you can display it with a number of compartments that reveal not only the
attributes and operations of the element, but also several other properties such as tags, constraints and tests.

Compartment Types

Images Remarks

Tags Compartment

Detail: The tags compartment lists all Tagged Values for an element as entered in
the Tagged Values window.

The fully-qualified option shows only those Tagged Values that were created in
Enterprise Architect release 7.1 or later; it does not expand Tagged Values created
in earlier releases.

Responsibilities Compartment

Detail: The responsibilities compartment shows a list of responsibilities as entered
on the 'Requirements' page of the element 'Properties' dialog.

Constraints Compartment

Detail: The Constraints compartment shows a list of element constraints as entered
in the 'Constraints' page of the element 'Properties' dialog.

Notes

To set the display of each of the various compartments, see the Feature Visibility topic; the display of the·
compartments is also controlled through the diagram properties, on the 'Elements' tab - the specific element settings
take precedence over the more general diagram settings
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Info view Style

Info view is an alternative notation to display a simplified view of an element that allows the name, description and
selected other properties to be displayed for an element instead of the normal notation showing child features. This view
allows a diagram to be constructed for a non-technical audience or any purpose where display of descriptions is more
important than the notations defined by the modeling language.

For example, a database engineer will normally need to see the columns and indexes of a Table, while a manager might
be more interested in seeing a high level description relating to each table.

Access

Context Menu Right-click element | Info view | Enabled

Right-click element | Info view | Visible Properties

Description

When you enable Info view on an element, the element is rendered as a rounded rectangle, divided into two. In the:

Top half, on the left, the element name, type and stereotype display; on the right a small image of the element's·
native shape displays

Bottom half, at least some of the element's notes display·
If there are more notes than can show in the available space, the text See more displays at the bottom, in which case you
can expose more of the notes text by dragging the 'expansion handles' to resize the element. (Under Linux, the Notes text
displays outside the element boundary.)

StockItem

- Author: string
- catalogNumber: string
- costPrice: number
- listPrice: number
- title: string

«property»
+ Author(): string
+ catalogNumber(): string
+ costPrice(): number
+ listPrice(): number
+ title(): string

Info view disabled

StockItem
Class

This element 
classifies the stock 
items in the 
Inwards Materials 
warehouse. 
Finished-product 
See more

Info view enabled

StockItem
Class
Proposed
Version: 1.0 Phase: 1.0
Author: Roy Chester

This element classifies the stock 
items in the Inwards Materials 
warehouse. Finished-product 
stock items are classified by the 
ProductItem Class.

Info view enabled, all properties visible, expanded 
display

Notes might not be shown on the original rendering (as in the illustration), but automatically show when Info view is
enabled. They display in italics but otherwise reflect any formatting applied to the Notes in the element.

The element has a minimum size; you cannot drag the element any smaller than that. However, if you reduce the element
to the minimum size in Info view, when you select the 'Enable' option again to turn off Info view, the element returns to
its original size to display all of its visible content.

The properties listed in the top left of the element are customizable. The list defaults to show the element type and
stereotype (where a stereotype exists) but you can chose to hide one or both of those properties, and to show any or all of
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the element Phase, Version, Status, Author and (for an element in the Requirement group) Priority. None of those five
properties are shown on the element when Info view is disabled.

To customize the properties shown:

Right-click on the element and select the 'Info view | Visible Properties' option; the 'Visible Properties' dialog1.
displays.

Select the checkbox against each property to display, and clear the checkbox against each property to hide.2.

Click on the OK button.3.

Notes

The Info view element icons reflect the fill and line colors of the original elements; if the 'Start > Workspace >·
Preferences > Diagram > Appearance > Use Element Group Style' option is selected these will be the colors
assigned to each element type, otherwise they will be the standard element fill and line colors, but not any default
appearance colors assigned to the individual element

If you do not want to show the element icon in the top right corner of the Info view display, you can hide the icon;·
right-click on the element, select the 'Info view | Visible Properties' option and, on the 'Visible Properties' dialog,
clear the checkbox against the 'Icon' option
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Element Property Displays

Enterprise Architect provides a number of ways to define, assign and review the properties and features of elements, each
offering different facilities more suited to one aspect or another of model development.

User interface screens for accessing element properties

Screen

Properties Dialog - the element 'Properties' dialog defines both the general properties of an element such as its
name, phase, version and status, and properties specific to the element type such as Table columns, Activity
behaviors and Chart format.

Properties Window - this window displays the general properties of the currently-selected element in a single view.
You can dock the window within the Enterprise Architect workspace or have it free-floating within or outside the
workspace.

Element Browser - the browser presents all of the existing add-on properties of an element in a folder structure,
through which you can create further property objects, operate on them, and delete them.

Scenarios & Requirements Window - this window provides a convenient method of quickly adding, viewing,
editing and deleting rules applied to an element. The window shows details of the requirements, responsibilities,
constraints and scenarios that impose such rules or restrictions on the element.

'Select <Item>' dialog - This dialog is a multi-purpose browser and search tool for locating model items such as
Classifier elements, properties, attributes and behaviors. The '<Item>' in the dialog title changes to represent the
type of object the original operation is working on.
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Properties Dialog

The element 'Properties' dialog helps you to define and review a wide range of properties of an element. For a Class,
these properties include:

General settings, such as name, notes, alias, stereotype (if any), version, scope, dates created and modified, and·
status

Details such as cardinality, concurrency and features (attributes and operations) owned·
Advanced, or custom, properties that you can edit·
Tagged Values assigned to the element·
Technology-specific Tagged Values grouped on a separate tab·
Requirements associated with the element, both internal (responsibilities) and external·
Constraints on the element's actions·
Scenarios under which the element operates·
External files associated with the element·
Links (relationships or connectors) in which the element is the source or target·
Template Parameters and Bindings·

These properties are presented on either a main tab of the 'Properties' dialog or a secondary tab in the panel at the right of
the dialog.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties

Context Menu Right-click on element | Properties

Keyboard Shortcuts Alt+Enter

Other Double-click on Element

Buttons

On any tab of the 'Properties' dialog, at any time, you can click on the buttons at the foot of the dialog and save or clear
your changes.

Button Action

OK Click on this button to save your changes and close the 'Properties' dialog.

Cancel Click on this button to abort your changes and close the 'Properties' dialog.

Apply Click on this button to save your changes and keep the 'Properties' dialog open, so
that you can continue working.

It is a good idea to click on this button when you have finished working on a tab
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and are just about to move on to another tab.

Help Click on this button to display the Help topic for the tab you are currently working
on.

Notes

The 'Properties' dialog automatically displays when you drop a new element onto a diagram; you can suppress this·
display of the dialog by deselecting the 'Edit Object on New' checkbox on the 'Objects' page of the 'Preferences'
dialog

There are several variations of the 'Properties' dialog:·
    - The dialog for a Table or Stored Procedure element has slight differences on the 'General' tab, and a 'Table
Details' (or
       'Stored Procedure Details') tab instead of a 'Details' tab
    - The dialog for a Class element of a stereotype other than Table is as shown in the General Settings topic
    - The dialog for an element of any type other than Class does not have a 'Details' tab
    - Port and Part elements have a 'Property' tab
    - Activity elements have a 'Behavior' tab, and Action and Invocation elements (depending on their type) have
other
       tabs such as 'Effect', 'Trigger' and 'Call' tabs
    - Action Pins have a 'Pin' tab
    - System Boundaries have a single 'Properties' tab on which you define the element appearance
    - The 'Properties' dialog for Wireframe elements automatically opens to either a top-level 'Wireframe' tab on
which
       you can edit the element rendering directly, or a second-level 'Wireframing Tagged Values' tab (see the note on
Tagged
       Values for stereotyped elements) if you define the element rendering by editing the XML for the properties of
that
       element type

In all cases, the 'Properties' dialog is expandable; you can enlarge it for adding longer entries and clearer reading of·
the text field values

The 'Tags' tab of the 'Properties' dialog simply provides the Tagged Values window within the frame of the·
'Properties' dialog

If Tagged Values have been derived from a stereotyped element in a Profile, they are listed on a separate tab having·
the Profile name; they are still listed on the Tagged Values window, in a separate compartment

An Object element will show the properties of its classifier, some of which are changed to represent this specific·
instance of the classifier
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General Settings

The 'General' tab of the element 'Properties' dialog provides the name of the element and any notes that are recorded on
it. To the right of the tab are four subordinate tabs:

'Main' - defining additional identification and status properties, as described here·
'Details' - defining the cardinality, concurrency and features (attributes and operations) of the element·
'Advanced' - defining any high-level properties of the element that might exist; the properties are a function of the·
element type, and you do not add or remove them but just reset their values

'Tags' - defines the Tagged Values of the element; this is the Tagged Values window conveniently integrated with·
the other element properties

Technology-specific Tagged Values grouped on a separate tab·

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties

Design > Element > Manage > Specific Properties Page > General

Context Menu Right-click on element | Properties or

Right-click on element | Properties Page | General

Keyboard Shortcuts Alt+Enter

Other Double-click on Element

General Options

Option Action

Name This field displays the element's name which, for a new element, defaults to either:

<element type><number of elements of this type already in the Package> (for·
example, Class3) or

A name conforming to the auto-naming/numbering convention you have·
defined

If necessary, over-type the default name with a different name.

Notes Type in or edit any notes text associated with the element, applying any notes
facilities required such as hyperlinks or Glossary terms.

You can format the notes text using the Notes toolbar at the top of the field.

Stereotype
(Optional) Type the name of a stereotype for the element, or click on the 
button to the right of the field and use the 'Stereotype Selector' dialog to select one.

Alias (Optional, for elements other than an Object element) Type in an alias or alternative
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display name for the element.

Scope Click on the drop-down arrow and select the element's scope ('public', 'private',
'protected', 'package').

Complexity Click on the drop-down arrow and select the appropriate development complexity
(used for project estimation). You normally select from three levels:

Easy·
Medium·
Difficult·

You can change your user defaults to add 'Extreme' and 'Unknown' to this list of
options.

Version Defaults to the value defined in the 'Object Display' options, for the version of the
current element.

If necessary, type over the field with a different version number or code.

Phase Defaults to the value defined in the 'Object Display' options, for the phase this
element is to be implemented in (for example: 1, 1.1, 2.0, ...).

If necessary, type over the field with a different phase number or code.

Language Defaults to the programming language defined for the model (in the 'Default
Language for Code Generation' field on the 'Source Code Engineering' page of the
'Preferences' dialog).

If this element is required to have a different language, click on the drop-down
arrow and select it. If the element is not language-specific, select '<none>'.

Filename
(Optional) If you intend to generate code from the element, click on the  button
to the right of the field and create or select the name and location of the file into
which the code will be generated.

Author This field defaults to the user ID of the person who created the element. If
necessary, you can type in a different user ID, or click on the drop-down arrow and
select one.

Status Click on the drop-down arrow and select the appropriate element management
status (such as Approved or Proposed).

Role (Optional, for an Object element) Type in the role played by the object represented
by the element.

Keywords (Optional) Type in any significant terms that the element might be associated with
and that might be filtered on to identify the element in Use Case Metrics and
Searches.

GUID This field displays the Globally Unique Identifier of the element. You can check
this GUID and copy it for reference in many of your modeling tasks.
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Details

The 'Details' tab of the element 'Properties' dialog helps you to define the structural and processing details for the
selected Class element, and provides direct access to the 'Features' dialog for defining Attributes and Operations in the
element.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > General > Details

Design > Element > Manage > Specific Properties Page > General > Details

Context Menu Right-click on element | Properties > General > Details or

Right-click on element | Properties Page | General > Details

Keyboard Shortcuts Alt+Enter : General > Details

Other Double-click on Element : General > Details

Set element details

Option Action

Persistence Click on the drop-down arrow and select the appropriate value (blank, persistent or
transient).

Cardinality Click on the drop-down arrow and select the number of instances of the element
that can exist - the value displays on the element in a diagram, in the Name
compartment.

The format of the options in the selection list is defined in the 'Cardinality' tab of
the 'UML Types' dialog.

Abstract Select the checkbox to identify the element as being abstract.

Is Root Select the checkbox to identify the element as being a root element that cannot be
descended from another element.

Is Leaf Select the checkbox to identify the element as being final, so it cannot be a parent
for other elements.

Is Specification Select the checkbox to identify the element as being a specification.

Is Active Select the checkbox to identify the element as being an Active Class.

Concurrency Select the appropriate radio button to identify how concurrent Activities should be
processed: Sequentially, Guarded, Active or Synchronous.
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Collection Classes Click on this button to define the Collection Classes (for generating code from
Association relationships) that apply to this Class only, as the source in an
Association relationship where the target role has a multiplicity of 1 or more.

This setting overrides the default for the programming language of the Class, set in
the 'Preferences' dialog.

The 'Collection Classes for Association Roles' dialog displays.

Attributes Click on this button to define the attributes for the Class.

The 'Features' dialog displays, showing the 'Attributes' tab.

Operations Click on this button to define the operations for the Class.

The 'Features' dialog displays, showing the 'Operations' tab.

Notes

When launched from an MDG Technology, the Attributes and Operations buttons are not available·
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Advanced Properties

The 'Advanced' tab displays the advanced properties of the element (where they exist). You can reset the values of these
properties.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > General > Advanced

Design > Element > Manage > Specific Properties Page > General > Advanced

Context Menu Right-click on element | Properties > General > Advanced or

Right-click on element | Properties Page | General > Advanced

Keyboard Shortcuts Alt+Enter : General > Advanced

Other Double-click on element : General > Advanced

Set a value for an advanced (or custom) property

Step Action

1 Click on the data field to the right of the property name.

2 Depending on the property, either:

Type the value in free text·
Click on the drop-down arrow and select the value from the list, or·

Click on the  button and search for the required value·

3 Click on the Apply button.
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Requirements

You use the 'Requirements' tab of the element 'Properties' dialog to create requirements that the element is being
designed to meet. Requirements are of two types:

Internal requirements (responsibilities) and·
External requirements (system requirements, elements connected to the current element by Realize connectors)·

The 'Requirements' tab lists both types, although you edit the properties of the external Requirement elements through
their own element 'Properties' dialog.

You can show the internal requirements for an element on a diagram directly, using the element 'Feature and
Compartment Visibility' function; it is also possible to show inherited requirements in this way.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Requirements

Design > Element > Manage > Specific Properties Page > Requirements

Context Menu Right-click on element | Properties > Requirements  or

Right-click on element | Properties Page | Requirements

Keyboard Shortcuts Alt+Enter : Requirements

Shift+Alt+R

Other Double-click on Element : Requirements

Define internal Requirements

Field/Button Action

Requirement Type in the name and/or short definition of the requirement.

This text will display on the element on a diagram, if the visibility is set to show
internal requirements.

Notes Type in any additional details or comments on the internal requirement.

You can format the notes text using the Notes toolbar at the top of the field.

Properties In this panel, click on the 'Value' field against each property, click on the
drop-down arrow and select the appropriate setting:

Status - select the current status of the requirement·
Difficulty - select the value that most closely reflects the difficulty of·
implementing the current requirement

Priority - select the value that best indicates how urgent the requirement is·
Stability - select the value that provides the best indication of the probability of·
the requirement - or understanding of the requirement - changing; high stability
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indicates a low probability of the requirement changing

Type - select the value that most accurately reflects the type or function of the·
requirement; Functional requirements are things that the system must do, such
as identify franked, unfranked and total credit for a dividend; Non-functional
requirements are things that the system must be, such as reliable or cost
effective

The 'Last Updated' field shows the date on which the requirement was last changed
and saved.

New Click on this button to clear the fields or set them to default  values, so that you can
create a new internal requirement.

Save Click on this button to save your changes to the currently-selected requirement.

Delete Click on this button to delete the requirement currently selected in the Requirement
list.

List Lists the requirements associated with the current element. For each requirement,
the list shows:

The requirement's name/short description·
The requirement type, and·
Whether the requirement is an external Requirement element·

The external Requirement element can be an internal requirement that has been
converted to an external one, or an independent external Requirement that has then
been connected to the current element.

To convert an internal requirement to an external Requirement element, right-click
on the requirement in the list and select the 'Move External' menu option.
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External Requirements

External requirements are those Requirement elements that have been connected to the current element using a
Realization connector. By creating the connector from the element to the Requirement, you create an expectation that the
element must implement the requirement as part of the system solution.

In Enterprise Architect, linked Requirement elements are shown in the 'Requirements' tab of the element 'Properties'
dialog, but they are marked external and cannot be directly edited (on selection, the property fields are grayed out).

Double-click an external requirement in the list to activate the 'Properties' dialog for the associated Requirement element,
where you can view and modify the requirement details and check the requirement hierarchy details.
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Constraints

If you need to define the conditions and rules under which an element operates and exists, you can do this by setting
Constraints on the element, in conjunction with its responsibilities (internal requirements). Typical constraints are pre-
and post-conditions, which indicate things that must be true before the element is created or accessed and things that
must be true after the element is destroyed or its action is complete.

You can show the constraints for an element directly on the diagram, using the element Feature and Compartment
Visibility function; this also reveals any constraints inherited from parent elements.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Constraints

Design > Element > Manage > Specific Properties Page > Constraints

Context Menu Right-click on element | Properties > Constraints  or

Right-click on element | Properties Page | Constraints

Keyboard Shortcuts Alt+Enter : Constraints

Shift+Alt+C

Other Double-click on Element : Constraints

Define constraints for an element

Field/Button Description

Constraint Type the value of the constraint.

Type Click on the drop-down arrow and select the appropriate type (Pre-condition,
Post-condition, Process, OCL or Invariant).

Status Click on the drop-down arrow and select the appropriate status.

Notes Type in any additional details or comments on the constraint·
You can format the notes text using the Notes toolbar at the top of the field·

New Click on this button to clear the fields ready to create a new constraint.

Save Click on this button to save the constraint data.

Defined Constraints This field lists the constraints defined in the element, showing the constraint name,
type and status.

Delete Click on a constraint in the Defined Constraints list and click on this button to
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immediately remove the constraint from the element.

updownhands (If you have two or more constraints in the element.) Click on a constraint in the
Defined Constraints list and click on one of these buttons to move the constraint
one position up or down in the list.
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Scenarios

A scenario is a real-world sequence of operations that describes how an element works in real-time. Scenarios can be
applied to any element - although generally to Use Cases - to describe functional behavior, business workflows and
end-to-end business processes. You create scenarios through the 'Scenarios' tab of the element 'Properties' dialog, which
has two internal tabs:

The 'Description' tab, on which you can create scenarios and write a simple text description of each scenario or of·
the structure of each scenario

The 'Structured Specification' tab (the default) through which you can create scenarios or select those you have·
created elsewhere and, for each scenario:
    - Create a series of steps for each part of the scenario
    - Structure the scenario to show how the basic path diverges into alternate paths and exception paths
    - Generate a number of types of diagram from the structure
    - Generate the structured scenario from an Activity diagram
    - Generate the structured scenario from text on the clipboard; this option has a variation in the 'Description'
       tab that you can use to translate scenario descriptions created prior to release 8.0 of Enterprise Architect,
       into structured scenarios in the latest release

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios

Design > Element > Manage > Specific Properties Page > Scenarios

Context Menu Right-click on element | Properties > Scenarios  or

Right-click on element | Properties Page | Scenarios

Keyboard Shortcuts Alt+Enter : Scenarios

Shift+Alt+S

Other Double-click on Element : Scenarios

Using the Description tab

Field/Button Action

Scenario Defaults to the name Basic Path. (You usually define the basic path of the scenario
first.)

If necessary, type in a different name for the scenario (to work on an existing
scenario, click on the drop-down arrow and select  the name from the list).

Type Defaults to Basic Path, for the direct steps of the scenario. For subsequent
scenarios, click on the drop-down arrow and select either:

Alternate - an alternative set of steps, in parallel with part of the basic path·
Exception - the path the scenario follows if a step of the basic path does not·
produce an appropriate result
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Description Record a textual description of how the user uses the current element.

You can format the description text using the Notes toolbar at the top of the field.

As well as applying the Notes window facilities, you can also generate a structured
specification from the text in this field; highlight the text, right-click on it and select
the 'Create Structure from Notes' option.

The text is copied to the 'Structured Specification' tab for the current scenario,
either as a new specification or as the continuation of an existing specification, with
a new step created at each carriage return.

Subsequent changes to the text on the 'Structured Specification' tab are not reflected
on the 'Description' tab.

New Click on this button to clear the data fields so that you can enter data in them to
create a new scenario.

Save Click on this button to save a new scenario, or changes to an existing scenario.

Scenarios This panel displays a list of the scenarios defined for this element, and the type of
each scenario.

Delete Click on this button to delete a scenario selected from the Scenarios panel.

updownhands (If you have two or more scenarios listed.) Click on a scenario in the Scenarios list
and click on one of these buttons to move the scenario one position up or down in
the list.

Notes

The 'Scenarios' tab does not prevent you from creating more than one basic path, but it would be unusual to define·
more than one

All the functions available on the 'Scenarios' tab are also available through the Scenarios & Requirements window;·
use the Browse Element icon in the window toolbar to list and select the scenarios for the element
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Structured Specification Tab

The 'Structured Specification' tab offers a wide range of facilities for generating and modifying scenario specifications,
which you can use to quickly and easily define the structure, actions and interactions of the scenarios defined for an
element such as a Use Case. These scenarios can be the main (basic) path, alternate paths or exception paths.

When you open the 'Structured Specification' tab it defaults to the basic path so that if it does not already exist, you can
create it. You can create alternate paths and exception paths as part of the process of adding them to steps of the basic
path.

You can also create all three types of scenario paths on the 'Description' tab, or in the Scenarios & Requirements
window.
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Set Up Scenario Specification

You can create a specification for a scenario in one of a number of ways:

Enter the specification yourself, as described here·
Generate a specification from an Activity diagram created under a Use Case element·
Generate a specification from the Notes text of the scenario in the Description tab·
Generate a specification from text held on the clipboard·

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification

Context Menu Right-click on element | Properties > Scenarios > Structured Specification  or

Right-click on element | Properties Page | Scenarios > Structured Specification

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification or

Shift+Alt+S > Structured Specification

Other Double-click on Element : Scenarios > Structured Specification

Enter the specification yourself, starting with the basic path

Step Action

1 In both the 'Scenario' and 'Type' fields, click on the drop-down arrow and select 'Basic Path'.

2 In the new step field in the 'Action' column, type the text of the first step or action.

3 Tab to the 'Uses' column and, if appropriate, type the name of each element used in this step. If the
elements are highlighted in blue and underlined, it indicates that they are already listed in the 'Context
References' tab.

You can also manage the list of elements as context references, and add to the list directly; see the Notes.

4 Tab to the Results column and, if appropriate, type the outcome of completing this step.

5 Tab to the State column and, if appropriate, type the name of the state into which the step moves the
action.

6 When you move out of the 'Action' column, the next new step field displays underneath.

Repeat steps 2 to 5 as many times as is necessary.

The 'Structured Specification' tab should now resemble this:
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7
Click on the  (Save) icon in the Structured Specification toolbar.

Notes

By default, the steps begin with a user step (indicated by an 'Actor' icon) and alternate between user and system·
(indicated by a screen icon) steps. However, you can control the responsible entity assigned to a step by typing a
keyword within the first 15 characters of the text in the 'Action' column; either 'User' or 'Actor' for a user step, or
'System' for a system step. Once a step has been saved, you can change the responsible entity by either
double-clicking on the icon or right-clicking on the step, and selecting 'Set Step as 'System'' or 'Set Step as 'User'' as
required

An entry for the basic path displays in the 'Entry Points' tab, as Step 0 with no value in the 'Join' column (the basic·
path does not rejoin itself)

The values in the 'Uses', 'Results' and 'State' columns, whilst optional, are significant if you want to generate a·
diagram from the specification; if you type the name of an element linked to the current element (and listed in the
'Context References' tab), the element name is highlighted and underlined

In the 'Uses' column, in edit mode, use the 'Manage Uses Context List' context menu option to enable and disable·
'Uses' cells as linked element lists as well as text fields, across the whole model; when the feature is enabled, the
column shows both context-linked elements and manually-entered text, and when disabled only text entries are listed
(the context-linked entries are hidden and deactivated, but not deleted - they are re-activated when the feature is
enabled)

As you develop the scenario, you can move steps to different positions in the scenario, and insert new step lines·
within the body of the scenario

You can also create constraints on the element that have an impact on the scenarios·
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Repeat this Set Up Scenario Specification procedure for each scenario you have created; you can now adapt,·
enhance and interrelate the scenario specifications using the facilities of the 'Structured Specification' tab:
    - Structured Specification Toolbar
    - Item context menu
    - Selected Text context menu
    - Entry Points context menu
    - Floating Toolbar
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Structured Specification Toolbar

In developing a Structured Specification, you can perform a range of operations using the icons on the Structured
Specification toolbar.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification

Context Menu Right-click on element | Properties > Scenarios > Structured Specification  or

Right-click on element | Properties Page | Scenarios > Structured Specification

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification or

Shift+Alt+S > Structured Specification

Other Double-click on Element : Scenarios > Structured Specification

Toolbar options

Icon Action

Click on this icon to save changes to the scenario specification.

Click on this icon to return to the basic path specification (if another specification is
currently displayed).

(Enabled when the basic path is displayed - you cannot add an alternate path to
another alternate path or an exception path.)

Click on this icon to create a branch from the selected step to an alternate path
scenario; select the path from the displayed list. If the appropriate scenario does not
yet exist, double-click on the new path line and type the scenario name, then click
off the line and back on to it.

Click on the OK button.

An entry for this alternate path displays in the 'Entry Points' tab, as 'Step a' of·
the basic path step it branches from; in the 'Join' column, click on the
drop-down arrow and select the number of the step at which action flows back
to the basic path, or select 'End' if the path terminates separately from the basic
path

You cannot join the end of the branch - whether alternate or exception - to·
more than one step of the basic path; if you change the join point of the branch,
any duplicates of that branch are updated to remain in synchrony with the join
point
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(Only enabled when the basic path is displayed - you cannot add an exception path
to another exception path or an alternate path.)

Click on this icon to create a branch from the selected step to an exception path
scenario - select the path from the displayed list. If the appropriate scenario does
not yet exist, double-click on the new path line and type the scenario name, then
click off the line and back on to it.

Click on the OK button.

An entry for this exception path displays in the 'Entry Points' tab, as 'Step a' of·
the basic path step it branches from; in the 'Join' column, click on the
drop-down arrow and select the number of the step at which action flows back
to the basic path, or select 'End' if the path terminates separately from the basic
path

You cannot join the end of the branch - whether alternate or exception - to·
more than one step of the basic path; if you change the join point of the branch,
any duplicates of that branch are updated to remain in synchrony with the join
point

Click on this icon to display the 'Manage Uses Context List' dialog, which you use
to set the 'Uses' column entries to linked context reference lists.

Click on this icon to move the currently-selected step one place up (including any
new step ... entry).

Click on this icon to move the currently-selected step one place down (including
any new step ... entry).

Click on this icon to display a list of diagrams that you can generate from the
scenario; click on the type of diagram that you want to generate.

Click on this icon to display a list of Test Suites and Test Cases you can generate,
based on this Use Case scenario. Click on the test structure you want to generate.

Click on this icon to delete the selected step from the scenario.

Click on this icon to display the Help topic for this tab.
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Structured Specification Item Context Menu

You can perform a wide range of operations to create and manage your Structured Specification, using the Structured
Specification item context menu.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification >
Right-click on item or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification > Right-click on item

Context Menu Right-click on element | Properties > Scenarios > Structured Specification |
Right-click on item  or

Right-click on element | Properties Page | Scenarios > Structured Specification |
Right-click on item

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification | Right-click on item or

Shift+Alt+S > Structured Specification | Right-click on item

Other Double-click on Element : Scenarios > Structured Specification | Right-click on
item

Item menu options

Option Action

Create Structure From
Clipboard Text

Click on this option to display two sub-options to generate a set of steps from a text
description or list captured on the clipboard; a new step is generated:

After each carriage return in the captured text ('New Line Delimited'), or·
For each sentence in the text; that is, after each full stop/space/capital letter·
combination ('Sentence Delimited')

If a set of steps is already displayed, it is overwritten by the generated steps.

Create Structure From
Generated Activity
Diagram

Click on this option to generate a set of steps from an Activity Diagram created for
a Use Case.

If a set of steps is already displayed, it is overwritten by the generated steps.

Add Alternate Path Click on this option to create a branch from the selected basic path step to an
alternate path.

Add Exception Path Click on this option to create a branch from the selected basic path step to an
exception path.

Insert Step Click on this option to display three sub-options, to insert a new step... line:
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Above the currently-selected step (press Esc to return this new line to the end·
of the scenario)

Below the currently-selected step (press Esc to return this new line to the end·
of the scenario)

At the end of the scenario·
Shortcut: Shift+Insert or Insert+Ctrl+N

Set Step As 'User'

Set Step As 'System'

Click on the appropriate option to switch the entity responsible for performing the
action of the selected step between user and system.

Link Step to Use Case Click on this option to display sub-options to:

Include the actions of an existing Use Case element·
Extend an existing Use Case element, or·
Invoke a Use Case as the action of the selected step·

Selecting the appropriate sub-option displays the 'Select Use Case' dialog, which
you use to browse for and select the required Use Case element.

The appropriate includes, extends or invokes stereotyped connector is created
between the current element and the selected Use Case.

For the include and extend actions, any text in the 'Action' field is overwritten by
the link to the Use Case; for the invoke action, this link is added to the end of the
'Action' text:

    (Invokes: <Use Case Name>)

Merge With Step Click on this option to merge the selected step with another.

A list of the other steps in the scenario displays; click on the step to merge with the
selected step.

Move After Step Click on this option to move the selected step to another position in the scenario.

A list of the other steps in the scenario displays; click on the step after which to
position the selected step.

Delete Click on this option to delete the selected step; any subsequent steps are moved up
one place.

A prompt displays to confirm the deletion. Click on the Yes button.

(c) Sparx Systems 2015 - 2017 Page 302 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Structured Specification Selected Text Context Menu

Further facilities are available in the 'Structured Specification' tab to work with the user-editable text of any part of a
specification step. You access these facilities through the item text context menu.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification |
Highlight text | Right-click or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification | Highlight text | Right-click

Context Menu Right-click on element | Properties > Scenarios > Structured Specification |
Highlight text | Right-click  or

Right-click on element | Properties Page | Scenarios > Structured Specification |
Highlight text | Right-click

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification | Highlight text | Right-click or

Shift+Alt+S > Structured Specification | Highlight text | Right-click

Other Double-click on Element : Scenarios > Structured Specification | Highlight text |
Right-click

Text menu options

Option Action

Create Click on this option to display two suboptions that you can select to use the
highlighted text as the base for either:

a glossary definition or·
a new element·

Link Step to Use Case Click on this option to display sub-options to define the actions of the selected step
by:

Including the actions of an existing Use Case element·
Extending an existing Use Case element, or·
Invoking a Use Case·

Selecting the appropriate sub-option displays the 'Select Use Case' dialog, which
you use to browse for and select the required Use Case element.

The appropriate includes, extends or invokes stereotyped connector is created
between the current element and the selected Use Case.

For the include and extend actions, any text in the 'Action' field is overwritten by
the link to the Use Case; for the invoke action, this link is added to the end of the
'Action' text:

(c) Sparx Systems 2015 - 2017 Page 303 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

    (Invokes: <Use Case Name>)

Link to existing Element ('Uses' and 'Results' field text only.) Click on this option to create a Realization or
Dependency relationship to a Requirement, Feature or other element elsewhere in
the model.

You select the element and connector types from submenu options that then display
the 'Select Element' dialog, which you use to browse for and select the required
element.

Insert context reference Click on this option to add a reference to an element stored elsewhere in the model,
and create an entry for the element in the 'Context References' tab.

Selecting this option displays the 'Select Element' dialog, which you use to browse
for and select the required reference element.

Insert glossary definition Click on this option to insert an existing glossary term at the cursor position. To
select the term, double-click on it in the displayed list.

When you select the term it is inserted into the field as highlighted and underlined
text, which displays the definition when you move the cursor over it. If you
highlighted part of the original text, the term overwrites that text.

Manage Uses Context List (On highlighted text or a specific cursor position in the 'Uses' column.)

Click on this option to display the 'Manage Uses Context List' dialog, which you
can use to:

Browse to or type in a context reference item·
Re-sort the list with up and down arrow keys·
Remove an entry from the list·
Enable or disable the 'Uses Context List' facility across the model·

You can resize the dialog to show the full details of context reference items.

If you enable the 'Uses Context List' facility, you do not necessarily have to use the
dialog to add context list items; you can type or insert an element name from the
'Context References' tab in the 'Uses' column, and that name is added to the 'Uses
Context List'.

If you disable the 'Uses Context List' facility, the context list items in the 'Uses'
column are hidden.

Split Step Click on this option to split the selected step into two consecutive steps.

The option is available only if you highlight a portion of the text in the selected
field. The new step takes the highlighted text as its Action text.

Search for <text> Click on this option to display the Code Editor menu of options for locating the
selected text in a number of locations.

Undo Click on this option to undo any unsaved changes you have just made in the step.

Cut Select this option to cut the selected text to the clipboard.

Copy Select this option to copy the selected text to the clipboard.

Paste Select this option to paste the current contents of the clipboard.

Delete Select this option to delete the selected text.
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Select All Select this option select all text in the current field.
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Structured Specification Entry Points Context Menu

Under the 'Structured Specification' tab, the 'Entry Points' tab shows how the basic path, alternate path and exception
path scenarios for the element are organized and interrelated. If an alternate path or exception path has been defined but
has not yet been added to the basic path, it is not listed on this tab. You can perform certain operations on the items of the
'Entry Points' tab, using the context menu.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification >
Entry Points > Right-click or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification > Entry Points > Right-click

Context Menu Right-click on element | Properties > Scenarios > Structured Specification | Entry
Points | Right-click  or

Right-click on element | Properties Page | Scenarios > Structured Specification |
Entry Points | Right-click

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification | Entry Points | Right-click or

Shift+Alt+S > Structured Specification | Entry Points | Right-click

Other Double-click on Element : Scenarios > Structured Specification | Entry Points |
Right-click

Entry Points menu options

Option Action

Edit Path Click on this option to display the steps of the scenario in the 'Structured
Specification' tab, with the first step highlighted.

Join with Step (Available only if the basic path scenario is displayed in the 'Structured
Specification' tab, to join the selected alternate or exception path with the basic
path. Not available to change the basic path scenario itself.)

Click on this option to highlight the 'Join' field and its drop-down arrow. Click on
the drop-down to define or change the step number at which the alternate or
exception path rejoins the basic path. Select 'End' if the path does not rejoin the
basic path steps.

Remove Entry Point (Available only if the basic path scenario is displayed in the 'Structured
Specification' tab, to delete a junction with the basic path. Not available to delete
any part of the basic path scenario itself.)

Click on this option to delete the relationship between the selected path and the
basic path, and remove the entry from the 'Entry Points' tab.

A prompt displays to confirm the deletion. Click on the Yes button to delete the
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junction.

Notes

You can switch focus between the 'Entry Points' tab and the 'Structured Specification' tab by pressing Alt+Q·
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Structured Specification Floating Toolbar

Wherever a reference to another element exists on the 'Scenario' tab (that is, where the text is highlighted and
underlined), if you move the cursor over the element name a short floating toolbar displays. You can select the icons on
this toolbar to:

Display the element's 'Properties' dialog·
Locate the element in its parent diagram·
Locate the element in the Project Browser·
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Generate Diagrams

When you have created a structured scenario, you can generate any of these diagrams from it:

Activity·
With ActivityParameter·
With Action·
With Action Pin·
Rule Flow·
State·
Sequence·
Robustness·

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification

Context Menu Right-click on element | Properties > Scenarios > Structured Specification  or

Right-click on element | Properties Page | Scenarios > Structured Specification

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification or

Shift+Alt+S > Structured Specification

Other Double-click on Element : Scenarios > Structured Specification

Generate the required diagram

Step Action

1 Create the scenario structure on the 'Structured Specification' tab.

2
Click on the  ('Generate Diagram') icon in the toolbar on the tab.

3 Click on the type of diagram to generate.

Enterprise Architect generates the diagram and notifies you that generation is complete. Click on the OK
button and then close the 'Properties' dialog to review the diagram.

If the diagram being generated already exists under the selected element, a prompt displays to overwrite
or synchronize with that diagram.

Select the appropriate radio button to:

Overwrite the existing diagram (delete the existing diagram and elements, and create a new diagram·
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and elements) or

Synchronize the elements in the existing diagram with the scenario steps (however, Sequence and·
Robustness diagrams cannot be synchronized)

Notes

The 'Synchronize elements in existing diagram' option enables the 'Preserve Diagram Layout' checkbox, which you·
can select to preserve the existing arrangement of elements and connectors on the diagram; any new elements are
added to the diagram in the default position, and you manually position them in the diagram as required; if you do
not select the checkbox, the diagram is recast in the default layout
It is recommended that you uncheck the 'Preserve Diagram Layout' checkbox if you are synchronizing elements with
scenario steps:
    - When new steps have been added or existing steps have been deleted or moved within the Use Case
    - For the first time in a Use Case that has been imported from XMI with the 'Strip GUIDs' option selected
    - For the first time in a Use Case that has been copied and pasted in the Project Browser, or
    - For the first time in a Use Case whose containing Package has been copied and pasted in the Project Browser
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Generate Activity Diagram

When you create a scenario on an element, and then generate an Activity diagram from the scenario, an Activity is
generated as a child of the selected element to act as a container for the diagram.

Each scenario step is modeled as an Activity·
The values of the Uses, Results and State columns for each step are added as memo Tagged Values of the·
corresponding Activity

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification :

 | Activity or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured

Specification :  | Activity

Context Menu
Right-click on element | Properties > Scenarios > Structured Specification : 
| Activity or

Right-click on element | Properties Page | Scenarios > Structured Specification :

 | Activity

Keyboard Shortcuts
Alt+Enter : Scenarios > Structured Specification :  | Activity or

Shift+Alt+S > Structured Specification :  | Activity

Other
Double-click on Element : Scenarios > Structured Specification :  | Activity

Example
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Diagram Types

There are three additional variations of the Activity diagram that you can generate.

Diagram Detail

Activity with
ActivityParameter

The values of the Uses and Results columns are modeled as ActivityParameters·
The ActivityParameters are added to the Project Browser and not to the·
diagram

The value of the State column is added as a Tagged Value of each Activity·

Activity with Action The scenario steps are modeled as Actions·
The values of the Uses, Results and State columns are added as Tagged Values·
of  each Action

Activity with ActionPin The scenario steps are modeled as Actions·
The values of the Uses and Results columns are modeled as Input Pins and·
Output Pins respectively

ActionPins are added to the Project Browser and not to the diagram·
The value of the State column is added as a Tagged Value of each Action·
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Generate RuleFlow Diagram

When you create a scenario on an element and then generate a RuleFlow diagram, a Rule Flow Activity is created as a
child of the selected element, to act as a container for the diagram.

The scenario steps are modeled as RuleTasks·
The values of the Uses, Results and State columns are added as Tagged Values of the RuleTasks·

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification :

 | RuleFlow or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured

Specification :  | RuleFlow

Context Menu
Right-click on element | Properties > Scenarios > Structured Specification : 
| RuleFlow  or

Right-click on element | Properties Page | Scenarios > Structured Specification :

 | RuleFlow

Keyboard Shortcuts
Alt+Enter : Scenarios > Structured Specification :  | RuleFlow or

Shift+Alt+S > Structured Specification :  | RuleFlow

Other
Double-click on Element : Scenarios > Structured Specification :  |
RuleFlow
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Generate StateMachine Diagram

When you create a scenario on an element and then generate a StateMachine diagram, a StateMachine is created as a
child of the selected element to act as a container for the diagram.

Each value in the State column is modeled as a State·
The scenario steps become the Transition connectors between the States·
The values of the Uses and Results columns are added as Tagged Values of the Transition connectors·

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification :

 | State or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured

Specification :  | State

Context Menu
Right-click on element | Properties > Scenarios > Structured Specification : 
| State  or

Right-click on element | Properties Page | Scenarios > Structured Specification :

 | State

Keyboard Shortcuts
Alt+Enter : Scenarios > Structured Specification :  |State or

Shift+Alt+S > Structured Specification :  |State

Other
Double-click on Element : Scenarios > Structured Specification :  | State

Example
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Generate Sequence Diagram

When you create a scenario on an element and then generate a Sequence diagram, an Interaction is created as a child of
the selected element to act as a container for the diagrams - the Basic, Alternate and Exception paths are each modeled as
a separate Sequence diagram under the Interaction.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification :

 | Sequence or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured

Specification :  | Sequence

Context Menu
Right-click on element | Properties > Scenarios > Structured Specification : 
| Sequence  or

Right-click on element | Properties Page | Scenarios > Structured Specification :

 | Sequence

Keyboard Shortcuts
Alt+Enter : Scenarios > Structured Specification :  | Sequence or

Shift+Alt+S > Structured Specification :  | Sequence

Other
Double-click on Element : Scenarios > Structured Specification :  |
Sequence

Notes

All the elements involved in the scenario should be identified in the 'Context Reference' tab; that is, relationships·
must already exist between the scenario parent element and the other elements named in the scenario

Each Context Reference element named in a scenario step is modeled as a Lifeline·
The step itself becomes the Message between an originator and its destination(s)·
The first Context Reference element in a step is treated as the originator·
The subsequent Context Reference element(s) become the destination(s)·
Because the diagram generator acts on element names in the step, you should avoid using the element names as·
normal text; for example, in step 1 in the example dialog, the term ATM-Card is interpreted as a reference to the
ATM element, and two 'Customer inserts ATM-Card into ATM' messages are generated for the step (to avoid
confusion, in the diagram the first Message has been deleted)

If the 'Show Sequence Numbering' checkbox on the 'Diagram Sequence' page of the 'Preferences' dialog is not·
selected, the Message name on the Sequence diagram is prefixed by the step number, as shown in the example
diagram; if the checkbox is selected, the message sequence number is shown instead of the step number

The values of the 'Uses', 'Results' and 'State' columns are added as Tagged Values of the Message·
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Example
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Generate Robustness Diagram

When you create a scenario on an element and then generate a Robustness diagram, a Collaboration is created as a child
of the selected element to act as a container for the Robustness diagram.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification :

 | Robustness or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured

Specification :  | Robustness

Context Menu
Right-click on element | Properties > Scenarios > Structured Specification : 
| Robustness  or

Right-click on element | Properties Page | Scenarios > Structured Specification :

 | Robustness

Keyboard Shortcuts
Alt+Enter : Scenarios > Structured Specification :  | Robustness or

Shift+Alt+S > Structured Specification :  | Robustness

Other
Double-click on Element : Scenarios > Structured Specification :  |
Robustness

Notes

All the elements involved in the scenario should be identified in the 'Context Reference' tab; that is, relationships·
must already exist between the scenario parent element and the other elements named in the scenario

Any values in the 'Uses', 'Results' and 'State' columns are ignored and not represented in the diagram·
Each UI element in a step becomes a Boundary element; a Dependency relationship is created from this Boundary·
element to the UI element (this connector is not shown on the diagram)

Each Actor referenced in a step is dropped into the Robustness diagram as a simple link·
Each Class referenced in a step is dropped into the Robustness diagram as a simple link, and is given the stereotype·
entity

Each step with a System trigger becomes a Controller; alternate/exception path Controllers are displayed with a red·
background color

Each step with a User trigger becomes the name of the Association between Controllers·

Example
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Generate Scenario From Activity Diagram

You can generate a range of diagrams from a scenario in an element. Conversely, you can also generate a structured
scenario within an element from an Activity diagram, reverse engineering the steps from the diagram elements
(effectively either regenerating the scenario within the Use Case, or transferring a scenario into another Use Case).

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification >
Right-click on space > Create Structure From Generated Activity Diagram or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification > Right-click on space > Create Structure From Generated Activity
Diagram

Context Menu Right-click on element | Properties > Scenarios > Structured Specification |
Right-click on space | Create Structure From Generated Activity Diagram  or

Right-click on element | Properties Page | Scenarios > Structured Specification |
Right-click on space | Create Structure From Generated Activity Diagram

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification | Right-click on space | Create
Structure From Generated Activity Diagram or

Shift+Alt+S > Structured Specification | Right-click on space | Create Structure
From Generated Activity Diagram

Other Double-click on Element : Scenarios > Structured Specification | Right-click on
space | Create Structure From Generated Activity Diagram

Generate a scenario from an Activity diagram

Step Action

1 On the 'Select an Activity (generated from a UseCase Scenario) containing the Diagram' dialog, search for
and select the Activity containing the required diagram.

2 Click on the OK button.

A prompt displays to remind you that any existing scenario steps will be deleted.

3 Click on the Yes button.

The system validates the diagram (displaying the results in the 'Scenario Generation' tab of the System
Output window) and, if the diagram is valid, generates the scenario steps in the 'Structured Specification'
tab.

Notes
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The source Activity diagram must be generated from another Use Case scenario·
This facility does not operate on the enhanced Activity diagrams generated from a Use Case - those generated with·
ActivityParameters, Actions and Action Pins
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Generate Test Cases

When you have defined a scenario, you can generate one of a number of Test Cases from it, including:

A Test Suite - Horizontal Layout·
A Test Suite - Vertical Layout·
An Internal Test Case or·
An External Test Case·

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification :

 |<testcase type> or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured

Specification :  |<testcase type>

Context Menu
Right-click on element | Properties > Scenarios > Structured Specification : 
|<testcase type>, or

Right-click on element | Properties Page | Scenarios > Structured Specification :

 |<testcase type>

Keyboard Shortcuts
Alt+Enter : Scenarios > Structured Specification :  |<testcase type> or

Shift+Alt+S > Structured Specification :  |<testcase type>

Other
Double-click on Element : Scenarios > Structured Specification :  |<testcase
type>

Test Cases Generated

Test Case Detail

Test Suite - Horizontal
Layout

A Test Case element is created, which acts as a container for the created diagram
and Test Suite elements.

The basic path and each alternate and exception path is represented by a Test Case
element. Each step in the basic, alternate and exception paths is represented by a
Test element.

A diagram is created under the container Test Case element, to which the Test Case
and Test elements are added.

The elements are displayed on the diagram in a matrix-like format, with the basic
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path and its steps forming the first column followed by the alternate and exception
paths.

Note that the name of each created Test Case and Test element is truncated to 25
characters.

Test Suite - Vertical
Layout

A Test Case element is created, which acts as a container for the created diagram
and Test Suite elements.

The basic path and each alternate and exception path is represented using a Test
Case element. Each step in the basic, alternate and exception paths is represented
by a Test element.

A diagram is created under the container Test Case element, to which the Test Case
and Test elements are added.

The elements are displayed on the diagram in a single column with the basic path
and its steps at the top followed by each alternate and/or exception path and its
steps.

Internal Test Case A test is generated for the basic path and each alternate and exception path in the
scenario, and added to the selected element.

In addition, for each step in the basic, alternate and exception paths that has a value
in the Results column, a test is generated and added to the selected element.

A diagram is created under the selected element, to which that element and a Note
(showing the element's Structured Specification) is added.

The created tests are displayed in the Test Scripts compartment of the selected
element on the diagram. Another way to view these tests is to click on the element
and display the Testing window.

These generated tests are written to the Scenario Class Type of the Testing window;
you can change the tests to another test-type if required.

External Test Case A Test Case element is created, linked to the selected element using the Trace
connector.

A diagram is created under this Test Case element, to which the selected element,
the Test Case element and a Note (showing the element's Structured Specification)
is added.

The created tests are displayed in the Test Scripts compartment of the Test Case
element on the diagram.

A test case is generated and added to the Test Case element for the basic path, and
for each alternate and exception path.

In addition, for each step in the basic, alternate and exception paths that has a value
in the Results column, a test is generated and added to the Test Case element.

You can review the tests within the Test Case element using the Testing window, as
for Internal Test Cases.
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Context References Tab

As you create a structured specification on the 'Scenarios' page of the element 'Properties' dialog, you can use the
'Context References' tab to create and display a list of all elements that are either:

Connected to the current element by any connector, on the current diagram or another, or·
Defined as a cross reference (or custom reference) on the current element·

Access

On a diagram or in the Project Browser, select an element, then use any of the methods outlined here to display the
'Select Element' dialog. Use the 'Select Element' dialog to locate and select the required cross reference element or
elements. For each cross reference you can also use context menu options to delete the entry in the list, or to open the
'Comment' field so that you can add or edit comment text.

For each element in the 'Context References' list, wherever the name of that element appears in the structured
specification, the name is highlighted and underlined; press the Ctrl key and click twice on the highlighted name to view
the element 'Properties' dialog.

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification >
Context References > Right-click on space > Add Context Reference or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification > Context References > Right-click on space > Add Context
Reference

Context Menu Right-click on element | Properties > Scenarios > Structured Specification | Context
References | Right-click on space | Add Context Reference  or

Right-click on element | Properties Page | Scenarios > Structured Specification |
Context References | Right-click on space | Add Context Reference

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification | Context References | Right-click
on space | Add Context Reference or

Shift+Alt+S > Structured Specification | Context References | Right-click on space |
Add Context Reference

Other Double-click on Element : Scenarios > Structured Specification
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Scenario Constraints Tab

The 'Structured Specification Constraints' tab is a simple link to the 'Constraints' page of the main element 'Properties'
dialog. It lists existing constraints; if you select the toolbar icons to add or edit a constraint, control switches to the
element 'Constraints' page.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Scenarios > Structured Specification >
Constraints or

Design > Element > Manage > Specific Properties Page > Scenarios > Structured
Specification > Constraints

Context Menu Right-click on element | Properties > Scenarios > Structured Specification |
Constraints  or

Right-click on element | Properties Page | Scenarios > Structured Specification |
Constraints

Keyboard Shortcuts Alt+Enter : Scenarios > Structured Specification | Constraints or

Shift+Alt+S > Structured Specification | Constraints

Other Double-click on Element : Scenarios > Structured Specification | Constraints
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Associated Files

An element can be linked to one or more files external to the repository, using the 'Files' tab of the element's 'Properties'
dialog. Having created the link, you can open the file and read its content from this tab.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Files

Design > Element > Manage > Specific Properties Page > Files

Context Menu Right-click on element | Properties > Files  or

Right-click on element | Properties Page | Files

Keyboard Shortcuts Alt+Enter : Files

Shift+Alt+F

Other Double-click on Element : Files

Manage File Links

Option Action

File Path Displays the directory path and name of the file currently selected in the 'Files' list.

To add a link to a file, click on the  button to display the 'Locate Files' browser
and locate and click on the appropriate file name. Then click on the OK button to
return to the element 'Properties' dialog.

Type Click on the drop-down arrow and select the appropriate value to identify the file
path as a local directory path or a web address.

Last Write Displays the date and time the file was last updated.

Size Displays the size of the file.

Notes Type in any comments or notes on the link to the file.

New Click on this button to clear the data entry fields so that you can add a new file link.

Save Click on this button to save any new or changed details on a linked file.

Files Displays the list of linked files. Click on a file to select it.

Launch Click on this button to open the selected file.

Local files open in their default application and web files open in the default
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browser.

Delete Click on this button to remove the link to the associated file.

The link is deleted from the list immediately.

Notes

Linked files are a good way to link elements to additional documentation and/or source code·
You can also insert hyperlinks to other files, in diagrams, and launch them directly from the diagram·
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Links

The 'Links' tab of the element 'Properties' dialog provides a list of all relationships that the current element is a partner in.

Access

On a diagram or in the Project Browser, select an element and:

Ribbon Design > Element > Manage > Properties > Links

Design > Element > Manage > Specific Properties Page > Links

Context Menu Right-click on element | Properties > Links  or

Right-click on element | Properties Page | Links

Keyboard Shortcuts Alt+Enter : Links

Shift+Alt+L

Other Double-click on Element : Links

Links Facilities

Facility Detail

Relationship Features The Relationships panel lists the relationships this element has, showing the:

Elements that this element is related to·
Stereotype (if any) of each related element·
Type of each related element·
Type of each connection or relationship·
Stereotype (if any) of the connector·

Links Page From the 'Links' tab you can perform operations on a relationship, by right-clicking
on the relationship to display the context menu.

To:

Display the 'Properties' dialog for a relationship, click on 'Relationship·
Properties'

Highlight the related element in the Project Browser, click on 'Locate Related·
Element'

Delete the relationship from the model and all diagrams, click on 'Delete·
relationship'; the system prompts you to confirm the deletion, click on the Yes
button to do so
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Templates

If you are working with Parameterized Classes or Binding Classes, you can use the 'Templates' tab of the Class's
'Properties' dialog to define:

The Parameterized Class template parameters and·
The Binding expressions on a Binding Class·

Access

Open the 'Templates' page of the element's 'Properties' dialog, using any of the methods outlined here.

In the 'Template Parameter(s)' panel, click on the Add button to add a new parameter, or click on an existing parameter
and on the Edit button to edit the parameter; in either case, the 'Template Parameter' dialog displays.

In the 'Binding(s)' panel, click on the Add button to add a new binding expression or click on an existing expression and
on the Edit button to edit the expression. When you click on the Add button, a short context menu displays from which
you select the type of relationship to generate, and then you define the binding expressions.

If either a template parameter or a binding expression is no longer required, click on it and then click on the
corresponding Delete button.

Ribbon Design > Element > Manage > Properties > Templates

Design > Element > Manage > Specific Properties Page > General > Templates

Context Menu Right-click on element | Properties > Templates  or

Right-click on element | Properties Page | General > Templates

Keyboard Shortcuts Alt+Enter : Templates

Other Double-click on Element : Templates
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Properties Window

The Properties window provides a convenient way to view (and in some cases edit) common properties of elements.
When an element is selected, the Properties window shows the element's name, stereotype, version, author, dates and
other pertinent information.

Access

Ribbon Start > Windows > Properties

Keyboard Shortcuts Alt+1

Properties Sections

The Properties window is divided into three expandable sections:

<Element type> Settings - for the basic element details·
Project - for general housekeeping settings·
Advanced - only active for generalizable elements·

Notes

When you click on a field name, a brief explanation of that field displays at the bottom of the Properties window,·
unless you have selected the 'Hide Properties Info Section' checkbox on the 'General' page of the 'Preferences' dialog

If you click on the field value for an editable field, a drop-down arrow displays that enables you to select a different·
value; one of the values offered might display a more advanced list or a dialog for adding new objects or selecting
multiple objects, as the 'Stereotype' field does
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The Document Window

The Document window has two tabs or pages, each of which supports the development and use of an important area of
documentation of your model.

The 'Dynamic Document' tab (the default) helps you to instantly generate a document on a selected element using·
one of a range of templates, to immediately display the information you require in the most appropriate structure and
format; the document can be printed, but is not stored electronically - it is dynamically generated for the current
element every time you select the tab and the template
The 'Dynamic Document' tab is also the screen for displaying the information from the elements defined in a
Reading List Artifact

The 'Linked Document' tab provides several quick methods of checking elements for Linked Documents, and for·
reviewing the documents that exist; it also provides searches to locate and list any elements with Linked Documents
in the model, and any elements that have Linked Documents that have been recently modified

Access

Ribbon Start > Windows > Document, or

Show > Window > Document
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Dynamic Documents in the Document Window

The 'Dynamic Document' tab of the Document window helps you to instantly generate a document on a selected element,
using one of a range of templates to immediately display the information you require in the most appropriate structure
and format. The document can be printed, but is not stored electronically - it is dynamically generated for the current
element whenever you select the tab and when you change the template. You cannot edit the document contents in the
Document window.
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The 'Dynamic Document' tab is also the display screen for Reading List Artifacts. These Artifacts define a list of
elements containing information that you should read consecutively. When you open the 'Dynamic Document' tab and
select a Reading List Artifact, the tab displays the text of the first element in the list. You can then select a 'Next' (and
'Previous') option to work through the Reading List of elements, displaying the text of each element in the defined
sequence.

Access

Ribbon Start > Windows > Document > Dynamic Document, or

Show > Window > Document > Dynamic Document

Using the Dynamic Document tab

Initially, when you open the Document window at the 'Dynamic Document' tab, the window displays the Notes text from
the currently-selected element, using the default Dynamic Document style sheet.

If you want to display information for a different aspect of the element:

Click on the '[Reading] - <element name>' header1.

Click on the 'Select Dynamic Style' option. The 'Dynamic Document Selector' dialog displays.2.

Click on the drop-down arrow in the 'Style' field and select one of the system-provided styles. These are designed to1.
display information for specific aspects of relevant elements, such as Testing or Development.

Click on the OK button. The document is refreshed to show the required information in an appropriate format.2.

If the system-provided style templates do not support your requirements, you can quickly create your own style
templates. A style template consists of one or more command lines, each of which defines an element type (or all
element types) and the document template to apply to the generated document. The document template can be:

A system-provided template, or·
A system-provided fragment, or·
A user-defined template, or·
A user-defined fragment·

Information on setting up a style template is provided in the Manage Dynamic Documents section.
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Manage Dynamic Documents

Task Description

Create Document
Templates

Document templates are held in the Resources window (Start > Explore >
Resources) in the Document Generation folder. Whilst you can select existing
system or user templates and template fragments for your dynamic document style
template, you can also create new document templates or fragments specifically for
dynamic documents. You could create these in the Templates or Fragments
sub-folders of the User Templates folder, or you could create a separate sub-folder
just for the dynamic document templates.

Whether you select existing templates or create new ones, you must enable the
Elements section in each template or fragment you use.

You would start to create the new document templates by either:

Right-clicking on the Templates sub-folder (or other sub-folder) name in the·
User Templates folder and selecting the 'Create Template' option, or

Opening the 'Generate Documentation ' dialog, clicking on the 'Templates' tab,·
and then clicking on the New button

In either case, the 'New Document Template' dialog displays, on which you specify
the template name, type, source and group before going on to define the template
contents.

Create Style Templates Style templates are also held in the Resources window, in the Document
Generation > Dynamic Documents Styles folder.

You can create a new style template:

Via the 'Dynamic Document Selector' dialog - click on the New button·
Via the Resources window - right-click on the Dynamic Documents Styles·
folder name and select the 'Create Dynamic Document Style' option

A prompt displays to enter the style template name; type the name in and click on
the OK button. The 'Dynamic Style' dialog displays, in which you type the style
definitions, in the format:

    <element name>:<stereotype>:<document template name>

If there is no stereotype, the format is:

    <element name>::<document template name>

The <element name> is an IF argument, to state that if the 'Dynamic Document' tab
is opened for an element of the defined type, the specified document template (or
fragment) is used to format its documentation. If you want to use a specific
template for information from an element of unspecified type (that is, a defined
default) you would type:

    Default::<document template name>
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You could also apply the system default template for displaying information from
an element of unspecified type, by just having the specified element statements with
no 'Default' statement at the end.

In this example, one template is defined to display information when the selected
element is a Use Case, another for information from elements used by Project
Support, a third for information from elements used in Database Engineering, and a
fourth (a defined default) for information from any other kind of element.

    UseCase::DD-UseCase

    Change::DD-Support

    Feature::DD-Support

    Issue::DD-Support

    Requirement::DD-Support

    Risk::DD-Support

    Task::DD-Support

    Class:Table:DD-DB Table

    Class:view:DD-DB SQL Element

    Class:dbsequence:DD-DB SQL Element

    Class:function:DD-DB SQL Element

    Class:procedure:DD-DB SQL Element

    Class:stored procedure:DD-DB SQL Element

    Class:trigger function:DD-DB SQL Element

    Class:functions:DD-DB SQL Element as Ops

    Class:sequences:DD-DB SQL Element as Ops

    Class:stored procedures:DD-DB SQL Element as Ops

    Class:procedures:DD-DB SQL Element as Ops

    Class:package:DD-DB SQL Element as Ops

    Artifact:sqlquery:DD-DB SQL Query

    Default::DD-Basic

Apply Style Templates Having created a style template in the Resources window, you can immediately
apply it to the information you display in the 'Dynamic Document' tab.

As explained in the Using the Dynamic Document Tab section, you click on the
[Reading] header and on the 'Select Dynamic Style' option, and then click on the
drop-down arrow in the 'Style' field. Your new style template will be listed with the
system templates and other user-defined templates.

Click on the style template to apply in the 'Dynamic Document' tab, and then on the
OK button.

The selected style will be applied to all documents shown in the 'Dynamic
Document' tab until you specifically change it again.

Increase or reduce
magnification

By default, the 'Dynamic Document' tab displays text as if it were printed on an A4
sheet. This is 100% zoom. If you want to change the display magnification, click on
the [Reading] header and select the 'Fixed Zoom' option. This provides a small set
of magnification options - '75%', '100%', '125%', '150%' and '200%'. It also provides
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a 'Custom' option; if you select this, a small dialog displays in which you type the
percentage magnification you prefer, between 10% and 500%.

When you click on the option, or the OK button on the small dialog, the selected
magnification is applied to the display.

The zoom factor remains set after you close the Document window, and is applied
when you re-open the window until you specifically change the zoom.

Display or hide page
outline

The Document window defaults to displaying information within the framework of
a page, but you can toggle to a full-screen display by clicking on the [Reading]
header and selecting the 'Toggle Page Border' option.

Scroll through elements In the 'Dynamic Document' tab, you can display the information from a set of
elements in sequence, using the 'Next' and 'Previous' options from the [Reading]
header context menu. If you have selected a:

Reading List Artifact element, the 'Next' and 'Previous' options display the·
information from the next or previous element in the reading list, wherever
they might be in the model

Other type of element, the 'Next' and 'Previous' options display the information·
from the next or previous element in the parent element or Package, as listed in
the Project Browser; the options cannot scroll outside the containing object

Edit Style Templates You can edit a style template:

In the Resources window by right-clicking on the template name and selecting·
the 'Edit Dynamic style' option, or

In the Document window by displaying the 'Dynamic Document Selector'·
dialog, selecting the style and clicking on the Edit button

In either case, the 'Dynamic Style' dialog displays, and you can delete or change the
statements as necessary. Right-click on a line of text to display a context menu
providing basic editing options.

Refresh the Display To update the display with any changes made to the information within the selected
element, click on the [Reading] header and select the 'Refresh' option.

The 'Dynamic Document' tab with the 'Refresh' option is a useful tool for
developing a document. You review the element's information in the Document
window, make any changes you think appropriate within the element, then select
the 'Refresh' option to immediately update the 'Dynamic Document' tab to show the
changes. You can therefore check how a document generated from the element
would look, as you develop it.

Print the document If you want to print a hard copy of the element's information, simply click on the
[Reading] header and select the 'Print' option. The contents of the Document
window are sent to the system default printer
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Linked Documents in the Document Window

The 'Linked Document' tab of the Document window provides several quick methods of checking elements for Linked
Documents, and for reviewing the documents that exist. It also provides searches to locate and list any elements with
Linked Documents in the model, and any elements that have Linked Documents that have been recently modified.

When you click on an element in the Project Browser, a diagram or an element list - such as the results of a search - the
'Linked Document' tab displays the name of the selected element and, if it has a Linked Document, the content of that
document. If the element does not have a Linked Document, the content panel is blank. If you click on another element,
the window updates immediately to show the element name and Linked Document (if any) of that element. You can
therefore quickly scan a number of elements to check whether they have Linked Documents, and/or review the
documents you locate. The 'Linked Document' tab provides options for reviewing the Linked Document, including
switching to an Edit mode so that you can create or update the document.

Access

Ribbon Start > Windows > Document > Linked Document or

Show > Window > Document > Linked Document

View Document

When you first open the Document window, it shows the selected element's Linked Document in View (Reading) mode.
The element name displays in the menu button at the top of the window, with the prefix 'Reading'. Click on the menu
button to access these options:

Option Description

Edit Document Switches the document into Edit mode and displays the Document Edit ribbon,
which provides the facilities for updating the document. If the element does not
currently have a Linked Document, you can immediately start typing in the display
panel or import a file to create a Linked Document for the element.

While in edit mode, the Document window becomes locked to the parent element,
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and selecting another element or context will not switch the window to a different
document. This helps you to move around the model, checking and gathering
information without having to close and open the document several times. Once
you quit edit mode, the window will again immediately refresh to show the
document for whichever element you select. To switch out of Edit mode, click on
the menu button and deselect the option.

Reload Refreshes the content of the displayed document from the last-saved version.

Fixed Zoom Displays a short list of magnifications (as a percentage of 'normal' size) you can
select to zoom the document display to, as well as a 'Custom' option that opens a
dialog on which you can set any magnification between 10% and 500%. The zoom
factor remains set after you close the document, and is applied when you re-open
the document until you specifically change the zoom.

Toggle Page Border Switches between full-screen display and page outline display (the default) where
the information is shown within the framework of a page border.

Find Elements with Linked
Documents

Opens the Find in Project view preloaded with an executed search for elements that
have Linked Documents; as you click on an item in the search results, the
Document window shows the corresponding Linked Document.

Find Elements with Linked
Documents Modified
Recently

Opens the Find in Project view preloaded with an executed search for elements that
have Linked Documents that have updated within the last seven days (you can
re-execute the search with a different number of days); as you click on an item in
the search results, the Document window shows the corresponding Linked
Document.

Print Displays the 'Print' dialog, which you use to configure the print job for printing the
Linked Document.
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The Element Browser

As you develop an element in your model, you can define a range of added-on properties of that element through the
appropriate dialogs, pages and tabs. It is possible to neatly summarize all of these properties for a selected element, using
the Element Browser. The properties listed - where they exist in the element - are grouped by type and include:

Operations·
Attributes·
Linked Features (Linked Operations and Attributes)·
Tagged Values·
Constraints·
Internal Requirements (Responsibilities)·
Attached Files·
Relationships·
Scenarios·
Maintenance Items (sub-grouped as Defects, Changes, Issues and Tasks)·
Testing Items (sub-grouped as Unit, Integration, System, Acceptance, Scenario and Inspection tests)·
Project Management Items (sub-grouped as Resource Allocation, Effort, Risk and Metrics records)·

Having listed these properties, you can also perform a number of operations on them, including dragging and dropping
many of them onto other elements.

Access

Ribbon Show > Window > Element Browser

Start > Explore > Element Browser

Keyboard Shortcuts Alt+9

Options

Option Action

Display element
'Properties' dialog

Double-click on the element name at the top of the dialog (the root node).

Add items of a specific
type

Right-click on the property type name and select the 'Add New <object>' option.
(This option is not applicable to Relationships or Linked Features, which cannot be
created without using information external to the selected element.)

The appropriate window or dialog displays, or the element 'Properties' dialog
displays on the appropriate page. Add new or edit existing items as necessary.

For example, if you right-click on the Attributes folder and select the 'Add New
Attributes' option, the '<element name> Features' dialog displays at the 'Attributes'
tab, and you can add to or edit the attributes in the element.

(c) Sparx Systems 2015 - 2017 Page 340 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Edit specific items Expand the appropriate folder and double-click on the required item.

The 'Properties' dialog, docked window or view displays with the focus on the
selected item. You can also go on to select and edit other items within the window
or dialog.

Drag a relationship onto a
diagram

Click on the relationship in the Element Browser and drag it onto the diagram.

If the element at one or both ends of the relationship is not already on the diagram,
those elements are also added to the diagram.

If the relationship is already on the diagram, but hidden, it becomes visible again.

Alternatively:

Right-click on the Relationships folder name and select the 'Place All Related·
Elements in Diagram' option, or

Right-click on the relationship and select the 'Place Related Elements in·
Diagram' option

Hide/Show a Relationship
in the current diagram

Right-click on the relationship in the Element Browser and select the 'Hide
Relationship' or 'Show Relationship' option, as appropriate.

Display the 'Properties'
dialog of the other element
in the relationship

Right-click on the relationship in the Element Browser and select the 'View Related
Element Properties' option.

Locate the related element
in the Project Browser

Right-click on the relationship in the Element Browser and select the 'Locate
Related Element' option.

Locate the related element
in other diagrams

Right-click on the relationship in the Element Browser and select the 'Find in all
Diagrams' option.

Open an associated file Double-click on the required file path within the Files folder.

If the file can:

Be opened within Enterprise Architect, the file opens on a separate tab in the·
Diagram View workspace

Not be opened within Enterprise Architect, the file opens in the default·
Windows viewer/editor for the file type

Display the source code for
a feature

Right-click on an attribute or operation in the Attributes or Operations folder or in
the Linked Features folder, then click on the 'View Source Code' option.

Alternatively:

Click on the attribute or operation and press Ctrl+E, or·
In the Linked Features folder, double-click on the attribute or operation·

If no code has been generated for the selected feature, nothing happens.

If code has been generated for the feature, the code is displayed. The source code
viewer in which the source code displays depends on which editor you select as the
default, either for the project as a whole or for a specific programming language; if
you select the Enterprise Architect internal editor, the code displays in the Source
Code Viewer with the cursor positioned on the selected feature.

Add a property to another
element

Click on the property in the Element Browser and drag it onto the other element in
a diagram. The properties you can do this for are:

Attributes·
Operations·
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Constraints·
Requirements·
Tagged Values·
Maintenance Items·
Test Items·

Attach a Recording Marker
to an Operation

Right-click on the operation and select the 'Visual Analyzer | Set Breakpoint'
option, and the option to set the required type of recording marker.
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Element Scenarios & Requirements

The Scenarios & Requirements window provides a convenient method of quickly adding, viewing, editing and deleting
rules applied to an element. The window shows details of the entities that impose such rules or restrictions on the
element, namely:

The element's scenarios·
The element's internal constraints (not external Constraint notes)·
The element's internal responsibilities or requirements·

Access

Ribbon Design > Element > Scenarios > Manage Scenarios

Keyboard Shortcuts Ctrl+Shift+3

Use of the window

The Scenarios & Requirements window is typically used to examine Use Case and Test Case elements, and any other
elements that realize an external Requirement.

For convenience, you can display the window as either a dockable window around the edge of your workspace, or as a
view in the center of your workspace (in which the Scenarios, Constraints and Requirements are shown on separate tabs).

Use the  icon in the window toolbar to toggle between these display options.

Review an internal requirement, constraint or scenario for an element

Step Action

1 Select the element in the Project Browser or diagram and select the Scenarios & Rules menu option.

The Scenarios & Requirements window displays.

2 Either:

Click on the required item in the list panel on the left of the window, or·

If the Element Browser is not already displayed, click on the  icon and select the required item·
from the Constraints, Requirements or Scenarios folder

The appropriate screen displays, with the details of the selected item in the fields.

3 The toolbar icons, from left to right, enable you to:

Add a new rule to the current screen (click on the appropriate folder to create an item of a different·
type)

Save the new or edited item·
Save the current (edited) item as a new item·
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Delete the current item·
Sort the contents of the selected folder into alphabetical order·
('Print' icon unavailable)·
Display the Element Browser window, or highlight the current item in the Element Browser window·
Switch between a docked window display and a workspace view display·

You can also add or edit formatted notes in the 'Notes' field, using the Notes toolbar at the top of the field.

The list panel also provides a context menu that provides options for adding a new item to a folder,
deleting the selected item or, for a requirement, converting an internal responsibility into an external
Requirement element.
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Select <Item> Dialog

The 'Select <Item>' dialog is a multi-purpose browser and search tool for locating model items such as Classifier
elements, properties, attributes and behaviors. The <Item> in the dialog title changes to represent the type of item the
original operation is working on.

The dialog is called in a range of operations; for example, setting:

The base type or classifier for an Object, Swimlane or Lifeline·
Classifiers for the return types for operations·
Classifiers for generalization sets·
The Information Item or classifier elements conveyed or realized on an Information Flow·
The associated behavior for a behavior call·
The type and return type for operation parameters·
Activities for State transitions·
Use Case Scenarios·
Pattern element defaults·
Activities from which to generate code·
The values of Tagged Values·

Multiple Selection

Where an operation permits the selection of multiple items, the 'Select <Item>' dialog is automatically enabled to support
this; to select the items, press Ctrl as you click on each item.

If you want to cancel a selected item, press Ctrl and click on the item.

Having selected an item, you can continue to expand and browse the hierarchy, and/or search for items; the dialog retains
the existing selections until you click on the OK button.

Select a required item

Step Action

1
During an operation, when it is necessary to locate an element or feature, click on the  button.

The 'Select <Item>' dialog displays.

2 If required, in the 'Go To Namespace' field select a namespace to reduce the scope of the displayed
hierarchy.

The dialog opens the section of the hierarchy associated with that namespace, and closes all
previously-open sections associated with other namespaces.

3 You can either:

Expand the selected area of the hierarchy on the 'Browse' tab, or any other Package, and locate the·
required item (go to step 5) or

Click on the 'Search' tab and, in the 'Find' field, type a partial or complete text string to search for the·
item
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4 On the 'Search' tab, you can filter the search further by selecting the 'Whole Word' and 'Match Case'
checkboxes.

Each list entry shows the name of the item, the type, any stereotype the item has, the immediate Package
in which the item is held, and any successive parent Packages (the Package path).

You can either:

Select the item immediately on the 'Search' tab or·
Right-click on one item or a group of items and select the 'Locate item(s) in tree' option; this·
redisplays the 'Browse' tab and highlights each selected item in the <namespace> hierarchy

5 Click on the required item.

6 Click on the OK button.

Notes

When you have selected an item, the Select <Item> dialog retains the context and item; next time you display the·
dialog, if the context is similar the dialog opens to the same Namespace and item - for example, if you have selected
an activity for a State transition and you start to do the same for another transition, the dialog opens to the activity
you previously selected

If the context is totally dissimilar, the dialog opens with the Namespace < any > and a collapsed model hierarchy·
If the available items do not meet your requirements, you can create a new item and define the appropriate properties·
- click on the Add New button; the appropriate Add <Item> dialog displays, on which you define the required item

The Add New button is not always available, depending on the context and the type of item being searched for·
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Select Property Dialog

The 'Select Property' dialog is a specific instance of the 'Select <Item>' dialog; it is used to select Ports, Parts, Attributes
and Association Ends as redefined or subsetted properties, from a hierarchical list of Classes and their contained
properties in the model. As an example, consider this section of the model:

Example

This would be represented in the dialog as shown:
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Locate and click on the required object to select it, then click on the OK button (to select several objects at once, press
and hold Ctrl while you click on each object).

Notes

AssociationEnds should be owned by the Class to be listed in the dialog·
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Set Feature Dialog

The 'Set Feature' dialog is the 'Set Operation' dialog used to change the operation represented by an Action on a diagram.

As the 'Set Operation' or 'Set Attribute' dialog, it is also used to set the 'Value' operation or attribute for Tagged Values of
type RefGUID or for the target of a hyperlink in a diagram.

Locate and select a value operation or attribute

Step Action

1 The 'Set Operation' (or 'Set Attribute') dialog displays, with the model hierarchy opened at the point at
which you selected the original operation or attribute.

2 If required, in the 'In Namespace' field, click on the drop-down arrow and select another model that
contains the required operation or attribute.

The Package hierarchy for that model displays.

3 Browse through the hierarchy, or use the 'Search' tab to locate the required operation or attribute, then
double-click on the item to select it.
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Element Context Menu Operations

You can perform a wide range of operations on element objects on a diagram, such as displaying an element's structural
components, displaying or hiding its features on the diagram, and changing the element's appearance. You access these
operations through the element context menu. If you are working under a technology such as SysML or BPMN, the
menu can also provide options that are specific to that technology.

Access

Context Menu Right-click on element on diagram

Element Context Menu Options

Option Action

Extensions Select this option to access a submenu of enabled Technologies on the system (for
example, ArcGIS or TOGAF), each of which provides options for performing
technology-specific operations on the element.

This option is available in the Professional, Corporate and all Extended editions of
 Enterprise Architect.

Properties Select this option to open the 'Properties' dialog for the selected element.

For State Lifeline and Value Lifeline elements, the 'Configure Timeline' dialog
displays.

For a Required Interface element, the 'Exposed Interface' dialog displays.

Shortcut: Alt+Enter

Properties Page Select this option to display a list of the common pages of the 'Properties' dialog.

Click on one of the page names to open the element 'Properties' dialog with that
page exposed.

Other Properties For State Lifeline, Value Lifeline and Required Interface elements, select this
option to display the 'Properties' dialog for the selected element.

Shortcut: Ctrl+Shift+G

Advanced Select this option to open the 'Advanced' sub-menu, which provides options for
performing more complex or specialized operations on the element.

New Child Element Select this option to attach:

One of a number of types of structural element, such as a Port, Part or Activity·
Parameter, to the selected element, or

A text element to the selected element, documenting a Note, Constraint,·
Rationale or Problem

New Child Diagram Select this option to display a submenu, listing - in order:

Individual types of child diagram (often technology-specific) that you might·
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usually create for this type of element

For classifier elements, options to create Activity, Interaction, StateMachine or·
Rule Flow elements that encompass the appropriate type of child diagram

Options for creating and displaying the child diagram for a Composite element·
An option to display the 'New Diagram' dialog to add any other type of·
diagram as the child diagram of this element

Features and Properties Select this option to add attributes and/or operations to the element, through the
'Attributes' (F9) or 'Operations' (F10) pages of the 'Features' dialog, or to override
any inherited attribute (Ctrl+Shift+R) values set on the element.

For an Object or State element you can add a new instance variable to the element
using the 'Define Run State' dialog.

For elements that can have interfaces, you can also select to show realized and/or
dependent interfaces (Ctrl+Shift+Y).

You also have the option of opening the 'Feature and Compartment Visibility'
dialog to define which features and feature properties to display on the element, and
which element compartments.

Structural Elements Select this option to display the 'Structural Elements' dialog, for managing the
structural elements (such as Provided Interfaces, Ports and Activity Parameters)
attached to the selected element.

Shortcut: Ctrl+Shift+B

Insert Related Elements Select this option to display the 'Insert Related Elements' dialog, to add elements
related to the selected element to the current diagram.

Decision Table For a selected Activity or Action element, select this option to display, set up and
edit the Decision Table for the element.

Draw as Decision Table
(Rules as Columns)

For a selected Activity or Action, replace the element shape on the diagram with its
Decision Table, showing the decision rules as columns.

The element is automatically sized to display the rule text; you cannot change the
element size manually.

Draw as Decision Table
(Rules as Rows)

For a selected Activity or Action, replace the element shape on the diagram with its
Decision Table, showing the decision rules as rows.

The element is automatically sized to display the rule text; you cannot change the
element size manually.

Draw as Activity

Draw as Action

Where an element is rendered as a Decision Table on the diagram, replace it with
the normal element shape.

Rule Composer For a Rule Task element, select this option to invoke the Rule Composer in
Business Rule Modeling.

Create (or Edit) Linked
Document

(Corporate, Business and Software Engineering, Systems Engineering and Ultimate
editions) Select this option to create a document linked to the element.

Shortcut: Ctrl+Alt+D

Delete Linked Document Select this option to delete an existing linked document for the element.

Generate Documentation Select this option to generate a range of reports and other documents on the
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element.

Shortcut: F8

Create Document to
Artifact

(On an Artifact element linked to a Report Package or Model Document element).
Select this option to generate a virtual document as the linked document of the
Artifact element.

Clear Checklist Select this option to clear any selected checkboxes in the current Checklist Artifact
element.

Info view Select this option to display a short submenu, from which you select to switch the
element between Info view display style and 'normal' UML style, and to set the
element characteristics that are shown in Info view style.

Find Select this option to display the 'Find' submenu, which provides options for:

Locating the selected element in other diagrams and in the Project Browser,·
and

Setting up cross references (Custom References) to other elements·

Appearance Select this option to display a short menu of options to change and reproduce the
appearance of the element.

Code Engineering Select this option to display a submenu showing options to:

Generate source code for the selected element (forward engineer), (Shortcut:·
F11)

Generate DDL for a Table, Procedure or View Class·
Reverse engineer source code for the selected element, (Shortcut: F7)·

You can also synchronize Class elements from the source code via the Project
Browser, and reverse engineer or forward engineer model Packages and code to
synchronize them and incorporate changes made in one but not in the other.

View source code in the source code editor, on an element for which it has·
been generated, (Shortcut: F12)

On a Class for which code has been generated, prepare the Class for Execution·
Analysis by (Shortcut: Ctrl+Shift+J):

    - Creating workbench variables from the selected Class

    - Marking up a process for the Class or

    - Marking up the Class for recording

Lock Element Select this option to lock the element so it can't be edited; to unlock the element,
select 'Lock Element' again.

This does not apply in the Corporate, Business and Software Engineering, Systems
Engineering and Ultimate editions when security is enabled; in that situation, use
the 'Lock' option for model elements.

Printable Defaults to selected, so that the element is depicted in any diagrams in reports
generated on its parent Package.

If you click on the option to deselect it, the element and its connectors will not be
visible in any diagrams in reports. You can, however, deselect a report option for an
instance of a report to force the display of non-printable elements.

Deselecting this option also hides the element and its connectors in the 'Print
Diagrams', 'Print to PDF' and 'Save Diagram as Image' operations.
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Selectable Select or deselect this option to toggle whether the element is selectable or not:

If an element is selectable, you can move it around the diagram and perform·
right-click context menu operations

If an element is unselectable, you cannot move it around the diagram and the·
only right-click operation available is to make the element selectable

This option has no effect on double-click operations on the element, such as
displaying child diagrams or 'Properties' dialogs.

An element on a locked diagram is also unselectable - if you click on it, the element
outline displays in red.

In a diagram, you can filter the display to show selectable or non-selectable
elements only.

Dockable Select this option to align and join two elements either vertically or horizontally, on
the current diagram only.

Both elements must have the 'Dockable' option selected, and must have the joining
edges parallel.

As the distance between the elements narrows, the moving element snaps to the
edge of the other element.

For Activity Partitions, the option is selected by default.

Deselecting the 'Dockable' option does not separate the elements; if necessary, you
can simply move the elements apart again.

Z-Order Select this option to display a short submenu providing options to:

Move the element further back in the diagram·
Move the element further forward in the diagram·
Put the element at the back of the diagram·
Put the element at the front of the diagram·

UML Help Select this option to display the Help topic describing the type of element you have
selected.

Delete <element name> Select this option to delete the element from the diagram. The element still exists
within the model and can be accessed from the Project Browser.

Shortcut: Ctrl+D

Notes

Context menus vary between element types; for example, the 'Code Engineering' option does not display for a Use·
Case element

If you select two or more elements at the same time, you can perform an operation on all of the selected elements at·
once; the operations available for multiple selection are provided on a separate context menu
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Advanced Operations on Elements

You can perform a wide range of more specialized functions on an element, specific to the element type and its
relationship to other modeling objects.

Access

Context Menu Right-click on element on diagram | Advanced

Advanced Options

Option Action

Instance Classifier (For an instance or Object element) Select this option to set the instance classifier
for the element, on the 'Select <Item>' dialog.

Shortcut: Ctrl+L

Parent (For a classifier element that can be generalized) Select this option to set the
element's parent.

Shortcut: Ctrl+I

Show element classifier Shows or hides the classifier names on Port elements.

Classifier Properties (For an instance or Object element) Select this option to open the 'Properties' dialog
for the classifier of the selected element.

Shortcut: Ctrl+Alt+Enter

Change to State (Value)
Lifeline

(For a State Lifeline or Value Lifeline element) Select this option to switch one
type of Lifeline element to the other.

Set Property Type (For a Part element) Select this option to browse for and select the element that
defines the Part type, using the 'Select <Item>' dialog.

Multiplicity Select this option to define the multiplicity for the element, using the format
defined on the 'Cardinality Values' tab of the 'UML Types' dialog ('Configure >
Reference Data > UML Types').

This is the number of instances of the element that can exist in a set; the value
displays on the element in a diagram, in the 'Name' compartment.

Port Size Customizable (For a Port element) Select this option to allow users to resize the Port from the
default size. If the option is not set, the element size cannot be changed.

Show Element Type (For a Port or Part element) Select this option to toggle between displaying and
hiding the element type, as set using the 'Set Property Type' option or on the
'Property' tab of the element's 'Properties' dialog.
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Set Property Values (For a Part element) Select this option to set the property value for the Part, using
the 'Set Property Values' dialog.

Shortcut: Ctrl+Shift+R

Edit Extension Points (For a Use Case element) Select this option to display the 'Use Case Extension
Points' dialog, which you use to insert the point at which the behavior should be
inserted.

Association Class (For a Class element) Select this option to connect the Class to a new Association.

Use Rectangle (Circle,
Actor) Notation

(For an element that uses non-rectangular notation) Select this option to apply
rectangle notation to the element (and switch back again).

Partition Activity (For an Activity element) Select this option to define an Activity Partition in the
element.

Set Object State (For an Object or instance element) Select this option to set the state of the element
based on the child states of its classifier.

Shortcut: Ctrl+Shift+S

Override Attribute
Initializers

(For a Class element with attributes) Select this option to pre-define initial values
for attributes that can be used to override existing defaults.

Shortcut: Ctrl+Shift+R

Convert to Instance
(Property/Invocation)

Select this option to convert a classifier to an instance, property or invocation,
depending on the type of classifier selected (for example, SysML classifiers are
always converted to properties).

Convert Linked Element
To Local Copy

Select this option to convert the occurrence of the element on the current diagram
from a link to the original element to a local copy of the element. A copy of the
element is also added to the diagram's parent Package in the Project Browser.

Make Sender/Receiver (For Send and Receive Event elements) Select this option to toggle the element
from a sender to a receiver and vice versa.

Accept Time Event (For a Receive element) Select this option to change the notation from an Accept
Event action to an Accept Time Event action.

Define Concurrent
Substates

(For a State element) Select this option to define the set of substates that can be
held simultaneously within that composite State.

Use State Label Notation (For a State object) Select this option to switch to State Label Notation (the element
name is displayed on a box on top of the element rather than inside it).

Deep History (For a History pseudo-State) Select this option to change the type of a shallow
History pseudo-state to a deep History pseudo-state.

Transform Select this option to transform the selected element from one domain to another.

Shortcut: Ctrl+H

Set Attached Links (For a Note element) Select this option to attach the element to a connector, or
several connectors on the diagram.
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Link to Connector
Constraints

(For a Note element) Select this option to display the connector type and to list the
constraints of the associated connector in the Note element.

Link to Connector Notes (For a Note element) Select this option to display or hide the text assigned to a
connector's 'Notes' field.

Link to Connector Tagged
Values

(For a Note element) Select this option to display the connector type and to list the
Tagged Values of the associated connector in the Note element.

Link to Diagram Notes (For a Note element) Select this option to display the diagram notes as the text of
the Note element.

Any current text is deleted and the Note is blocked from being edited other than
through the 'Notes' field in the diagram 'Properties' dialog.

Hide (Show) attached links (For a Memo style or Memo2 style Note element) Select this option to hide or show
the Notelink connectors to the elements to which the Note refers.

Vertical Partition (For an Activity Partition element) Select this option to switch a horizontal
Partition to a vertical Partition.

Tagged Value Select this option to add a Tagged Value to the selected element, through the
'Tagged Value' dialog. The Tagged Values window (if not already open) is also
opened so that you can do further work on the Tagged Value, such as create Notes.

Notes

Context menus vary between element types, and few of the menu options shown here are present on all element·
context menus; 'Tagged Value' is often the only option available

If an element appearance is overridden by a Shape Script, several of the appearance options are disabled; for·
example, 'Use Rectangle (Circle) Notation'
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Finding Elements

When you have selected an element on a diagram, you might want to find out where it is held in the model structure,
where else it is used in the model, and how to locate it easily in the future. For these operations, you can select the Find
submenu.

Access

Ribbon Design > Element > Manage > Find in Diagrams

Design > Element > Manage > Find in Project Browser

Context Menu Right-click on element | Find

(see Find Options for a description of the sub-menu).

Keyboard Shortcuts Alt+G   (find in Project Browser)

Ctrl+U   (find in all Diagrams)

Find Options

When 'Find' is selected from the context menu, a sub-menu is displayed, providing options as described here.

Option Action

Locate in State Table

Locate in State Chart

For a State element, select this option to switch to the alternative diagram display
format and highlight the element.

In Project Browser Select this option to highlight the currently selected element in the Project Browser.

Shortcut: Alt+G

Locate Classifier In Project
Browser

For an instance or Object, select this option to highlight the classifier for that
element in the Project Browser.

Shortcut: Ctrl+Alt+G

Locate Operation in Project
Browser

For an Action element, select this option to highlight the call operation for that
element in the Project Browser.

Shortcut: Ctrl+Alt+G

Find in all Diagrams Select this option to list the other diagrams in which the element is also used, on the
'Element Usage' dialog.

Shortcut: Ctrl+U

Custom References Select this option to identify and, if necessary, open the 'Properties' dialog for any
elements that are the target of a cross reference from the selected element.

Shortcut: Ctrl+J

Add to Favorites Select this option to add the selected element to the Favorites folder in the
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Resources window.
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Changing Element Appearance

If you want to modify the appearance of a specific element on a diagram, you can use a range of facilities available
through the element context menu on the diagram.

Some of these facilities are also available via the Layout ribbon's Style panel, or through the Format toolbar.

Access

Ribbon Layout > Style (changes the appearance of the selected element on the current
diagram only)

Context Menu Right-click on the element on the diagram and select the 'Appearance' option; this
displays the 'Element Appearance' sub-menu, described here.

Keyboard Shortcuts F4 (displays the 'Default Appearance' dialog, described here)

Other Right-click on element on diagram - the Format toolbar is displayed above the
context menu

(changes the appearance of the selected element on the current diagram only)

Element Appearance Options

Option Action

Default Appearance Click on this option to override the global default appearance of all elements
(which you set on the 'Standard Colors' and 'Diagram Appearance' pages of the
'Preferences' dialog) with a different default for just the selected element on all
diagrams in which it is used.

To change the appearance of the selected element on the current diagram only, use
the Format toolbar.

Shortcut: F4

Apply Image From
Clipboard

Click on this option to paste the image held on the clipboard onto the selected
element, as an alternative image.

This image is added to the Image Library under an automatically-assigned name.
The image can be accessed from and renamed in the Image Manager.

Select Default Image Click on this option to change the element's appearance to an alternative image,
using the Image Manager.

This appearance applies to the element on all diagrams in which it is used.

Select Alternate Image Click on this option to change the element's appearance to an alternative image,
using the Image Manager.

This appearance applies to the element on the current diagram only.

Shortcut: Ctrl+Shift+W
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Hide/Show Name Under
Image

For an element that has an alternative image, click on this option to hide or
redisplay the name label under the element.

Set Font Click on this option to change the font type, size, color and effects for the text in
the element.

Diagram Frame
Appearance

For Diagram Frame elements; click on this option to set the appearance of the
frame.

Show Labels For embedded elements, or those with an alternate image that show element
properties as labels; click on this option to reveal the hidden labels on the element.

(The option is not listed if there are no hidden labels.)

Standard Memo

Memo (Style 2)

Pin

Sticky

Paperclip

For a Note element, click on one of these options to apply the corresponding image
to the element.

Copy Appearance to
Painter

Click on this option to copy the default element appearance (set using the 'Default
Appearance' option) to the painter.

You then paste the default appearance using the 'Paste Appearance' option on the
Diagram toolbar.

Copy Image to Clipboard Click on this option to copy the element image to the clipboard. You can use the
'Apply Image from Clipboard' option to recover and use the image elsewhere.

Notes

You can also change the appearance (and other aspects) of several selected elements at once·
Context menus vary between element types, and not all menu options shown here are present on all element context·
menus; for example, the 'Select Alternate Image' option does not display for a Lifeline element
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Operations on Multiple Elements

It is possible to perform various operations on two or more elements on a diagram at once, either to add the same feature
or to standardize the size or orientation of the selected elements. This makes it much faster to update the diagram than if
you had to modify each element separately.

To select the required elements, either click and drag the cursor over the group to highlight them, or press Ctrl as you
click on each element separately.

The selected element that is drawn with a hatched border is the context element. The context element is used as the
'master' element when aligning or resizing elements as a set.

Access

Select a set of elements on a diagram, then right-click on one of the selected elements to display a context menu (for
format/layout operations, right-click on the element against which to standardize the others - this sets the clicked element
as the context element).

The 'Layout' ribbon's 'Style' panel also provides options for changing appearance related properties for a set of selected
elements, while the 'Alignment' panel provides numerous options for aligning and resizing elements.

Ribbon Layout > Style (changes the appearance of the selected elements on the current
diagram only)

Layout > Alignment (changes the size or position of the selected elements on the
current diagram only)

Context Menu Right-click on a selected element on a diagram. The context menu for multiple
selections displays; this is described here.

Keyboard Shortcuts F4 (displays the 'Default Appearance' dialog, described here)

Other Right-click on a selected element on diagram - the Format toolbar is displayed
above the context menu

(changes the appearance of the selected elements on the current diagram only)

Options

Option Detail

Extensions Select this option to access a submenu of enabled Technologies on the system (for
example, ArcGIS or TOGAF), each of which provides options for performing
technology-specific operations on the elements.

This option is available in the Professional, Corporate and Extended editions of
 Enterprise Architect.

Align Select one of these options to align elements against the 'master' element's:

left edge·
right edge·
top edge·
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bottom edge·
center, vertically or·
center, horizontally·

You can also edge-align groups of elements using the Diagram Toolbar; the four
alignment buttons are made available when more than one element is selected in a
diagram.

Shortcut:

Ctrl+Alt+Left Arrow

Ctrl+Alt+Right Arrow

Ctrl+Alt+Up Arrow

Ctrl+Alt+Down Arrow

Space Evenly (For three or more selected elements.) Select this option to automatically even out
the spacing between the selected elements, either horizontally or vertically.

Shortcut: Alt+-   Alt+=

Same Height/Width Select one of these options to make all the selected elements match the 'master'
element's height or width, or both.

In Use Case diagrams, these options are blocked if the 'Allow Elongated Use Cases'
option is turned off on the 'Preferences' dialog 'Objects' page.

Feature and Compartment
Visibility

Select this option to define the visibility of features and compartments on all
selected elements.

Shortcut: Ctrl+Shift+Y

Add Tagged Value Select this option to add the same Tagged Value to all selected elements.

Autosize Select this option to automatically resize the selected elements to their default
minimum size (element content permitting).

Shortcut: Alt+Z

Appearance Select this option to set the same default appearance and font for all of the selected
elements at once.

Shortcut: F4

Info view Select this option to display a short submenu, from which you select to switch the
selected elements between Info view display style and 'normal' UML style, and to
set the element characteristics that are shown in Info view style.

Clear Checklist Select this option to clear the checkboxes in all of the selected Checklist Artifact
elements.

Make Non-Selectable Select this option to make the selected elements on the diagram non-selectable.

To make the elements selectable again, either:

Right-click on individual elements and click on the 'Selectable' option, or·
Right-click on the diagram background and select the 'Make All Elements·
Selectable' option

Printable Defaults to selected, so that the selected elements are depicted in any diagrams in
reports generated on their parent Package(s).

If you click on the option to deselect it, the elements will not be visible in any
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diagrams in reports. You can, however, deselect a report option for a report to force
the display of the non-printable elements.

Deselecting this option also hides the element and its connectors in the 'Print
Diagrams', 'Print to PDF' and 'Save Diagram as Image' operations.

Dockable Select this option to turn the 'Docking' feature on or off for the selected elements.
When two elements are dockable, they can be moved together to automatically join
along their common edge.

Code Generation (For Class elements) Select this option to either:

Generate code for the selected elements together, or·
Synchronize code and model for each of the selected elements·

Shortcut: Shift+F11   Ctrl+R

Transform Select this option to transform the selected elements using a transformation
template in a single operation.

Shortcut: Ctrl+H

Generate Documentation Select this option to generate a single document report on the selected elements.

(Do not, in this instance, use the F8 key.)

Copy Select this option to copy the selected elements to the clipboard.

Layout Selected Elements Select this option to automatically adjust the layout of the selected elements on the
diagram.

Delete Selected Elements Select this option to delete the selected elements from the diagram only.

Shortcut: Ctrl+D
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Notes

Notes are textual descriptions that can be added to an element, diagram, feature or connector in Enterprise Architect.
They provide valuable information that describes the entity being modeled. Many newcomers to modeling are not aware
that these textual descriptions are core to many of the modeling languages including UML, BPMN and SysML; without
them the model will be hard to understand and remain opaque. A well-formed note is unambiguous and doesn’t contain
redundant information that has been entered in other properties of the entity.

The notes can be formatted using the Notes Toolbar, conveniently located above the 'Notes' field. This formatting can be
carried through to documentation generated from the model and includes such markup as italics, bolding, bullets and
hyperlinks. Glossary Terms and model elements can also be referenced from the 'Notes' field. There are also convenient
keyboard shortcuts available for quick editing in the 'Notes' field.

Notes can be accessed in the Notes Window, which can be docked anywhere in the application, or through the
'Properties' dialog for an element, feature, connector or diagram. Many experienced modelers have the Notes window
visible and when they select an entity in a diagram, the Project Browser or another window they can view, create or edit
these textual descriptions.

Access

Ribbon Show > Window > Notes

Start > Windows > Notes

Context Menu Right-click on model entity | Properties    (displays 'Notes' field in 'Properties'
dialog)

Keyboard Shortcuts Ctrl+Shift+1

Notes Context Menu options

Option Action

Create | Glossary
Definition

Click on this option to create a Project Glossary definition, with the Glossary term
taken from the selected 'Notes' text.

To create the Glossary entry:

If suitable Notes text is available, highlight the text to use as the Glossary1.
definition and press Ctrl+C to copy it.

Highlight the text to use as the Glossary term, right-click on it and select the2.
menu option; the 'Glossary Detail' dialog displays, with the selected text in the
'Term' field.

If you have copied some definition text, paste it into the 'Meaning' field;3.
otherwise type a suitable definition of the term in this field.

In the 'Type' field, select the appropriate term type.4.

Click on the Apply button to save the new Glossary definition.5.

The term displays in the 'Notes' text as a Ctrl+click hyperlink, which displays the
Glossary definition of the term in the 'Glossary Detail' dialog.

Once you have created a Glossary definition, here or elsewhere in the model, you
can add the Glossary term anywhere in the text of the Notes window (or 'Notes'
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field of a dialog) where, again, it becomes a Ctrl+click hyperlink to the definition.
Either:

Simply type the term in the text, or·
If you are not certain of the term or have multiple definitions:·
Move the cursor to the point in the text at which to insert the term.1.

Press Ctrl+Space; the Glossary Term Selection window displays.2.

Double-click on the term to insert it in the text.3.

Create | New Element from
Selection

Click on this option to create a new element in the model, the name of which is
taken from the selected Notes text.

Click on the option.1.

The 'New Element' dialog displays, with the 'Name' field pre-filled with the2.
selected text.

Set the element type and other options as necessary, then click on the Create3.
button. (You can also select an option on the dialog to add the element to the
diagram.)

The system creates the element, adds it to the model (and diagram) and creates4.
a hyperlink to it from the selected Notes text.

Create | Element on
Diagram

Click on this option to create a new element in the model, and explicitly in the
diagram also, with its name taken from the selected Notes text. This option does not
make the selected text a hyperlink to the element.

Click on the option.1.

The 'Toolbox Shortcut' menu displays for the diagram type. If necessary, click2.
on the 'Other' option and select from a different set of element types.

Click on the required element type and then click on the diagram. A new3.
element is created at the cursor position, with the selected text as the element
name.

Create | Link to existing
element

Click on this option to create a hyperlink from the selected Notes text to an existing
element in the model.

Click on the option.1.

The 'Select Classifier' dialog displays. Locate and select the required element,2.
and click on the OK button.

The selected Notes text becomes a hyperlink to the element. The target element3.
name and Notes text remain unchanged and do not necessarily mirror each
other.

Search for <'selected'> Click on this option to display a subset of the functions of the common Code Editor
menu 'Search' option, to locate a text string outside the element.

In a 'Notes' field (not in the Notes window) you can perform a search of the text for
a text string:

Press Ctrl+F and specify the text string and the direction of search·
Press F3 to locate more instances of the word in a forward search, or Ctrl+F3·
in a backwards search

Undo

Cut

Copy

Paste

These six options provide simple functions for editing the Notes text.
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Delete

Select All

Keyboard Options For Notes

Option Description

Switch text orientation Hold Ctrl, press Shift

Description: On a line of text, right-justifies or left-justifies the paragraph in which
that line occurs.

Use the keys on the left of the alphanumeric keyboard to left-justify the text; use
the keys on the right of the keyboard to right-justify the text.

Insert Date and Time F5

Description: Inserts the current date and time at the cursor position, in the format:

    DD/MM/YYYY HH:MM:SS AM (or PM)

For example:

    22/12/2016 3:39:50 PM

Spell check Notes text F7

Description: Performs a simple spell check on the Notes text.

Undo changes Ctrl+Z

Description: Reverses the last change made to the Notes text.

Redo changes Ctrl+Y or

Ctrl+Shift+Z

Description: Re-applies the last reversed change to the Notes text.

Copy Ctrl+C

Description: Copies a highlighted Notes text string to the Enterprise Architect
buffer.

Paste Ctrl+V

Description: Pastes a copied or cut text string from the Enterprise Architect buffer
into the Notes text.

Cut  Ctrl+X

Description: Removes a highlighted Notes text string and places it in the Enterprise
Architect buffer.
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Notes Toolbar

Although it is not an independent toolbar that you can pin to the screen top or sides, or float in your work area, the Notes
toolbar appears in many places across Enterprise Architect in the 'Notes', 'Description' and 'History' fields in, for
example, the:

Element and connector 'Properties' dialogs·
Features 'Properties' dialog·
Diagram 'Properties' dialog·
'Hyperlink Details' dialog·
Testing window descriptions·
Notes window·
'Glossary Detail' dialog·
'Assigned Resources' dialog·
Project Management windows·
Scenarios & Requirements window·

Options

The options of this toolbar operate on selected text and any new text continuing from the formatting. The options (with
some keyboard shortcuts) are, from left to right:

Make text bold (Ctrl+B)·
Make text italic (Ctrl+I)·
Underline text   (Ctrl+U)·
Change the font color of the text·
Insert list bullet points (Ctrl+.) (full stop)·
Insert list numbering (Ctrl+1)·
Make text superscript·
Make text subscript·
Insert a hyperlink - this displays the 'Hyperlink Details' dialog, on which you specify the type of hyperlink and type·
in or browse for the location of the target of the hyperlink

Create a new linked document for the element, or edit an existing one·

Notes

If the toolbar is displayed but grayed out, the text field is read-only and cannot be edited; other long text fields in·
Enterprise Architect might not have the toolbar, in which case the Notes facility is not available for those fields

For any Notes text that is displayed on a diagram, you must select the 'Render Formatted Notes' checkbox on the·
'Feature and Compartment Visibility' dialog in order to reproduce the formatting

You can create a Project Glossary term and definition from text in any field that has the Notes toolbar·
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Linked Documents

When you are developing elements in your model, you might want to provide extensive documentation on an element, to
provide more structured text than you can create in the element 'Notes' field. In this case, you can create a formatted
document that is linked to the element. You can create a linked document from scratch, or from one of a range of Linked
Document Templates that you define with the Linked Document Template Editor. The linked documents are held within
the model.

Working with Linked Documents

Task Detail

Create linked documents You can create a linked document either:

Within a Document Artifact element attached to your model element, or·
Directly on the model element·

The advantages of using a Document Artifact to host the linked document include:

Visibility of the Document Artifact and hence linked document in the Project·
Browser

As you can only have one linked document in an element, hosting each of·
several documents in its own Document Artifact and connecting the several
Document Artifacts to one model element means that you have broader scope
for providing information

Similarly, associating several elements with one document by connecting them·
to the host Document Artifact element means that you can share information
rather than duplicating it

The advantages of using a linked document directly on an element include:

More tightly binding the content of the document to the element, so there is·
less ambiguity in what the information refers to

More tightly binding the document itself to the element, so there is less risk of·
the document being changed, moved or deleted without reference to the
element it belongs to

Create linked document
templates

You can base your linked document on one of a range of system-provided
templates, each of which represents a project document type.

You can also create and use your own linked document templates in the Resources
window, within the Document Generation > Linked Document Templates folder.

Edit linked documents You can define the style, format and layout of your linked document both in the
template from which you create the document and in the document itself. You can
edit the Linked Document from a selected element in either the Document Editor or
the Document Window.

Create hyperlinks in linked
documents

Linked documents are intimately associated with specific elements, but you can
also create hyperlinks in the document directly to other elements in the model.
Having followed the link, you can perform any normal operation on that element.

Similarly, you can create new elements or diagrams to link to.

You can also create hyperlinks to other forms of documentation.

Include linked documents
in RTF reports

Linked documents, however they are created, are rendered into document reports
when you select the Linked Document checkbox in the Document Template
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Designer.

Locate Linked Documents In diagrams, any element that has a linked document is marked with an A symbol in
the bottom right corner.

You can also use the Model Search facility to search for elements that have linked
documents, by creating a custom search containing this SQL Query:

SELECT ea_guid AS CLASSGUID, Object_Type AS CLASSTYPE, Name AS
Object, Object_Type AS [Type], Stereotype, Author, Scope, Status, Phase,
CreatedDate, ModifiedDate

FROM t_object

WHERE t_object.Style LIKE '#WC#MDoc=1#WC#'

Delete linked documents You can completely remove a linked document from an element, or you can remove
the contents of the document and replace them with the contents of an external file.

Notes

You can create a Document Artifact element to contain a linked document in all editions of Enterprise Architect·
You can create and link a document to any UML element in the model, in the Professional, Corporate, Business and·
Software Engineering, Systems Engineering and Ultimate editions of Enterprise Architect

You can work on linked documents through the Automation Interface, using the methods GetLinkedDocument(),·
DeleteLinkedDocument(), SaveLinkedDocument(string Filename) and LoadLinkedDocument(string Filename)
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Create Document Artifact

You can create a Document Artifact element to host a linked document for another model element. You can either create
an appropriate connector between the Document Artifact and the documented element (to indicate how the document
impacts the element), or drag the Document Artifact over the model element on the diagram or in the Project Browser so
that it becomes a child of the model element.

Create a linked document in a Document Artifact

Step Action

1 Open the diagram containing the element for which to create the linked document.

2 Open the Common page of the Diagram Toolbox.

Drag and drop the Document Artifact element icon from the Toolbox into your diagram.

3 Double-click on the Document Artifact element.

A default blank-page document opens in the Linked Document Editor, based on the Normal.rtf style
template.

4 Apply a template and/or continue to develop the linked document as described in Create Linked
Document On UML Element, from step 2 onwards.

Notes

There is a limit of one linked document per Document Artifact element, but you can provide more than one linked·
document for a model element by linking it to more than one Document Artifact

This operation is available in all editions of Enterprise Architect; it is the sole method of creating a linked document·
in the Desktop edition

When you have saved the document, an A symbol displays in the bottom right corner of the element·
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Create Linked Document on an Element

If you need to provide more extensive and structured documentation on an element, you can develop this as a formatted
document directly linked to the element. You can develop the document from a blank page or using a system template or
user-defined template, at several different points in the work area.

Access

Select an element in the Project Browser, Diagram List, Package Browser, Specification Manager, Model Search or
diagram, then use any of the methods outlined here to open the Linked Document window.

Ribbon Show > Window > Document

Start > Windows > Document

Design > Element > Manage > Edit Linked Document

Context Menu Right-click | (Create) Linked Document

Keyboard Shortcuts Ctrl+Alt+D

Create a linked document

Step Action

1 A default blank-page document opens in the Linked Document Editor, based on the Normal.rtf style
template.

The 'New Linked Document from Template' dialog might display, depending on whether you have
previously selected the 'Show this dialog on document creation' checkbox. In this case, go to step 3.

2 If you do not want to apply a system template or user-defined template, go to step 6.

If you do want to base the document on a selected template, click on the  icon in the editor toolbar.  A
prompt displays for you to confirm that you are clearing the current document; click on the OK button.

The 'New Linked Document from Template' dialog displays.

3 In the 'Template' field, click on the drop-down arrow and select the template from which to create the
document.  

This can be either a system-supplied template or a template that you have previously created yourself.

4 If you want to display the 'New Linked Document from Template' dialog by default whenever you start to
create a linked document, select the' Show this dialog on document creation' checkbox.

If you no longer want to display the dialog by default, deselect the checkbox.

5 Click on the OK button.

The new linked document opens in the Linked Document Editor. If you have based the document on a
selected template, the document shows the content applied by the template.
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6 Enter and format the text of the document, using the facilities of the Linked Document Editor.

Notes

You can create only one linked document on an element; if you need to create more, develop each document within·
its own Document Artifact element and link these to the model element

This operation is available in the Professional, Corporate, Business and Software Engineering, System Engineering·
and Ultimate editions

When you have saved the document, an A symbol displays in the bottom right corner of the element·
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Edit Linked Documents

To develop the contents of a linked document, you use the Linked Document Editor. This provides a frame for working
on the document, using a wide range of convenient features from the Document Edit Ribbon. These features help you in
formatting and editing the document, and adding links from and references to the content of the document. Some editor
facilities are duplicated in a right-click context menu for convenience.

Access

Select an element in the Project Browser, Diagram List, Package Browser, Specification Manager, Model Search or
diagram, then use any of the methods outlined here to open the Linked Document.

Ribbon Show > Window > Document

Start > Windows > Document

Design > Element > Manage > Edit Linked Document

Context Menu Right-click | (Edit) Linked Document

Keyboard Shortcuts Ctrl+Alt+D

Other From the Notes window or from the 'Notes' field of the element 'Properties' dialog,

click on the  icon on the Notes toolbar.

Option Descriptions

The Linked Document Editor option descriptions are grouped according to the actions you are performing.

Action

Creating and importing documents

Configuring the editor page display and formatting tools shown

Incorporating stylesheets, special texts and Tables of Contents

Managing the base styles in the Normal.rtf style template file

Moving through, searching and selecting text

Formatting characters and text strings

Formatting paragraphs and text blocks

Inserting tab points

Inserting sections, columns and page breaks, and repaginating

Inserting and editing page headers and footers, and footnotes and endnotes
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Inserting tables

Inserting hyperlinks

Inserting images, OLE objects, frames and drawing objects

Printer setup and printing documents

Checking spelling and use of words

Tracking, accepting and rejecting changes to text

Protecting document text from accidental change

Create and refer to definitions of Glossary terms in the Project Glossary (using the 'Create | Glossary Definition'
menu option)

Notes

Throughout your document editing:·
    - To undo one or more immediately previous edits, press Ctrl+Z, or select the 'Undo' context menu option; you
can still undo a change
       even after you have saved the change
    - To redo one or more immediately previous undone edits, press Ctrl+Y, or select the 'Redo' context menu option
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Replace or Delete Linked Documents

If a Linked Document is out of date you can edit the text, or you can:

Delete the content and replace it from another file, or·
Delete the document altogether·

Replace the document content

Step Action

1 Either:

Right-click on the element and select the 'Edit Linked Document' menu option, or·
Click on the element and press Ctrl+Alt+D·

The linked document opens in the 'Linked Document Editor'.

2 Click in the body of the document and press Ctrl+A to select all the document text.

3 Press the Delete key.

4 Select the 'File > Import File' ribbon option.

The Windows 'Open' dialog displays, in which you can browse for the file to import into the document.

5 Click on the Save icon in the Linked Document Editor toolbar.

Delete the linked document

Step Action

1 Right-click on the element in the Project Browser or diagram, and select the 'Delete Linked Document'
option.

2 A prompt displays for you to confirm the deletion; click on the Yes button.
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Create Linked Document Templates

To create a linked document, you can open an empty file and add the text and contents as you want. You can also base
your linked document on a linked document template that you either:

Select from a drop-down list of (initially) system-provided templates in the 'New Linked Document from Template'·
dialog or

Create in the 'Linked Document Templates' folder of the Resources window·
Linked document templates that you create are added to the drop-down list on the 'New Linked Document from
Template' dialog.

Access

Open the 'New Document Template' dialog using any of the methods outlined here.

When opened using one of these methods, the 'Template Type' field is set to 'Linked Document Template'.

Ribbon Start > Explore > Resources > 'Linked Document Templates' folder > right-click on
a <template group> folder > Create Template

Show > Window > Resources > 'Linked Document Templates' folder > right-click
on a <template group> folder > Create Template

Create a template

On the 'New Document Template' dialog:

Step Detail

1 In the 'New template' field, type a name for your template.

2 In the 'Copy template' field, if you want to base the new template on an existing template, click on the
drop-down arrow and select the name of the source template.

Otherwise leave the field set to 'None'.

3 Click on the OK button.

The template opens in the Linked Document Template Editor in the Diagram View. Create and edit the
template contents as you need.

4
Save the template (File > Save) and close the editor (  in the top right corner of the editor window).
The template is immediately available for use.

5 If you want to assign your template to another group, right-click on the template name in the Resources
window and select the 'Move' option.

The 'Enter the Linked Document Template Group name' dialog displays. In the 'Enter Value' field type a
new or existing category name and click on the OK button.

The template is immediately transferred to the named group.
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Notes

You can transport customized linked document templates between models, using the 'Configure > Model > Transfer·
> Export Reference Data' and 'Import Reference Data' ribbon options
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Edit Linked Document Templates

To develop the contents of a linked document template, held in the Resources window, you use the Linked Document
Template Editor. This opens the Document - Edit ribbon, which provides access to a wide range of convenient features
for formatting and editing the template, and for adding links from and references to the content of the documents
generated from the template. An in-text context menu also provides editing options for the template.

Access

Within the Resources window, click on 'Linked Document Templates > (template group) > Right-click on template name
| Open'

Ribbon Start > Explore > Resources

Show > Window > Resources

Option Descriptions

The Linked Document Template Editor option descriptions are grouped according to the actions you are performing.

Actions

Creating and importing template documents

Configuring the editor display

Incorporating stylesheets, special texts and Tables of Contents

Managing the base styles in the Normal.rtf style template file

Moving through, searching and selecting text

Formatting characters and text strings

Formatting paragraphs and text blocks

Inserting tab points

Inserting sections, columns and page breaks, and repaginating

Inserting and editing page headers and footers, and footnotes and endnotes

Inserting tables

Inserting hyperlinks

Checking spelling and use of terms

Tracking, accepting and rejecting changes to text
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Protecting template text from accidental change

Inserting images, OLE objects, frames and drawing objects

Printer setup and printing documents

Notes

Throughout your template editing:·
    - To undo one or more immediately previous edits, press Ctrl+Z, or select the 'Undo' context menu option; you
can still undo a
       change even after you have saved the change
    - To redo one or more immediately previous undone edits, press Ctrl+Y, or select the 'Redo' menu option
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Hyperlink From Linked Document

Within the text of your linked document, you can create hyperlinks to other elements in the model, and to web pages,
Help files, Model Searches and Team Review Forums. When you next open the linked document, you can double-click
on the hyperlink to open the linked files or to locate and highlight the object in the Project Browser. You can perform all
normal operations on the object, including opening any linked document that element might have.

Create hyperlinks

Task Action

Create Hyperlinks to
elements

Click on the element in the Project Browser and drag it into the linked document to
the position at which to create the hyperlink. The 'Linked Document Editor'
automatically creates the hyperlink, using the object name as the hyperlink text.
You can edit this text if you prefer.

Alternatively:

Highlight the link text in the linked document, right-click on it and select the
'Create | Link to Existing Element' option. The 'Select Classifier' dialog displays,
through which you browse for and select the element to link to.

Create hyperlinks to other
documents

Highlight the appropriate text and select the 'Create | Hyperlink' context menu
option.

The 'Hyperlink Details' dialog displays, through which you specify the type of
document to link to, and its location. When specifying the object location, you can
use full paths or local (path substitution) paths.

In some cases you might not want to have normal text as the hyperlink, but the text
of the link itself. In this case, do not highlight any text or, in the 'Hyperlink Details'
dialog, type any link text in. The system then inserts the address path as the link
text.
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Create Element From Document

Whilst you can set up hyperlinks from the linked document to existing elements and diagrams in the Project Browser,
you can also create new elements to illustrate and support information written in the linked document. You can create
and link to any type of element or diagram, but the facility has specific options for these element types:

Class·
Requirement·
Issue·

The element or diagram is created in the same Package as the element for which the linked document was created. A
hyperlink is automatically created in the document to the new object. When you click on the hyperlink, the element or
diagram is highlighted in the Project Browser.

Create element or diagram

Step Action

1 Open the linked document in the model element or Document Artifact element.

2 Enter or select the appropriate text to act as the hyperlink text (such as the element or diagram name).

Highlight this text and right-click on it; the 'Editor' context menu displays.

3 Select the 'Create | New' menu option, and one of the submenu options. If you select the:

'Class', 'Requirement' or 'Issue' option, the corresponding element is immediately created in the·
Project Browser

'Other' option, the 'New Element' dialog displays; specify the element type and - if appropriate -·
stereotype, and click on the Create button

'Diagram' option, the 'New Diagram' dialog displays; specify the diagram type and click on the OK·
button

4 The highlighted text is now a hyperlink to the new object in the Project Browser. Click on the link to
highlight the object.

You can now edit or expand the element or diagram as required.
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Connectors

Connectors link elements together, and are typically represented as lines on diagrams showing how the elements relate to
each other. Making a comparison to natural languages, if the elements are nouns the Connectors are verbs that describe
how the nouns relate to each other.

The connector types are defined by the modeling languages or profiles they belong to; for example, Associations and
Generalizations are part of the grammar of UML, Sequence Flows and Message Flows are part of the grammar of
BPMN, and Allocates and Item Flows are part of the grammar of SysML. Each connector type has a notation that helps
modelers recognize the connector and understand its purpose; the types also inform tools such as the Code Templates
Framework how to generate resulting models, schemas or programming code.

Connectors can be viewed in a wide range of windows, such as the Relationships Window, the Hierarchy Window, the
Relationship Matrix, the Element Browser and the 'Properties' dialog of elements.
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Connector Management Options

If you right-click on a connector in a diagram, one of two connector context menus can display. This provides quick
access to some important functions.

Menus

Menu Description

Context Menu The menu is split into up to seven distinct sections:

Extensions - displays in the first section only if you have Add-Ins installed and·
registered

Properties, including Advanced features·
Type Specific·
Style and Appearance·
Position·
UML Help - Displays the Enterprise Architect Help topic for this connector·
type

Delete - delete the connector with this option·

Connector Role Context
Menu

For connectors with Roles, right-clicking a connector within 60 pixels of an end
point displays a role-specific context menu that offers three additional menu
options:

'Source/Target Role...' - opens the connector specification dialog with the·
respective role page selected

'Multiplicity' - opens a submenu through which you can set the multiplicity for·
the role

'Link to Element Feature' - displays a dialog through which you can attach the·
end of the connector to a specific attribute or operation

Notes

Context menus vary slightly between connector types, and not all menu options are present on all connector context·
menus; the type-specific menu options are not always included
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Connector Type-Specific Options

The 'Type-Specific' section of the connector context menu is specific to the object, and only appears for a few different
connectors. Some examples are described here.

Connector Options

Connector Menu Option

Transition Locate in State Table

Action: Switch a StateMachine diagram to a State Table, with the selected
Transition cell highlighted on the table.

Transition Message

Action: Set the value of the Message.

Transition Find Triggers Associated

Action: Identify hidden triggers, and locate a trigger in the Project Browser; if
there:

Is one trigger, it is immediately highlighted in the Project Browser·
Are two or more triggers the 'Element Usage' dialog displays, listing the·
triggers; double-click on the required trigger to highlight it in the Project
Browser

Transition Queue Triggers in Simulation

Action: (Available when a simulation is being executed.)

Adds the Trigger to the end of the list in the 'Simulation Events' tab of the
Breakpoints & Events window, without signalling it.

Transition Signal Triggers in Simulation

Action: (Available when a simulation is being executed.)

Adds the Trigger to the 'Simulation Events' tab of the Breakpoints & Events
window and signals it at the current step of the simulation, leaving it with the status
signalled.

Association Find Association Class

Action: Locate and highlight the Association Class element in the Project Browser.

Aggregation Set Aggregation to Composite

Action: Change the Aggregation to Composite.

Aggregation Set Aggregation to Shared

Action: Set the Aggregation to shared; this appears after Set Aggregation to
Composite has been selected.

InformationFlow Find Items Conveyed

Action: (Listed only if there are Information Items on the connector.)

Locate the Information Item in the Project Browser; if there:
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Is one item, it is immediately highlighted in the Project Browser·
Are two or more items the 'Element Usage' dialog displays, listing the items;·
double-click on the required item to highlight it in the Project Browser

Notes

Context menus vary slightly between connector types, and not all menu options are present on all connector context·
menus; the type-specific menu options are not always included
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Manage Connector Properties

The 'Properties' section of the connector context menu provides a small set of options.

Menu options

Option Action

<Connector type>
Properties

Open the Properties window for the selected connector.

Advanced Display the Advanced menu.

Attach Note or Constraint Attach a note or constraint to the connector.

Notes

Context menus vary slightly between connector types, and not all menu options are present on all connector context·
menus; the type-specific menu options are not always included
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Advanced Connector Management Options

The 'Advanced' section of the connector context menu provides a number of options.

Menu Options

Option Action

Set Source and Target Change the source and/or target of the connector.

Change Type Change the connector type.

Change Direction Keep the ends of the connector the same but change the direction setting. There are
four options:

Unspecified·
Source -> Destination·
Destination -> Source·
Bi-Directional·

Reverse Direction Reverse the ends of the connector; for example, if the connector is an arrow, the
arrowhead swaps to the other end.

This command maintains the direction of the connector (such as Source ->
Destination).

Specialize Associations Specify how the properties of this Association specialize the properties of other
Associations.

Information Items
Conveyed

Add information items to an Information Flow connector.

Information Flows
Realized

Realize any information items conveyed on an Information Flow connector
between two elements.

Dependency Stereotypes Select a stereotype for the Dependency (or Trace, Role Binding, Occurrence or
Represents connector).

Extension Points On an Extend connector between two Use Cases, provides options to:

Specify which Extension Point (if any) in the target Use Case the connector·
and its source Use Case relate to

Show or hide the Note element that identifies the defined Extension Point·

Notes

Context menus vary slightly between connector types, and not all menu options are present on all connector context·
menus; the type-specific menu options are not always included
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Connector Style Options

The' Style' section of the connector context menu provides a number of options.

Style Options

Option Action

Line Style Set the connector line style; the options are:

Direct·
Auto Routing·
Custom Line·
Bezier (not on all diagram types)·
Tree Style Horizontal or Tree Style Vertical·
Lateral Horizontal or Lateral Vertical·
Orthogonal (with Square or Rounded corners)·

Apply Line Style on
Diagram

Apply the line style of the selected connector to all other connectors on the diagram
of the same:

Type·
Subtype (including Type) or·
Stereotype (including Type and Subtype)·

This helps you apply a style change to one connector to many other connectors on
the diagram, in one go.

On this section of a diagram there are six connectors.
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All connectors except a are Aggregation connectors (a is an Association)·
Connectors b and c are the subtype 'weak' Aggregations; connectors d, e and f·
are 'strong' Aggregations

All connectors are Direct line style·
Connectors b, d and f have the stereotype <<navigate>>·

Suppose you change connector d to the line style Orthogonal Rounded.

If you right-click on connector d and select the 'Connectors of the same Type'
option, you should see these changes to the connectors (all connectors, being
Aggregations, are now Orthogonal Rounded style except for a, which is not the
same type as the others):
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OR, if you right-click on connector d and select the 'Connectors of the same
SubType' option, you should see these changes to the connectors (only connectors e
and f change because only those two are the same type and subtype as d, being
strong Aggregations):
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OR, if you right-click on Connector d and select the 'Connectors of the same
Stereotype' option, you should see these changes to the connectors (connector f
changes because it has the same type, subtype and stereotype as d; connector b is
unaffected because it is not the same subtype, and e is unaffected because it is not
the same stereotype):
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Note that the 'Connectors of the same Subtype' option is of value for the small
group of connector types that support subtypes, such as Aggregations (Shared or
'weak' and Composite or 'strong') and Dependencies (Trace, Abstraction).

The option only applies if the subtype is set from the context menu as part of the
process of creating the connector. If the subtype was derived from the nature of the
source element, target element and/or base connector, the option does not function.

Pin End(s) Pin the connector start and/or end to the current position on the target element; a
sub-menu displays to offer the options of pinning the start point only, the end point
only, or both.

Once one or both ends are pinned, a fourth option is available to UNPIN both ends.

Some connector line styles (such as the Tree styles) are not compatible with
pinning the connector ends; if a pinned connector is changed to one of these styles,
the connector ends will be unpinned.

Bend Line at Cursor Insert an anchor point on the line at the point of the cursor so you can change the
shape of the line.

Shortcut: Ctrl+Q

Suppress Line Segment Hide a segment of a connector so that you can view a part of the diagram that it
crosses.

To reverse the change, right-click on the connector and select the 'Show All Line
Segments' option.
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Straighten Line at Cursor Remove an anchor point on the line at the point of the cursor.

(This is the exact opposite of 'Bend Line at Cursor', and Ctrl+Q toggles the
connector point between the options).

Shortcut: Ctrl+Q

Notes

Context menus vary slightly between connector types, and not all menu options are present on all connector context·
menus; the type-specific menu options are not always included

If two connectors cross, the later connector has a 'hoop' at the intersection, indicating that the connectors are·
crossing
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Connector Appearance Options

The 'Appearance' section of the connector context menu provides a number of options.

Appearance Options

Option Action

Appearance Set the line color and line thickness of the connector.

Visibility Set connector visibility; see the next table for sub-menu options.

Tidy Line Angles Tidy the line angles of a custom connector.

Visibility Sub-Menu

Option Action

Hide Connector Hide the connector.

To show the connector again, follow the steps in the Hide/Show Connectors topic.

Hide Connector in Other
Diagrams

Hide or show the connector in other diagrams.

Hide All Labels Hide or show all labels attached to the connector.

Set Label Visibility Hide or show labels attached to the connector, individually.

Notes

Context menus vary slightly between connector types, and not all menu options are present on all connector context·
menus; the type-specific menu options are not always included
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Connector Tasks

This topic identifies the commoner tasks associated with managing model connectors, such as:

Connect Elements·
Connect to Element Feature·
Connector Styles·
Arrange Connectors·
Change Connector Type·
Create Connector in Project Browser·
Reverse Connector·
Delete Connectors·
Hide/Show Connectors·
Generalization Sets·
Change the Source or Target Element·
Relationship Visibility·
Add a Note to a Connector·
Tree Style Hierarchy·
Create Connector in Project Browser·
Show Uses Arrow Head·
Set Association Specializations·
Change Sequence Message Scope·

Notes

In the Corporate, Business and Software Engineering, System Engineering and Ultimate editions, if security is·
enabled, you must have Update Element permission to update or delete a connector
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Connect Elements

This topic explains how to connect elements using the appropriate connector types on a diagram.

Actions

Action Detail

Connect Elements on a
Diagram

The fastest and simplest ways to create connectors are using the Quick Linker and
using the Toolbox.

To create another connector of the same type as the last connector you used, click
on the appropriate source element and press F3.

Selecting Connectors To select a connector, simply click on it; drag handles display, indicating that the
connector is selected.

This gives the connector focus for keyboard commands such as 'Delete', and
displays connector properties in docked windows such as the Tagged Values
window.

If there is more than one connector on a diagram, you can cycle through them using
the arrow keys.

Drag Connectors You can drag a connector to position it; click on the connector and drag it to where
it is to appear - note that there are some limitations on how far or to where you can
drag a connector.

You can also reattach the end of a connector to a different source or target element.

Connector Properties and
Commands

You can double-click on a connector to change properties, or right-click to display
the context menu containing commands to change connector type and direction.

You can also highlight the connectors on a specific element; select the element and
press and hold the L key - all the connectors issuing from or terminating at that
element are highlighted in separate colors. This is a useful feature to apply in
conjunction with the context filtering facility on an element on a diagram.

Create Connectors Without
a Diagram

Sometimes it is useful to create relationships between elements without a
diagrammatic representation; you can do this using the Project Browser and the
Relationship Matrix.

Notes

You can reposition a connector by selecting and dragging the connectors as required·
If a connector has source and target roles, you can attach either end of the connector to a specific attribute or·
operation in the source or target element
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Connect to Element Feature

If a connector has source and target roles, you can connect either end of the connector to a specific operation or attribute
in the source or target element. This is entirely a visual aid, to indicate which features are significant in the relationship.
In code generation or transformation, the link is interpreted as a normal source-element to target-element relationship.

Notes

The 'Link to Element Feature' option is not supported for reflexive/self connectors.·

Connect the end of the connector to a specific operation or attribute

Step Action

1 Right-click on the end of the connector joined to the element containing the required feature.

2 Select the 'Link to Element Feature' context menu option.

The 'Link to Element Feature' dialog displays.

3 In the 'Feature Type' field, click on the drop-down arrow and select the required feature type - 'Attribute'
or 'Operation'.

The attributes or operations from the element are listed in the 'Feature' field.

4 Click on the required attribute or operation, and click on the OK button.

The end of the connector changes to a bracket next to the selected feature.

You might create a number of feature-to-feature relationships between two elements (such as a Class and
a Table that represents the Class data) to produce a diagram similar to this:

You can change the feature to which the connector is attached by following the procedure and selecting
the new feature.

You can break the link to the selected feature in any of these ways:

Work through the procedure, setting the 'Feature Type' to 'None'·
Delete the attribute or operation from the element·
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Change the connector type to a type that does not have source and target roles·
Change the connector to a different source or target element that does not contain the feature·

Note that reversing the direction of the connector does not break the connector's attachment to the feature.
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Connect to a Connector

Under certain circumstances, it can be useful to create a connector that issues or terminates (or both) on another
connector. For example, you might create a connector between two elements, and then create a link between that
connector and a Requirement element to show that the relationship between the two elements was a predefined
specification of the design.

In releases of Enterprise Architect from 13.0 onwards, you can add connectors to other connectors. The linking
connector can connect as source and target:

Two other connectors·
An element and a connector·
A connector and an element·

The appearance of each configuration of a connector/connector link is illustrated here:

ClassA ClassB

ClassC ClassD

ClassE ClassF

«trace» «trace»

As you create the connector on another connector, the connector end displays with this circle symbol to indicate that it is
on another connector, and to help you position the end accurately.

(Select connector) 

(Move connector end) 

There is effectively no limit to the number of connectors that can issue from or terminate on another connector.

Create a connector on another connector

You can create a connector that issues from or terminates on another connector in the same two ways as you create one
on an element; that is:
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Using the Quick Linker arrow or·
Using a connector icon from the Toolbox·

Method Action

Quick Linker Click on the source connector (or element). A Quick Linker arrow displays at1.
the center point of the line.

Drag the arrow onto another connector or onto an element, to display a short2.
menu of possible connector types; select the appropriate type.

You can also drag the Quick Linker arrow into empty space; a short menu of
element types displays and you can select to generate an element of one of those
types whilst the system automatically creates an appropriate type of connector to it.

Toolbox Click on the icon for the required connector type.1.

Click-and-drag from the source connector or element to the target connector or2.
element.

Certain connector types are not UML-compliant for linking to another connector,
and if you select such types you might get an error message. You can continue to
create this type of connector by de-selecting the 'Strict Connector Syntax' option on
the 'Links' page of the 'Preferences' dialog (Start > Workspace > Preferences).
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Add a Note to a Connector

This topic describes how you can connect notes and constraints to graphical relationships.

Notes enable you to provide explanations and further detail for one or more connectors on a diagram, with a visible Note
element.

Add a note or constraint to a connector

Step Action

1 Right-click on one of the connectors to attach a note to.

The context menu displays.

2 Select the 'Attach Note or Constraint' menu option.

The 'Link Relations' dialog displays.

3 Select the appropriate radio button in the Link Type panel.

4 Check all the connectors that participate in the set.

5 Click on the OK button to complete the note or constraint creation.

6 Use the normal 'Note' dialog to enter the appropriate text for the note or constraint.

Notes

The constraint note is drawn slightly differently to a regular note, and has { and } automatically added to visually·
indicate the constraint form

As an alternative to the procedure above, you can drag the Quick Linker arrow on an existing Note or Constraint,·
and drag it to the required connector; a Notelink is automatically created to attach the Note or Constraint to the
connector
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Arrange Connectors

Connectors between two elements can be moved around the element borders to create a good layout. There is a limit to
how much a connector can be moved around, but generally it is very easy to find an acceptable layout. For the best
layouts, use the custom line style; this enables you to add as many line points and bends as you require to create a clean
and readable diagram.

Move and arrange connectors on a diagram

Step Action

1 Click once on the connector to select it.

2 Holding the mouse button down, move the connector in the required direction.

3 To refine the movement, click and hold very near to one end of the connector; this enables a slightly
different movement range.

4 To further refine the movement and range, select either a routed, direct or custom line style; each behaves
slightly differently.
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Change Connector Type

This topic explains how to change the type of a connector. Note that not all connector types are available depending on
the types of the source and target elements.

Access

Context Menu Diagram | Right-click on Connector | Advanced | Change Type

Change a connector type

Step Action

1 In the 'Connector Type' field, click on the drop-down arrow and select the required connector type.

2 Click on the OK button to apply changes.
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Change the Source or Target Element

After you have created a connector between two elements, you might later want to change either the source or target.
Instead of deleting and re-creating the connector, Enterprise Architect enables you to change the source or target. There
are two ways of doing this: using the 'Set Source and Target' dialog or using the mouse.

Using the 'Set Source and Target' dialog

Step Action

1 Right-click on the connector to open the context menu.

2 Select the 'Advanced | Set Source and Target' menu option.

The 'Set Source and Target' dialog displays.

3 Click on the drop-down arrows on the 'From Element' and 'To Element' fields, and select the source and
target elements.

4 Click on the OK button to apply changes.

Using the mouse

Step Action

1 Click on the connector and position the cursor over the 'handle' at one end.

2 When the cursor changes, click the right mouse button and drag the handle to the new element.

Notes

The connector does not actually move until you release the mouse button over the new source or target element;·
however:

A dotted line shows where the connector would be during the move·
The solid outline of the nearest element or extension changes to a hatched outline as you move the cursor onto it;·
this helps you identify where the connector should connect to, if there are many closely-arranged elements, Parts,
Ports and other extensions
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Connector Styles

Connectors come in a number of different routing styles. Additionally, if one solid-line connector crosses another, the
second one 'jumps' over the first (unless the 'Enable Connector line jumps' option is deselected on the 'Diagram' page of
the 'Preferences' dialog). You can also bend a connector to quickly and easily route connectors in the required layout.

Styles

Style Description

Direct A straight line from element A to element B.

You can move the line (back and forward, up and down) to a limited degree.

Auto Routing A vertical and horizontal route from A to B with 90-degree bends.

You can move the line to improve the route, but the location and number of bends
are not configurable.

Bezier A smooth curved line from A to B.

Bezier style is directly available for Data Flow diagram connectors, Mind Mapping
connectors, State Flows, State Transitions, Object Flows, and Control Flows.

Custom Line The most flexible option; you can add one or more line points and bend and push
the line into virtually any shape, using the 'Toggle Line Point at Cursor' option.

Tree Style - Vertical

Tree Style - Horizontal

A line from element A to B with two right-angle bends, and the end points fixed to
selected locations on the elements (Vertical or Horizontal).

Lateral - Vertical

Lateral - Horizontal

A line from element A to B with a single right-angle bend, and the end points fixed
to selected locations on the elements (Vertical or Horizontal).

Orthogonal - Square

Orthogonal - Rounded

You can add one or more line points and bend and push the line into a variety of
shapes, using the 'Toggle Line Point at Cursor' option.

All line segments thus created are either vertical or horizontal.

Set the Connector Style

Step Action

1 Right-click on the connector to change.

The context menu displays.

2 Select the 'Line Style' option.

3 From the submenu, select the required style:

Direct·
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Auto Routing·
Custom·
Tree·
Lateral, or·
Orthogonal·
(or Bezier, where appropriate)·

Set the Connector Style (alternative method)

Step Action

1 Select the connector to change.

2 Press these keys to change the style:

Ctrl+Shift+D for Direct·
Ctrl+Shift+A for Auto Routing·
Ctrl+Shift+C for Custom·
Ctrl+Shift+Z for Bezier (where appropriate)·

Bend a connector

Step Action

1 Right-click on the connector.

The context menu displays.

2 Set the line style to 'Custom Line' (Ctrl+Shift+C); this enables the 'Bend Line at Cursor' option in the
context menu.

3 Click on the 'Bend Line at Cursor' option to add a line point.

Right-clicking a line point displays the 'Straighten Line at Cursor' option, which you can use to remove
the line point.

4 Using the mouse, drag the line point to the required position.

Bend a connector (alternative method)

Step Action

1 Hold down Ctrl or Shift and click on a point on the connector to create a line point.
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Ctrl+click also removes a line point.

2 Using the mouse, drag the line point to the required position.

Tidy line angles (custom connector)

Step Action

1 Right-click on the connector.

The context menu displays.

2 Click on the 'Tidy Line Angles' menu option; this nudges the custom line in horizontal and vertical
increments, saving you the time of trying to get a good layout manually.

You can set the 'Tidy Line Angles' option to operate by default; click on the 'Start > Workspaces >
Preferences' ribbon option to display the 'Preferences' dialog, and select the 'Diagram Behavior' page.

Suppress individual line segments

Step Action

1 Right-click on the connector.

The context menu displays.

2 Set the line style to 'Custom Line' - press Ctrl+Shift+C.

This enables the 'Suppress Line Segment' option in the context menu.

3 Click on the 'Suppress Line Segment' option to suppress a line between two bend points.

The segment you right-clicked on is suppressed.

4 To show the segment again, right-click on the line and click on the 'Show All Line Segments' option.

One application for this is to represent the continuation of flow when your diagram crosses the page
boundary marker in the Diagram View.

When you suppress the line segment that crosses the boundary, the link name (connector properties)
displays at both ends of the hidden segment; when you print the diagram on multiple pages, the link name
identifies the connection apparently broken by the page boundary.
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Create Connector in Project Browser

You can create a connector from one element to another directly in the Project Browser.

Connect elements from the Project Browser

Step Action

1 In the Project Browser, either:

Right-click on the element to create a connector for, and select the 'Add | Create Link' option, or·
Select the element, press the Insert key and select the 'Create Link' option·

The 'Create Link' dialog displays.

2 In the 'Direction' field, click on the drop-down arrow and select the direction of the new connector
('Outgoing' means this element is the source).

3 In the 'Link Type' field, click on the drop-down arrow and select the type of connector.

4 In the 'Choose target(s)' list, click on the name of the target.

(If necessary, in the 'Select Target Type' field click on the drop-down arrow and select a feature to list
only elements having that feature).

5 Click on the OK button to create the connector.

Notes

You can also reproduce an existing connector between two elements when you paste those elements from the Project·
Browser into a diagram as instances; an option enables you to copy just the elements, or the relationship as well
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Relationship Visibility

You can change the visibility of individual connectors or relationships on an open diagram.

Access

Display the 'Set Visible Relations' dialog, using one of the methods outlined here.

Keyboard Shortcuts Ctrl+Shift+I

Set relationship visibility

Step Action

1 On the 'Set Visible Relations' dialog, select the checkbox against each list item to show, and clear the
checkbox against each item to hide.

If you want to display the information in a more readable layout, you can resize the dialog.

2 Click on the OK button to apply the changes.
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Hide/Show Connectors

Connectors/relations that appear in multiple diagrams can be selectively shown or hidden. This makes it easier to read
diagrams where elements might have many connectors, but not all are relevant in the context of the current diagram.

Hide or show a connector in the current diagram

Step Action

1 Double-click on the required diagram element in the Diagram view.

The element 'Properties' dialog displays.

2 Select the 'Links' tab.

This lists the connectors linked to the element, whether or not they are hidden on the diagram.

3 Right-click on the connector to hide or show.

The context menu displays.

4 Select the 'Show Relation' option to show the hidden connector on the diagram, or the 'Hide Relation'
option to hide the visible connector.

Alternatively, hide a connector by right-clicking on it on the diagram and selecting the 'Visibility | Hide
Connector' option; however, you must use the 'Links' tab of the element 'Properties' dialog to show the
relationship again.

Hide or show a connector in other diagrams

Step Action

1 Right-click on the connector in the diagram.

The context menu displays.

2 Select the 'Visibility | Hide Connector in Other Diagrams' menu option.

The 'Set Connector Visibility' dialog displays.

3 If the two connected elements have been included in other diagrams, these diagrams are listed here.

In the list, all diagrams for which the checkbox is selected show the connector; deselect the checkbox for
any diagrams in which to hide the connector.

If you want to display the information in a more readable layout, you can resize the dialog.

To hide the connector in all of the diagrams listed, click on the Suppress All button.

4 Click on the OK button to save the changes.

Notes
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Certain elements, such as Requirements, do not have a 'Links' tab in the 'Properties' dialog·
In these cases, open the Relationships window ('Start > Windows > Relationships') for the element, right-click on the
relationship in the list and select the context menu option to hide or show that relationship in the diagram
Be aware that, in the Corporate, Business and Software Engineering, System Engineering and Ultimate editions with
security on, locks on the diagram and elements can make the required option unavailable
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Delete Connectors

This topic explains how to delete a connector from the model. Note that is possible to either hide the connector in one or
more diagrams and still retain it in the model, or remove it completely (deletion).

Delete a Connector

Step Action

1 Right-click on the connector and select the 'Delete Connector' option.

The 'Remove Connector' dialog displays; this dialog provides the options to hide the connector so that it
remains functional, or remove the connector completely.

2 Click on the appropriate radio button and click on the OK button.

If you select the 'Hide' option, it has the same effect as hiding the connector on the 'Links' tab of the
source element 'Properties' dialog, or using the 'Visibility | Hide Connector' context menu option.

It also hides the connector on the Relationships window.

Notes

The dialog does not display if:·
    - You have previously selected the 'Don't ask again' checkbox or
    - On the 'Links' page of the 'Preferences' dialog ('Start > Workspaces > Preferences > | Links')
       the 'Prompt on connector deletes' checkbox is not selected

Selecting the 'Don't ask again' checkbox also deselects the 'Prompt on connector deletes' checkbox·
Selecting the 'Prompt on connector deletes' checkbox restores the dialog if you have used the 'Don't ask again'·
checkbox

If you hide the dialog, the 'Delete Connector' context menu option defaults to the setting you last used on the dialog;·
make sure that you have selected the right option to default to
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Generalization Sets

A Generalization Set enables you to specify the relationship of a group of Generalizations. Each Generalization is a
binary relationship that relates a specific Classifier to a more general Classifier (for example, from a Class to its
Superclasses). Each Generalization Set defines a particular set of Generalization relationships that describe the way in
which a general Classifier (or superclass) can be divided using specific subtypes.

Access

Context Menu Right-click on connector | Advanced | Generalization Set | New

Create a Generalization Set

Step Action

1 Select the 'New' menu option.

The 'Generalization Set' dialog displays.

2 In the 'Name' field, type the name of the Generalization set; for example, 'Gender'.

3 In the 'Power Type' field, either:

Type a new power type, or·

Click on the drop-down arrow or  and select an existing one from the 'Select <Item>' dialog·

4 Check the 'IsMember' column for the child subtypes that are part of this Generalization set.
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Connector In-place Editing Options

You can edit many of the Enterprise Architect connector labels directly on the diagram. Each label can be bound to a
single connector field.

Put a label in Edit mode

To put a label into Edit mode, either:

Select the 'Edit Label' option from the context menu, or·
Select a label and press F2·

To save the current text to the field, either press the Enter key or deactivate the Edit window.

To cancel edit mode without saving any changes, press Esc.
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Reverse Connector

You can reverse the direction of a connector without having to delete and re-create it. This is helpful if your design
changes or you add the connector wrongly to begin with.

Reverse the direction of a connector

Step Action

1 Right-click on the incorrect connector.

2 Select the 'Connection Detail | Reverse Direction' context menu option.
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Set Association Specializations

UML enables specialization of properties defined by Associations. Enterprise Architect enables this through the
'Specialize Associations' option in the 'Advanced' section of the context menu for an Association.

A dialog displays, showing all Associations between the two Classes connected by the current Association and their
parents.

The left two columns define the source role of the current Association, while the right two define the target role. With
this you are able to select the relationships of each end of the properties listed. When a relationship is set then this is
drawn at the corresponding end of the connector on any diagram it appears on.

The dialog displays when you select the 'Advanced | Specialize Associations' context menu option on the lowest
Association connector in this diagram.

Example
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Change Sequence Message Scope

A message in a Sequence diagram represents a dynamic interaction from one element to another. Sometimes when you
are designing your model you might have to change either the start or end point of a message as the responsibilities of
elements change during design. For this reason, Enterprise Architect enables you to change the message scope by setting
a new start or end element.

Change Message Scope

Step Action

1 Select the message in the Sequence diagram.

2 Right-click on the message to open the context menu.

3 Select 'Advanced | Set Source and Target'.

4 In the pop up dialog, in the 'From Element' and 'To Element' fields, click on the drop-down arrows and
select the required elements.

5 Click on the OK button to save changes.

The message is re-routed to meet your changed requirements.
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Show Uses Arrow Head

By default the Use connector in Use Cases has no arrow head.

Generate arrow heads on Use connectors

Step Action

1 Select the 'Start > Workspace > Preferences > Links' option.

The 'Links' page of the 'Preferences' dialog displays.

2 In the 'General' panel, select the 'Show Uses arrowheads' checkbox.

3 Click on the Close button.

When you save the Use Case diagram, the Use connectors change to display arrowheads.

(c) Sparx Systems 2015 - 2017 Page 418 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Tree Style Hierarchy

In Enterprise Architect you can create a tree style inheritance diagram using a special form of the Generalization
connector, as shown.

Create a tree style connector

Step Action

1 Create a normal Generalization between two elements.

2 Right-click on the connector to open the context menu.

3 Select the 'Line Style | Tree Style - Vertical' or the 'Line Style | Tree Style - Horizontal' menu option.

4 Enterprise Architect automatically makes the Generalization layout conform to a specific shape.

By adding more Generalization connectors, and checking their Tree Style options, you can achieve the
appearance of the diagram above.

You can slide the root and child Classes left and right to achieve the required result; Enterprise Architect
maintains the conformity of the branch connectors.

Set this style of connector as default

Notes

In the example diagram, the Son ->Parent connector has not yet been put in Tree Style - Vertical style·
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This style of diagram provides a clearer layout for inheritance hierarchies and is easy to work with·

Step Action

1 Select the 'Start > Workspace > Preferences > Links' option.

The 'Links' page of the 'Preferences' dialog displays.

2 Select the 'Generalization link style Default = Tree' checkbox to make this branching style the default
style for inheritance connectors.

(c) Sparx Systems 2015 - 2017 Page 420 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Connector Properties

A connector can have a wide range of properties, with some connector types having fewer, simpler properties and others
having more and more-complex properties. You edit these properties on the '<connector type> Properties' dialog. Some
properties are visible on a diagram as text labels on or around the connector, and you can change these labels using the
'Label' context menu.

The properties on the dialog are presented on these tabs:

General·
Advanced properties·
Tagged Values·
Source and Target Roles·
Constraints·

Access

Context Menu Right-click on Connector | Properties

Other Double-click on Connector

General Tab Options

Option Action

Name (Optional) Type a representative name for the connector; this name displays on the
diagram.

Notes (Optional) Type any comments you want to record on the connector. You can
format the text using the Notes toolbar at the top of the field.

These notes can be included in searches, reports and documentation, if required.

Connector Properties Panel

Source Displays the name of the source element for the connector.

Target Displays the name of the target element for the connector.

Alias (Optional)Type an alternative name or alias for the connector.

Direction Click on the drop-down arrow and select the appropriate direction details: from
source to destination, destination to source, bi-directional, or unspecified.

Some connectors have arrow heads that depend on this setting, and some
connectors are logically dependent on this (such as Inheritance).

Style Click on the drop-down arrow and select the appropriate connection style; choose

(c) Sparx Systems 2015 - 2017 Page 421 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

from:

Direct·
Auto-Routing·
Custom·
Tree (Vertical, Horizontal, Lateral Vertical or Lateral Horizontal), or·
Orthogonal (Square Corners or Rounded Corners)·

Some connectors can also have the Bezier style, under which the connector follows
a smooth curve.

Stereotype
(Optional) Type the name of a stereotype for the connector, or click on the 
button and select the stereotype from the 'Stereotype Selector' dialog.

If specified, the stereotype is displayed on the diagram and it over-rides the
connector type in the report documentation.

Virtual Inheritance (For Generalization connectors)  Click on the drop-down arrow and select True or
False to indicate if inheritance is virtual or not.

Scope (For Generalization connectors where the child Class is C++.) Click on the
drop-down arrow and select the appropriate value for the scope (used for
inheritance).

Notes

Instead of displaying properties on tabs in the dialog, you can select the 'Property Sheets use Tree style' checkbox·
through the 'Start > Workspace > Visual Styles' ribbon option to display the properties on screen pages selected
through a hierarchical list

Generalize, Realize, Associate and Template Binding connectors also have a 'Binding' tab, on which you define·
binding expressions and parameter substitutions for the connector
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Connector Advanced

You use the 'Advanced' tab of the 'General' page to reset the values of any system-defined advanced properties that the
connector has.

Access

Context Menu Right-click on Connector | Properties > Advanced

Other Double-click on Connector > Advanced

Set a value for a connector's advanced property

Step Action

1 Click on the data field to the right of the property name.

2 Depending on the property, either:

Type the value in free text·
Click on the drop-down arrow and select the value from the list·

Click on the  button and search for the required value·

3 Click on the OK button.
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Connector Tagged Values

You can define Tagged Values for a connector and, for Association and Aggregation connectors, set additional Tagged
Values for the source role and/or target role. You might set these Tagged Values separately on the Tagged Values
window but, for convenience, you can continue working in the connector 'Properties' dialog, which encapsulates the
Tagged Values window in the 'Tags' tab.

Access

Context Menu Right-click on Connector | Properties > Tags

Other Double-click on Connector > Tags

Set Tagged Values for the connector

Step Action

1 Click on the connector type name, Connector Source or Connector Target as required.

2
Either click on the  icon in the toolbar, or press Ctrl+N.

The 'Tagged Value' dialog displays.

3 In the 'Tag' field type the tag name, or click on the drop-down arrow and select a predefined Tagged Value
type.

4 In the 'Value' field, type the value for the tag.

5 Click on the OK button to save the changes and close the dialog.

The Tagged Value is displayed under the object name you selected in step 1.
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Source and Target Role

For certain types of connector, such as Association or Aggregation, the elements at either end of the connector can have
defined roles. You define the roles in the connector 'Properties' dialog, on the 'Role(s)' tab.

The 'Role(s)' tab has two identical panels, one for each of the Source and Target role definitions. The field descriptions
here apply to both panels.

Access

Context Menu Right-click on Connector | Properties > Role(s)

Other Double-click on Connector > Role(s)

Enter Role definitions

Option Action

<top field> Type the name of the role assigned to the element.

Alternatively, click on the drop-down arrow and select an attribute name from the
opposite element (that is, select the source role name from the names of attributes
on the target element, and vice versa).

<second field> Type any notes required to describe the role.

Multiplicity

Multiplicity Click on the drop-down arrow and select the required multiplicity for the role (you
can edit the possible values of this field on the 'Cardinality' tab of the 'UML Types'
dialog).

Multiplicity is the range of instances of the role that can be active in the
relationship - for example, one employee can be assigned to one or more tasks; for
the target role you define the range of instances (such as tasks) that the employee
could be assigned to.

The values have these formats:

*, or 0..* - zero, one or many instances·
0..n - zero or up to n instances, but no more than n·
n - exactly n instances·
n..* - n, or more than n instances·

You can also define source and target role multiplicity in the corresponding
element's attribute properties.

Ordered Click on the drop-down list and select True or False to indicate whether or not the
role is an ordered list.

Allow Duplicates Click on the drop-down list and select True or False to indicate that the role can
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contain duplicate elements (relevant only if multiplicity is > 1).

This field maps to the UML property 'isUnique' (selecting the checkbox maps to the
'isUnique' value of False).

Detail

Stereotype (Optional) Type the name of a stereotype that applies to this end of the connector,

or click on the  button at the end of the field and select a stereotype from the
'Stereotype Selector' dialog.

Alias (Optional) Type in an alias for the role.

Access Click on the drop-down arrow and select the appropriate access level for the role.

Navigability Click on the drop-down arrow and select a value to indicate whether or not this role
is navigable (whether non-navigable ends are shown on the diagram depends on the
diagram properties).

Aggregation Click on the drop-down arrow and select a value to indicate the type of aggregation
that this role uses.

Scope Click on the drop-down arrow and select a value to indicate the level (instance or
classifier) at which this role applies.

Constraints Type the names of any constraints on the role.

Qualifier(s) Type the names of any qualifiers or restrictions on the role; separate multiple
qualifiers with a semi-colon.

Alternatively, click on the  button at the end of the field, and define a new
qualifier on the 'Qualifiers' dialog (qualifiers typed into the 'Qualifiers' field are also
automatically added to this dialog).

Advanced

Member Type Type the name of a role-type that can be used when generating collection Classes
for multiplicity > 1.

Changeable Click on the drop-down arrow and select a value to indicate whether this role is
subject to change.

Containment Click on the drop-down arrow and select a value to indicate the nature of the
containment at the Destination (Reference or Value).

Derived Click on the drop-down arrow and select True or False to indicate whether the role
value or values can be computed from other information.

Derived Union Click on the drop-down arrow and select True or False to indicate whether the role
is derived from the properties that subset it.

Owned Click on the drop-down arrow and select True or False to indicate whether the role
is owned by the opposite Class rather than the Association.

Selecting True adds a 'dot' to the appropriate end of the connector ( ).
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Notes

Source role details are displayed at the start end of a connector; if you have drawn the connector the wrong way,·
correct it by selecting the 'Reverse Direction' option from the connector context menu

Destination role details are displayed at the terminating end of a connector on the diagram·
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Connector Constraints

A UML connector can also have associated constraints placed on it. Constraints provide information on the rules and
conditions under which a relationship operates. For example, it might be a pre-condition that a customer is of a certain
type before an Association connector to an Account is allowed.

Access

Context Menu Right-click on Connector | Properties > Constraints

Other Double-click on Connector > Constraints

Set constraints on a connector

Option Action

Constraint Type the name of the constraint.

Type Click on the drop-down arrow and select the appropriate type of the constraint
(such as Pre-condition).

Notes Type any explanatory notes you might require on the constraint. You can insert line
breaks in the text by pressing Ctrl+Enter.

Save Click on this button to save the constraint definition.

The constraint is added to the 'Defined Constraints' list.

New Click on this button to clear the dialog fields so that you can enter details of a new
constraint.

Defined Constraints Displays a list of the constraints defined for this connector.

Delete Click on this button to delete a constraint you have selected in the 'Defined
Constraints' list.

The constraint is immediately removed from the list.

Notes

Constraints on an Association connector can be added to further refine the model; constraints detail the business and·
operational rules for the model
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Binding

Generalize, Realize, Associate and Template Binding connectors have a 'Binding' tab or page on their 'Properties' dialog.
You use this tab to define binding expressions and parameter substitutions for the connector.
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Tagged Values

Tagged Values are additional properties that can be assigned to UML elements and connectors. The UML defines
properties such as name and description for elements and connectors, and Enterprise Architect adds a number of
additional properties such as status, phase and author, but Tagged Values provide a means of defining your own
properties (tags) and their values.

For example, a requirements modeler might want to record the owner of a set of requirements. The UML doesn’t specify
this property, but it can be easily added as a tag. A tag named Requirement Owner could be created and then each
Requirement element could be assigned a value for the owner. This information would also be available in
documentation.

Enterprise Architect has enriched the basic concept of Tagged Values with its powerful structured Tagged Value facility.
To assist you when entering data, the values can be restricted using user interface controls such as drop down lists, spin
controls, date selectors and many more.

Tagged Values are widely used in profiles and technologies to add information that helps guide the presentation of
elements or metadata for code or schema generation.

The Tagged Values window

You can use the Tagged Values window to view and modify Tagged Values for a selected modeling item, either from the
current diagram or in the Project Browser. It is a dockable window that you can use to:

Assign a Tagged Value to an Item·
Modify Tagged Values·
Assign Notes to a Tagged Value·
Perform advanced tag management·

Model Elements and Features with Tagged Values

These model components can use the Tagged Values window as a convenient way to quickly view and modify Tagged
Values:

Elements - display their own tags, along with any inherited values·
Object Instances - display their own tags and those obtained from their classifier·
Ports and Parts - display similar information to objects but show the Port/Part 'Type' instead of a classifier; tags are·
included for all parents and other structures of the Ports type

Attributes - display their own tags and those received from attribute type classifiers, with the inclusion of any·
inherited tags

Operations - display their own tags·
Connectors - display their own tags·

When over-riding an inherited property, the system copies the tag from the parent down to the child element and sets the
new value, leaving the original tag unchanged.
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Tagged Values Toolbar Buttons

Using the buttons from the toolbar at the top of the Tagged Values window, you can add, edit, sort, delete and arrange
the Tagged Values of model features.

From left to right, the button functions are:

Show in compartments - displays the Tagged Values in element compartments on diagrams·
Sort and Show Alphabetically - sorts the current Tagged Values alphabetically for the element·
New Tagged Value - adds a new tag, to which you assign a value·
Edit Tagged Value Notes - opens a note in which you type an explanation of the purpose of the Tagged Value·
Delete Tagged Value - removes the currently selected Tagged Value·
Default Tagged Value Types - provides quick access to tag definitions created using the 'Configure > Reference·
Data > UML Types > Tagged Value Types' option

Tagged Value Options - provides options to show or hide the fully qualified paths for the Tagged Values in the·
window, and to show duplicate Tagged Values

Help - displays information on the use of the Tagged Values window·

(c) Sparx Systems 2015 - 2017 Page 431 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Quick Start - Add Tagged Value To Elements

You can add a Tagged Value to one or more elements within a diagram, using a context menu option. You can also use
the Current Element toolbar, on which the last button is a shortcut to the 'Add Tagged Value' option.

To delete the Tagged Value you must open the 'Properties' dialog for each element, go to the 'Tagged Values' tab and
manually delete the item. There is currently no shortcut to delete tags from multiple elements simultaneously.

To add notes to the Tagged Value, in the element 'Properties' dialog go to the 'Tagged Values' tab, click on the Tagged
Value name, and click on the Edit Notes button in the tab toolbar. The 'Notes' dialog displays.

Any Notes text you enter also displays in the 'Info' section at the bottom of the Tagged Values window.

Access

Context Menu On diagram | Right-click single element | Advanced | Tagged Value

On diagram | Select multiple elements | Right-click on one | Add Tagged Value

Keyboard Shortcuts Ctrl+Shift+T

Add a Tagged Value to elements

Step Action

1 On the 'Tagged Values' dialog, in the 'Tag' field, type in the tag name.

2 In the 'Value' field, type in the value for the tag.

3 Click on the OK button to add your new Tagged Value to the currently selected elements.
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Assign a Tagged Value to an Item

You can assign Tagged Values to a range of model objects, including elements, object instances, connectors, attributes
and operations, using the Tagged Values window. You would probably have the window open already as a docked
window, and any object you select becomes the focus of the window; you can then review and add or delete Tagged
Values for that object.

Access

Ribbon Start > Windows > Tagged Values

Show > Window > Tagged Values

Keyboard Shortcuts Ctrl+Shift+6

Assign a Tagged Value to an item

Step Action

1 Select the model feature to which to assign a Tagged Value. This feature becomes the focus of the
window.

2
In the Tagged Values window, either click on the  icon or press Ctrl+N.

The 'Tagged Value' dialog displays.

3 In the 'Tag' field type the tag name, or click on the drop-down arrow and select the appropriate tag to
assign to the item.

4 If appropriate, type a specific value for the tag in the 'Value' field.

5 To confirm selection of the Tagged Value, click on the OK button.

Notes

You can also assign a Tagged Value directly to an element in a diagram either by right-clicking on the element and·
selecting 'Advanced | Tagged Value' or by clicking on the element and pressing Ctrl+Shift+T, then completing the
Tagged Value dialog as described above

(c) Sparx Systems 2015 - 2017 Page 433 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Assign Notes to a Tagged Value

Once a Tagged Value has been assigned to a model feature, you can add information and notes describing the Tagged
Value to the information property of the Tagged Value.

Access

Ribbon Start > Windows > Tagged Values

Show > Window > Tagged Values

Keyboard Shortcuts Ctrl+Shift+6

Assign a note to a Tagged Value

Step Action

1 Select the Tagged Values menu option.

The Tagged Values window displays.

2 Click on the model feature for which to edit the Tagged Values.

Its Tagged Values display in the Tagged Values window.

3 Click on the Tagged Value to add information to.

4 Click on the Edit Tagged Value Notes button or press Ctrl+E.

The 'Tagged Value Note' dialog displays.

5 In the 'Note' field, type the information relating to the Tagged Value.

Click on the OK button.

The information is displayed in the lower portion of the Tagged Values window whenever the Tagged
Value is selected.
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Modify Tagged Values

Once a Tagged Value has been assigned to a model feature (such as an element or connector), it is possible to edit the
values in the Tagged Values window.

Access

Ribbon Start > Windows > Tagged Values

Show > Window > Tagged Values

Keyboard Shortcuts Ctrl+Shift+6

Edit Tagged Values

Step Action

1 Click on the model feature for which to edit the Tagged Values.

The Tagged Values window shows all of the tags for the selected feature, each with their current value.

2 Edit the fields as appropriate; the information entered can only reflect the value types that have been
defined by the tag's Tagged Value Type.

There are six types of value field for a Tagged Value:

'Open' fields, in which you can type any appropriate value·
Structured Tags, where you do not directly edit the composite value but expand the tag to show the·
component tags and edit the component values in 'open' fields; the composite value updates as you
click off the component field

'Drop-down list' fields, where you click on the drop-down arrow to select from a discrete list of·
possible values such as 'M' or 'F', or 'Win', 'Lose' or 'Draw'

'Spin' fields, where you click on up or down arrows in the field to increase or decrease the value·
within certain limits

Checklist fields, where  you click on the  button in the field to display the 'Check List' dialog,·
which lists a set of items that can be selected by ticking the checkbox against each item; if any
checkboxes are not selected the value of the tag is 'Incomplete', and when all checkboxes are selected
the tag value is 'Complete'

'Further detail' fields, where you click on the  button in the field to display a dialog in which you·
enter information (such as notes) or indicate a source of further information (such as a classifier)

Notes

To override a Tagged Value defined in a parent element, edit the value in the from <parentname> compartment of·
the Tagged Values window
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Once this has been done the tag is moved into the selected element's Tagged Values; this does not affect the Tagged
Values defined in the parent element

(c) Sparx Systems 2015 - 2017 Page 436 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Show Duplicate Tags

Tagged Values are by default set to hide duplicate values. This setting is used to facilitate inherited and overridden tag
names.

Set the Tagged Values window to show duplicate values

Step Action

1
On the Tagged Values window toolbar, click on the  Options icon.

2 Select the 'Show Duplicate Tags' context menu option.

Alternatively

Step Action

1 Select the 'Start > Workspace > Preferences'option.

The 'Preferences' dialog displays.

2 From the hierarchical tree, select the Objects item.

3 Select the 'Show Duplicate Tags' checkbox.

Notes

In either procedure, to hide duplicate values again deselect the option or check box·
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Advanced Tag Management

Tagged Values can also be managed within a type hierarchy and with respect to element instances, using the Tagged
Values window. It is possible to:

View Tagged Values inherited from parent Classes or realized interfaces or applied stereotypes·
Override Tagged Values derived from parents or applied stereotypes with a unique value for the current element·
Delete Tagged Values from the current element (if a parent version of the Tagged Value exists, it re-appears in the·
list after the override is deleted)

For a reference Tagged Value (of type RefGUID), it is also possible to locate and select the object that the Tagged Value
refers to, in the Project Browser. Simply right-click on the Tagged Value name in the Tagged Values window and select
the 'Find in Project Browser' option.

Tag Hierarchy

This diagram illustrates a complex tag hierarchy and the way Tagged Values can be either inherited or overridden in
specialized Classes to create the final tagged property set for an element. A similar concept applies to instances, where
the full tag set is created from the directly owned tags, plus all of those merged in from the classifier's type hierarchy,
additional stereotypes and realized interfaces.

(c) Sparx Systems 2015 - 2017 Page 438 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

(c) Sparx Systems 2015 - 2017 Page 439 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Attributes

Attributes define the properties or internal data elements of an element. Not all element types support attributes, and
others have restrictions; for example, attributes of Interfaces must have Public scope. In the Project Browser, elements
with attributes (typically Classes) have their attributes listed under the element name, each preceded by a blue box ( ).
When depicted in diagrams, the attributes are listed in the first properties compartment of the element, as shown in this
Customer Class example.

Attributes themselves have several important characteristics, such as type, scope (visibility), derivation and notes.

Access

Ribbon Design > Element > Attributes

Context Menu Right-click element in diagram | Features and Properties | Attributes  or

Right-click element in Project Browser | Attributes

Right-click attribute in Project Browser | Attribute Properties

Keyboard Shortcuts F9

Other In Project Browser, double-click on an Attribute

Maintain Attributes

Action Detail

Create and Modify
Attributes

On the 'Attributes' page of the '<element name> Features' dialog, you create and
modify attributes using the various panels and tabs.

You can copy or move existing attributes between elements, if the target element

(c) Sparx Systems 2015 - 2017 Page 440 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Move and Copy Attributes also supports attributes.

Define Properties You can create  property implementations specific to your coding languages for
each attribute.

Identify Inherited
Attributes

The attributes of an element can be inherited from one or more successive parent
elements in the model. On a diagram, you can show which attributes are inherited
from which 'owning' element in the hierarchy.

Notes

Attributes, with Operations, are collectively referred to as Features of an element·
If you are creating many attributes, go to the 'Attribute/Operations' page of the 'Preferences' dialog ('Start >·
Workspace > Preferences > Source Code Engineering > Attribute/Operations') and de-select the 'After save, re-select
edited item' checkbox; now, when you create an attribute and click on the Save button, the 'Attribute' page fields
clear ready for you to enter the details of the next attribute - this helps you when you want to create attributes
quickly and might not necessarily want to fully define each one as you create it

If the parent element provides source or target roles for a connector, the connector can be attached to a specific·
attribute (as a feature)

An alternative method of creating relationships between elements and attributes is to drag an attribute onto an·
Activity diagram, which generates an Object element named after the attribute; you then create relationships to and
from this Object element
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Create and Manage Attributes

The 'Features' dialog has a page each for the attributes and operations that you create in an element. When you display
the 'Attributes' page, you can create and manage attributes using the panels and tabs of the page, and a context menu on
the main panel.

Access

Ribbon Design > Element > Attributes

Context Menu Right-click element in diagram | Features and Properties | Attributes  or

Right-click element in Project Browser | Attributes

Keyboard Shortcuts F9

Create a New Attribute

Either:

Click on the New Attribute... text and type a name for the new attribute·
Right-click on the top panel and select 'Add New' (or press Ctrl+N) or·
Right-click on an existing attribute and select 'Copy as New' (or press Ctrl+C), provide a new name for the attribute·
and click on the OK button

A new attribute entry displays in the list.

Edit Attribute Properties

Option Action

Name If you want to change the attribute name, click on the field and overtype it with the
new name.

Type Defaults to 'int'. To change this, overtype the field or click on the drop-down arrow
and click on:

The required type or·
'<none>' for no type, or·
'Select Type' and browse for the appropriate attribute classifier (you can add a·
new one if there are no classifiers that suit)

The type can be defined by the code language (data type) or by a classifier element;
when you click on the drop-down arrow, the set of values in the list provides the
data types, and the 'Select Type' browser provides the possible classifiers.

To add new code language data types that can be displayed in this list, see the Data
Types topic.
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Scope Define the attribute as Public, Protected, Private or Package; if necessary, click on
the drop-down arrow and select a different scope.

Stereotype (Optional) Define one or more stereotypes for the attribute; either:

Type a stereotype name, or·

Click on the  button and select the stereotype from the 'Stereotype Selector'·
dialog

Alias (Optional) Type an alternative name or reference for the attribute.

Initial Value (Optional) Either:

Type in a simple initial value, or·

Click on the  button and construct a more complex value on the Default·
Initial Value window

Attribute <name> panel In the fields of this panel, define the detailed properties of the selected attribute.

Notes Tab Enter any comments and discussion you want to record on the attribute; you can
format the notes text using the Notes toolbar at the top of the field.

You can also perform a range of operations on the Notes text, using the 'Notes'
context menu.

Constraints tab Define any constraints associated with the attribute.

Redefines tab On this tab, identify any redefined and/or subsetted properties of the attribute, using
the 'Select Property' dialog.

Click on the Add button for each type of property to display the dialog and define
the property.

Click on a property and on the Delete button to remove it from the appropriate list.

Tagged Values tab On this tab, define any Tagged Values that the attribute has.

Close Click on this button to close the 'Features' dialog, saving all information you have
recorded in it.

Context Menu options

Right-click on the upper panel, or on a specific attribute name.

Option Action

Add New Add a new attribute to the list, with default values in the dialog fields.

Shortcut: Ctrl+N

Copy as New Copy a selected attribute as a new attribute. Provide a new name for the attribute
and click on the OK button.

Shortcut: Ctrl+C
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Qualifiers Add Qualifiers to the selected attribute. The 'Qualifiers' dialog displays.

Restore Sort Order If you have used the column header arrows to reorganize the sequence in which the
attributes are displayed, click on this option to redisplay them in the default
sequence (alphabetical by name).

Move up Move the selected attribute one row up the list.

Shortcut: Ctrl+Up Arrow

Move down Move the selected attribute one row down the list.

Shortcut: Ctrl+Down Arrow

Field Chooser Display the 'Field Chooser' dialog, which contains any column headings not
currently applied to the page.

Drag a column heading from the 'Field Chooser' into the preferred position in the
row of column headings. You can also drag the column headings into a different
sequence.

To return a column heading to the 'Field Chooser', drag it out of the heading row.

Enable Group Box Show or hide the Group Box, in which you reorganize the list sequence  of the
attributes according to one or more characteristics.

Toggle Filter Bar Show or hide the Filter Bar, in which you type text strings that the data in the
corresponding column must match in order to be listed.

Delete Immediately delete the selected attribute from the element.

Shortcut: Ctrl+Del

Notes

By default, the attributes are listed in alphabetical order; before being able to change this sequence, you must·
deselect the 'Sort Features Alphabetically' checkbox on the 'Objects' page of the 'Preferences' dialog ('Start >
Workspace > Preferences > Objects') - the system prompts you to allow it to make this change for you

(c) Sparx Systems 2015 - 2017 Page 444 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Attribute Details

On the 'Attributes' page of the 'Features' dialog, you can define a number of important properties of an attribute using the
properties list in the bottom left of the dialog.

Access

Ribbon Design > Element > Attributes

Context Menu Right-click element in diagram | Features and Properties | Attributes  or

Right-click element in Project Browser | Attributes

Keyboard Shortcuts F9

Define Properties

Field Action

Containment Type the name of the containment type, or click on the drop-down arrow and select
a standard type (By Reference, By Value or Not Specified).

Static Click on the drop-down arrow and select True or False to indicate whether the
attribute is a static member.

Property
If the attribute has automatic property creation, click on the  button to define
how it should be implemented for the programming language you are modeling for.

The 'Create Property Implementation' dialog displays.

Is Literal (For Enumeration elements) Click on the drop-down arrow and select True or False
to indicate whether the attribute is an enumeration literal.

In the Attributes compartment on the diagram, the enumeration literals are listed
separately, above the normal attributes (check that the 'Stereotype' field for the
normal attribute is not set to 'enum').

Transient (For Java code) Click on the drop-down arrow and select True or False to indicate
whether the attribute can change regardless of what the code is performing.

Derived Click on the drop-down arrow and select True or False to indicate whether the
attribute is derived from one or more other attributes; for example, full name can be
derived from the last name and first name attributes.

Is ID Click on the drop-down arrow and select True or False to indicate whether the
attribute can be used to uniquely identify an instance of the containing Class.

Multiplicity
Click on the  button to display  the 'Multiplicity' dialog, and define the
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multiplicity of the attribute.

Upper bound - Type the  upper limit to the number of elements allowed in the·
collection

Allow Duplicates - Select the checkbox to indicate that duplicate values are·
allowed; this field maps to the UML property isUnique, with a value False

Multiplicity is Ordered - Select the checkbox to indicate that the collection is·
ordered

OK - Click on this button to save the information and close the dialog·

Is Collection Click on the drop-down arrow and select True or False to indicate whether the
attribute is a collection (array), so that it can contain multiple concurrent values, or
a single value.

Container Type Type the name of the container type for the collection.
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Create Properties

You can configure Enterprise Architect to automatically create properties in the modeled code in any of the
programming languages that the system supports. You control property creation from the 'Attributes' page of the
'Features' dialog. Each language has slightly different syntax and generates slightly different results:

Java and C++ generate get and set functions·
C# and VB.Net create property functions·
Delphi creates get and set functions as well as a specialized Delphi property Tagged Value·

Access

Ribbon Design > Element > Attributes

Context Menu Right-click element in diagram | Features and Properties | Attributes  or

Right-click element in Project Browser | Attributes

Keyboard Shortcuts F9

Configure Properties for an attribute

Step Action

1 In the list of attributes, click on the attribute for which to configure property creation.

2
In the lower left panel of the dialog page, click on the 'Property' field and on the  button.

The 'Create Property Implementation' dialog displays.

3 The 'Language' panel defaults to the radio button for the language defined in the Class properties;
however, you can click on any other radio button to select another language for which to configure
property creation.

Each language enables its own combination of fields in the 'Property Details' panel.

4 The 'Name' field defaults to the name of the attribute. If necessary, you can overtype this with a different
name.

Select the checkboxes or values from drop-down lists for these fields as required (and if available) to
define the property for the selected programming language:

By Ref·
Stereotype·
Get Scope·
Set Scope·
Published·
Read·
Write·
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Abstract·

5 Click on the OK button

The system generates the required operations and properties to comply with the selected language.

Notes

Get and Set functions have the stereotypes «property get» and «property set», making it easy to recognize property·
functions in the operations compartment of the element on a diagram; you can also hide these specialized functions
on a specific diagram, by deselecting the 'Property Methods' checkbox on the 'Features' page of the 'Diagram
Properties' dialog, which then makes it easier to view the Classes uncluttered by many get and set methods

For the Delphi programming language, enable the Tagged Values compartment to see the generated property Tagged·
Value
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Attribute Tagged Values

Tagged Values are a convenient means of extending the properties a model element supports, including attributes. Such
extensions can then be used by code generators and other utilities to transform UML models into other forms.

Access

Ribbon Design > Element > Attributes > Tagged Values

Context Menu Right-click element in diagram | Features and Properties | Attributes > Tagged
Values  or

Right-click element in Project Browser | Attributes > Tagged Values

Keyboard Shortcuts F9 > Alt+V

Add a Tagged Value to an attribute

Step Action

1
Click on the  button.

The 'Tagged Value' dialog displays.

2 In the 'Tag' field, type the tag name or click on the drop-down arrow and select a defined tag.

3 In the 'Value' field type a specific value for the tag.

4 Click on the OK button to confirm the operation.

The tag name and value are displayed under the attribute in the 'Tagged Values' tab.

Notes

Tagged Values are supported for attributes, operations, objects and connectors·
You can define custom tags by creating a Custom Tagged Value Type·
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Attribute Constraints

Attributes can have constraints associated with them, which typically indicate such things as maximum value, minimum
value and length of field. You define these constraints within the attribute properties.

Access

Ribbon Design > Element > Attributes > Constraints

Context Menu Right-click element in diagram | Features and Properties | Attributes > Constraints
 or

Right-click element in Project Browser | Attributes > Constraints

Keyboard Shortcuts F9 > Alt+T

Define Constraints

Option Action

Constraint Type in the name or action of the constraint.

Type Click on the drop-down arrow and select the appropriate constraint type.

(Notes) Type in any comments or notes concerning the constraint.

New Click on this button to clear any displayed data from the constraint fields, so that
you can define a new constraint.

Save Click on this button to save any new data in the fields, and to clear the fields in
preparation for defining another constraint. The saved constraint is added to the top
of list at the bottom of the 'Constraints' tab.

Delete Click on a constraint in the list and click on this button to immediately remove the
constraint from the attribute.
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Display Inherited Attributes

When displaying a Class with attributes in a diagram, you can also show the inherited attributes from all parents in the
element's type hierarchy (ancestors).

Access

Context Menu Right-click element on diagram | Features & Properties | Feature and Compartment
Visibility

Keyboard Shortcuts Ctrl+Shift+Y

Enable Display of Inherited Attributes

In the 'Inherited Features' panel, select the 'Show Attributes' checkbox.

You can also override an inherited attribute's initial value, selecting the 'Features & Properties | Override Attribute
Initializers' option to display the 'Override Attribute Initializers' dialog.

When you view the inherited attributes, the system merges the list of attributes from all ancestors and applies the
attribute initializers, so that the final child Class displays the correct attribute set and initial values.

Option Action

Variable Click on the drop-down arrow and select the variable name.

Operator Click on the drop-down arrow and select the appropriate operator.

Value Type a new initial value.

Note Type in any comments or notes concerning the variable.

OK Click on this button to save the variable and close the dialog.

Example
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Create Object From Attribute

If you drag an attribute from the Project Browser onto an Activity diagram, the attribute generates an Object element of
the same name.

This is very useful for creating connectors between elements and specific attributes. For example, a Class element of
stereotype <<table>> defines its fields as attributes; Action elements that define the use or update of those fields can then
be linked to the appropriate table fields via the attribute Object elements.

Example

In this example diagram, the invoice Object was generated by dragging the invoice attribute from the Billing Details
Class in the Project Browser onto the diagram.

The user then created Object Flow relationships between the Receive Invoice Action element and the invoice element,
and between the invoice element and the Make Payment Action element.

Notes

You can also create this relationship more directly by linking an attribute in an element to another element, or·
linking two attributes in different elements
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Classifiers and Instances

Some types of element (such as Classes) model classifications, which provide a specification of an abstract concept. For
example, the concept of a Building can be represented by a set of Classes that define types of building such as Bungalow,
Miner's Cottage, Office Block, Shop and so on. Other types of element (such as Objects) model instances of such
classifications, such as 23 High Street Shop or 45 Village Green Cottage. The instance elements represent actual objects
in a run-time scenario, based on the specification of the classifier element. For example:

An Object element represents a man called Joe Smith, as a specific instance of the concept of 'a person' defined by·
the Class element Person; the object is rendered as a rectangle showing the name of the classifier - if you name the
object it becomes <ObjectName>:<ClassifierName> or, in this example, Joe Smith:Person

If you develop a Person Class with attributes such as Age, Name, Address and Sex, and functions such as GetAge and
GetName, then when you derive an object from that Class the object takes on all the Person Class behavior and state (as
well as inherited state and behavior from the parent elements of the Person Class, if any).

Associating an instance with a classifier greatly increases the descriptive power of the model in capturing the
functionality and responsibility of objects and their associated state at run-time. This is a powerful means of moving your
model from the analysis phase into detailed design.

Notes

An object is an instance of a classifier at runtime, so the object's features are actually those of the classifier; in the·
context menu for a classified object, if you select the 'Attributes' or 'Operations' menu options, the 'Features' dialog
displays for the classifier, not the object

Similarly, if you have set the classifier for an object in a Sequence diagram, when you add a message and display its·
'Message Properties' dialog, the 'Message' drop-down list is drawn from the operations of the target object's
classifier, not from the object itself
In this way you can associate Sequence diagram objects with Classes and use the defined behavior of the Class to
model actual behavior at run time; the same concept applies to Messages for a State Flow connector

In the 'Message' dialog, you can also select to include messages defined in the inheritance hierarchy of the classifier·
for the target object
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Classify an Object

Objects can be created and classified in a number of ways. You can define a classifier first and then create instances of
that classifier. Alternatively, you might develop several separate objects that turn out to have a similar specification,
which you then formally define as a classifier. You would then classify the existing objects as instances of that new
classifier.

Methods of Classifying an object

Method Detail

Drop Classifier Onto
Diagram

Drag an existing classifier element from the Project Browser onto a diagram.
Depending on how you configure the 'Drop <element> from Project Browser'
dialog, you can create an associated object as an instance, or the instance is
automatically generated.

If your classifier contains Property elements, you also have the option of adding
some or all of these properties to the instance as 'slots'.

Classify Existing Object (Where both object and classifier already exist, separately.)

On a diagram, right-click on the object and select the 'Advanced | Instance
Classifier' option. (Or click on the object and press Ctrl+L.)

The 'Select Classifier' dialog displays. Browse or search through the model for the
classifier element to associate with the object, and double-click on it.

The object is associated with the classifier and displays the naming convention
described above.

Classify new or existing
object from classifier
Associations

A classifier is usually a component of a model structure, and can have Associations
with other classifiers.

If an object is classified, any other objects related to that object can be classified by
the related elements of the classifier. For example:

Class A is associated with Class B and Class C·
Object 1 is classified by Class A·
If you create an Association between Object 1 and Object 2, the 'Choose an·
Association Connector' dialog offers the option of setting either Class B or
Class C as the classifier of Object 2
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Add Property Slots to Instance

A classifier element can have a range of characteristics that are automatically applied to an instance based on that
classifier. You can also, optionally, add any Property elements (Ports, Parts and Expose Interfaces) on the classifier to
the instance, as 'slots' for the definition of each Property. This provides some flexibility in creating variations of the
design defined in the classifier. For example, models of car might have doors of the same specification, but in a two-door
or four-door configuration.

Add classifier Property elements to an instance

Step Action

1 Create and save the classifier element with the configuration of Property elements you need.

2 Create or assign an instance of the classifier on your work diagram.

3 Right-click on the instance and select the 'Structural Elements' option.

The 'Structural Elements' dialog displays, listing the Property elements defined for the classifier.

4 Select the check box against each Property to reproduce in the instance element, and click on the Close
button.

Each Property element is shown in the top left of the instance; drag the elements into the arrangement you
want. The Property element name within the instance is prefixed with a / character.
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Classify Object Via Classifier Associations

When building an instance model from a predefined Class model, Enterprise Architect can assist in setting classifiers and
role names for objects involved in a relationship. For example, if ClassA has association relationships with ClassB and
ClassC, you can create an instance of ClassA (ObjectA), then draw an association to a new unclassified object and have
the choice of selecting ClassB or ClassC as the classifiers of the new object.

Access

Where you have an existing association between a classified object and an unclassified object, use either method outlined
here, to display the 'Choose an Association' dialog.

Context Menu Right-click on existing Association | Advanced | Instance Classifier

Keyboard Shortcuts Select the existing Association : Ctrl+L

Choose an Association Connector dialog

Field/Button Action

Classifier Name Displays the name (if defined) of each Association connector issuing from the
source object's classifier.

If the connector has no name, the value <anonymous> displays.

Association Represents the source and target classifier elements in each Association connector
issuing from the source object's classifier.

If you select one of these, the target classifier becomes the classifier for the target
object element.

Select <none> if you want to create the Association, but not based on the classifier
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relationships.

<Source Object Name>
Role

Identifies any Roles defined in the Association for the source classifier element,
according to the source role multiplicity setting; if you select one of these roles, this
will become the specific Role for the source object, as shown on the name of the
element on the diagram.

If the multiplicity is not set, or the upper bound is * (asterisk), just the role name
displays in the list.

<Target Object Name>
Role

Identifies any Roles defined in the Association for the target classifier, according to
the target role multiplicity setting; if you select one of these roles, it will become
the specific Role for the target object as shown on the name of the element in the
diagram (and on the 'Binding' page of the Association connector 'Properties'
dialog).

If the multiplicity is not set, or the upper bound is * (asterisk), just the role name
displays in the list.

OK Click on the Association and source and target roles, then click on this button to:

Create the Association between the two objects based on the relationship·
between the two classifiers, and

Make the target classifier the classifier for the target object·
If you selected the <none> entry, a simple Association is created and the target
object is unclassified.

Cancel Cancel the dialog without changing any classifier settings.

Notes

When creating a new association or object, the 'Properties' dialog might appear before the 'Choose an Association·
Connector' dialog; complete any 'Properties' fields as required, and click on the OK button
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Behavior

Enterprise Architect enables you to define an element's behavior through the element's operations and parameters. You
can also define the behavior of more specific behavioral elements such as Activities, Interactions, Actions and
Interaction Occurrences, through the 'Behavior' and 'Call' tabs of the element 'Properties' dialogs.
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Operations

Operations are features of a Class or other element that represent the behavior or services an element supports. For a
Customer Class, UpdateCustomerName and GetCustomerAddress can be operations. Operations have several important
characteristics, such as type, scope (visibility), static, abstract and notes.

Access

Ribbon Design > Element > Operations

Context Menu Right-click element in diagram | Features and Properties | Operations  or

Right-click element in Project Browser | Operations or

Right-click operation in Project Browser | Operation Properties

Keyboard Shortcuts F10

Other In Project Browser, double-click on an Operation

Create and Modify Operations

You create and modify the operations of an element on the 'Operations' tab of the 'Features' dialog. This tab itself
contains panels and tabs that you can use to completely define the operations you need for an element.

Appearance on diagram

In diagrams, elements with operations (typically Classes) list the operations in the second properties compartment, in
colored text, as shown.

The default text color is dark green, as in the example. Some characteristics modify the display; for example, static
operations display underlined, whilst abstract operations are italicized.

Appearance in Project Browser

In the Project Browser, operations are listed underneath their parent element name, each preceded by a pink box ( ).
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Notes

If the parent element provides source or target roles for a connector, the connector can be attached to a specific·
operation

You can also drag, copy or move existing operations between elements; this facility is only available if the target·
element supports operations
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Define Properties of Operations

You create and modify the operations of an element on the 'Operations' tab of the 'Features' dialog. This tab itself
contains panels and tabs that you can use to completely define the operations you need for an element. You can,
however, simply create a number of operation names if you want to create operations quickly and not necessarily fully
define them as you create them.

Access

Ribbon Design > Element > Operations

Context Menu Right-click element in diagram | Features and Properties | Operations  or

Right-click element in Project Browser | Operations or

Right-click operation in Project Browser | Operation Properties

Keyboard Shortcuts F10

Other In Project Browser, double-click on an Operation

Create and define Operations

Field/Button Action

Name Overtype the New Operation... text to create a new operation, or click on the name
to edit an existing operation.

Parameters Lists the parameters that have been defined for this operation on the 'Parameters'
tab.

Return Type (This option is not shown for State or StateMachine elements.)

Defaults to 'void'. To change this, overtype the field or click on the drop-down
arrow and click on:

The required data type returned by the operation, as defined by the code·
language (data type) or

'<none>' for no type (or you can type in a value manually if you prefer), or·
'Select Type' and browse for the appropriate operation classifier (you can add a·
new one if there are no classifiers that suit)

To add new code language data types that can be displayed in this list, see the Data
Types topic.

Action Define the action of the operation: do, exit or entry.

(Displayed for operations of State or StateMachine elements.)

Scope Click on the drop-down arrow and select one of:

Public·
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Protected·
Private·
Package·

Stereotype (Optional) Define one or more stereotypes for the operation; either:

Type a stereotype name, or·

Click on the  button and select the stereotype from the 'Stereotype Selector'·
dialog

Alias (Optional) Type an alternative name or reference for the operation.

Method <operation name>
panel

Define the detailed properties of the selected operation.

Parameters tab Define parameters to modify how the operation takes action.

Notes tab Enter any comments and discussion you want to record on the operation; you can
format the notes text using the Notes toolbar at the top of the field.

You can also perform a range of operations on the Notes text, using the 'Notes'
context menu.

Behavior tab Define the behavior or functionality of the operation.

Redefines tab (Optional) In a Generalize relationship, configure the selected operation to redefine
an operation in the target element.

You can also set up the operation to check for an exception, and at that point switch
control to a specified Classifier.

Pre tab Define pre-conditions that modify the action of the operation.

Post tab Define post-conditions that modify the action of the operation.

Tagged Values tab Define any Tagged Values that the operation has.

Close Click on this button to close the 'Features' dialog, saving all information you have
recorded in it.

Context Menu options

Right-click on the upper panel, or on a specific operation name.

Option Action

Add New Add a new operation to the list, with default values in the dialog fields.

Shortcut: Ctrl+N

Copy as New Copy a selected operation as a new operation. Provide a new name for the operation
and click on the OK button.

Shortcut: Ctrl+C
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Restore Sort Order If you have used the column header arrows to reorganize the sequence in which the
operations are displayed, click on this option to redisplay them in the default
sequence (alphabetical by name).

Move up Move the selected operation one row up the list.

Shortcut: Ctrl+Up Arrow

Move down Move the selected operation one row down the list.

Shortcut: Ctrl+Down Arrow

Field Chooser Display the 'Field Chooser' dialog, which contains any column headings not
currently applied to the page.

Drag a column heading from the 'Field Chooser' into the preferred position in the
row of column headings. You can also drag the column headings into a different
sequence.

To return a column heading to the 'Field Chooser', drag it out of the heading row.

Enable Group Box Show or hide the Group Box, in which you reorganize the list sequence  of the
operations according to one or more characteristics.

Toggle Filter Bar Show or hide the Filter Bar, in which you type text strings that the data in the
corresponding column must match in order to be listed.

Delete Immediately delete the selected operation from the element.

Shortcut: Ctrl+Del

Notes

This helps you when you want to create operations quickly and might not necessarily want to fully define each one as
you create it
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Operation Details

In defining the behaviors of the model elements you create, you can also define how the operations translate into
methods in code. For this, you set options on the 'Method <operation name>' panel of the 'Operations' tab of the
'Features' dialog.

Access

Ribbon Design > Element > Operations

Context Menu Right-click element in diagram | Features and Properties | Operations  or

Right-click element in Project Browser | Operations or

Right-click operation in Project Browser | Operation Properties

Keyboard Shortcuts F10

Other In Project Browser or in a diagram, double-click on an Operation

Define Detailed Properties

Option Action

Concurrency Click on the drop-down arrow and select the concurrency of the operation -
Sequential, Guarded or Synchronous.

Virtual If the operation's language is set to C++, click on the drop-down arrow and map to
the C++ Virtual keyword.

Otherwise this option is 'Abstract'.

(This option is not shown for State or StateMachine elements.)

Abstract Pertaining to an abstract function. Click on the drop-down arrow and set to True or
False.

(This option is not shown for State or StateMachine elements.)

Static Indicate whether the operation is a static member. Click on the drop-down arrow
and select True or False

(This option is not shown for State or StateMachine elements.)

Modifiers
Click on the  button to display the 'Select Modifiers' dialog, and select the
appropriate checkboxes:

'Pure' - indicates that the method statement is pure virtual syntax. For example:·
          virtual void myFunction() = 0;

'Const' - indicates that the return type of the method is constant·
'Is Query' - indicates that the method does not modify the object·
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'Return Array' - indicates that the method's returned value is in the form of an·
array

'Synchronized' - for Java, sets a code engineering flag that relates to multi·
threading

(These options are not shown for State or StateMachine elements.)

Advanced Click on the drop-down arrow and select True for each coding convention to assign
as a Tagged Value on the operation (corresponding to a coding keyword).
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Operation Behavior

You can define the behavior of an operation in one of two ways:

As a text description consisting of pseudo-code, structured English or just simple text·
As a reference to a behavior element, such as an Activity or Interaction, or to another operation·

You can set an option to show the behavior text or reference on the depiction of the parent element on a diagram. In this
State element example, the entry operation applies the behavior of the ActivityComp Activity, whilst the exit behavior is
described in simple text.

You can also define initial code to be inserted into an operation Body when that operation is initially generated to file;
after that initial generation the code is no longer used and, if other behaviors have been defined, they are applied instead.

Access

Ribbon Design > Element > Operations > Behavior

Context Menu Right-click element in diagram | Features and Properties | Operations | Behavior or

Right-click element in Project Browser | Operations | Behavior or

Right-click operation in Project Browser | Operation Properties | Behavior

Keyboard Shortcuts F10 > Alt+B

Other In Project Browser, double-click on an Operation | Behavior

Set Behavior

Either:

In the 'Behavior' field, type the text or code description of the behavior, or·
Click on the Element button to display the 'Select Behavior' dialog, then browse for and select the appropriate·
element or operation; when you click on the OK button, the fully qualified object name displays in the 'Behavior'
field

If you want to use initial code, click on the Initial Code button and enter the code on the 'Initial Code' screen.

If you want the behavior to be shown on any diagram that the operation appears in, select the 'Show Behavior in
Diagram' checkbox.

When you have defined the operation behavior, click on the Save button.

Delete behavior
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If you have typed in a behavior description in free text, simply delete the text.

If you have selected another behavioral object, click on the Element button and select the '<none>' option at the foot of
the 'Select Element' hierarchy.

Example of Associated Behavior

An operation of, for example, a Class can be associated with a behavior elsewhere in the model. The operation is then set
as the specification of that associated behavior. In code generation, the behavior of the associated behavioral element is
generated as the operation's code; in this illustration, op1 is associated with the Activity 'Activity'.
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The generated code for op1 is as shown:

    package Behavior;

    public class Container {

         public Container() {

         }

         public void finalize() throws Throwable {

         }

         public void op1() {

         /*Activity element(Activity)'s behavior rendered as

              operation(op1)'s code*/

              //Action1;

              if (cond1)

              {

                   //Action2;

              }

              else

              {

                    //Action3;

              }

              //Action4;

         }

         /*Activity element (Activity) not rendered*/

         public void Activity2()

         {

              // behavior is an Activity

         }

         public void Interaction()

         {

              // behavior is an Interaction

         }

    } //end Container
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Initial Code

The 'Initial Code' screen is used to enter the code that is inserted into an operation Body when that operation is initially
generated to file. After this point, the initial code is no longer referenced during forward code generation and
synchronization. This code is most useful when combined with Design Patterns; elements within a Pattern often require
the same stub code. The initial code is also useful for ensuring that the generated code is directly compilable. The
language-specific Patterns available from the web site resources include initial code for some of the defined operations;
this helps speed up the process of applying Patterns from model to implementation.

By default, the initial code also is not imported into the model during reverse engineering, but you can select to import
the code by ticking the 'Include method bodies in model when reverse engineering' checkbox on 'Attribute/Operations'
page of the 'Preferences' dialog.

Access

Project Browser | Right-click on Operation | Operation Properties > Behavior: Initial Code

On the 'Initial Code' screen, type in the code to use on initial generation. When you have finished entering code, click on
the OK button.

On the 'Behavior' tab, the Initial Code button shows an asterisk (*) indicating that initial code exists for the operation.

Ribbon Design > Element > Operations > Behavior : Initial Code

Context Menu Right-click element in diagram | Features and Properties | Operations | Behavior :
Initial Code  or

Right-click element in Project Browser | Operations | Behavior : Initial Code or

Right-click operation in Project Browser | Operation Properties | Behavior : Initial
Code

Keyboard Shortcuts F10 > Alt+B : Initial Code

Other In Project Browser, double-click on an Operation | Behavior : Initial Code
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Redefine Operation and Check for Exceptions

If the parent element of a selected operation is the source element for a Generalize connector, you can configure the
operation to redefine an operation in the target element. Also, you can create code in your application to check for an
exception and, if one occurs, to switch to the code defined by a Classifier element. You can identify the target operation
and/or the classifier element on the 'Redefines' tab.

Access

Ribbon Design > Element > Operations > Redefines

Context Menu Right-click element in diagram | Features and Properties | Operations | Redefines
 or

Right-click element in Project Browser | Operations | Redefines or

Right-click operation in Project Browser | Operation Properties | Redefines

Keyboard Shortcuts F10 > Alt+R

Other In Project Browser, double-click on an Operation | Redefines

Tasks

Task Action

Redefine a target element
Operation

Click on the operation, and on the Add button beneath the 'Redefined Operation'
panel.

The 'Select Operation' dialog displays, showing the operations in the target element.

Click on the appropriate operation; if you want to redefine more than one operation
in the target element, press Ctrl as you click on each one.

Click on the OK button.

A statement displays in the 'Redefined Operation' panel, of the format:

    <Package>::<Target Element>.<Operation>

On the parent element in a diagram, the Operation compartment shows the
complete statement, of the format:

    <Operation>:{redefines <Package>::<Target Element>.<Operation>

If you want to change the redefined operation(s) at any point, return to the
'Redefines' tab and again click on the Add button, and repeat the process. The
original selection is replaced by the new selection.

Identify Exception
Classifier

Click on the operation and on the Add button beneath the 'Raised Exception' panel.

The 'Select Classifier' dialog displays; browse or search through the model
hierarchy for the appropriate Classifier.

Click on the OK button; the name of the parent Package and the Classifier displays
in the 'Raised Exception' panel.

If you want to change the Classifier at any point, return to the 'Redefines' tab and
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again click on the Add button, and repeat the process. The original selection is
replaced by the new selection.
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Operation Constraints

Constraints define the contractual behavior of an operation, what must be true before they are called (pre-conditions) and
what is true after they are called (post-conditions). In this respect they are related to the State model of a Class and can
also relate to the guard conditions that apply to a transition. You can define both pre- and post- conditions for an
operation.

Access

Ribbon Design > Element > Operations

Context Menu Right-click element in diagram | Features and Properties | Operations  or

Right-click element in Project Browser | Operations or

Right-click operation in Project Browser | Operation Properties

Keyboard Shortcuts F10

Other In Project Browser, double-click on an Operation

Define Constraints

The fields and options on the 'Pre' and 'Post' tabs of the dialog are identical. Click on the appropriate tab to define the
conditions prior to and following on from the operation behavior.

Option Action

Pre-Condition:

Post-Condition:

Type in the name or effect of the condition.

Type Click on the drop-down arrow and click on the appropriate condition type.

<notes> Type in any further explanation or description that is necessary for the condition.

New Click on this button to clear the fields to define another condition.

Save Click on this button to save the new or updated condition and to add the changes to
the 'Pre-Condition' or 'Post-Condition' list.

This button also clears the data fields so that you can create another condition.

Pre-Condition

Post-Condition

Lists the pre-conditions or post-conditions that have been defined for this operation.

Click on an item in this list to re-populate the dialog fields with the details, to edit
or delete the condition.

Delete Click on an item in the Pre-Condition or Post-Condition list and click on this button
to delete that condition from the operation.
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Operation Tagged Values

Both operations and the parameters assigned to operations can have Tagged Values associated with them. Tagged Values
offer a convenient extension mechanism for UML objects, so you can define any tags you need and then assign values to
them using this form.

Tagged Values are written to the XMI output, and can be input to other third party tools for code generation or other
activities.

Access

Ribbon Design > Element > Operations | Tagged Values

Context Menu Right-click element in diagram | Features and Properties | Operations | Tagged
Values  or

Right-click element in Project Browser | Operations | Tagged Values or

Right-click operation in Project Browser | Operation Properties | Tagged Values

Keyboard Shortcuts F10 > Alt+V

Other In Project Browser, double-click on an Operation | Tagged Values

Add a Tagged Value for an operation

Step Action

1 Click on the operation or parameter to which to assign the Tagged Value.

2 Click on the New Tagged Value button.

The 'Tagged Value' dialog displays.

3 In the 'Tag' field, type the tag name (or select a defined tag from the drop-down list).

In the 'Value' field type the initial tag value.

4 Click on the OK button to confirm the operation.

Notes

Tagged Values are supported for attributes, operations, objects and connectors·
You can define custom tags using a predefined Tagged Value Type·
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Override Parent Operations

You can automatically override methods from parent Classes and from realized Interfaces, using the 'Override
Operations/Interfaces' dialog. You can configure the system to display this dialog each time you add a Generalization or
Realization connector between Classes, and review their possible operations/interfaces to override/implement.

Access

Use any of the methods outlined here to display the 'Overrides & Implementations' dialog.

On the dialog, you simply:

Select the checkbox against each operation or interface to automatically override (or click on the Select All button)·
and click on the OK button; Enterprise Architect generates the equivalent function definitions in your child Class

To display the dialog automatically, from the Start ribbon, select 'Workspace > Preferences > Preferences : Links' and
select the 'Show Override Operation dialog on new connector' checkbox.

Ribbon Design > Element > Manage > Overrides and Implementations

Keyboard Shortcuts Ctrl+Shift+O
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Display Inherited Operations

You can configure a selected element in a diagram to display the complete operation set obtained from all ancestors in
the element's type hierarchy, as well as those directly owned.

Access

Context Menu Right-click on element on diagram | Features and Properties | Feature &
Compartment Visibility

Keyboard Shortcuts Ctrl+Shift+Y

Enable Behavior

On the 'Feature and Compartment Visibility' dialog, in the 'Inherited Features' panel, select the 'Show Operations'
checkbox.

Example

This diagram illustrates the behavior, where it has been enabled for each element in a simple hierarchy. The Child
element inherits from all other levels of the hierarchy.
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Interactions and Activities

The behavioral aspects of Interactions and Activities are modeled using the 'Behavior' tab of the element's 'Properties'
dialog, on which you assign parameters and return types to the elements.

Access

Select an Interaction or Activity element on a diagram or in the Project Browser, then display the 'Behavior' page of the
element's 'Properties' dialog, using any of the methods outlined here.

On the 'Behavior' page of the dialog, click on the Edit Parameters button to edit the element's parameters. When you
create a new parameter using the dialog, it internally creates an Activity Parameter Node for an Activity or an Interaction
Parameter for an Interaction.

In the 'Return' field, click on the drop-down arrow and select the return type of the element. Alternatively, click on the

'Select Behavior'  button and use the 'Select Type' screen to locate the appropriate classifier.

The 'Specification' field is populated automatically when an operation is associated with the Activity as a behavior.

Ribbon Design > Element > Manage > Properties > Behavior

Context Menu Right-click on Activity element | Properties > Behavior

Keyboard Shortcuts Alt+Enter > Behavior

Other Double-click on Element > Behavior
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Behavior Calls

A behavior call is the invocation of a behavior. You can represent an invocation with a CallOperation Action
(Operation), CallBehavior Action (Activity) or Interaction Occurrence (Interaction) element. You model the properties of
the behavior call using the 'Call' tab of the element 'Properties' dialog. You use behavior calls to:

Edit Arguments·
Re-associate the call with a different behavior·
Synchronize the arguments with the parameters in the associated behavior·

Editing a Behavior Call

Click on the Edit button to create and delete arguments, and relate them to a corresponding parameter in the associated
behavior.

Click on the  button to re-associate the invocation with a different behavior or to remove any association with the
current behavior.

The 'Interaction Occurrence' panel is displayed only for Interaction Occurrence elements. It enables you to enter the
return value and attribute of the behavior call.
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Associate with Different Behaviors

On the 'Call' tab of the 'Behavior Call Properties' dialog, when you click on the  button the 'Select Element' dialog
displays, listing all available behaviors in the model.

Select '<none>' to remove any existing association between an invocation and a behavior, or select another classifier to
re-associate the invocation with a different behavior.

The Synchronize with Parameters button is enabled only if a valid behavior is identified in the 'Behavior' field.
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Synchronize Arguments

In your project, you can synchronize the parameters and arguments in a behavioral invocation.

On the 'Call' tab of the element 'Properties' dialog, click on the Synchronize with Parameters button to synchronize the
number of arguments in the invocation element with the number of parameters in the associated behavior.

This automatically creates or deletes arguments based on the number of parameters in the behavior.

If any arguments are to be deleted, Enterprise Architect prompts you to confirm the operation. Click on the Yes button to
confirm.

Notes

The Synchronize with Parameters button is enabled only if the invocation is associated with a valid behavior, as·
identified in the 'Behavior' field
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Behavior Call Arguments

You define the arguments of a Behavior Call using the 'Arguments' dialog, which you display by clicking on the Edit
button on the 'Call' tab of the element 'Properties' dialog.

Define the arguments of a Behavior Call

Step Action

1 In the 'Name' field, type the name of an argument to map to the behavior.

2 In the 'Parameters' field, click on the drop-down arrow and select a behaviors parameter from the list of
parameters associated with the behavior.

3 In the 'Value' field, set any required value.

4 If a diagram is displayed, and if required, select the 'Show in current diagram' checkbox to add an Action
Pin on the diagram.

5 Click on the Save button.

6 If appropriate, click on the New button and repeat steps 1 to 5 for another argument:parameter mapping.

Notes

If you attempt to map a newly created argument to a parameter that is already associated with a different argument,·
Enterprise Architect identifies the mapping and prompts you to confirm that you intend to change the association
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Behavior Parameters

Within the 'Operations' tab of the 'Features' dialog, you have a number of facilities for defining, editing and extending the
parameters of behavioral operations, Activities and Interactions.
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Define Parameters

Within the properties of an operation, Activity or Interaction, you can define parameters to control how that object and
its subordinate objects behave.

The order or sequence of the parameters in the object properties is reproduced in code. You can set and manage the order
using facilities available within the 'Parameter' tab of the object 'Features' dialog.

Access

Ribbon Design > Element > Operations > [select or create an operation] > Parameters

Context Menu Right-click on element | Features & Properties | Operations | [select or create an
operation] > Parameters

Keyboard Shortcuts F10 | [select or create an operation] > Parameters

Define the Parameters

Option Action

Parameter Overtype the New Parameter text with the new parameter name.

Type Click on the drop-down arrow and click on:

The required data type of the operation, as defined by the code language (data·
type)  or

<none> for no type (or you can type in a value manually if you prefer), or·
Select Type and browse for the appropriate operation classifier (you can add a·
new one if there are no classifiers that suit)

To add new code language data types that can be displayed in this list, see the Data
Types topic.

Default Value (Optional) Type a default value for the parameter.

Stereotype
(Optional) Type in the appropriate stereotype name, or click on the  button and
select one using the Stereotype Selector.

Alias (Optional) Type an alternative name or reference for the parameter.

Direction Click on the drop-down arrow and select the way the parameter is passed to a
function:

In = By Value·
InOut = By Reference·
Out = Passed By Reference, but only the return value is significant·
Return - Indicates that the parameter is a returned value·
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Fixed Value Click on the drop-down arrow and select True, even if the parameter passed by
reference.

Multiplicity
Click on the Selector  button to display the 'Multiplicity' dialog, and specify the
multiplicity of the parameter.

Notes
Click on the Selector  button and type any additional notes on the parameter.
These notes are unformatted.

Define Multiplicity

Option Action

Lower bound Type a lower limit to the number of elements allowed in the collection.

Upper bound Type an upper limit to the number of elements allowed in the collection.

Allow Duplicates Select the checkbox if you want to allow duplicates.

This maps to the UML property 'isUnique', with the value False.

Multiplicity is Ordered Select the checkbox if you want to indicate that the collection is ordered.

OK Click on this button to save the changes and close the dialog.

Notes

To organize parameters into the required sequence, and reorganize the display of information, right-click on the·
background of the 'Parameter' tab or on a specific parameter and select from the same context menu options as for
the 'Operations' panel

Set the amount of parameter detail to display in a specific diagram using the 'Show Parameter Detail' drop-down list·
on the 'Features' tab of the 'Diagram Properties' dialog; the setting applies only to the current diagram, and the
default is to show the type only

You can set Tagged Values on a parameter, as well as on the parent operation·
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Parameter Tagged Values

Behavioral parameters of operations, Activities and Interactions can have Tagged Values associated with them. Tagged
Values offer a convenient extension mechanism for UML elements; you can define any tags you need and then assign
values to them.

Tagged Values are written to the XMI output, and can be input to other third party tools for code generation or other
activities.

Access

Display the Tagged Values window using any of the methods outlined here. Then, in the Project Browser or a diagram,
select the object containing the parameter.

Ribbon Start > Windows > Tagged Values

Show > Window > Tagged Values

Keyboard Shortcuts Ctrl+Shift+6

Other On diagram or Project Browser | Double-click object containing parameter >
Tagged Values

Add a Tagged Value for a parameter

Step Action

1 The 'Tagged Values' tab shows the Tagged Values for the selected object and its parameters.

Click on the required parameter in the 'Parameters' section, and click on the New Tags button.

The 'Tagged Value' dialog displays.

2 In the 'Tag' field, type the tag name (or select a defined tag from the drop-down list).

In the 'Value' field type the initial tag value.

3 Click on the OK button to confirm the Tagged Value.

Notes

Tagged Values are supported for attributes, operations, objects and connectors·
Custom tags can be created using a predefined Tagged Value Type·
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Operation Parameters by Reference

In your project, you can set operational parameters to be passed 'By Reference', as a global setting.

Access

Ribbon Start > Workspace > Preferences > Preferences > Objects > Feature reference
indicator

Define Parameters

Image Detail

parambyreference3 You can select to highlight parameters declared as 'Kind: inout' or 'Kind: out' with
an additional user-defined prefix or suffix.

If you select the 'Highlight References' checkbox, you can also indicate whether a
prefix or suffix should be used, and the actual reference character to use. In the
example image, the '&' character has been set as a prefix.

When you declare a parameter of type 'inout', it is assumed you are passing the
parameter by reference rather than by value. If you have elected to highlight
references, then this is displayed in the Diagram View.

The example shows that, in the getName operation, the parameter 'strName' is a
string reference, and is highlighted using the chosen character and position.

Notes

This facility applies to operations only·
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Hyperlinks

Hyperlinks are very simple structures, but they add an incredible versatility to both navigation of your model and the
provision of information through the various methods of communication within your project. You can create hyperlinks:

As elements or references in diagrams·
In the text of notes and descriptions in the properties of modeling objects and project management objects·
In the element specifications in the Specification Manager·
In the text of linked documents or generated reports, through the document and template editors·
In Model Mails and Team Review postings·

In each case, the targets of these hyperlinks might be:

Packages, elements, diagrams, attributes or operations in the model·
Specific topics in the Enterprise Architect Help·
External files·
Web sites·
Team Review postings·
Diagram images and other graphics·
Commands to initiate operations and processes in Enterprise Architect·
Model Searches to run·
Matrix profiles to display·
Learning Center topics·

Between any two contexts, the way in which you create the hyperlink and the range of objects you can link to might
differ, but the common benefit is that you are providing a wealth of information on a specific point without
overburdening:

The object with a lot of text in one volume·
Yourself in having to re-create and maintain the information in every instance of its use·
Your readers with too much information at once·

Table of Methods

Create a Hyperlink Description

As an element on a
diagram

To create a Hyperlink element on a diagram and assign a target object to it, either:

Drag the 'Hyperlink' icon onto the diagram from the 'Common' page of the·
Diagram Toolbox, or

Click on the icon in the 'UML Elements' Toolbar and then click on the diagram·
You provide the text of the link directly on the diagram, then double-click on the
element to display the element 'Hyperlink Details' dialog on which you identify the
type of target object, the target itself and any other necessary properties of the link.
Note that initially the link text is held in the 'Alias' field and can be edited there, but
if you select certain types of target object the link text is read from the 'Notes' field.

After you have defined the target object, double-clicking on the element executes
the link; to edit the element's properties, right-click on it and select the 'Properties'
option. For most type of link, the element displays as shown here:
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Certain types of link, however, have their own icon; for example, a Hyperlink

element linking to a diagram and a link to a Help topic ( ).

On a diagram to another
diagram

To create a link to another diagram on the current diagram:

Drag the target diagram on to the current (host) diagram. The 'Select Type'1.
dialog displays.

Select the 'Hyperlink' option and click on the OK button.2.

The final hyperlinked diagram should now have a link referencing the target
diagram, like this:

The link will open (in this case) the 'Location' diagram in the 'Location' Package.
The target diagram name is written to the element 'Notes' field, and you can edit
this field in the element properties to an alternative link text.

A hyperlink to a diagram, whether created by this method or by dragging the
'Hyperlink' icon onto the diagram, has a different icon to the standard Hyperlink
element icon, although in all other respects it is the same type of element.

(If the hyperlink displays as a Sub Activity, select the 'Start > Workspace >
Preferences > Diagram > Behavior' ribbon option and deselect the 'Use Automatic
SubActivities' checkbox.)

On a diagram to a file To create a hyperlink on a diagram to an external file, simply click on the file in a
file list (such as Windows Explorer) or on your Desktop and drag it onto the
diagram.

A short context menu displays with two options - 'Hyperlink' and 'Artifact'. Click
on the 'Hyperlink' option to create the hyperlink on the diagram.

The link is effective immediately, and you can right-click on it to add or change
properties as necessary.

Files of most types - including .sql and .ddl - are opened within the appropriate
Enterprise Architect code editor.

On a diagram to a Script You can create a hyperlink on a diagram to execute a script. Simply drag the
required script from the Execution Analyzer window onto the diagram. A context
menu displays, from which you select whether the script to be executed is a Build,
Test, Run, Debug or Deploy script. The hyperlink is effective immediately; when
you click on it, the script executes.

As an Action element on a
diagram

Drag an Action element from the 'Activity' page of the Toolbox onto the diagram; a
context menu displays (if not, hold Ctrl as you drag the Action onto the diagram).

Select the 'Other' option; the 'New Action' dialog displays, with the 'Other' radio
button selected.

Click on the drop down arrow on the text field in the 'Select Kind' panel, and click
on the 'Hyperlink' option.

Click on the OK button; the Hyperlink Action element displays on the diagram.

Right-click on the element and select the 'Advanced | Set Hyperlink' menu option;
the 'Hyperlink Details' dialog displays. Set the hyperlink's properties.

From Notes to a specific
element

Within the text of the 'Notes' field of an object's 'Properties' dialog, or in the Notes
window, you have three options for creating a hyperlink to another element:

Right-click on a highlighted text string and select the 'Create | Link to Existing·
Element' option, to link to an element anywhere in the model

Right-click on a highlighted text string and select the 'Create | New Element·
from Selection' option, to create a new element in the same Package and link to
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it; the name of the element is the highlighted text

Click on the 'Hyperlink' icon in the 'Notes' toolbar to display the in-text·
'Hyperlink Details' dialog, select 'Element' in the 'Type' field, and select the
existing element to link to; the element name forms the link text in the 'Notes'
text, at the cursor position

In Notes/Description text In a 'Notes', 'Description' or similar text field, you can also click on the 'Hyperlink'
icon in the 'Notes' toolbar to create links to a range of types of object other than
'Element'. You can use full paths or local (path substitution) paths, and you can
either select or type the link text, or leave the text blank to use the link address as
the text.

Within the Specification
Manager

As you build the specification of an element and create Notes text to describe it,
you can add hyperlinks to a wide range of target objects to support and enhance the
specification. Highlight the link text, right-click on it and select the 'Create |
Hyperlink' option. The 'Hyperlink Details' dialog displays, on which you specify the
target object type and the object itself.

In a report document When you generate a report on a section of your model, the Document Generator
either:

Activates any hyperlink in that part of the model and includes the linked object·
(generally a diagram image) in the report, or

Displays the hyperlink as a reference to the linked object (most other links)·
You can, however, add other hyperlinks directly to either the generated report or
the report template, to display material external to the model; namely a web page,
Enterprise Architect Help topic, or a document file. To do this, you right-click on
the appropriate point in the report and select the 'Insert | Hyperlink' option; then
specify the access path of the object to link to.

Within a Linked Document When you have created a linked document for an element, you can add hyperlinks
in the text of that document to other elements in the model, and to web pages, Help
files, Model Searches and Team Review Forums. When you next open the linked
document, you can double-click on the hyperlink to open the linked files or to
locate and highlight the object in the Project Browser.

To create a link to an element, you can simply drag the element from the Project
Browser into the document. Alternatively, right-click in the text and, for an
element, select the 'Create| Link to Existing Element' option or, for links to other
objects, select the 'Create | Hyperlink' option.

In a Team Review post The Team Review facility provides a number of options for creating links out of
dragged objects or specifically providing link text and a link address within a
document or post. The 'Resources' folder underneath a Team Review Post consists
entirely of links you create to objects of relevance to the post.

In a Model Mail When you are using Model Mail to discuss a modeling object or supporting
information, you can add a hyperlink to your text to open the object that you are
discussing.

A quick way to create a hyperlink is to select the modeling object in the Project
Browser, place the cursor at the appropriate position in your message text, click on
the Insert Quick Link button and select the name of the modeling object. The
hyperlink to the object is immediately created at the cursor position.

If you need to search for the modeling object, or you want to link to a different type
of target such as a file, Model Search or Team Review message, click on either:

The 'Hyperlink' icon in the toolbar or·
The Insert Quick Link button and select the 'Other' option·
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The 'Hyperlink Details' dialog displays. Use this to create the required link.
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Hyperlink Target Objects

Some of the hyperlink facilities in Enterprise Architect are filtered to create a link between two specific types of object.
Other facilities, however, give you a choice of types of target object with minor variations in the information you provide
to identify the target. The widest variety of target types is available from the:

Element 'Hyperlink Details' dialog displayed when you create a Hyperlink element on a diagram, and·
In-text 'Hyperlink Details' dialog displayed when you create a hyperlink in the element Notes, either from the Notes·
Toolbar or in the Specification Manager

The in-text 'Hyperlink Details' dialog does not prompt for the link text, so you either highlight a word or phrase in the
text to act as the link text before you create the hyperlink, or you allow the name or path of the linked object to become
the link text.

Most hyperlinks can only be actioned within the diagram or element in which they are created, but links to diagram
images and Image Manager images are also actioned within a generated report and actually show the linked image.

Identify Target Objects

This table provides instructions for specifying the target object of a hyperlink, for each of the available types of object,
using either of the two 'Hyperlink Details' dialogs.

Link to Action

An attribute In the 'Type' field, click on the drop-down arrow and click on 'Attribute'. The 'Set
Attribute' browser displays, in which you locate and click on the required attribute.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the attribute is highlighted in the Project Browser.

A source path In the 'Type' field click on the drop-down arrow and click on 'Browse for File'. A
file browser opens, from which you select the source directory containing a number
of files that the user might want to open.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If a user activates the link, a 'Locate File' dialog displays at the specified source
directory, and the user can select any of the files in that directory to open within
Enterprise Architect or a registered external application.

An element image In the 'Type' field, click on the drop-down arrow and click on 'Element Image'. The
'Select an Element' browser displays, in which you locate and click on the required
image-stereotyped Artifact element.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the element 'Properties' dialog opens. In a generated report,
the element image displays instead of the link.

A diagram In the 'Type' field, click on the drop-down arrow and click on 'Diagram'. The 'Select
a Diagram' browser displays, in which you locate and click on the required
diagram. You can filter the browser to show all diagrams in the model or only those
of a small number of specific types.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the diagram opens. In a generated report, an in-text link acts
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as a simple reference to the diagram.

A diagram image In the 'Type' field, click on the drop-down arrow and click on 'Diagram Image'. The
'Select a Diagram' browser displays, in which you locate and click on the required
diagram. You can filter the browser to show all diagrams in the model or only those
of a small number of specific types.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the diagram opens. In a generated report, an image of the
diagram displays instead of the link.

An Enterprise Architect
command

In the 'Type' field, click on the drop-down arrow and click on 'EA Command'. In
the unlabelled 'Address' field, click on the drop-down arrow and select the required
command from the list. If the command is not part of the default set, click on the
drop-down arrow in the second field and select the technology that provides the
command. For some commands you might have to provide further parameters, in

which case the  button displays; click on this button and complete the resulting
dialog.

Click on the OK button to create the hyperlink.

If you activate the link, the system actions the command and displays the resulting
screen, dialog or message.

An element In the 'Type' field, click on the drop-down arrow and click on 'Element'. The 'Select
Element' browser displays, in which you locate and click on the required element.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link on a diagram, the element is highlighted in the Project
Browser.

If you activate an in-text hyperlink, the system will act on the element according to
its type, with the same result as if you double-click on the element in the Project
Browser. For example, if you click on the hyperlink to a Document Artifact
element, the document, specification or matrix that the Artifact represents opens; if
you click on a hyperlink to a Chart element, its 'Properties' dialog opens at the chart
'Source' page.

A file 'File' is the default setting for the 'Type' field.

In the 'Address' field, type or paste the file path and file name to access, or click on

the  button to browse for the file. (If you click on the 'Type' drop-down arrow
and select 'File', the browser displays automatically.)

Click on the OK button to create the hyperlink.

If you click on a link created through the in-text 'Hyperlink Details' dialog, the file
opens in an editor. In the element 'Hyperlink Details' dialog you can specify
whether the file will be opened for editing or just for viewing.

A Help topic In the 'Type' field, click on the drop-down arrow and click on 'Help'. In the
'Address' field, type or copy the .htm file name of the Enterprise Architect Help
topic to link to; for example, add_a_legend.htm. You can get this address by
displaying the Help topic and copying the contents of the address field at the top of
the screen.

Click on the OK button to create the hyperlink.

If you activate the link, the Help topic opens from the Sparx Systems website.

In the 'Type' field, click on the drop-down arrow and click on 'Image Manager'. The
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An Image Manager Image 'Image Manager' dialog displays, in which you locate and click on the required
image name.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the View Image window displays, showing the selected
image. In a generated report, the image is also displayed instead of the link.

A Learning Center topic In the 'Type' field, click on the drop-down arrow and click on 'Learning Center'.
The path of the default Learning Center topic (Use the Learning Center) displays in
the 'Address' field. Click on the 'arrow-head' symbols in the path to display the
contents of each child section and browse to the topic you want to link to.

Click on the OK button to create the hyperlink.

If you activate the link, the Learning Center view opens, displaying the topic.

A Relationship Matrix
profile

In the 'Type' field, click on the drop-down arrow and click on 'Matrix'. The 'Select a
Matrix Profile' dialog displays; click on the drop-down arrow and on the required
profile name.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the Relationship Matrix displays with all fields set
according to the selected profile.

An Operation In the 'Type' field, click on the drop-down arrow and click on 'Operation'. The 'Set
Operation' browser displays, in which you locate and click on the required
operation.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the operation is highlighted in the Project Browser.

A Package In the 'Type' field, click on the drop-down arrow and click on 'Package'. The 'Find
Package' browser displays, in which you locate and click on the required Package.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the Package is highlighted in the Project Browser.

A Model Search In the 'Type' field, click on the drop-down arrow and click on 'Search'. The 'Select a
Search' dialog displays, in which you specify the search term, the search category
that contains the search, and the name of the search itself.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the Find in Project view displays with the results of the
executed search.

A Team Review Posting In the 'Type' field, click on the drop-down arrow and click on 'Team Review'. The
'Select a Topic to Link' browser displays, in which you locate and click on the
required review document.

Click on the OK button to return to the 'Hyperlink Details' dialog, and again to
create the hyperlink.

If you activate the link, the Team Review view displays, showing the linked
document. The Team Review window also displays. showing where the document
came from and providing the opportunity to select and display related documents.

A web site In the 'Type' field, click on the drop-down arrow and click on 'Web Site'. In the
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'Address' field, type or paste the web address of the site.

Click on the OK button to create the hyperlink.

If you activate the link, the selected web page displays in a separate window.

Notes

To activate a Hyperlink element, double-click on it; to activate an in-text link, press Ctrl as you click on it·
When creating a hyperlink, for most target objects the system automatically opens a browser to populate the·

'Address' field; when you edit the hyperlink, use the  icon at the end of the field to display the browser and
change the target object
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Hyperlinks Between Diagrams

Create a hyperlink between diagrams

Step Action

1 Open the diagram in which to display the hyperlink to another diagram.

From the Project Browser select the diagram you want to create a hyperlink to:

2 Drag the diagram on to the current diagram.

The 'Select Type' dialog displays.

3 Select the 'Hyperlink' option and click on the OK button.

The final hyperlinked diagram should resemble this diagram, where the 'Class' diagram is the diagram to
which the 'Product Order' diagram hyperlinks (notice that the hyperlink icon is different).

Example
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Notes

If the hyperlink appears as a Sub Activity, select the 'Start > Workspace > Preferences > Diagram > Behavior' option·
and deselect the 'Use Automatic SubActivities' checkbox
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In-place Editing Options

This topic explores the tasks that can be performed using in-place editing of elements on a diagram in Enterprise
Architect. The tasks include:

In-place Editing Tasks·
Edit Element Item Name·
Edit Feature Stereotype·
Edit Feature Scope·
Edit Attribute Keyword·
Edit Operation Parameter Keyword·
Insert Operation Parameter·
Edit Parameter Kind·
Edit Custom Compartment·
Insert New Feature (Attribute or Operation)·
Insert Maintenance Feature·
Insert Testing Features·
In-place Editing Tasks·
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In-place Editing Tasks

This topic explains how to edit and work with some properties of an element directly in the diagram.

Use In-place Editing Options

Step Action

Open the diagram containing the element.

Click on the element, and on the item to manipulate within the element.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

Edit and manipulate the items in the element, either by pressing the appropriate
keyboard keys or by right-clicking on the highlighted item and choosing a task
from the 'Element Items' context menu.

The available commands are listed in this table. Not all options are available for
every type of item.

Options

Menu option... Action

Extensions Display a submenu of extension products; click on one to display a further menu of
operations to perform within the selected product.

Edit Selected Change the name, scope or stereotype of the element or element item.

Shortcut: F2

Insert New After Selected Insert a new item in the element.

Shortcut: Insert key

View Properties Display the dialog containing details of the element.

Shortcut: Enter key
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Find in Project Browser Locate the item in the Project Browser.

Open in Specification
Manager

If the element is a Package element, and the selected item is a subPackage, you can
select this option to open and edit the subPackage in the Specification Manager.

Add Attribute Add an attribute to the element.

Shortcut: Ctrl+Shift+F9

Add Operation Add an operation to the element.

Shortcut: Ctrl+Shift+F10

Add Other Insert a feature on the specific element item, such as Maintenance features and
Testing features.

Shortcut: Ctrl+F11

Delete Selected from
Model

Delete the selected item from the model.

Shortcut: Delete key

View Source code Display the source code for the element, in the default external editor.

Shortcut: F12

Visual Analyzer Set a breakpoint on a highlighted operation (including a breakpoint, start recording
marker, end recording marker or stack auto-capture marker.)

Set Type Set a classifier type for the selected item.

Shortcut: Ctrl+L

Navigate Diagram
Selection

Navigate the diagram between elements without having to use the mouse.

Shortcut: Ctrl+Shift+arrow

Highlight Element Toggle element highlight option on and off.

Shortcut: Shift+Enter

Keys

Other keyboard options that are available while editing element attributes or operations in a diagram include:

Shortcut Description

Enter key Accept current changes.

Ctrl+Enter Accept current changes and open a new slot to add a new item.

Esc Abort the edit, without save.

Tab key or Shift+Tab Move the cursor between segments of a feature definition.

Shift+F10 Display the context menu for in-place editing.
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Ctrl+Shift+Space Invoke the 'Select <Item>' dialog.

Ctrl+Space Display an autocompletion list for a feature classifier.

Notes

Where an in-place editing menu command has a keyboard alternative, if the selected item happens to be off-screen·
when you press the keys, the diagram automatically scrolls to show the whole element, so that you can see what you
are changing
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Edit Element Item Name

You can edit the name of an element, operation or attribute directly on the diagram using in-place editing.

Edit element or feature name

Step Action

1 Open the diagram containing the element.

2 Click on the element and on the name to change within the element.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

3 Right-click on the item.

The context menu displays.

4 Select the 'Edit Selected' menu option, or press F2 to enable you to edit the item
directly from the diagram.

The name of the attribute or operation is highlighted.

5 Delete or type over the name.

6 Press the Enter key to accept the change, or Esc to cancel the change.
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Edit Feature Stereotype

You can use in-place editing to edit a feature stereotype directly on a diagram.

Change the stereotype of an operation or attribute

Step Action

Open the diagram containing the element.

Click on the element, and on the item to edit within the element.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

Right-click on the item.

The context menu displays.

Select the 'Edit Selected' menu option (or press F2) to enable you to edit the
attribute or operation directly from the diagram.

The name of the item is highlighted.

Move the cursor to the position before the name or within the existing attribute or
operation stereotype (denoted by «stereotype name»).

Delete or type over the previous name to change the stereotype name of the
attribute or operation.
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Press the Enter key to accept the change or Esc to cancel the change.

Notes

You can assign multiple stereotypes by including a comma-separated list inside the stereotype markers·
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Edit Feature Scope

You can rapidly edit the scope of an attribute or operation directly on a diagram, using in-place editing.

Change the scope of a feature

Step Action

Open the diagram containing the element.

Click on the element and on the item to edit within the element.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

Right-click on the item.

The context menu displays.

Select the 'Edit Selected' menu option (or press F2) to enable you to edit the
attribute or operation directly from the diagram.

The name of the item is highlighted.

Move the cursor to the scope of the item and delete the previous entry.

Reassign the entry by typing in one of these symbols:

+ indicates that the scope is Public·
- indicates that the scope is Private·
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~ indicates that the scope is Package·
# indicates that the scope is Protected·

Press the Enter key to save the change, or Esc to cancel the change.

The diagram is updated to reflect the changes (also see the catalogNumber attribute
in the screen illustrations).
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Edit Attribute Keyword

You can add features such as attribute keywords and classifiers directly to an element, using the Element Keywords and
Classifiers menu. This enables you to rapidly assign details element item by element item, directly from a diagram.

Add Features directly to an element

Step Action

In Enterprise Architect, open the diagram containing the element.

Click on the element, and on the attribute to edit within the element.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

Right-click on the item.

The context menu displays.

Select the 'Edit Selected' menu option (or press F2) to enable you to edit the
attribute directly from the diagram.

The name of the attribute is highlighted.

Right-click on the attribute name to display the context menu.

From the context menu, you can:

Change the attribute classifier to static or fixed - select the 'static' or 'fixed'·
menu options as appropriate; the diagram is updated to reflect the changes

Display the Class properties - click on the 'Goto Definition' menu option;·
Enterprise Architect locates the Class in the Project Browser and opens its
'Properties' dialog

If the data type is a raw data type, Enterprise Architect displays the message: The
data type is a raw data type.
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Edit Operation Parameter Keyword

You can directly edit operation classifiers by element, using the in-place editing menu. This enables you to rapidly assign
parameter keywords.

Directly edit operation classifiers by element

Step Action

Open the diagram containing the element.

Click on the element, and on the operation to edit within the element.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

Right-click on the item.

The context menu displays.

Select the 'Edit Selected' menu option (or press F2) to enable you to edit the
operation directly from the diagram.

The name of the operation is highlighted.

Right-click on the data type of a parameter to display the context menu.

From the context menu you can:

Change the operation classifier by clicking on the appropriate menu option -·
'static', 'isquery', 'abstract' or 'fixed'; the diagram is updated to reflect the
changes

Display the Class properties - click on the 'Goto Definition' menu option·
If the data type is 'Class', Enterprise Architect locates the Class in the Project
Browser and opens its 'Properties' dialog

If the data type is a raw data type, Enterprise Architect displays the message This
data type is a raw data type

If the data type is not defined in the model, the message is: The data type is not
defined in the model
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Edit Parameter Kind

You can edit operation parameter kinds such as (in), (inout) and (out) directly from a diagram element by element, using
the Element Keywords and Classifiers menu. This enables you to rapidly assign the parameter directly from a diagram.

Edit operation parameter kinds directly from a diagram

Images Action

1.    In Enterprise Architect, open the diagram containing the element.

2.    Click on the element, and on the operation to edit within the element.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

3.    Right-click on the item.

The context menu displays.

4.    Select the 'Edit Selected' menu option (or press F2) to enable you to edit the
item directly from the diagram.

The name of the item is highlighted.

5.    Right-click on the item name to display the context menu.

6.    Select the appropriate menu option for the parameter kind value: (in), (inout)
and (out).

The diagram is updated to reflect the change.
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Edit Custom Compartment

Items listed within a Custom Compartment can also be in-place edited. They have a similar in-place editing menu as
other compartment items such as Operations and Attributes within a Class.

For example: a SysML Block element can have a Parts custom compartment. In-place editing can be performed upon the
Parts listed within this compartment.

In-place edit an item in a Custom Compartment

Step Action

1 Open the diagram containing the element.

2 Click on the element and on the item to change within the custom compartment.

The item line is highlighted in a lighter shade (the default is white), to indicate that it has been selected.

3 Right-click on the item.

The context menu displays.

4 Select the 'Edit Selected' menu option, or press F2 to enable you to edit the item directly from the
diagram.

The name of the item is highlighted.

5 Delete or type over the name.

6 Press the Enter key to accept the change, or Esc to cancel the change.

Notes

Custom Compartments such as Parts and Ports within a SysML Block also provide a Set Type command on the·
right-click menu to set the classifier type of the selected item.
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Insert New Feature

You can insert a new element feature directly on a diagram, using in-place editing.

Add attributes and operations to a Class diagram element

Step Action

In Enterprise Architect, open the diagram containing the element.

Click on the element and, within the element, on the item after which to insert the
operation or attribute.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

Either press the Insert key or right-click on the selected element item to display the
context menu, and select the 'Insert New After Selected' menu option

Enterprise Architect inserts a new data line in the diagram, underneath the selected
item.

Type in the relevant information for the attribute or operation.

Use the Tab key and Tab+Shift keys to move the cursor through the segments of the
attribute or operation, and select the classifier from either the:

Autocompletion list (press the Ctrl+Space keys) or·
Select <Item> dialog (press the Ctrl+Shift+Space keys)·

Press the Enter key to accept the change or Esc to cancel the change.

The diagram is updated to reflect the changes.
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Insert Operation Parameter

You can add operation parameters to an operation through the in-place editing options, using hotkey commands or menu
shortcuts.

Add parameters to operations in a Class diagram element

Step Action

Open the diagram containing the element.

Click on the element, and on the operation to update within the element.

The item line is highlighted in a lighter shade (the default is white), to indicate that
it has been selected.

Press F2, or right-click on the selected item and select the 'Edit Selected' option.

Move the cursor inside the parameter brackets and type the parameter name,
followed by a colon (for example, bks: for a vector containing books).

Give the parameter a type.

Place the cursor after the colon at the end of the name and add the classifier; either:

Press Ctrl+Space to invoke the classifier autocompletion list·
Press Ctrl+Shift+Space to select a classifier from the 'Select <Item>' dialog or·
Click the right mouse button to display the inline editing options context menu·
and select the 'Insert Classifier' option

The 'Select <Item>' dialog displays.

Press the Enter key to accept the change or Esc to cancel the change.

The diagram is updated to reflect the changes.
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Insert Maintenance Feature

You can quickly insert a new maintenance item directly on a diagram, using in-place editing.

Assign maintenance details directly to an element from a diagram

Step Action

Open the diagram containing the element.

Click on the element name.

The name is highlighted in a lighter shade (the default is white), to indicate that it
has been selected.

Either press Ctrl+F11 or right-click on the highlighted name and select the 'Add
Other' option.

The 'Insert Feature' dialog displays.

Click on the appropriate radio button option to associate the required maintenance
feature with the element item.

Click on the OK button.

The '<Maintenance Feature> details for <element>' dialog displays.

Complete the fields to define the maintenance activity, and then click on the Apply
button.

To create a subsequent maintenance activity of this type, click on the New button.

When you have defined all of the maintenance activities of this type, click on the
OK button.

The maintenance details are added to the element.
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Notes

To ensure that the maintenance items are visible in the diagram element, as shown in step 7, select the 'Maintenance'·
checkbox on the 'Elements' tab of the 'Diagram Properties' dialog
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Insert Testing Features

You can add test records such as Unit, Integration, System, Acceptance, Inspection and Scenario tests directly to an
element displayed on a diagram.

Add testing features to an element directly from a diagram

Step Action

Open the diagram containing the element.

Click on the element.

The element name is highlighted in a lighter shade (the default is white), to indicate
that it has been selected.

Either press Ctrl+F11 or right-click on the highlighted name and select the 'Add
Other' option

The 'Insert Feature' dialog displays.

Click on the appropriate radio button option to associate the required testing feature
with the element.

Click on the OK button.

The Testing window opens, showing the appropriate panel for the type of test
selected.

Complete the fields to define the test activity, and then click on the Save icon in the
window toolbar.

The test is added to the element.

To create a subsequent test activity of this type, click on the 'New' icon.

To add items for other types of test, click on the appropriate tab.
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Notes

To ensure that the test items are visible in the diagram element, as shown in step 7, select the 'Testing' checkbox on·
the 'Elements' tab of the 'Diagram Properties' dialog

(c) Sparx Systems 2015 - 2017 Page 517 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Non-printable Elements

When you intend to generate a report that depicts diagrams from your model, you might decide that you do not want to
show certain elements on a diagram in the report. You might have, for example:

Notes and Text elements containing short pieces of information or explanations·
Artifact elements containing standards or instructions in linked documents·
Any other element that is not relevant to the purpose or subject of the report·

You can exclude such elements (with their connectors) from being printed in any depiction of the diagram in a report, by
manipulating the 'Printable' status of each non-relevant element. Conversely, you can force the inclusion of these
non-printable elements in the printed diagram, by turning off the 'Hide non-printable objects' option in report generation.

Configure the Printable Attribute

All elements added to a diagram have the status 'Printable' by default. To turn this off and make an element non-printable
(or turn it back on again) right-click on the element and click on the 'Printable' option.

You can turn this option on or off for multiple elements, by selecting the elements and right-clicking on one of them to
display the context menu, then clicking on the option.

Activate Printable Option for Reports

You can control the printing of non-printable elements on depictions of diagrams in reports, through the 'Options' page of
the 'Document Generation' dialog.

Option Action

Using in Ad Hoc Reports Select the parent Package or element for the diagram, and press F8; set up your
report generation parameters as required.

On the 'Options' page, the 'Hide non-printable objects' checkbox defaults to
selected, to omit all elements that have the 'Printable' option turned off from
depictions of diagrams in the report.

If you want to include non-printable elements in the diagrams in the report, click on
the checkbox to clear it.

Using in Document
Templates

The 'Hide non-printable objects' option is a global, registry, setting and cannot be
turned off in document templates or in document generation through the
Automation Interface.

Notes

Turning off the 'Printable' option for an element also hides the element and its connectors when you print the·
diagram, print to PDF and save an image of the diagram
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Model Glossary

The Project Glossary enables you to set up a list of defined terms for your project, review the technical and business
terms already defined for a model, add to the list, delete or change items, apply reporting styles to terms of specific types,
and filter the list to exclude by type.

Access

Ribbon Publish > Documentation > Glossary

Keyboard Shortcuts Alt+2

Project Glossary functionality

Tasks

Add, delete and modify the Project Glossary entries through either the:

Glossary View, or·
'Glossary' dialog·

Separate glossary items by type; for example, Business terms and Technical terms.

Define Markup Styles to apply to terms of specific types where they occur in generated document reports

Save the glossary in Rich Text format for inclusion as part of a larger project document.

Create glossary terms and definitions from text in the Notes window, or from any 'Notes' or 'Description' fields that
have the Notes toolbar.

Insert existing glossary terms into any other 'Notes' fields.

Notes

In the Corporate, Business and Software Engineering, System Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Manage Glossary' permission in order to create, update or delete
Glossary items; if security is not enabled, you can manage Glossary items without any permissions

You might include a Glossary Report in your project requirements or functional specifications documents·
You can transport glossary definitions and glossary style mark-ups between models, using the 'Configure > Model >·
Transfer > Export Reference Data' and 'Import Reference Data' ribbon options
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Project Glossary View

The Project Glossary view displays the glossary terms already defined for your model. You can use this View to:

Add glossary terms·
Assign a Markup Style to a glossary term type, to print in a documentation report any terms of that type in that style·
Modify glossary terms·
Filter the display to show terms of a specific type only·
Change a definition type for all terms of that type·
Print the displayed list of terms·
Delete glossary terms·

Access

Use one of the methods described in the table, to display the Glossary view.

Within the Glossary view, right-click on an entry and select the appropriate option for the operation you intend to
perform (as listed); if you select the:

'Add New' or 'Modify Selected' options, the 'Glossary Detail' dialog displays; complete the fields as indicated in the·
Glossary Detail Fields table

'Assign Markup Styles' option the 'Glossary Markup' dialog displays, on which you assign display styles to terms of·
each existing term type; the style is applied when you generate an RTF report containing the glossary terms

'Rename type' option, the 'Rename Glossary Type' dialog displays on which you enter the alternative type name·
(either one of the existing types or a new type); when you click on the OK button, all entries of the original type are
changed to the new type

'Set term filter' option, the 'Term Type Filter' dialog displays on which you enter the type of glossary term to list;·
when you click on the OK button, only items of that type are shown on the Glossary view

'Remove term filter' option, the Glossary view refreshes to show glossary items of all types·
'Print List' option, the 'Print' dialog displays on which you define the printing parameters; when you click on the OK·
button, the currently-displayed list prints out

'Delete' option, a prompt displays to confirm the deletion; click on the Yes button to remove the term from the·
glossary

Ribbon Publish > Documentation > Glossary

Keyboard Shortcuts Alt+2

Glossary Detail Fields

Field Action

Term (Mandatory) Type the term to include in the glossary.

Type (Mandatory) Select the required type.
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If you require a different glossary type, click on the  button and specify the
name of the new type.

This field applies the type only to the selected term; you can rename a type for all
terms of that type, using the context menu.

Meaning Type the definition or description of the term.

If necessary, format the text of this description using the Notes toolbar at the top of
the field.

New Clear the dialog fields so that you can define a new Glossary term.

Apply Save the new or updated glossary entry.

Delete Delete the entry.

A prompt displays to confirm the deletion; click on the Yes button to remove the
term from the glossary.

Notes

In the Corporate, Business and Software Engineering, System Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Manage Glossary' permission in order to create, update or delete
Glossary items; if security is not enabled, you can manage Glossary items without any permissions

You can re-sequence, filter and group the glossary items in the list using the List Header facilities·
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Glossary Styles

When you are defining your Glossary terms, you can also define a documentation style to apply to terms of a specific
term type. When you generate RTF, PDF or DOCX documents those terms are shown in the defined color, font and/or
emphasis. This applies a visual key to the Glossary terms of each type, and makes it easier for the reader to recognize all
the terms for which they can obtain a definition or explanation.

The term type also acts as a key for substituting the meaning of any term of that type for the term itself. For example, if
you select a term type of 'edition', in a report the terms 'Corp', 'BSE', 'SysE' and 'Ult' would be replaced by the meanings
'Corporate', 'Business and Software Engineering', 'Systems Engineering' and 'Ultimate', respectively.

You apply the glossary styles and meaning substitution through the 'Generate Documentation' dialog. You should not set
up term substitution in a model from which you generate HTML reports; the HTML report generator does not apply
glossary styles, nor does it substitute meanings.

Configure Glossary Styles

You configure Glossary styles within a Glossary Style Sheet, using the 'Glossary Markup' dialog; you display this dialog
from the Glossary View. For each Glossary Term Type, you define one style in the Style Sheet, using the standard CSS
style definition language. This is an example of two style definitions in a style sheet:

.paragraph {

      font-family: courier;

      font-size: 16px;

      font-weight: italic;

      color: #FF0000;

      background: none;

      text-transform: capitalize;

}

.language-term {

      font-family: arial;

      font-size: 14px;

      font-weight: bold;

      color: #800000;

      background: none;

      text-transform: capitalize;

}

Access

Use one of the methods described here to display the Glossary view, then:

Right-click within the Glossary view > Assign Markup Styles

Ribbon Publish > Documentation > Glossary

Keyboard Shortcuts Alt+2
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Define Styles

Assign one style to each of the Glossary Term Types, which have been defined on the 'Glossary' dialog.

Option Action

Term This column lists the existing Term Types in the Glossary.

Style Name This column identifies the style assigned to each Term Type. If no style has been
assigned, the field is blank.

To assign or switch the style, double-click on the row, type the style name on the
'Input' prompt and click on the OK button. If the name contains more than one
word, link the words with hyphens.

The new style name is added to the top of the 'CSS' panel.

CSS Between the parentheses under the style name, type in or copy/paste the new style
definition, or edit an existing definition. The styles are created one after another
within the single style sheet for the Glossary.

OK Click on this button to save changes to the style definitions and close the dialog.

Using Glossary Styles

You use Glossary Styles to identify and highlight Glossary terms in your printable reports, and to indicate what kinds of
term they might be. You can also use the terms as place-holders for more complex text strings in the term definitions, so
that the report generator substitutes the text string for the place-holder term. Both text formatting and text substitution are
enabled by selecting options on the 'Generate Documentation' dialog (click on a Package or element and press F8).

Configure Reporting for Glossary Styles

You can apply glossary styles to your RTF, PDF or DOCX documentation through the 'Generate Documentation' dialog.

Task Action

Using the Markup Style Select the Markup Glossary Terms checkbox to apply, in the generated report, any
styles applied to any Glossary terms through the Notes text of an element.

A style is applied to a Glossary term according to its Glossary term type.

Using Substitutions (Available if the 'Markup Glossary Terms' checkbox is selected.)

In the 'Use Glossary Substitution' field, click on the drop-down arrow and select a
term type. For all glossary terms of that type, wherever a term occurs in the report it
will now be replaced by its meaning.

Notes
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You can copy the Glossary Style Sheet between models as reference data, using the 'Configure > Model > Transfer >·
Export Reference Data' and 'Import Reference Data' ribbon options
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The Glossary Dialog

Using the 'Glossary' dialog, you can create, maintain and delete definitions of terms used in your project, as a Glossary.
When reviewing the Glossary terms, you can filter the list to display terms of a specific type.

Access

Ribbon Publish > Documentation > Glossary > Edit

Maintain Glossary terms

Option Usage

Glossary Term Type the term to include in the glossary.

Glossary Type (Mandatory) Click on the drop-down arrow and select the required type.

If you require a new glossary type, click on the  button and specify the name of
the new type.

This field applies the type only to the selected term; you can rename a type for all
terms of that type, using the Glossary view.

Description (Mandatory) Type the definition or description of the term.

If necessary, format the text of this description using the Notes toolbar at the top of
the field.

Limit Display To Click on the drop-down arrow and select the appropriate glossary type to filter the
'Type | Term' list and show entries of that type only.

Select the '<All>' option to display all glossary entries.

New Click on this button to clear the dialog fields so that you can define a new Glossary
term.

Type | Term Review the list of defined glossary terms; click on an entry to edit it in the dialog
fields.

Save Click on this button to save the new or updated glossary entry.

Delete Click on this button to delete the entry selected from the Type | Term list.

Report Click on this button to generate and print a glossary report.

Notes
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In the Corporate, Business and Software Engineering, System Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Manage Glossary' permission in order to create, update or delete
Glossary items; if security is not enabled, you can manage Glossary items without any permissions
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Generate a Report

You can generate a rich text format file of your model's glossary, which you can either print or attach to any other
appropriate document file.

The file can contain all glossary entries, or just those of selected types.

Access

Ribbon Publish > Documentation > Glossary > Edit : Report

Generate an RTF report of the Project Glossary

Step Action

1 In the 'Filename' field, type or select a filename for the glossary.

2 In the 'Heading' field, type a suitable heading for the glossary.

3 In the 'Include Glossary Items' panel, select the checkbox for each type of glossary entry to include.

To select all types of entry, click on the Select All button.

4 If necessary, to define the page setup and language for the report, click on the Page Setup and/or
Language buttons.

5 To include page breaks, select the 'Page break between sections' checkbox.

6 Click on the Generate button to generate the report.

7 Click on the View button to open the report.
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Glossary Report Output Sample

An example of the output from a Glossary report is shown here:

Glossary

Business Terms

Accounting Periods

A defined period of time whereby performance reports can be extracted (normally 4 week periods).

Customer

A person or a company that requests an entity to transport goods on their behalf.

Technical Terms

Association

A relationship between two or more entities. Implies a connection of some type - for example, one entity uses the
services of another, or one entity is connected to another over a network link.

Component Model

The component model provides a detailed view of the various hardware and software components that make up the
proposed system. It shows both where these components reside and how they inter-relate with other components.
Component requirements detail what responsibilities a component has to supply functionality or behavior within the
system.

Deployment Model

A model of the system as it is physically deployed.

Extends Relationship

A relationship between two Use Cases in which one Use Case 'extends' the behavior of another. Typically this represents
optional behavior in a Use Case scenario - for example a user might optionally request a list or report at some point in a
performing a business Use Case.
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Editing Documents and Templates

Within Enterprise Architect you can create various documents from templates, and you can create customized templates
to help tailor the documents to the needs and standards of your organization. You can create Linked Documents, Linked
Document Templates and Document (Report) Templates, amongst others. In each case, selecting to create or edit the
document opens the Document-Edit ribbon, which provides a wide range of editing and formatting facilities that you can
use to develop your documentation. This section explains how to perform various editing tasks using the ribbon.

Each type of document can also have its own context menu of additional options, and the editing window might also
have an option toolbar. These facilities are described in the topics specific to the type of document.

Access

Ribbon Create or edit a document or template file; the Document - Edit ribbon displays
automatically

Option Descriptions

The descriptions of the Document - Edit ribbon options are grouped according to the actions you are performing.

Actions

Creating and importing documents

Configuring the editor page display and formatting tools shown

Moving through, searching and selecting text

Formatting characters and text strings

Formatting paragraphs and text blocks

Inserting tab points

Inserting sections, columns and page breaks, and repaginating

Incorporating stylesheets, special texts and Tables of Contents

Managing the base styles in the Normal.rtf style template file

Inserting and editing page headers and footers, and footnotes and endnotes

Inserting tables

Inserting hyperlinks

Inserting images, OLE objects, frames and drawing objects

Printer setup and printing documents
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Checking spelling and use of words

Tracking, accepting and rejecting changes to text

Protecting document text from accidental change

Create and refer to definitions of Glossary terms in the Project Glossary (using the 'Create | Glossary Definition'
menu option)

Notes

Throughout your document editing:·
    - To undo one or more immediately previous edits, press Ctrl+Z, or select the 'Undo' context menu option; you
can still undo a change
       even after you have saved the change
    - To redo one or more immediately previous undone edits, press Ctrl+Y, or select the 'Redo' context menu option
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File Control

The Document Edit ribbon provides a number of options for changing and saving a document report file contents as a
complete file as well as for setting page layout options, such as margins, and for printing the document.

Access

Ribbon Document-Edit > File > File > [options]

File control options

To Action

Import an RTF file Select the option 'Document-Edit > File > File > Import File'. This imports the
contents of an existing document into the current file.

The 'Import File' option is useful when creating documents from existing
documents external to Enterprise Architect, such as your own corporate standards
templates and, in conjunction with the 'New' option, of updating the document from
the external file.

Export a Document file Select the option 'Document-Edit > File > File > Save As (Export to File)'. This
saves your document to an external document file.

The 'Export' option is useful for saving a specific template or document to be
imported into another project.

Clear a file for redesign Select the option 'Document-Edit > File > File > New (Clear Document)'. This
clears the existing contents of the document.

If you have made any unsaved changes to the file, the editor prompts you to save
them. If you want to protect those changes, click on the Yes button to display a
browser screen and select a file path and file name to save the changes to.

This is a method of clearing out an existing document for redesign. As you do not
change the name, all references to it simply pick up the changed content.

Roll back changes to
previous version

Select the option 'Document-Edit > File > File > Reload from Repository' to roll
back the file contents to the previously-saved version.

Save changes Select the 'Document-Edit > File > Save' icon to save the file contents to the current
file.

Save Template Applicable to the Document Template Designer and Linked Document template
editor.

The key combination Ctrl+Shift+S invokes the 'Save As' command to save a
 template contents under a new name, which you are prompted to type in. This
command is not available when editing a document - see 'Export a Document file'
instead.

Close the file and editor Click on the cross at the right of the document tab or in the top right corner of the
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Document Window.

Print options

When you are editing a document or template, you can manage print jobs within the Document Editor. You can select
from options to define the page layout, text to be printed and number of copies, and to check the appearance of the
printing before actually submitting the print job.

To Action

Set the page margins for
viewing and printing the
document

Select the option 'Document-Edit > File > File > Page Layout'.

The 'Page Parameters' dialog displays, on which you can define the left, right, top
and bottom page margins in inches.

The 'Top' and 'Bottom' margins define how much space is set aside to contain
header and footer text.

In the 'Header distance from the Page Top' and 'Footer distance from the Page
Bottom' fields, type the separation of the header and footer text from the edge of the
paper.

Set the parameters for the
print run

Select the option 'Document-Edit > File > File > Printer Setup', or press
Ctrl+Shift+P.

The 'Setup Page' dialog displays for the default printer, which you would have
selected on the Windows 'Control' panel.

You can simply confirm or reselect the core parameters such as page size, paper
source and page orientation, or click on the Properties button to define more
advanced settings such as use of a watermark, duplex printing and print resolution.

Print your document Select the option 'Document-Edit > File > File > Print Preview', or press Ctrl+P.

The 'Print' dialog displays, on which you can select the pages to print and the
number of copies, and initiate the print task.

You can also choose to print only a selected part of the file. To do this, highlight
the required text before selecting the 'Print' option. You can print a highlighted
block of:

Lines, or·
Characters·

Preview document before
printing

Select the option 'Document-Edit > File > File > Print Preview' to display the
document as it would appear when printed.

The editor displays either one page or two - toggle the display by clicking on the
One Page button or Two Pages button. Scroll to further pages using the scroll bar.

By default the preview rectangle is sized to fit the current window; you can use the
'Fitted' field to enlarge or shrink the size of the displayed pages as required.

Click on the Print button to display and use the 'Print' dialog.

To return to editing mode click on the Edit button, or on the 'Document-Edit > File
> File > Print Preview' menu option again.
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Editor Display Options

Within the Document Editor, to help you edit the document contents you can configure the page display and the
formatting tools visible, using the 'View' menu options in the 'File' panel of the 'Document-Edit' ribbon.

Access

Ribbon Document-Edit > File > View > [options]

Editing tools and options

Menu Option Action

Page Layout Mode Select the option 'Document-Edit > File > View > Page Layout Mode'. Toggles the
text display between page layout and full window layout.

Borderless Mode Select the option 'Document-Edit > File > View > Borderless Mode'. Toggles the
display of page borders, allowing the document to occupy the entire display area.

Horizontal Ruler Select the option 'Document-Edit > File > View > Horizontal Ruler'. Displays or
hides the ruler at the top of the page.

The ruler shows tab stops and paragraph indentation marks; you can also use it to
create or delete tab stops.

Vertical Ruler Select the option 'Document-Edit > File > View > Vertical Ruler'. Displays or hides
the ruler against the left edge of the page.

The ruler indicates the depth of the top and bottom margins of the page.

Status Ribbon Select the option 'Document-Edit > File > View > Status Ribbon'. Displays or hides
the status ribbon at the bottom of the editing panel.

The status ribbon displays the current page number, line number and column
number; it also indicates the current insert/overtype mode (at the left end of the
ribbon).

Hidden Text Select the option 'Document-Edit > File > View > Status Ribbon'. Shows or hides
'hidden' text.

Text formatted with the 'Hidden' option is shown with a dotted underline; when the
'Hidden Text' option is turned off, the hidden text is not visible and the normal text
closes up to single character or line spacing.

Field Names Select the option 'Document-Edit > File > View > Field Names'.

Applicable to all document editing:

If you have inserted any data fields and values, the 'Field Names' option toggles
between displaying field names in the text and displaying the field values.

Applicable to the Document Template Designer:

As you develop your custom document template, you right-click on sections to
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insert field markers and select the 'Insert Fields' option. The 'Field Names' option
makes the 'Insert Fields' option available.

Hyperlink Cursor Select the option 'Document-Edit > File > View > Hyperlink Cursor'.

Applicable to the Document Template Designer and Linked Document Template
Editor:

Toggles the cursor icon when you 'mouse over' a hyperlink, between your default
image (usually a line or arrow) and a 'pointing hand'.

Page Header/Footer Select the option 'Document-Edit > File > View > Page Header/Footer'. Displays or
hides the text of page headers and footers.

To edit the header or footer text, select the option 'Document-Edit > Edit > Edit >
Page Header/Footer'.

Zoom Select the option 'Document-Edit > File > Fixed Zoom'. A short menu displays,
from which you can select from a range (10% to 200%) of percentages of normal
size by which to shrink or enlarge the display of the document content. The menu
also has a 'Custom' option that you can select to display the 'Zoom Parameter'
dialog, on which you define the percentage you need, between 10% and 500%.
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Styles, Special Text & Table of Contents

Using the Document Editor, you can define character-based styles and paragraph-based styles.

A character style constitutes a set of character formatting attributes and is applied to a character string·
A paragraph style constitutes both a set of character formatting attributes and a set of paragraph formatting·
attributes, and is applied to one or more paragraphs

You can also include special, structured text in the document, such as page number, date and time, table of contents and
text input fields.

Every custom template or document you create is automatically based on the Normal.rtf template file. This provides
default styles, numbering and other base formats, which you can change using the Document Editor facilities and save
either as a specific document, template or document report Stylesheet.

Access

Select options from the 'Document Edit' ribbon bar.

Editing Styles

To Action

Create and edit styles Select the option 'Document-Edit > Edit > Edit > Edit Style'. The 'Edit Stylesheet'
dialog displays.

Select the appropriate radio button to define a paragraph style or a character style.

If you want to update an existing style, select that style from the list box. If you
want to create a new style, select the 'Create a new style' checkbox, and type a name
in the 'Style Name' field. Short style names are best, but you can type in long names
if necessary.

To begin defining the style properties, click on the OK button.

You can use the ruler, toolbar or context menu selections to modify the style
properties; for an existing stylesheet item, these also reflect the currently-selected
properties.

After you have defined the required style, you set it by either selecting the
'Document-Edit > Edit > Edit > Edit Style' menu option again or clicking anywhere
in the document:

If you modified an existing stylesheet item, the document automatically·
reflects the updated style

If you created a new stylesheet item, you can apply the style to highlighted text·
by selecting the 'Document-Edit > Font > Font > Style' or 'Document-Edit >
Paragraph > Paragraph > Style' ribbon options

Update the standard styles
used

Right-click on the document and select 'Update Styles > [select Stylesheet to
update]'

Re-import the standard styles from Normal.rtf, into the current document, or·
Apply one of the system-supplied standard Stylesheets to the document·

A submenu displays from which you select the appropriate style source.

This is useful for maintaining consistency of styles across all your documents,
including such things as numbering formats.
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Edit the hyperlink style This option operates specifically on the style of any hyperlinks you want to create.

Select the option 'Document-Edit > Font > Font > Hyperlink', then select the font,
font size and emphasis (bold, italic) you want to apply. You cannot remove the
hyperlink underline or change the color from blue.

Select the option 'Document-Edit > Font > Font > Hyperlink' again to set the style.

When you create a hyperlink from this point onwards, the link text will be in the
style you have set. Links created before you changed the style remain in the earlier
style.

Apply character styles Highlight the text to be styled and select the option 'Document-Edit > Font > Font >
Style'; the 'Select a Style' dialog displays, from which you select the character style
to apply.

Alternatively, select a character style from the drop-down list in the 'Font' panel of
the 'Document-Edit' ribbon.

Apply paragraph styles Highlight the text to be styled and select the option 'Document-Edit > Paragraph >
Paragraph > Style'; the 'Select a Style' dialog displays, from which you select the
paragraph style to apply.

Alternatively, select a paragraph style from the drop-down list in the 'Font' panel of
the 'Document-Edit' ribbon.

Clear unused lists from the
template or document

Select the option 'Document-Edit > File > Manage > Remove Unused Lists'.

The system prompts you to confirm removal of the lists when the file is saved.
Click on the Yes button.

When you have list formats such as for bullet or numbered lists in the file, and you
have reversed or otherwise not used them, the formatting instructions for applying
these lists to the text remain in the file. You can see this when you set up the list
and then toggle the bullets or numbering on and off.

If you select the 'Remove Unused Lists' option, when you save the file the unused
format instructions are removed from the file, reducing the number of list formats
maintained in the file and reducing file size.

Insert date and time fields At the point in the text at which to insert the current date and/or time field, select
the option 'Document-Edit > Edit > Insert > Date and Time'.

The 'Insert Current Date/Time' dialog displays, from which you can select the
required date and time format. You can insert the date or time fields separately, or
as a combined field.

The date and time are automatically updated whenever the page text is refreshed
(that is, clicked on).

Insert a table of contents Edit the Table of Contents level styles (TOC 1 to TOC 9) as required, using the
option 'Document-Edit > Edit > Edit > Edit Style'. Add at least one 'Heading n' style
to the document.

Move the cursor to the point at which to insert the Table of Contents, and select the
option 'Document-Edit > Edit > Insert > Table of Contents'. A small dialog displays
in which you specify the highest and lowest Table of Contents levels to apply in the
table in this document; when you have specified the levels, click on the OK button.
If there are corresponding headings within the specified range, the Table of
Contents displays; otherwise, the line remains blank.

To create a Table of Contents heading that displays in the generated document, type
the appropriate text at least one line above the inserted list and define the style as
required - use a Heading style to include the heading itself in the Table of Contents,
otherwise use a non-heading style.
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The Table of Contents is automatically generated and updated whenever generation
or repagination occurs.

Insert your own data fields Move the cursor to the point at which to insert the data field and select the option
'Document-Edit > Edit > Insert > Data Field' menu option.

The 'Data Field Parameters' dialog displays, in which you enter the field name and
the data value. Wherever you insert the data field, the values are automatically
updated with the most recent data value you enter.

Insert your own text entry
field

You insert text entry fields so that anyone using the document can type in their own
text in response to either a lead-in sentence or the field name itself.

Move the cursor to the point at which to insert the text entry field and type in any
lead-in text you want to use. Then select the option 'Document-Edit > Edit > Insert
> Text Input Field'.

The 'Input Field Parameters' dialog displays, in which you enter:

The field name·
The initial value to display as a default·
The maximum length of the field·
The text font in which to display the text·

You can also specify whether or not the field has a border.

For example: 

If you insert a text entry field in a template, any document generated from the
template shows the typed entry as normal text, not boxed.

Insert a selectable
checkbox

You insert checkboxes in a document so that the users of the document can mark
the item represented by the box. The checkbox can be selected and deselected in a
document, a template and a document generated from a template.

Move the cursor to the point at which to insert the checkbox and select the option
'Document-Edit > Edit > Insert > Checkbox Field'.

The 'Checkbox Field Parameters' dialog displays, in which you enter:

The field name (which does not display in the text)·
Whether the checkbox defaults to selected·
The size of the checkbox·

Click on the OK button.

Insert a selection
(drop-down) field

You insert selection fields in a document so that the users of the document can
select one of the items presented in a drop-down list.

Move the cursor to the point at which to insert the checkbox and select the option
'Document-Edit > Edit > Insert > Selection Field'.

The 'Selection Field Parameters' dialog displays, in which you enter:

The field name·
The options to present in the drop-down list (separated by the | character)·
The value from this list to display as a default·

Click on the OK button.

Insert a non-breaking space Move the cursor to the point at which to insert the non-breaking space and select
the 'Insert | Non-breaking Space' menu option.

Insert a non-breaking dash Move the cursor to the point at which to insert the non-breaking dash and select the
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'Insert | Non-breaking Dash' menu option.

Insert an optional hyphen Move the cursor to the point at which to insert the hyphen and select the 'Insert |
Optional Hyphen' menu option.

Insert a Project Constant (For Document Report templates.)

You can create Project Constants to insert a specific text string wherever you place
the flag for that string. You can therefore design a report containing many instances
of that string, but create and edit the actual value in one place - on the 'Project
Constants' tab of the 'Generate Report' dialog.

Right-click at the point at which you want to insert the Constant (flag), and select
the 'Project Constants | <flag name>' option. The Constant displays at that point in
the template, and when the report is generated the flag is replaced by its defined
value.

You can insert a Project Constant anywhere in the template - in the text body,
section headings, headers, footers, endnotes or footnotes. Project Constants are
available to any template in the model.

Define level numbering in
generated document

(Used in the Document Template Editor.)

Select the option 'Document-Edit > Edit > Edit > Lists and Overrides'.

Set up the numbering list and the list overrides.

Apply the numbering list to the headings set for Packages and elements, using
paragraph numbering.

Use double-byte characters Select the option 'Document-Edit > Edit > Edit > Inline Ime'.

Double-byte characters are, broadly, complex characters used in languages such as
Japanese, Chinese, and Cyrillic.

With this menu option, you can use both single-byte characters and double-byte
characters in your text, without having to switch to an external Input Method Editor
(IME) application.
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Manage Page Counting

As you set up the document structure, especially if you divide the document up into sections, you can insert page counts,
insert and reset page numbers, and repaginate the document to update the page number, page count and Table of
Contents.

Access

Ribbon Document-Edit > Edit > Insert > Page Number

Document-Edit > Edit > Insert > Page Count

Document-Edit > Edit > Edit > Repaginate

Insert the page number

Position the cursor at the point at which to display the page number, and select the option 'Document-Edit > Edit > Insert
> Page Number'.

The page number is displayed in gray.

Insert the page count

Position the cursor at the point at which to display the total number of pages in the document, and select the option
'Document-Edit > Edit > Insert > Page Count'. The page count is displayed in gray.

Repaginate the document

Select the option 'Document-Edit > Edit > Edit > Repaginate'.

The 'Page Number' and 'Page Count' fields and the Table of Contents are all updated.
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The Normal.rtf Style Template

Every custom template or document you create is automatically based on the 'Normal.rtf template' file. This is an
external file that provides default styles, numbering and other base formats, such as the default list numbering,
MasterList. You can edit the Normal.rtf file to apply your own default styles to the documents and templates you create.
You also have the options of:

Editing selected styles within a template, so that reports or documents created from that template always have those·
different styles

Using the standard Stylesheets or creating custom Stylesheets, to optionally apply to any document report you·
generate independent of the template you are using

Access

The Normal.rtf template is stored in %APPDATA%\Sparx Systems\EA\RTF Templates

Edit Normal.rtf

Step Action

1 Open the Document Template Designer and create a new template called, for example, Normal.

2 Select the 'Document-Edit > File > File > Import File' menu option to import the Normal.rtf file into the
Normal template.

3 Modify the Normal template style definitions as you want, and remove any text before you save the
template.

4 Export the modified template ('Document-Edit > File > File > Save As (Export to File))' back into the
Normal.rtf file in the RTF Templates folder. The modified styles will be applied to all documents and
templates you create from now on.

Notes

You must not edit the SSbookmark style; this defines the section styles and must be preserved·
A related feature in the Document Editor is the 'Update Styles' context menu option, which you select to update an·
existing template to reflect any changes to Normal.rtf, or to apply a standard Stylesheet to the template
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Scroll, Search and Select Text

In the Document Editor, you can move the cursor through the template or document using either the keyboard or the
mouse. Alternatively, you could move the cursor to a position in the file by searching for a text string.

Having positioned the cursor on the required text, you can then highlight and manipulate it with various options, in
addition to the standard 'mouse-click-and-drag' and the 'Ctrl+X', 'Ctrl+C' and 'Ctrl+V' keys.

Cursor Positioning

Scroll Using Options

Keyboard Keys Press:

Ctrl+Left Arrow to move to the previous word·
Ctrl+Right Arrow to move to the next word·
Ctrl+Up Arrow to move to the first column of the current line (if not already on·
the first column) or the first column of the previous line

Ctrl+Down Arrow to move to the first column of the next line·
F10 to display the 'Jump to line number' dialog; type in a line number to jump·
to, and click on the OK button

Mouse To perform various scrolling functions, click on the vertical or horizontal scroll
bars. These functions are available when the scroll bars have been enabled by the
startup parameters.

Vertical Scroll Bar: To scroll the screen up or down by one line, click on the
arrows on either end.

To scroll the screen up by one page, click above the elevator (the block within the
scroll bar); similarly, to scroll the screen down by one page, click below the
elevator.

You can also scroll the screen up or down by dragging the elevator in the
appropriate direction.

Horizontal Scroll Bar: To scroll the screen left or right by one column, click on
the arrow on the appropriate end of  the bar; to scroll the screen left or right by half
a screen, click on the bar on the appropriate side of the elevator.

You can also scroll the screen left or right by dragging the elevator along the bar in
the appropriate direction.

Text Search

When you search for a text string, the dialog for specifying the search details does not persist on the screen, so you can
simply use keyboard keys or a menu option to continue the search without obscuring text behind a dialog.

To Action

Find first instance of a text
string

Select the option 'Document-Edit > Edit > Search > Search', or press F5.

The 'Search String Parameters' dialog displays. Specify:

The term to search for·
Whether to search from the start of the file or forwards or backwards from the·
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current cursor position, and

Whether the search should exactly match the case of the search term·
The editor searches for the first instance of the specified character string as defined
by the parameters.

Find next instance of a text
string

Select the option 'Document-Edit > Edit > Search > Search Forward', or press
Ctrl+F.

The editor searches forwards through the file for the next instance of the previously
specified text string, and highlights it.

Find previous instance of a
text string

Select the option 'Document-Edit > Edit > Search > Search Backward', or press
Ctrl+Shift+F.

The editor searches backwards through the file for the next instance of the
previously specified text string, and highlights it.

Replace a text string Select the option 'Document-Edit > Edit > Search > Replace', or press F6.

The 'Replace String Parameters' dialog displays, in which you specify:

The text string to locate·
The text string to replace it with·
Whether to search the whole document or just a highlighted block of text·
Whether to confirm each replacement before making the change·

If you want to confirm replacement, a prompt displays for each occurrence of the
search term to confirm or skip replacing that occurrence.

Text Selection

To Action

Highlight a word Double-click on the word.

Highlight a line Move the cursor onto the line and press F8.

Delete a line Press Shift+F9 to delete the current line; the remaining lines close up.

Paste special objects Select the option 'Document-Edit > Edit > Edit > Paste Special'; the 'Paste Special'
dialog displays, listing the appropriate data type formats for inserting the copied
object.

Click on the Paste button to embed the data into your application, or click on the
Paste Link button to create a link to the original file.

'Native Object Format' - If available, this is the first format in the list box; you·
can edit data in this format using the original application, by double-clicking
the object

'Formatted Text' - A text format; this option offers the most suitable format if·
the data is pasted from another text output application, as the font and
formatting attributes are reproduced accurately

'Unformatted Text' - Another text format; this option pastes the text without·
retaining the formatting information

'Picture Format' - The data is available in Picture format; you can later edit the·
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object, by double-clicking on it and invoking the Microsoft MS Draw
application
This format is preferable to the Bitmap and the Device Independent Bitmap
formats

'Device Independent Bitmap' and 'Regular Bitmap' formats - The data is·
available in bitmap formats; you can later edit the object, by double-clicking on
it and invoking the Microsoft MS Draw application
The editor converts these formats into the Picture format before calling the
drawing application
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Format Text

When you create a document template or document, the default character or text styles are already defined, as they are
derived directly from the Normal.rtf style template file. Within the document you can edit any of these character styles or
apply individual formatting to text strings as you require.

When you change the format of existing text, any new characters you type immediately after that text automatically
assume the formatting characteristics you have applied.

Access

Highlight the text to which to apply the format, then select options from the 'Font' panel of the 'Document-Edit' ribbon
bar.

Text formatting options

To Action

Apply character format Highlight the text to which to apply the format, and use one or more of these menu
options or key combinations.

From the 'Font' panel of the 'Document-Edit' ribbon, choose:

 or 'Font | Normal', or press Alt+0·

 or 'Font | Bold', or press Ctrl+B·

 or 'Font | Italic', or press Ctrl+I·

 or 'Font | Underline', or press Ctrl+U·

 | 'Double Underline', or 'Font | Double Underline', or press Ctrl+D·

 or 'Font | Subscript', or press Alt+5·

 or 'Font | Superscript', or press Alt+4·

 or 'Font | Strike', or press Alt+6 (puts a line through the text)·

 | 'Double Strike', or 'Font | Double Strike'·

 | lowercase·

 | UPPERCASE·
Font | All Caps·
Font | Small Caps·

To reset any character format, highlight the text and select the option  or 'Font |
Normal', or press Alt+0.

Change font typeface and
point size

Highlight the text to change and select the required typeface from the 'Font'
drop-down list in the 'Font' panel of the 'Document-Edit' ribbon bar. Select the
required point size from the 'Size' drop-down list, beside the 'Font' list.

Alternatively, select the option 'Document-Edit > Font > Font > Fonts'. The 'Font
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Selection' dialog displays, from which you select the required typeface and point
size. Click on the OK button.

Change character style Highlight the text to change and select the required character style from the 'Style'
drop-down list in the 'Font' panel of the 'Document-Edit' ribbon bar.

Alternatively, select the option 'Document-Edit > Font > Font > Style'.

The 'Select a Style' dialog displays, listing the currently-defined character styles in
the template stylesheet. Select the required style and click on the OK button.

Change the color of text,
background (permanent
highlight) or underline

Highlight the text to change and select one or more of these options, as required:

Document-Edit > Font > ·

Document-Edit > Font > ·

Document-Edit > Font >  > Underline Color·
In each case, the 'Color' dialog displays, through which you can select or define the
required color.

When you have selected a color, click on the OK button.

Change character spacing Normal character spacing (the space between characters) is 20 twips; if you want to
change this (or return to it), highlight the text to adjust, and select the option
'Document-Edit > Font > Font > Spacing'. The 'Character Spacing' dialog displays.

Select the radio button to expand or compress spacing, or to return to normal
spacing; if you are changing from normal spacing, enter the number of twips to set
the spacing to.

Click on the OK button.

Change horizontal scaling Highlight the text to change and select the option 'Document-Edit > Font > Font >
Horizontal Scaling'.

The 'Horizontal Character Scaling' dialog displays. Enter a percentage value for the
amount of scaling required (valid values are 10 to 999 inclusive), then click on the
OK button. The text (both characters and spaces) is scaled horizontally, by the
specified amount.

Hide text Hidden text is not displayed on the screen or printer, but remains in the document
and is not deleted.

Highlight the text to hide and select the option 'Document-Edit > Font > Font >
Hidden', or press Ctrl+H.

The highlighted text is not displayed and the rest of the text closes up.

To view hidden text, select the option 'Document-Edit > File > View > Hidden
Text'; you can then make the text normal again by highlighting it and deselecting
the option 'Document-Edit > Font > Font > Hidden'.

Create a box around text Highlight the text to box and select the 'Font | Boxed' menu option; this creates a
broken-line border around the selected text.

Protect text Highlight the line, block or section of text to be protected, and select the option
'Document-Edit > Font > Font > Protect'.

The selected text is displayed in a gray font, and cannot be edited.

To release the text for editing again, highlight it and reselect the option
'Document-Edit > Font > Font > Protect'.

You can select and release a portion of the protected text; the remainder stays
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protected.

Note: If the ribbon option is unavailable, or the text is not faded, it means that you
have not removed the protection lock. (See Protect Document Contents.)
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Create Tables

Within any document report, you can present information using simple tables with any number of rows and columns. In a
report template, it is also possible to render a model section as a table, defined with any number of columns but with only
two rows. You can either add your own text to the tables, or populate the table cells with fields that extract information
from your model.

Access

Ribbon Document-Edit > Paragraph > Table > [option]

Create and format a table

To Action

Insert a table in the
document

Position the cursor on the point in the text to create the table, and select the option
'Document-Edit > Paragraph > Table > Insert Table'.

The 'New Table Parameters' dialog displays, in which you specify the number of
table rows and columns. For a model section table in a report template you can
accept the default values of two rows and three columns. Click on the OK button.

Your table might be invisible; if so, select the option 'Document-Edit > Paragraph >
Table > Show Gridlines' to reveal the table and cell borders in dotted lines. These
lines are for guidance in creating the document, and do not display on the printed
document. You can add printable borders using other context menu options.

The editor initially creates a table with cells of equal width across the page; you can
change the cell width by dragging the cell borders using the mouse, or using other
context menu options.

Insert a new row above the
current row

Click on a row and then select the option 'Document-Edit > Paragraph > Table >
Insert Row'.

Insert a new column to the
left of the current column

Click on a column and then select the option 'Document-Edit > Paragraph > Table
> Insert Column'.

Merge cells Highlight the cells to merge and select the option 'Document-Edit > Paragraph >
Table > Merge Cells'.

The width and/or height of the resulting cell is the sum of the widths and/or the sum
of the heights of the merged cells.

You can merge cells across a row, down a column, and in a block spanning both
rows and columns.

Split a cell Select the cell to split and select the option:

'Document-Edit > Paragraph > Table > Split Cell Horizontally' to split the·
selected cell into two cells of equal width within the column

'Document-Edit > Paragraph > Table > Split Cell Vertically' to split the cell·
into two cells of equal height, doubling the height of the whole row

Any text in the original cell is assigned to the first cell, and the second cell is
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created empty.

Delete cells Select the cells to delete and select the option 'Document-Edit > Paragraph > Table
> Delete Cells'.

The 'Delete Table Cells' dialog displays, on which you specify whether to delete:

Cells - deletes the highlighted cells; realign the column and/or row after doing·
this

Columns - deletes the column or columns containing the highlighted cells, or·
Rows - deletes the row or rows containing the highlighted cells·

If you delete all cells in a table, the table itself is automatically deleted.

Position the table on the
page

Click on any part of the table and select the option 'Document-Edit > Paragraph >
Table > Row Position'.

The 'Table Row Alignment' dialog displays, on which you select a radio button to
left-justify, center or right-justify the table on the page.

Leave the 'All Rows in the Table' checkbox selected.

This menu option has greater effect if the table is narrower than the page or text
column.

Set the height of a row, or
all rows

Highlight the rows to adjust and select the option 'Document-Edit > Paragraph >
Table > Row Height'.

The 'Row Height Parameters' dialog displays; you can select to:

Allow the row height to be determined automatically·
Set a minimum row height, or·
Set an exact row height·

If you are setting the height, type the value in twips.

You can apply the setting to the selected rows only, or select the 'Apply to all rows
in the current table' checkbox to set the height of all rows in the table.

Add a header row Select the top row of the table, and then select the option 'Document-Edit >
Paragraph > Table > Header Row'. Apply any heading text, settings and formatting
to the highlighted row.

In the document or compiled report, the heading row is repeated at the top of the
columns each time the table flows on to a new page. In a report, if the heading row
is populated with the values from field names, the heading rows on subsequent
pages reflect the values from that first row.

This option operates on the single row at the top of the table, and not on multiple
rows. If you edit the table and add a row to the top of the table to act as a new
header, selecting the menu option on the new row clears the previous setting.

Keep row text together if it
continues over a page

Select the rows to protect (preferably all rows in the table) and select the option
'Document-Edit > Paragraph > Table > Keep Row Together'.

If the row continues over the end of the page, the whole row is moved to the top of
the next page.

Set the text flow in the
table rows

Select the rows and select the option 'Document-Edit > Paragraph > Table > Row
Text Flow'.

The 'Table Text Flow' dialog displays, on which you select a radio button to set the
text flow in the rows to:

Left to right·
Right to left·
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Default·
You can apply the text flow to just the selected rows, or select the 'Apply to all
rows in the current table' checkbox to set the text flow for all rows in the table.

This option also moves the selected rows over to the appropriate side of the page or
column.

Set the width of selected
cells

Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
> Cell Width'.

The 'Set Cell Width' dialog displays, on which you set the width of the cells and the
margin between the text and the left and right sides of each cell, both in twips. You
can apply the settings to:

All cells in the table·
The selected cells only·
The complete column or columns containing the selected cells, or·
The complete row or rows containing the selected cells·

Define the width of the cell
borders

Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
> Cell Border Width'.

The 'Set Cell Border' dialog displays, on which you set the width of the lines at any
or all of the top, bottom, left and right of the selected cells. If you want the border
to enclose:

The selected cells as a block, select the 'Draw outline border around the·
selected cells' checkbox

Each selected cell separately, leave the checkbox unselected·
You can also set the margin between the text in each cell and the left and right
borders, in twips, and apply all the settings to:

All cells in the table·
The selected cells only·
The complete column or columns containing the selected cells, or·
The complete row or rows containing the selected cells·

Define the color of the cell
borders

Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
> Cell Border Color'.

The 'Set Cell Border Color' dialog displays, on which you set the color of each of
the lines at the top, bottom, left and right of a cell, or all of the cell borders at once.

You can apply the settings to:

All cells in the table·
The selected cells only·
The complete column or columns containing the selected cells, or·
The complete row or rows containing the selected cells·

Define the degree of
shading on the cell color

Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
> Cell Shading'.

The 'Cell Shading Parameters' dialog displays, in which you type the shading
percentage.

Shading is the intensity of the cell background color, expressed as a percentage, and
is uniform across the selected cells. If the cells have no colored background, a
shading of 0% is white. For colored backgrounds, 0% is the color initially set. In all
cases, a shading of 100% is black.

You can apply the setting to:
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All cells in the table·
The selected cells only·
The complete column or columns containing the selected cells, or·
The complete row or rows containing the selected cells·

Define the background
color of the cell

Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
> Cell Color'.

The 'Cell Color Parameters' dialog displays. Click on the Set Color button to
display the 'Color' dialog, on which you select a basic color or define a more
specific color.

When you have selected the color, click on the OK button.

You can apply the setting to:

All cells in the table·
The selected cells only·
The complete column or columns containing the selected cells, or·
The complete row or rows containing the selected cells·

Vertically align text in cells Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
> Cell Vertical Align'.

The 'Cell Vertical Alignment' dialog displays, on which you select to align the text
in the selected cells by the top, center or bottom of the cell or the baseline of the
lowest top line of text.

Text in a table defaults to being aligned with the top of the cell and, as you type it
in, it scrolls downwards. You can change this alignment to the center or bottom of
the cell so that text scrolls out from the center or up from the bottom of the cell.

If you have special formatting - such as 'before-paragraph' spacing - you can align
the text to the base of the lowest first line (the baseline), so that text in a row of
cells is aligned with the special formatted text rather than with the top or bottom of
the cell. If the special formatting is changed or removed, the text remains aligned.

You can apply the setting to:

All cells in the table·
The selected cells only·
The complete column or columns containing the selected cells, or·
The complete row or rows containing the selected cells·

Rotate the text of a cell to
display vertically

Select the cells to act on and select the option 'Document-Edit > Paragraph > Table
> Cell Rotate Text'.

The 'Cell Text Rotation' dialog displays, on which you select to display text
vertically up the cell, vertically down the cell or, if the text is already vertical,
horizontally across the cell,

Text in a table defaults to running horizontally across the cell from left to right, and
scrolling down the cell from top to bottom. You can change the text position so that
the text is rotated through 90 degrees to display:

From top to bottom, scrolling across the cell from right to left, or·
From bottom to top, scrolling across the cell from left to right·

If the text is running horizontally, you can type as much as you need - the row
height increases to accommodate the text. If the text is running vertically, you
adjust the row height and column width manually to accommodate your text.

You can apply the setting to:

All cells in the table·
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The selected cells only·
The complete column or columns containing the selected cells, or·
The complete row or rows containing the selected cells·

Select a column Click on a cell and select the option 'Document-Edit > Paragraph > Table > Select
Current Column'.

The whole column is highlighted and selected for further formatting.

Show gridlines Show or hide grid lines for the current table. Note that, for printing purposes,
'Border Width' must be set to a non-zero value.

Notes

Under some circumstances, a table in a generated report might repeat the header row rather than the output row; if·
this occurs, create another row in the table between the header row and the output row, and leave this blank
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Format Paragraphs

When you create a document template or document the default paragraph styles are already defined, as they are derived
directly from the Normal.rtf style template file. Within the document you can edit any of these paragraph styles or apply
individual formatting to text blocks as you need.

Each formatting option operates on the current paragraph, or on a highlighted block of text.

Access

Ribbon Document-Edit > Paragraph > Paragraph > [options]

There is also a range of icons in the 'Paragraph' panel of the 'Document-Edit'
ribbon, that provide direct access to commonly used paragraph formatting options

Paragraph formatting options

To Action

Clear all paragraph
formatting

Select the 'Paragraph | Normal' menu option.

All paragraph formatting applied to the current paragraph or selected text will be
removed.

Center text Select the 'Paragraph | Center' menu option, or press Alt+8.

Right-justify text Select the 'Paragraph | Right Justify' menu option, or press Alt+9.

Justify both sides of text Select the 'Paragraph | Justify Both' menu option.

Double Space Select the 'Paragraph | Double Space' menu option to put a double line space
between paragraphs.

Indent paragraph left Select the 'Paragraph > Indent Left' menu option, or press Alt+L.

Select the option again to increase the indent.

To reduce or cancel the indent, click on the 'Decrease Indent' icon in the Ribbon.

Indent paragraph right Select the 'Paragraph | Indent Right' menu option or press Alt+R.

Select the option again to increase the indent.

Create hanging indent Select the 'Paragraph | Hanging Indent' menu option or press Alt+T.

Select the option again to increase the indent of all lines below the first.

Keep paragraph lines
together

Select the 'Paragraph | Keep Together' menu option.

The editor attempts to keep all lines within the paragraph on the same page.
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Keep paragraphs together Select the 'Paragraph | Keep with Next' menu option.

The editor attempts to keep the last line of the current paragraph and the first line of
the next paragraph on the same page.

Prevent 'widow' and
'orphan' lines

Select the 'Paragraph | Widow/Orphan Control' menu option.

The editor attempts to avoid having:

the first line of the paragraph on the previous page ('widow' line)·
the last line of the paragraph on the next page ('orphan' line)·

Start text on new page Move the cursor to the point at which to start the new page, and select the
'Paragraph | Page Break Before' menu option.

Insert border and shading
for text block

Select the 'Paragraph | Border and Shading' menu option.

The 'Paragraph Box Parameters' dialog displays, on which you specify:

Which sides of the box to display (including a line between text lines)·
Whether the lines are thick or doubled·
The degree of gray shading behind the text·
The color of the lines·

Define line spacing Select the 'Paragraph | Paragraph Spacing' menu option.

The 'Paragraph Spacing Parameters' dialog displays, on which you specify the line
spacing and the point spacing before and after lines.

Alternatively, to just set double line spacing, select the 'Paragraph | Double Space'
menu option.

Set a background color for
text space

Select the 'Paragraph | Background Color' menu option.

The 'Color' dialog displays, on which you select the background color.

The editor highlights the full width of the page in that color, for the selected lines.

Create a bulleted list Select the 'Paragraph | Bullet' menu option.

The editor formats the lines into a simple bullet list.

If you want to indent the list (or a part of it) further, select the 'Paragraph | Increase
Level' menu option. If you have increased the indent but now want to decrease it,
select the 'Paragraph | Decrease Level' option.

Create a numbered list Highlight the required lines of text and select the 'Paragraph | Numbering' menu
option.

The editor formats the lines into a simple numbered list.

To create multiple-level numbered lists, see Set the list characters.

Apply numbering to
paragraphs

(Used in the 'Document Template Editor'.)

Set up a numbering list and overrides ('Document-Edit > Edit > Edit > List and1.
Overrides > Create List Item' and 'Create List Override').

Apply the numbering levels to the template sections ('Document-Edit >2.
Paragraph > Paragraph > List Numbering').

Apply a paragraph style
from the template
stylesheet

Select the 'Paragraph | Style' menu option.

The 'Select a Style' dialog displays, listing the currently-defined paragraph styles in
the template stylesheet.
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Select the required style and click on the OK button.

Set text flow in document To set the text flow for:

A highlighted block of text, select the 'Document-Edit > Paragraph >·
Paragraph > Text Flow' ribbon option; the 'Paragraph Text Flow' dialog
displays

The entire document, select the 'Document-Edit > Edit > Document Text Flow'·
menu option; the 'Document Text Flow' dialog displays

In either case, select the required text flow direction and click on the OK button.
The options are:

Left to right·
Right to left·
Default·

The 'Default' action depends on the language setting of the system; for example, if
the system language is Hebrew or Chinese, the default text flow is right to left.

Paragraph Marker Displays or hides the various space markers in the text, such as:

The paragraph marker at the end of each paragraph·
The Tab indicators between tabbed blocks of text, and·
The blank character marker between words·

This option is useful when working with page-formatted text that is structured using
both style definitions and key-strokes.

Set the list characters  When you have set up your bulleted or numbered list elements, you can toggle
between the list character options using the drop-down arrow icon just to the left of
the bullet list icon on the lower toolbar of the document template editor.

When you click on this icon, you are prompted to select between a single-level list
format and a multiple-level list format. When you select one of these options, you
then make a further selection between:

Single-level: Arabic numerals, Roman numerals, upper-case letters and·
lower-case letters

Multiple-level: Arabic numerals, Roman numerals and bullet symbols·
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Define Document Sections

Using the Document Editor, you can partition your text into separate sections, present the text in a section in columnar
format, and set different page orientations and printing for each section. A multiple section document is useful to:

Change the presentation and format of the text for different areas of information·
Change between portrait and landscape orientation for different parts of the document·
Vary the page margins from one page to another·

Access

Ribbon Document-Edit > Edit > Insert > Insert Break > Section Break

Create a section

Select the 'Insert | Insert Break | Section Break' menu option. This creates a new section on a new page.

The section break is represented by a dotted line; if this is not visible, click on the  icon in the 'Paragraph' panel of
the 'Document-Edit' ribbon.

The 'Section Break' menu option is not effective when 'Edit Page Header/Footer' is active, because editing control passes
to the header and footer bands away from the body of the document.

Set section properties

Section properties apply to all the document content following the section break, up to the next section break line.

Select the option 'Document-Edit > Edit > Edit > Edit Section' to display the 'Section Parameters' dialog. Complete each
panel to set up the section as you require.

To Action

Set number of columns in a
section

The 'Number of Columns' field defaults to '1', to present the text as a normal page
of text (effectively a single column).

To structure the text in two or more columns on a page:

In the 'Number of Columns' field, type the number of columns to divide the·
text into across the page

In the 'Space Between the Columns' field, type the separation of the columns,·
in inches

If you want to separate the columns with a vertical line, select the 'Line·
Between Columns' checkbox

When you close the dialog, the text is displayed in the selected number of  columns
of equal width, across the page. The text wraps at the edge of the column and, when
it reaches the foot of the page, continues at the top of the next column.

Start section on new page If you want to insert a page break before the new section, select the 'Start Section
on New Page' checkbox.

If you also want to adjust the page numbering so that the new section starts at a

(c) Sparx Systems 2015 - 2017 Page 555 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

specific page, select the 'Restart Page Number at' checkbox and type the page
number.

The section start page will often be 1, but this facility is also useful for inserting
another document of a constant number of pages between, for example, an
introduction and a technical section.

Set text direction Set the direction of the text flow within the section by selecting the appropriate
radio button.

Set page orientation Set the page orientation within the section by selecting the appropriate radio button.

Set paper size for section Select a standard paper size for the pages of the section.

Alternatively, you can scroll down the list and select the 'Custom Size' option, and
then define the page width and height, in inches.

You can also define special page margins by selecting the option 'Document-Edit >
File > File > Page Layout'.

Set paper source The 'Paper Source' selections both default to 'Auto Select', so that the pages of the
section print from whatever paper trays have paper available.

If you are printing on paper from a specific tray, or are manually feeding paper to
the printer for this section, select the appropriate option. You can select different
options for the first page of the section and subsequent pages of the section.

Delete a section break

Move the cursor onto the labeled Section Break line and press the Delete key.

When you delete a section break, the section properties of the preceding section now apply to the document content
following the deleted line.
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Set Tabs

Using the Document Editor, you can define left, right, center and decimal tab points to define the positions of text strings
and columns across the page. A paragraph or highlighted block of text can have as many as twenty tab points, which
apply to every line of the selected text.

If you do not set tab points, the Tab key moves the cursor to default tab points at 0.5-inch intervals.

Access

From the 'Document-Edit > Paragraph' panel on the ribbon, drop-down the 'Paragraph' menu and choose one of:

Set Tab·
Clear Tab·
Clear All Tabs,·

or click on the ruler at the top of the page.

Create and Clear Tab Points

Operation Detail

Using the ruler If the ruler is not visible, select the option 'Document-Edit > File > View >
Horizontal Ruler'.

To create a:

Left tab, click on the required tab position on the ruler; the left tab is indicated·
on the ruler by an 'L' shape

Right tab, right-click on the required tab position on the ruler; the right tab is·
indicated on the ruler by a reversed 'L' shape

Center tab, press Shift and click on the required tab position on the ruler; the·
center tab is indicated on the ruler by an inverted 'T' shape

Decimal tab, press Shift and right-click on the required tab position on the·
ruler; the decimal tab stop is indicated on the ruler by an inverted 'T' shape
with a dot on the right hand side
This tab is for numbers with a decimal point; numbers scroll left from the tab
until you type the point, then numbers scroll right.

To move a tab position, click on the tab symbol on the ruler and drag it to the new
position.

Using the Set Tab menu
option

The 'Paragraph > Set Tab' menu option displays the 'Set a Tab Position' dialog, on
which you select from a set of radio buttons to specify the tab type.

The dialog provides two advantages over the ruler; you can:

Set the tab position with more precision and with a clear value (in inches) that·
you can duplicate

Select from a set of radio buttons to add or remove a dotted, broken or solid·
line preceding the tab point

Click on the OK button to save the settings.
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Clearing a single tab point Highlight the block of text and select the 'Paragraph | Clear Tab' menu option.

The 'Clear a Tab Position' dialog displays.

Select the tab to clear and click on the OK button.

Clearing all tab points for a
text block

Select the block of text and select the 'Paragraph | Clear All Tabs' menu option.

Notes

The option 'Document-Edit > File > Manage > Snap To Grid' affects the movement of the tabs (and the paragraph·
indentation markers) on the ruler; when you select this option, the movements of the tab markers are locked on to an
invisible grid at intervals of 1/16 inch (half a ruler division)

(c) Sparx Systems 2015 - 2017 Page 558 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Manage Page Breaks

As you set up the document structure, you might want to insert a page or column break to force a specific part of the
document content to start on a new page or column.

Access

Ribbon Document-Edit > Edit > Insert > Insert Break > Page Break, or

Document-Edit > Edit > Insert > Insert Break > Column Break

Keyboard Shortcuts Ctrl+Enter    (page break)

Force a page break

Select the option 'Document-Edit > Edit > Insert > Insert Break > Page Break', or press Ctrl+Enter.

The forced page break is indicated by a labeled solid line; if this is not visible, click on the  icon, in the 'Paragraph'
panel of the 'Document-Edit' ribbon.

Create a column break

Move the cursor to the appropriate point in the column text and select the option 'Document-Edit > Edit > Insert > Insert
Break > Column Break'. The break is indicated by a labeled 'dot and dash' line.

Normally in a multiple column section, the text flows from the end of one column to the top of the next column; a
column break forces the text to the next column before the current column is completely filled.

Delete a break

A page break or column break is indicated by a labeled line. To delete the break, move the cursor onto this line and press
the Delete key.
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Insert Headers, Footers, Footnotes and Endnotes

When creating a document report or template, you can include page headers, footers, endnotes and footnotes. You switch
options on to create and edit these items, and then switch these options off again to protect the entries. While you are
creating headers and footers, you can also continue to edit the body of the document. You can create headers and footers:

To apply throughout the document·
Separately for each section that you might create in your document·
Separately for the first page of the document and for the subsequent pages (for example, to leave no header and·
footer text on the title page of the document)

Separately for left-hand and right-hand pages·

Header and footer options

To Action

Create the page header and
footer

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer'.

A dotted line marks off the header area at the top of the page and the footer area at
the bottom of the page. This dotted line is at a position that is set using the 'Page
Setup' dialog ('Document-Edit > File > File > Page Layout').

Within each of these two areas, a paragraph marker displays to indicate where the
text will sit relative to the top and bottom edges of the paper. This position is also
defined on the 'Page Setup' dialog.

You can type in any kind of free-form or formatted text and insert icons as you
prefer. You would normally work well within the defined areas for the header and
footer, but if the text exceeds the area, the dotted lines simply move to
accommodate the text.

Edit or delete the page
header and footer text

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer', move the cursor to the text and make any changes required. If you
need to, delete the text altogether.

Create separate header and
footer for the initial page of
the document

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > First Page
Header/Footer' and either:

The 'Create First Page Header' option, or·
The 'Create First Page Footer' option·

A paragraph marker displays at the top or bottom of the first page of the document.
If you want specific text to display on the first page of the document, type it in and
format it.

Alternatively, leave the spaces blank so that the first page has no header or footer
text.

Display the common
document header and
footer on the initial page

If you have created a separate initial page header and/or footer and now want to
display the same header and footer text on the initial page as is shown on
subsequent pages of the document, you specifically delete the 'first page
header/footer' assignment.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
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Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > First Page
Header/Footer' and either:

The 'Delete First Page Header' option or·
The 'Delete First Page Footer' option·

The 'first page' assignment and text are removed from the first page header and/or
footer spaces.

Create separate header and
footer for left-hand pages

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Left Page
Header/Footer' and either:

The 'Create Left Page Header' option, or·
The 'Create Left Page Footer' option·

Scroll to the nearest left-hand page and in the header or footer space type in any
kind of free-form or formatted text and insert icons as you require.

This text displays on every left-hand page in the section or, if there are no sections,
in the document.

Format your document to put left-hand page information on pages with left-hand
headers and footers. For example, in English language documents, even-numbered
pages are usually left-hand pages.

Create separate header and
footer for right-hand pages

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Right Page
Header/Footer' and either:

The 'Create Right Page Header' option, or·
The 'Create Right Page Footer' option·

Scroll to the nearest right-hand page and in the header or footer space type in any
kind of free-form or formatted text and insert icons as you require.

This text displays on every right-hand page in the section or, if there are no
sections, in the document.

Format your document to put right-hand page information on pages with right-hand
headers and footers. For example, in English language documents, odd-numbered
pages are usually right-hand pages, and sections such as Title, Introduction and
Table of Contents start on right-hand pages.

Delete left or right page
headers and footers

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces.

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > <side>
Page Header/Footer' (where <side> is either Left of Right) and either:

The 'Delete <side> Page Header' option, or·
The 'Delete <side> Page Footer' option·

You are prompted to confirm the deletion; click on the Yes button.

Left and Right page headers or footers balance each other. If you create one, the
system responds as if the other exists but is blank. If you delete one, the system
responds as if the other is the 'common' header/footer for the section, and all page
headers now contain that remaining text.

Close and protect headers
and footers

Select the option 'Document-Edit > Edit > Edit > Page Header/Footer > Edit Page
Header/Footer' to access the header and footer text spaces again, and check that you
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cannot move the cursor into the header and footer spaces.

Footnote and Endnote options

To Action

Create a footnote Move the cursor to the position at which to insert the footnote marker, and select
the option 'Document-Edit > Edit > Insert > Footnote/Endnote > Footnote'.

The 'Footnote' dialog displays. In the:

'Footnote Marker' field type the marker you want to use, such as a number,·
asterisk, hash or letter of the alphabet, or any text string of up to 10 characters

'Footnote Text' field, type the text of the footnote·
'Superscript Footnote Marker' field, leave the checkbox selected to display the·
marker as a superscript, or clear the checkbox to display the marker in the same
format as the preceding text

Click on the OK button; the editor inserts the footnote marker at the current cursor
location and displays the marker and text at the bottom of the page, above the page
footer space.

Edit footnote text Select the option 'Document-Edit > Edit > Edit > Edit Footnote/Endnote > Edit
Footnote text'.

The marker and text of each footnote displays in the document text where the
marker was originally inserted, highlighted by a broken underline.

Locate the text and make the required changes. These changes are immediately
reflected in the footnote text at the bottom of the page.

When you have finished editing footnote text, click again on the option
'Document-Edit > Edit > Edit > Edit Footnote/Endnote > Edit Footnote text'; the
footnote text is no longer shown in the document text.

Create an endnote Move the cursor to the position at which to insert the endnote marker, and select the
option 'Document-Edit > Edit > Insert > Footnote/Endnote > Endnote'.

The 'Endnote Parameters' dialog displays. In the:

'Endnote Marker' field type the marker you want to use, such as a number or·
letter of the alphabet, or any text string of up to 10 characters

'Endnote Text' field, type the text of the endnote·
'Superscript Endnote Marker' field, leave the checkbox selected to display the·
marker as a superscript, or clear the checkbox to display the marker in the same
format as the preceding text

Click on the OK button; the editor inserts the endnote marker at the current cursor
location and displays the marker and text at the end of the section or, if there are no
sections, at the end of the document.

Edit endnote text Select the option 'Document-Edit > Edit > Edit > Edit Footnote/Endnote | Edit
Endnote text'.

The marker and text of each endnote displays in the document text where the
marker was originally inserted, highlighted by a broken underline.

Locate the text and make the required changes; these changes are immediately
reflected  in the endnotes at the end of the section or document.

When you have finished editing endnote text, click again on the option
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'Document-Edit > Edit > Edit > Edit Footnote/Endnote | Edit Endnote text'; the
endnote text is no longer shown in the document text.

Notes

You can create and edit headers and footers whether the option 'Document-Edit > File > View > Page Layout Mode'·
is switched on or switched off; this option makes no difference.

(c) Sparx Systems 2015 - 2017 Page 563 of 583 Created with Enterprise Architect



User Guide - Building Models 30 June, 2017

Insert Hyperlinks

Within a document, you can insert hyperlinks to display material held outside the document, such as external documents,
Help topics or web pages.

Access

Ribbon Document-Edit > Edit > Insert > Hyperlink

Insert hyperlinks

To insert a hyperlink, right-click on the point in the text at which to create it and select the option 'Document-Edit > Edit
> Insert > Hyperlink'; the 'Insert Hyperlink' dialog displays.

In the 'Link Text' field, type the text to be hyperlinked and, in the 'Link Code' field, type or paste the:

Web page URL·
Help topic file name or·
External file path and name·

To capture the Help topic file name and path, right-click on the displayed topic and copy the file name and path from the
address field at the top of the screen.

Click on the OK button; the hyperlinked text displays in the document. Edit the sentence to accommodate the link text.

To display the web page, Help page or external document:

Linked in a document, double-click on the link·
Linked in a report template, compile the report and click on the hyperlink in the report·

In a Team Review document, you can also insert hyperlinks to related objects in the model.
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Insert Images, Objects and Frames

In creating your document or template, you might want to embed or display images and other objects in the text, to insert
external information and/or structure the text and graphics on a page. You could insert, for example:

An image in the text or as background to the text·
A link to an image·
An Object Linking and Embedding (OLE) object, which you create and edit using an external application·
A frame - a rectangular border within the text that can contain separate text and pictures, and that the existing text·
flows around

A drawing object - a rectangle, text box or line that can sit over the existing text·
Another document file·

Having inserted an object, you can subsequently move, edit or delete it.

Insert items

To Action

Insert a picture in the
document

You can insert a picture bitmap or Windows metafile in your document as either an
embedded picture or a link to the external picture file.

Position the cursor at the point at which to insert the picture, and select either:

'Document-Edit > Edit > Insert > Embed Picture' (F8) or·
'Document-Edit > Edit > Insert > Link Picture'·

A browser dialog displays, through which you select the picture to insert in the
document; the picture is shown at the current cursor location.

The embedded picture is saved within the document; only the filename of the linked
picture is saved with the document, which is a better option if you intend to edit the
picture over time.

Embed an OLE object in
the text

Position the cursor at the point at which to embed the object, and select the
'Document-Edit > Edit > Insert > OLE Object' menu option.

The 'Insert Object' dialog displays, listing the applications that are available to
create the object.

When you select an application, the editor launches it and you create the  object;
when you save the application, the editor inserts an icon or view that represents the
inserted object.

You can also use the option 'Document-Edit > Edit > Edit > Paste Special' to import
OLE objects, provided that the object is available in the clipboard.

You can later edit the object using the application, by double-clicking on the object
or by selecting the option 'Document-Edit > Edit > Edit > Edit OLE Object'.

Change the size and
alignment of an embedded
picture

Click on the picture and select the option 'Document-Edit > Edit > Edit > Edit
Picture'; the 'Edit Current Picture' dialog displays, through which you can change
the height and width of the picture, in inches.

You can also align the top, middle, or bottom of the picture with the baseline of any
text on the same line as the picture, or offset the bottom of the picture from that
baseline by any number of twips.

Insert a background or Select the option 'Document-Edit > File > Manage > Watermark Picture'; a browser
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watermark picture for the
document pages (document
report templates)

dialog displays, through which you select the graphic file to insert as a watermark.
The picture occupies the entire text area, and is displayed as a washed-out image. If
you choose an image that is already washed-out, no watermark is displayed at all.

To remove the watermark image, deselect the option 'Document-Edit > File >
Manage > Watermark Picture'.

Insert a document File Position the cursor at the point at which to insert the file, and select the option
'Document-Edit > Edit > Insert > Insert RTF File'.

Embed a frame at the
cursor position

Select the option 'Document-Edit > Edit > Insert > Frame'.

The border of the frame displays, with the cursor at the top left corner. You can
change the size of the frame by clicking on the border and dragging the small black
'handles'.

Embed a drawing object at
the cursor position

Select the option 'Document-Edit > Edit > Insert > Drawing Object'.

The 'Select Drawing Object Type' dialog displays, on which you select the radio
button for either a:

Text Box·
Rectangle or·
Line·

Click on the OK button; the selected object displays, overlaid on the existing
document content.  If required, you can change the size of the object by clicking on
the border and dragging the small black 'handles'.

You can also change the appearance and the relationship of the object to the
document text.

Move the frame or drawing
object

Click on the outline of the frame or drawing object and then move the cursor just
outside the outline so that the cursor changes to a plus-shape.

Drag the plus shape (and hence the outline) to the new position.

Edit the border,
background and impact on
document text of a drawing
object

Select the drawing object by clicking on its outline, then select the option
'Document-Edit > Edit > Edit > Edit Frame/Drawing Object > Edit Drawing
Object'.

The 'Line and Fill attributes' dialog displays.

Select the options to define:

Whether to display a border line and, if so, your preferred border thickness,·
type and color

Whether the object is transparent or filled and, if filled, the fill color·
The wrapping behavior of the text outside the object:·
    - 'Wrap Through' causes the document text to flow through the diagram
object so that
       they overlap each other
    - 'No Wrap' causes the document text to skip over the object, so that the text
resumes
       below the object
    - 'Wrap Around the Object' causes the document text to flow around the
object, into a
       column on one side or the other of the object, or on both sides; if you move
the object
       across the page, the editor tends to leave a wider margin before it starts to
wrap text to
       the left of the object

The Z Order of the object, so that if there is an overlap the object either lies in·
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front of the document text (Z-order = 1) or behind the document text (Z Order
= >1)

Insert text into the frame,
text box or rectangle

Click inside the outline and type the text at the cursor position. The text wraps at
the right hand side of the box and, for a:

Frame, extends the bottom border of the box·
Text box and rectangle, overflows the bottom of the box but is still associated·
with the box and not with the 'normal' text of the document; to enclose all lines
adjust the height manually to enclose the text

If you change the width of the outline, any text inside the outline is automatically
wrapped to adjust to the new width.

Rotate text to display it
vertically in the frame or
text box

Select the option 'Document-Edit > Edit > Edit > Edit Frame/Drawing Object >
Rotate Text'. The 'Text rotation' dialog displays; select the radio button for the text
direction you want to apply:

'Horizontal' (default) - the text flows from the top left corner of the box across·
the width of the box, wrapping at the right border and scrolling downwards

'Top to Bottom' - the characters are rotated through 90 degrees to flow from the·
top right corner of the box downward, wrapping at the bottom edge of the box
and scrolling right to left

'Bottom to Top' - the characters are rotated through 90 degrees to flow from the·
bottom left corner of the box upward, wrapping at the top edge of the box and
scrolling left to right

If the text is running horizontally, you can type as much as you need - the box
height increases to accommodate the text. If the text is running vertically, and it
flows outside the box, you adjust the box height and width manually to
accommodate your text.

Click on the OK button to apply the change.

Insert a picture into a frame
or drawing object text box

Click inside the outline and either insert the picture as previously explained, or
copy and paste it at the cursor position.

If the frame or text box contains only the picture, the picture size is automatically
adjusted to as nearly fill the outline as possible without distorting the image.

If you change the width or height of the box, the picture is adjusted to completely
fill the outline; you continue manually adjusting the outline to reduce the distortion
of the image.

Lock a frame or drawing
object to a point on the
page

You can fix the position of the outline to a specific point so that as you enter and
format the text the outline maintains its position relative to that point.

The default position is relative to the first character of the paragraph, in which case
the outline moves on the page with any change that affects the position of the
paragraph.

You can also fix the position relative to either the:

Top edge of the page or·
Top margin of the page·

In these cases, if the document text on the page is adjusted it flows past the outline.

Click on the outline and select the option 'Document-Edit > Edit > Edit > Edit
Frame/Drawing Object > Vertical Base Position' menu option.

The 'Object Position' dialog displays. Select the radio button for the locking point
you prefer:

'Top of the Page'·
'Top Margin'·
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'Current Paragraph'·
Click on the OK button to apply the lock.

Delete a frame or drawing
object

Click on the outline and press the Delete key.

The editor prompts you to confirm the deletion; click on the Yes button.

This deletion is reversible - press Ctrl+Z or select the option 'Document-Edit > Edit
> Edit > Undo'.
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Checking Text

In developing a document or template, you would probably want to spell-check the text that you have entered; for
example, to make sure that 'boiler-plate' text is correct, as it will be used many times in many reports. In the Document
Editor you can both spot-correct a word from a context-sensitive list, or run a spell checker over the whole document.
You can also check the use of a word against an online thesaurus, to see if there is a more precise term or to check the
opposite meaning of the word.

Access

Ribbon Document-Edit > Edit > Spell Check > [options]

Check Spelling

To Action

Spot-correct a word Select the option 'Document-Edit > Edit > Spell Check > Auto Spell Checking'.

When the 'Auto Spell Checking' option is on, the Document Editor automatically
checks the spelling of all typed or pasted text in the document (but not field names
or generated text). Words that are apparently spelt incorrectly are underlined in red.

Right-click on an underlined word; a short list displays, containing the correct
spelling of the assumed word and a selection of other words that this word might
have been intended to be. Click on:

One of the words, to use it in place of the misspelt word·
The 'Ignore All' option to use the word as it is in this context·
The 'Add' option to add the word to the suggested list of spellings/other words·

You might be using a language for which there is no spelling dictionary installed,
or text that contains a high proportion of new terms, in which case you might not
want to have the auto spell function underlining all the text. You can turn it off by
selecting the 'Other | Auto Spell' option again.

Run the spell checker over
the whole document

Select the option 'Document-Edit > Edit > Spell Check > Spell Check'.

The 'Check Spelling' dialog displays, identifying the first apparent spelling mistake
in the document.

You might want to modify the things that the Spell Checker identifies as errors;
click on the Options button to tailor the operation of the checker.

Having tailored the spell checker, respond to each of the possible errors that it
highlights in your document.

When you have acted on all the words presented by the Spell Checker (or clicked
on the Cancel button) a status message displays identifying the number of words
picked up and the number of those words you have corrected. Click on the OK
button.

Run Thesaurus
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To Action

Access the Thesaurus Select a word in the text, then select the option 'Document-Edit > Edit > Spell
Check > Thesaurus'.

The 'Thesaurus' dialog displays, showing the:

Selected word·
Word-categories the word belongs to, in the 'Categories' panel·
List of synonyms for the word within the first category (words that have the·
same meaning as the selected word)  in the 'Synonyms' panel

If there are several categories, click on each one to display the synonyms within
each category.

Display antonyms If you want to display the antonyms for the word (the opposite meanings of the
word), select the Antonyms checkbox.

The Antonyms title displays in the Categories panel, with the word-categories for
the opposite of the selected word listed underneath.

Click on a category name to list the antonyms in that category, in the Synonyms
panel.

Check for homonyms A homonym is a word that sounds like another and can be confused with it. For
example, 'Sympathy' might be confused with 'Empathy' or 'Symphony'.

If you want to check that you have not chosen a sound-alike word by mistake, click
on the Suggest button.

The 'Suggestions' dialog displays, listing possible sound-alike words. If you want to
use one of those words, or check for another with the same meaning, click on the
Look up button.

The 'Thesaurus' dialog refreshes with the new word you have selected.

Search for new terms If you want to examine a totally different word, in the 'Term' field type the new
word and click on the Look up button.

The display changes to show the synonyms (and antonyms) of the new word.

Change to a synonym Click on a synonym (or an antonym, if required) in the list, and click on the OK
button.

The word in the text changes to the selection.
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Track Changes

In a team environment, two or more people might work on developing documents and/or templates. You might,
therefore, need to review each other's work, or just be able to see what changes another person has made to the file. In
the Document editor, you can turn on change tracking to highlight the changes you make to the text.

Access

Ribbon Document-Edit > Edit > Edit > Track Changes > [options]

Tracking options

To Action

Turn tracking on Select the option 'Document-Edit > Edit > Edit > Track Changes > Enable
Tracking'.

Any changes made after Tracking is turned on are immediately highlighted:

Inserted text - printed in a different color·
Deleted text - struck through with a single colored line·
Formatting changes - indicated by a colored dotted underline·

A change bar is also inserted in the page or column margin to indicate the line on
the page on which the change was made.

If you mouse over a highlighted change, a tool-tip displays the type of change, the
name of the person who made the change, and the date and time the change was
made.

Turn tracking off Select the option 'Document-Edit > Edit > Edit > Track Changes > Enable
Tracking' again.

Any changes made after Tracking was turned on remain highlighted, but changes
made after tracking was turned off are not highlighted.

Hide changes If you want to review the document as it is, without the highlighted changes, but
you do not want to lose the changes or highlighting, select the option
'Document-Edit > Edit > Edit > Track Changes > Hide Changes'.

The highlighted additions and deletions are hidden, and the remaining text closes
up. Format changes are not hidden.

To expose the hidden changes, click on the option 'Document-Edit > Edit > Edit >
Track Changes > Hide Changes' again.

Locate changes Select the option 'Document-Edit > Edit > Edit > Track Changes > Find Next
Change' or 'Document-Edit > Edit > Edit > Track Changes > Find Previous Change'
to search the text and place the cursor on the next or previous change made,
respectively.

Respond to change If you want to assess each change and act on your decision, select the option:

'Document-Edit > Edit > Edit > Track Changes > Accept Change' to confirm·
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the change, or

'Document-Edit > Edit > Edit > Track Changes > Reject Change' to reverse the·
change to the original text or format

In either case, the change tracking markings are removed. You can make further
changes if necessary.

Accept all changes If you are not assessing each change, for example if you just want to see what a
colleague has done before making your own changes, you can accept all changes
across the document in one action.

Select the option 'Document-Edit > Edit > Edit > Track Changes > Accept All
Changes'.

Reject all changes If you are not assessing each change, but just want to reverse all changes across the
document in one action, select the option 'Document-Edit > Edit > Edit > Track
Changes > Reject All Changes'.

A prompt displays for you to confirm the action; click on the Yes button.

You might do this if, for example, you or a colleague have edited the wrong version
of a document or acted on a technical change that was itself reversed.
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Protect Document Contents

When you have created a document, or some important text within a document, you might want to protect it from being
edited or deleted so that it is safe from accidental change. The Document Editor defaults to locking against protection, so
you first turn off the lock and then protect either the whole document or a selected block of text. Once protection is set,
neither you nor any other user can change the text without specifically removing the protection.

Access

Ribbon Document-Edit > File > Manage > Text Selection Lock

Document-Edit > Font > Font > Protect

Document-Edit > File > Manage > Protect Document

Protect text

To Action

Enable text protection By default, the Text Selection Lock is enabled.

Select the option 'Document-Edit > File > Manage > Text Selection Lock' to disable
this option.

You can now set protection on your text.

To re-enable the protection lock and prevent protection of further text, select the
option 'Document-Edit > File > Manage > Text Selection Lock' again. The text that
you have already protected, however, remains protected and cannot be edited until
you or another user specifically removes the protection. You cannot remove
protection from this text until you turn off the protection lock again.

Protect text Highlight the line, block or section of text to be protected, and select the option
'Document-Edit > Font > Font > Protect'.

The selected text is displayed in a gray font, and cannot be edited.

If the menu option is unavailable, or the text is not faded, it means that you have
not removed the protection lock (above).

To release the text for editing again, highlight it and reselect the option
'Document-Edit > Font > Font > Protect'. You can select and release a portion of
the protected text; the remainder stays protected.

Protect a document

Within the document or template, select the option 'Document-Edit > File > Manage > Protect Document'.

The entire document is protected.

An exception is protecting a template in the Document Template Designer. As you select checkboxes in the 'Sections'
panel, section markers are still added to the 'Content' panel. You cannot, however, add fields or text between the markers.

To release the document for editing again, reselect the option 'Document-Edit > File > Manage > Protect Document'.
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Spell Checking

Enterprise Architect provides a powerful spell checking facility. This operates at both project level and Package level.

Topics

Topic Detail

Automatic Spell Checking The spell checker can be set to run automatically, so that it highlights possible
errors in text as it is created or pasted in:

Select 'Start > Workspace > Preferences > Objects'·
Deselect or select the 'Disable spelling' checkbox·

Spelling Configuration You can configure what types of text error the spell checker should detect, using
the 'Spelling Options' dialog.

Using Languages Other
Than English

Enterprise Architect is supplied with dictionaries for US English, Canadian English
and British English; you can download a set of dictionaries for other languages
from the Sparx Systems website.

Using the Spell Checker You can run the spell checker manually on the whole model, or on a selected
Package.

Correcting Text As the spell check progresses, Enterprise Architect highlights any errors or
unknown words; you have several options for responding to these potential spelling
errors.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have 'Spell Check' permission to perform any spell check or change any
spell check options
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Select Spell Checker Options

You can configure the spell checker to ignore or detect specific types of text conformation. Ignoring the conformation
means to skip over the text without identifying it as an error.

Access

Ribbon Publish > Documentation > Spelling | Spelling Options

Configure the spell checker

Option Action

Ignore capitalized words Ignore any words beginning with a capital letter, such as 'David'.

You might enable this option if the text being checked contains many proper
names.

Ignore all-caps words Ignore any words containing all capital letters, such as RADAR.

You might enable this option if the text being checked contains many acronyms.

Ignore Words with
Numbers

Ignore any words containing embedded digits, such as 'Win95' and 'Q4'.

You might enable this option if the text being checked contains many code words
or other symbols containing digits.

Ignore Words with Mixed
Case

Ignore any words containing an unusual mixture of upper- and lower-case letters,
such as 'MicroHouse' and 'CapsLock'.

You might enable this option if the text being checked contains many variable
names or other symbols that use changes in letter-case to distinguish words.

Ignore Domain Names Ignore any words that appear to be Internet domain names, such as
wintertree-software.com.

Report Doubled Words Detect any word appearing twice in a row, such as 'the the'.

Case Sensitive Distinguish between capitalized and non-capitalized words.

For example, canada would be considered as different from Canada, and therefore
reported as a misspelling.

When the option is disabled, canada and Canada are considered  to be identical.

Note that the performance of the spell checker is reduced if this option is disabled.

Phonetic Suggestions Suggest alternative words based on phonetic (sounds-like) similarity to the
misspelled word; this option tends to improve the correction of badly misspelled
words.

Enabling this option increases the time required to locate suggestions.

Note that either this option or the 'Typographical Suggestions' option must be
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enabled in order to list suggestions of alternative words.

Typographical Suggestions Suggest alternative words based on typographical (looks-like) similarity to the
misspelled word. This option is appropriate for people who are generally good
spellers.

Note that either this option or the 'Phonetic Suggestions' option must be enabled in
order to list suggestions of alternative words.

Suggest Split Words Suggest two separate words as a replacement for a misspelling containing two
joined words.

For example, is the would be suggested as a replacement for isthe.

Auto Correct Automatically change words marked with Auto Change actions to their specified
replacements.

When this option is disabled, a confirmation prompt displays before the words are
changed.

Main Dictionary Language Set the language of the main dictionary used to check spelling; the drop-down list
shows only languages for which dictionaries are installed on your system.

To check spelling in a different language, select the language in the list.

Suggestions Determine the speed and accuracy of the initial automatic search for suggested
replacements for misspelled words.

Click on the appropriate radio button for your choice.

OK Close the 'Preferences' dialog, and save any changes made to the settings.

Cancel Close the ''Preferences' dialog, and discard any changes made to the settings.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have Spell Check permission to perform any spell check or change any
spell check options
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Use Languages Other Than English

Enterprise Architect is supplied with three dictionaries, for US English, Canadian English and British English.
Additional dictionaries are available as a pack, for download from the registered pages of the Sparx Systems website.

The dictionaries in this downloadable file enable spell checking in these languages:

Brazilian·
Danish·
Dutch·
Finnish·
French (Continental)·
German·
Italian·
Norwegian·
Portuguese·
Spanish and·
Swedish·

Download the additional language dictionary pack

Step Action

1 Access the registered user page on the Sparx Systems web site.

2 At the end of the page, download the EADict.zip file from the Enterprise Architect Dictionary section.

3 Unzip the file into the Enterprise Architect install directory - C:\Program Files\Sparx Systems\EA.

This makes the non-English spelling dictionaries available to the Enterprise Architect spell checker.

Notes

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have Spell Check permission to perform any spell check or change any
spell check options

Enterprise Architect .EAP files default to use Jet 3.5 as the database engine; this does not support unicode character·
sets, which makes the use of certain languages - such as Portuguese - difficult, including spell checking words in
those languages

If you use such languages, it is recommended that you either upsize to a DBMS repository or set JET 4.0 as the
database engine

If your .EAP project is not in a Jet 4.0 database, you should also download a copy of the Jet 4.0 EABase model from
the Sparx Systems website, and do an EAP to EAP transfer of your model into the Jet 4.0 file
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Using the Spell Checker

Enterprise Architect has an inbuilt spell checker, which you can configure to detect a range of types of possible spelling
error in your project, and to use one of several language dictionaries other than English.

Access

Ribbon Publish > Documentation > Spelling > Spell Check Project

Publish > Documentation > Spelling > Spell Check Current Package

Keyboard Shortcuts Ctrl+F7            (spell check project)

Ctrl+Shift+F7        (spell check current Package)

Run the spell checker

Step Action

1 Select the 'Spell Check Project' or 'Spell Check Current Package' menu option, as required.

The 'Spell Check' dialog displays.

2 ('Spell Check Project' option.) Select the checkbox against each of the items to spell check within your
model.

3 Click on the Start button to begin the spell check.

As the spell check proceeds, the text being checked displays in the text panel at the bottom of the screen;
if an error is detected, the 'Check Spelling' dialog displays, offering several options to correct the error.

Notes

You can use the Spell Check Project menu option to check spelling for the entire project·
The Spell Check Current Package option only checks the Package currently open, and you cannot select items to·
check

In the Corporate, Business and Software Engineering, Systems Engineering and Ultimate editions of Enterprise·
Architect, if security is enabled you must have Spell Check permission to perform any spell check or change any
spell check options
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Correcting Words

As a spell check progresses, Enterprise Architect highlights any errors or unknown words in the 'Check Spelling' dialog.
The inbuilt spell check stores user-defined words in the user dictionary (%APPDATA%\Sparx Systems\EA\userdic.tlx).
During the spell check process, if you add a word, it is written into this file for later reference. While the spell check is in
progress you can:

Correct the spelling of a word·
Ignore the error·
Add the word to the user dictionary·
Suggest alternatives or·
Otherwise assist in the spelling correction process·

Correct spelling

As the Spell Checker identifies possibly mis-spelled words, make the appropriate response:

Action

Modify the spelling by hand and click on the Change or Change All button to change the word to that spelling·
Click on a suggested alternative and click on the Change or Change All button to change the word to that·
spelling

Click on the Ignore or Ignore All button to exclude the word from the spell check·
Click on the Add button to add the word to the user dictionary·
Click on the Suggest button to list alternative spellings or words·
Click on the Cancel button to abort the spell check entirely·
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Bookmarks

A bookmark is a visual clue that something is different about an element; it is represented by a small red triangle (or red
Delta symbol) that displays above the element in the diagram or Model Search.

You can assign any meaning to the bookmark as is appropriate to your model.

You can bookmark:

Single elements manually, or·
All elements in a Package automatically when they assume a defined status·

Bookmark Options

Option Action

Bookmark a selected
element in a diagram

Either:

Press Shift+Space, or·
Select the 'Design > Element > Manage > Bookmark' ribbon option·

Clear a bookmark on a
selected element

Use either of the above two options again.

Bookmark Multiple
Elements in a Package

Project Browser | Right-click on Package | Contents | Bookmarks

The 'Manage Bookmarks' dialog displays, which you can use to automatically
bookmark any elements (and, if required, their children) in the Package that have:

New changes defined in the Maintenance window·
New defects defined in the Maintenance window, and/or·
Test scripts defined in the Testing window·

This is useful to highlight elements that have additional project information.

Clear all elements of
bookmarks

To clear all bookmarks:

Throughout the current Package, click on the Clear All button on the 'Manage·
Bookmarks' dialog

In the current diagram, select the bookmarked elements and then press·
Shift+Space

Notes

You should reload the project to update it with the new or cleared bookmarks·
The Find in Project window provides the facility to search based on bookmarked elements·
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